Pulse Measurements (R&S FSW-K6)
Contents
  • Welcome to the Pulse Measurements Application
  • Measurements and Result Displays
  • Measurement Basics
  • Configuration
  • Analysis
  • Export Functions
  • How to Perform Measurements in the Pulse Application
  • Remote Commands for Pulse Measurements
  • List of Commands
Top


Welcome to the Pulse Measurements Application

Pulse Measurements (R&S FSW-K6) > Welcome to the Pulse Measurements Application
Welcome to the Pulse Measurements Application

The R&S FSW-K6 is a firmware application that adds functionality to perform measurements on pulsed signals to the R&S FSW.

The pulse measurements application provides measurement and analysis functions for pulse signals frequently used in radar applications, for example.

The R&S FSW-K6 features:

  • Measurement of basic pulse characteristics
  • Analysis of parameter trends over time
  • Display of amplitude, frequency and phase measurement traces for individual pulses

This user manual contains a description of the functionality that the application provides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage (http://www2.rohde-schwarz.com/product/FSW.html).

Installation

You can find detailed installation instructions in the R&S FSW Getting Started manual or in the Release Notes.

Contents
  • Starting the Pulse Application
  • Understanding the Display Information


Starting the Pulse Application

Pulse Measurements (R&S FSW-K6) > Welcome to the Pulse Measurements Application > Starting the Pulse Application
Starting the Pulse Application

Pulse measurements require a separate application on the R&S FSW.

To activate the Pulse application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "Pulse" item.

    The R&S FSW opens a new measurement channel for the Pulse application.

For details see "Operating Modes" .

The measurement is started immediately with the default settings. It can be configured in the Pulse "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").

Multiple Measurement Channels and Sequencer Function

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs (including the "MultiView") as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .


Understanding the Display Information

Pulse Measurements (R&S FSW-K6) > Welcome to the Pulse Measurements Application > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram during analyzer operation. All different information areas are labeled. They are explained in more detail in the following sections.

1 = Channel bar for firmware and measurement settings
2+3 = Window title bar with diagram-specific (trace) information
4 = Diagram area
5 = Diagram footer with diagram-specific information, depending on measurement
6 = Instrument status bar with error messages, progress bar and date/time display
MSRA/MSRT operating mode

In MSRA and MSRT operating mode, additional tabs and elements are available. A colored background of the screen behind the measurement channel tabs indicates that you are in MSRA/MSRT operating mode.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

Channel bar information

In the Pulse application, the R&S FSW shows the following settings:

Information displayed in the channel bar in the Pulse application
Ref Level | Reference level
Att *) | RF attenuation
Freq *) | Center frequency for the RF signal
Meas Time | Measurement time (data acquisition time)
Meas BW *) | Measurement bandwidth
SRate | Sample rate
SGL | The sweep is set to single sweep mode.
*) If the input source is an I/Q data file (see "Settings for Input from I/Q Data Files"), most measurement settings related to data acquisition are not known and thus not displayed. For details see "Basics on Input from I/Q Data Files".

In addition, the channel bar also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values (e.g. transducer or trigger settings). This information is displayed only when applicable for the current measurement. For details see the R&S FSW Getting Started manual.

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in the Pulse application
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
6 = Trace mode
Diagram footer information

The diagram footer (beneath the diagram) contains the start and stop values for the displayed time range.

Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.


Measurements and Result Displays

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays
Measurements and Result Displays

During a pulse measurement, I/Q data from the input signal is captured for a specified time or for a specified record length. Pulses are detected from the signal according to specified thresholds and user-defined criteria. The measured signal is then compared with the ideal signal described by the user and any deviations are recorded. The defined range of measured data is then evaluated to determine characteristic pulse parameters. These parameters can either be displayed as traces, in a table, or be evaluated statistically over a series of measurements.

Measurement range vs result range

The measurement range defines which part of a pulse is measured (for example for frequency deviation), whereas the result range determines which data is displayed on the screen in the form of ampltiude, frequency or phase vs. time traces.

Exporting Table Results to an ASCII File

Measurement result tables can be exported to an ASCII file for further evaluation in other (external) applications.

For step-by-step instructions on how to export a table, see "How to Export Table Data".

Contents
  • Pulse Parameters
  • Evaluation Methods for Pulse Measurements


Pulse Parameters

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters
Pulse Parameters

The pulse parameters to be measured are based primarily on the IEEE 181 Standard 181-2003. For detailed descriptions refer to the standard documentation ("IEEE Standard on Transitions, Pulses, and Related Waveforms", from the IEEE Instrumentation and Measurement (I&M) Society, 7 July 2003).

The following graphic illustrates the main pulse parameters and characteristic values. (For a definition of the values used to determine the measured pulse parameters see "Parameter Definitions".)

Definition of the main pulse parameters and characteristic values

In order to obtain these results, select the corresponding parameter in the result configuration (see "Result Configuration") or apply the required SCPI parameter to the remote command (see "Configuring the Results" and "Retrieving Results").

Contents
  • Timing Parameters
  • Power/Amplitude Parameters
  • Frequency Parameters
  • Phase Parameters


Timing Parameters

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Timing Parameters
Timing Parameters

The following timing parameters can be determined by the R&S FSW-K6 application.

└ Timestamp
└ Settling Time
└ Rise Time
└ Fall Time
└ Pulse Width (ON Time)
└ Off Time
└ Duty Ratio
└ Duty Cycle (%)
└ Pulse Repetition Interval
└ Pulse Repetition Frequency (Hz)


Timestamp

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Timing Parameters > Timestamp
Timestamp

The time stamp uniquely identifies each pulse in the capture buffer. It is defined as the time from the capture start point to the beginning of the pulse period of the current pulse. Depending on the user-specified definition of the pulse period, the period begins with the mid-level crossing of the current pulse's rising edge (period: high-to-low) or the mid-level crossing of the previous pulse's falling edge (period low-to-high). See also "Pulse Period".

Remote command:

[SENSe:​]PULSe:​TIMing:​TSTamp?

CALCulate<n>:​TABLe:​TIMing:​TSTamp


Settling Time

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Timing Parameters > Settling Time
Settling Time

The difference between the time at which the pulse exceeds the mid threshold on the rising edge to the point where the pulse waveform remains within the pulse boundary (ON Inner/ ON Outer)

See figure "Definition of the main pulse parameters and characteristic values"

Remote command:

[SENSe:​]PULSe:​TIMing:​SETTling?

CALCulate<n>:​TABLe:​TIMing:​SETTling


Rise Time

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Timing Parameters > Rise Time
Rise Time

The time required for the pulse to transition from the base to the top level. This is the difference between the time at which the pulse exceeds the lower and upper thresholds.

See figure "Definition of the main pulse parameters and characteristic values"

Remote command:

[SENSe:​]PULSe:​TIMing:​RISE?

CALCulate<n>:​TABLe:​TIMing:​RISE


Fall Time

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Timing Parameters > Fall Time
Fall Time

The time required for the pulse to transition from the top to the base level. This is the difference between the time at which the pulse drops below the upper and lower thresholds.

See figure "Definition of the main pulse parameters and characteristic values"

Remote command:

[SENSe:​]PULSe:​TIMing:​FALL?

CALCulate<n>:​TABLe:​TIMing:​FALL


Pulse Width (ON Time)

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Timing Parameters > Pulse Width (ON Time)
Pulse Width (ON Time)

The time that the pulse remains at the top level ("ON"). This is the time between the first positive edge and the subsequent negative edge of the pulse in seconds, where the edges occur at crossings of the mid threshold.

See figure "Definition of the main pulse parameters and characteristic values"

Remote command:

[SENSe:​]PULSe:​TIMing:​PWIDth?

CALCulate<n>:​TABLe:​TIMing:​PWIDth


Off Time

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Timing Parameters > Off Time
Off Time

The time that the pulse remains at the base level ("OFF"). This is the time between the first negative edge and the subsequent positive edge of the pulse in seconds, where the edges occur at crossings of the mid threshold.

See figure "Definition of the main pulse parameters and characteristic values"

Remote command:

[SENSe:​]PULSe:​TIMing:​OFF?

CALCulate<n>:​TABLe:​TIMing:​OFF


Duty Ratio

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Timing Parameters > Duty Ratio
Duty Ratio

The ratio of the "Pulse Width" to "Pulse Repetition Interval" expressed as a value between 0 and 1 (requires at least two measured pulses)

Remote command:

[SENSe:​]PULSe:​TIMing:​DRATio?

CALCulate<n>:​TABLe:​TIMing:​DRATio


Duty Cycle (%)

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Timing Parameters > Duty Cycle (%)
Duty Cycle (%)

The ratio of the "Pulse Width" to "Pulse Repetition Interval" expressed as a percentage (requires at least two measured pulses)

Remote command:

[SENSe:​]PULSe:​TIMing:​DCYCle?

CALCulate<n>:​TABLe:​TIMing:​DCYCle


Pulse Repetition Interval

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Timing Parameters > Pulse Repetition Interval
Pulse Repetition Interval

The time between two consecutive edges of the same polarity in seconds (requires at least two measured pulses). The user-specified definition of the pulse period (see"Pulse Period") determines whether this value is calculated from consecutive rising or falling edges.

Remote command:

[SENSe:​]PULSe:​TIMing:​PRI?

CALCulate<n>:​TABLe:​TIMing:​PRI


Pulse Repetition Frequency (Hz)

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Timing Parameters > Pulse Repetition Frequency (Hz)
Pulse Repetition Frequency (Hz)

The frequency of occurrence of pulses, i.e. inverse of the "Pulse Repetition Interval" (requires at least two measured pulses)

Remote command:

[SENSe:​]PULSe:​TIMing:​PRF?

CALCulate<n>:​TABLe:​TIMing:​PRF


Power/Amplitude Parameters

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters
Power/Amplitude Parameters

The following power/amplitude parameters can be determined by the R&S FSW-K6 application.

└ Top Power
└ Base Power
└ Pulse Amplitude
└ Average ON Power
└ Average Tx Power
└ Minimum Power
└ Peak Power
└ Peak-to-Avg ON Power Ratio
└ Peak-to-Average Tx Power Ratio
└ Peak-to-Min Power Ratio
└ Droop
└ Ripple
└ Overshoot
└ Power
└ Pulse-to-Pulse Power Difference


Top Power

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Top Power
Top Power

The median pulse ON power. The value of this parameter is used as a reference (100%) to determine other parameter values such as the rising / falling thresholds. Various algorithms are provided to determine the top power (see "Measurement Algorithm").

Remote command:

[SENSe:​]PULSe:​POWer:​TOP?

CALCulate<n>:​TABLe:​POWer:​TOP


Base Power

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Base Power
Base Power

The median pulse OFF power. The value of this parameter is used as a reference (0%) to determine other parameter values such as the rising / falling thresholds.

Remote command:

[SENSe:​]PULSe:​POWer:​BASE?

CALCulate<n>:​TABLe:​POWer:​BASE


Pulse Amplitude

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Pulse Amplitude
Pulse Amplitude

The difference between the "Top Power" and the "Base Power". This value determines the 100% power range (amplitude).

Remote command:

[SENSe:​]PULSe:​POWer:​AMPLitude?

CALCulate<n>:​TABLe:​POWer:​AMPLitude


Average ON Power

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Average ON Power
Average ON Power

The average power during the pulse ON time

Remote command:

[SENSe:​]PULSe:​POWer:​ON?

CALCulate<n>:​TABLe:​POWer:​ON


Average Tx Power

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Average Tx Power
Average Tx Power

The average transmission power over the entire pulse ON + OFF time

Remote command:

[SENSe:​]PULSe:​POWer:​AVG?

CALCulate<n>:​TABLe:​POWer:​AVG


Minimum Power

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Minimum Power
Minimum Power

The minimum power over the entire pulse ON + OFF time

Remote command:

[SENSe:​]PULSe:​POWer:​MIN?

CALCulate<n>:​TABLe:​POWer:​MIN


Peak Power

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Peak Power
Peak Power

The maximum power over the entire pulse ON + OFF time

Remote command:

[SENSe:​]PULSe:​POWer:​MAX?

CALCulate<n>:​TABLe:​POWer:​MAX


Peak-to-Avg ON Power Ratio

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Peak-to-Avg ON Power Ratio
Peak-to-Avg ON Power Ratio

The ratio of maximum to average power over the pulse ON time (also known as crest factor)

Remote command:

[SENSe:​]PULSe:​POWer:​PON?

CALCulate<n>:​TABLe:​POWer:​PON


Peak-to-Average Tx Power Ratio

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Peak-to-Average Tx Power Ratio
Peak-to-Average Tx Power Ratio

The ratio of maximum to average power over the entire pulse ON + OFF interval.

Remote command:

[SENSe:​]PULSe:​POWer:​PAVG?

CALCulate<n>:​TABLe:​POWer:​PAVG


Peak-to-Min Power Ratio

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Peak-to-Min Power Ratio
Peak-to-Min Power Ratio

The ratio of maximum to minimum power over the entire pulse ON + OFF time

Remote command:

[SENSe:​]PULSe:​POWer:​PMIN?

CALCulate<n>:​TABLe:​POWer:​PMIN


Droop

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Droop
Droop

The rate at which the pulse top level decays, calculated as the difference between the power at the beginning of the pulse ON time and the power at the end of the pulse ON time, divided by the pulse amplitude.

Droop values are only calculated if "Pulse Has Droop" is set to "On" (default behaviour).

For more information see "Amplitude Droop"

Note: The percentage ratio values are calculated in %V if the "Measurement Level" is defined in V (see "Reference Level Unit"), otherwise in %W.

Remote command:

[SENSe:​]PULSe:​POWer:​ADRoop:​DB?

[SENSe:​]PULSe:​POWer:​ADRoop[:​PERCent]?

CALCulate<n>:​TABLe:​POWer:​ADRoop:​DB

CALCulate<n>:​TABLe:​POWer:​ADRoop[:​PERCent]


Ripple

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Ripple
Ripple

The ripple is calculated as the difference between the maximum and minimum deviation from the pulse top reference, within a user specified interval.

For more information see "Ripple"

Note: The percentage ratio values are calculated in %V if the "Measurement Level" is defined in V (see "Reference Level Unit"), otherwise in %W.

Remote command:

[SENSe:​]PULSe:​POWer:​RIPPle:​DB?

[SENSe:​]PULSe:​POWer:​RIPPle[:​PERCent]?

CALCulate<n>:​TABLe:​POWer:​RIPPle:​DB

CALCulate<n>:​TABLe:​POWer:​RIPPle[:​PERCent]


Overshoot

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Overshoot
Overshoot

The height of the local maximum after a rising edge, divided by the pulse amplitude.

For more information see "Overshoot".

Note: The percentage ratio values are calculated in %V if the "Measurement Level" is defined in V (see "Reference Level Unit"), otherwise in %W.

Remote command:

[SENSe:​]PULSe:​POWer:​OVERshoot:​DB?

[SENSe:​]PULSe:​POWer:​OVERshoot[:​PERCent]?

CALCulate<n>:​TABLe:​POWer:​OVERshoot:​DB

CALCulate<n>:​TABLe:​POWer:​OVERshoot[:​PERCent]


Power

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Power
Power

The power measured at the pulse "measurement point" specified by the "Measurement Point Reference" and the "Offset"

Remote command:

[SENSe:​]PULSe:​POWer:​POINt?

CALCulate<n>:​TABLe:​POWer:​POINt


Pulse-to-Pulse Power Difference

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Power/Amplitude Parameters > Pulse-to-Pulse Power Difference
Pulse-to-Pulse Power Difference

The ratio of the "Power" values from the first measured pulse to the current pulse.

Remote command:

[SENSe:​]PULSe:​POWer:​PPRatio?

CALCulate<n>:​TABLe:​POWer:​PPRatio


Frequency Parameters

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Frequency Parameters
Frequency Parameters

The following frequency parameters can be determined by the R&S FSW-K6 application.

└ Frequency
└ Pulse-Pulse Frequency Difference
└ Frequency Error (RMS)
└ Frequency Error (Peak)
└ Frequency Deviation
└ Chirp Rate


Frequency

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Frequency Parameters > Frequency
Frequency

Frequency of the pulse measured at the defined "Measurement Point"

Remote command:

[SENSe:​]PULSe:​FREQuency:​POINt?

CALCulate<n>:​TABLe:​FREQuency:​POINt


Pulse-Pulse Frequency Difference

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Frequency Parameters > Pulse-Pulse Frequency Difference
Pulse-Pulse Frequency Difference

Difference in frequency between the first measured pulse and the currently measured pulse

Remote command:

[SENSe:​]PULSe:​FREQuency:​PPFRequency?

CALCulate<n>:​TABLe:​FREQuency:​PPFRequency


Frequency Error (RMS)

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Frequency Parameters > Frequency Error (RMS)
Frequency Error (RMS)

The RMS frequency error of the currently measured pulse. The error is calculated relative to the given pulse modulation. It is not calculated at all for modulation type "Arbitrary". The error is calculated over the "Measurement Range".

Remote command:

[SENSe:​]PULSe:​FREQuency:​RERRor?

CALCulate<n>:​TABLe:​FREQuency:​RERRor


Frequency Error (Peak)

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Frequency Parameters > Frequency Error (Peak)
Frequency Error (Peak)

The peak frequency error of the currently measured pulse. The error is calculated relative to the given pulse modulation. It is not calculated at all for modulation type "Arbitrary". The error is calculated over the "Measurement Range".

Remote command:

[SENSe:​]PULSe:​FREQuency:​PERRor?

CALCulate<n>:​TABLe:​FREQuency:​PERRor


Frequency Deviation

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Frequency Parameters > Frequency Deviation
Frequency Deviation

The frequency deviation of the currently measured pulse. The deviation is calculated as the absolute difference between the maximum and minimum frequency values within the "Measurement Range".

Remote command:

[SENSe:​]PULSe:​FREQuency:​DEViation?

CALCulate<n>:​TABLe:​FREQuency:​DEViation


Chirp Rate

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Frequency Parameters > Chirp Rate
Chirp Rate

A known frequency chirp rate (per μs) to be used for generating an ideal pulse waveform.

Note: a chirp rate is only available for the "Pulse Modulation" type "Linear FM".

Remote command:

[SENSe:​]PULSe:​FREQuency:​CRATe?

CALCulate<n>:​TABLe:​FREQuency:​CRATe


Phase Parameters

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Phase Parameters
Phase Parameters

The following phase parameters can be determined by the R&S FSW-K6 application.

└ Phase
└ Pulse-Pulse Phase Difference
└ Phase Error (RMS)
└ Phase Error (Peak)
└ Phase Deviation


Phase

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Phase Parameters > Phase
Phase

Phase of the pulse measured at the defined "Measurement Point"

Remote command:

[SENSe:​]PULSe:​PHASe:​POINt?

CALCulate<n>:​TABLe:​PHASe:​POINt


Pulse-Pulse Phase Difference

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Phase Parameters > Pulse-Pulse Phase Difference
Pulse-Pulse Phase Difference

Difference in phase between the first measured pulse and the currently measured pulse

Remote command:

[SENSe:​]PULSe:​PHASe:​PPPHase?

CALCulate<n>:​TABLe:​PHASe:​PPPHase


Phase Error (RMS)

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Phase Parameters > Phase Error (RMS)
Phase Error (RMS)

The RMS phase error of the currently measured pulse. The error is calculated relative to the given pulse modulation. It is not calculated at all for the "Pulse Modulation" type "Arbitrary". The error is calculated over the "Measurement Range".

Remote command:

[SENSe:​]PULSe:​PHASe:​RERRor?

CALCulate<n>:​TABLe:​PHASe:​RERRor


Phase Error (Peak)

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Phase Parameters > Phase Error (Peak)
Phase Error (Peak)

The peak phase error of the currently measured pulse. The error is calculated relative to the given pulse modulation. It is not calculated at all for the "Pulse Modulation" type "Arbitrary". The error is calculated over the "Measurement Range".

Remote command:

[SENSe:​]PULSe:​PHASe:​PERRor?

CALCulate<n>:​TABLe:​PHASe:​PERRor


Phase Deviation

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Pulse Parameters > Phase Parameters > Phase Deviation
Phase Deviation

The phase deviation of the currently measured pulse. The deviation is calculated as the absolute difference between the maximum and minimum phase values within the "Measurement Range".

Remote command:

[SENSe:​]PULSe:​PHASe:​DEViation?

CALCulate<n>:​TABLe:​PHASe:​DEViation


Evaluation Methods for Pulse Measurements

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements
Evaluation Methods for Pulse Measurements

The data that was measured by the R&S FSW can be evaluated using various different methods. All evaluation modes available for the Pulse measurement are displayed in the selection bar in SmartGrid mode.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

By default, the Pulse measurement results are displayed in the following windows:

  • Magnitude Capture
  • Pulse Results
  • Pulse Frequency
  • Pulse Magnitude
  • Pulse Phase

The following evaluation methods are available for Pulse measurements:

└ Magnitude Capture
└ Marker Table
└ Parameter Distribution
└ Parameter Spectrum
└ Parameter Trend
└ Pulse Frequency
└ Pulse Magnitude
└ Pulse Phase
└ Pulse Phase (Wrapped)
└ Pulse Results
└ Pulse Statistics
└ Result Range Spectrum


Magnitude Capture

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Magnitude Capture
Magnitude Capture

Displays the captured data. Detected pulses are indicated by green bars along the x-axis. The currently selected pulse is highlighted in blue. Additionally, the pulse detection reference level is indicated ("Ref"), as well as the specified pulse detection threshold ("Det").

Segmented data capturing

As of firmware version 2.00, data can be captured non-contiguously, that is, in segments (see "Segmented Data Capturing"). For segmented data, the measured time span may be very long, whereas the relevant signal segments may be relatively short. Thus, to improve clarity, the Magnitude Capture display is compressed to eliminate the gaps between the captured segments. The segment ranges are indicated by vertical blue lines. Between two segments, the gap may be compressed in the display. The time span indicated for the x-axis in the diagram footer is only up-to-date when the measurement is completed.

Remote command:

LAY:ADD:WIND '2',RIGH,MCAP see LAYout:​ADD[:​WINDow]?

Segmented data:

TRACe<n>:​IQ:​SCAPture:​BOUNdary?

TRACe<n>:​IQ:​SCAPture:​TSTamp:​SSTart?

TRACe<n>:​IQ:​SCAPture:​TSTamp:​TRIGger?


Marker Table

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Parameter Distribution

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Parameter Distribution
Parameter Distribution

Plots a histogram of a particular parameter, i.e. all measured parameter values from the current capture vs pulse count or occurrence in %. Thus you can determine how often a particular parameter value occurs. For each parameter distribution window you can configure a different parameter to be displayed.

This evaluation method allows you to distinguish transient and stable effects in a specific parameter, such as a spurious frequency deviation or a fluctuation in power over several pulses.

Note: Limit lines. Optionally, limit lines can be displayed in the Parameter Distribution diagram. You can drag these lines to a new position in the window. The new position is maintained, the limit check is repeated, and the results of the limit check in any active table displays are adapted.

Note that averaging is not possible for parameter distribution traces.

Remote command:

LAY:ADD:WIND '2',RIGH,PDIS see LAYout:​ADD[:​WINDow]?


Parameter Spectrum

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Parameter Spectrum
Parameter Spectrum

Calculates an FFT for a selected column of the Pulse Results table. This "spectrum" allows you to easily determine the frequency of periodicities in the pulse parameters. For example, the Parameter Spectrum for "Pulse Top Power" might display a peak at a particular frequency, indicating incidental amplitude modulation of the amplifier output due to the power supply.

The Parameter Spectrum is calculated by taking the magnitude of the FFT of the selected parameter and normalizing the result to the largest peak. In order to calculate the frequency axis the average PRI (pulse repetition interval) is taken to be the "sampling rate" for the FFT. Note that in cases where the signal has a non-uniform or staggered PRI the frequency axis must therefore be interpreted with caution.

Remote command:

LAY:ADD:WIND '2',RIGH,PSP see LAYout:​ADD[:​WINDow]?


Parameter Trend

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Parameter Trend
Parameter Trend

Plots all measured parameter values from the current capture vs pulse number or pulse timestamp. This is equivalent to plotting a column of the "Pulse Results" table for the rows highlighted green. This evaluation allows you to determine trends in a specific parameter, such as a frequency deviation or a fluctuation in power over several pulses.

The parameter trend evaluation can also be used for a more general scatter plot - the parameters from the current capture can not only be displayed over time, but also versus any other pulse parameter. For example, you can evaluate the rise time vs fall time.

For each parameter trend window you can configure a different parameter to be displayed for both the x-axis and the y-axis, making this a very powerful and flexible analysis tool.

Note: Limit lines. Optionally, limit lines can be displayed in the Parameter Trend diagram. You can drag these lines to a new position in the window. The new position is maintained, the limit check is repeated, and the results of the limit check in any active table displays are adapted.
If a limit is defined for a parameter that is displayed in a Parameter Trend diagram, the "Auto Scale Window" function is not available for the axis this parameter is displayed on (see also "Activating a limit check for a parameter"). This avoids the rapid movement of the limit lines which would occur if the axis scale changed.

Note that averaging is not possible for parameter trend traces.

Note: Setting markers in Parameter Trend Displays. In Parameter Trend displays, especially when the x-axis unit is not pulse number, positioning a marker by defining its x-axis value can be very difficult or unambiguous. Thus, markers can be positioned by defining the corresponding pulse number in the "Marker" edit field for all parameter trend displays, regardless of the displayed x-axis parameter. The "Marker" edit field is displayed when you select one of the "Marker" softkeys.
However, the position displayed in the marker information area or the marker table is shown in the defined x-axis unit.

Remote command:

LAY:ADD:WIND '2',RIGH,PTR see LAYout:​ADD[:​WINDow]?

CALCulate<n>:TRENd:<GroupName>:X, see e.g. CALCulate<n>:​TRENd:​FREQuency:​X

CALCulate<n>:TRENd:<GroupName>:Y, see e.g. CALCulate<n>:​TRENd:​FREQuency:​Y


Pulse Frequency

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Pulse Frequency
Pulse Frequency

Displays the frequency trace of the selected pulse. The length and alignment of the trace can be configured in the "Measurement Range" dialog box (see "Measurement Range").

Remote command:

LAY:ADD:WIND '2',RIGH,PFR see LAYout:​ADD[:​WINDow]?


Pulse Magnitude

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Pulse Magnitude
Pulse Magnitude

Displays the magnitude vs. time trace of the selected pulse. The length and alignment of the trace can be configured in the "Measurement Range" dialog box (see "Measurement Range").

Remote command:

LAY:ADD:WIND '2',RIGH,PMAG see LAYout:​ADD[:​WINDow]?


Pulse Phase

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Pulse Phase
Pulse Phase

Displays the phase vs. time trace of the selected pulse. The length and alignment of the trace can be configured in the "Measurement Range" dialog box (see "Measurement Range").

Remote command:

LAY:ADD:WIND '2',RIGH,PPH see LAYout:​ADD[:​WINDow]?


Pulse Phase (Wrapped)

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Pulse Phase (Wrapped)
Pulse Phase (Wrapped)

Displays the wrapped phase vs. time trace of the selected pulse. The length and alignment of the trace can be configured in the "Measurement Range" dialog box (see "Measurement Range").

Remote command:

LAY:ADD:WIND '2',RIGH,PPW see LAYout:​ADD[:​WINDow]?


Pulse Results

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Pulse Results
Pulse Results

Displays the measured pulse parameters in a table of results. Which parameters are displayed can be configured in the "Result Configuration" (see "Result Configuration"). The currently selected pulse is highlighted blue. The pulses contained in the current capture buffer are highlighted green.

Limit check

Optionally, the measured results can be checked against defined limits (see "Limit Settings for Table Displays"). The results of the limit check are indicated in the Pulse Results table as follows:

Limit check results in the result tables
Display color | Limit check result
white | No limit check active for this parameter
green | Limit check passed
red, asterisk before | Limit check failed; limit exceeds lower limit
red, asterisk behind | Limit check failed; limit exceeds upper limit

Note: The results of the limit check are for informational purposes only; special events such as stopping the measurement are not available.

Note: Optionally, limit lines can be displayed in the "Parameter Distribution" and "Parameter Trend" diagrams. You can drag these lines to a new position in the window. The new position is maintained, the limit check is repeated, and the results of the limit check in any active table displays are adapted.

Remote command:

LAY:ADD:WIND '2',RIGH,PRES see LAYout:​ADD[:​WINDow]?


Pulse Statistics

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Pulse Statistics
Pulse Statistics

Displays statistical values (minimum, maximum, average, standard deviation) for the measured pulse parameters in a table of results. Both the current capture buffer data and the cummulated captured data from a series of measurements are evaluated. The statistics computed only from pulses within the current capture buffer are highlighted green. For reference, the measured parameters from the "Selected Pulse" are also shown, highlighted blue. The displayed parameters are the same as in the Pulse Results and can be configured in the "Result Configuration" (see "Result Configuration").

Note: Limit checks are also available for Pulse Statistics; see "Pulse Results".

Remote command:

LAY:ADD:WIND '2',RIGH,PST see LAYout:​ADD[:​WINDow]?


Result Range Spectrum

Pulse Measurements (R&S FSW-K6) > Measurements and Result Displays > Evaluation Methods for Pulse Measurements > Result Range Spectrum
Result Range Spectrum

Calculates a power spectrum from the captured I/Q data, within the time interval defined by the result range (see "Result Range".

The Result Range Spectrum is calculated using a Welch periodogram, which involves averaging the spectrum calculated by overlapping windows.

The shape of the window used for the calculation can be specified. The length of the window is calculated such that a specific resolution bandwidth is obtained.

Remote command:

LAY:ADD:WIND '2',RIGH,RRSP see LAYout:​ADD[:​WINDow]?


Measurement Basics

Pulse Measurements (R&S FSW-K6) > Measurement Basics
Measurement Basics

Some background knowledge on basic terms and principles used in pulse measurements is provided here for a better understanding of the required configuration settings.

Contents
  • Parameter Definitions
  • Pulse Detection
  • Parameter Spectrum Calculation
  • Segmented Data Capturing
  • Receiving Data Input and Providing Data Output
  • Trace Evaluation
  • Pulse Measurements in MSRA/MSRT Mode


Parameter Definitions

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Parameter Definitions
Parameter Definitions

The pulse parameters to be measured are based primarily on the IEEE 181 Standard 181-2003. For detailed descriptions refer to the standard documentation ("IEEE Standard on Transitions, Pulses, and Related Waveforms", from the IEEE Instrumentation and Measurement (I&M) Society, 7 July 2003).

The following definitions are used to determine the measured pulse power parameters:

Value | Description
L0% | The magnitude in V corresponding to the pulse OFF level (base level)
L100% | The magnitude in V corresponding to the pulse ON level (top level)
LOv | The magnitude in V at the peak level occurring directly after the pulse rising edge (mid-level crossing)
Lrise | The magnitude in V of the reference model at the top of the rising edge (beginning of the pulse top)
Lfall | The magnitude in V of the reference model at the top of the falling edge (end of the pulse top)
Lrip+ | The magnitude in V corresponding to the largest level above the reference model which occurs within the ripple portion of the pulse top
Ltop+ | The magnitude in V of the reference model at the point in time where Lrip+ is measured
Lrip- | The magnitude in V corresponding to the lowest measured level below the reference model which occurs within the ripple portion of the pulse top
Ltop- | The magnitude in V of the reference model at the point in time where Lrip- is measured
Contents
  • Amplitude Droop
  • Ripple
  • Overshoot


Amplitude Droop

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Parameter Definitions > Amplitude Droop
Amplitude Droop

The amplitude droop is calculated as the difference between the power at the beginning of the pulse ON time and the power at the end of the pulse ON time, divided by the pulse amplitude:

Illustration of levels used to define the droop measurement


Ripple

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Parameter Definitions > Ripple
Ripple

The ripple is calculated as the difference between the maximum and minimum deviation from the pulse top reference, within a user specified interval.

The default behaviour compensates for droop in the pulse top using the following formulae:

However, if "Pulse Has Droop" is set to "Off" or the 100 % Level "Position" is set to "Center", then the reference model has a flat pulse top and Ltop+ = Ltop- = L100%. Thus, the formulae are reduced to:

The following illustration indicates the levels used for calculation.

Illustration of levels used to define the ripple measurement.


Overshoot

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Parameter Definitions > Overshoot
Overshoot

The overshoot is defined as the height of the local maximum after a rising edge, divided by the pulse amplitude:

Illustration of levels used to define the overshoot measurement


Pulse Detection

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Pulse Detection
Pulse Detection

A pulsed input signal is a signal whose carrier power is modulated by two states: ON and OFF. Basically, a pulse is detected when the input signal power exceeds a threshold, then subsequently falls below that threshold, or vice versa. Pulses that rise to and then remain at a peak (positive) power level for a certain duration, and then fall again are referred to as positive pulses, whereas the opposite - falling to and remaining at a minimum (negative) power level, then rising - is referred to as a negative pulse. The "ON" power level is referred to as the top or 100% level, whereas the "OFF" level is referred to as the base or 0% level.

A hysteresis can refine the detection process and avoid falsely interpreting instable signals as additional pulses. Optionally, detection can be restricted to a maximum number of pulses per capture process.

If the top power level is not constant, this is called an amplitude droop. Since the top level is an important reference for several pulse parameters, a droop should be taken into consideration where possible. If a signal is known to have a droop, the reference level is calculated separately for the rising and falling edges, rather than as an average or median value over the ON time.

The time it takes the signal power to rise from the base level to the top is called the rise time.

The duration the signal power remains at the top level is considered the ON time, which also defines the pulse width.

The time it takes the signal power to fall from the top to the base level is called the fall time.

The duration the signal power remains at the base level is called the OFF time.

The pulse repetition interval (also known as pulse period) is defined as the duration of one complete cycle consisting of:

  • the rise time
  • the ON time
  • the fall time
  • the OFF time

To avoid taking noise, ripples, or other signal instabilites into consideration, threshold values are defined for calculation of these characteristic values rather than using the absolute peak or minimum power values.

More precise definitions and an illustration of how these values are calculated are provided in "Pulse Parameters".


Parameter Spectrum Calculation

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Parameter Spectrum Calculation
Parameter Spectrum Calculation

When a signal is measured over time, it is possible to calculate the frequency spectrum for the measured signal by performing an FFT on the measured data. Silmilarly, it is possible to calculate a "spectrum" for a particular pulse parameter by performing an FFT. This "spectrum" allows you to easily determine the frequency of periodicities in the pulse parameters. For example, the Parameter Spectrum for "Pulse Top Power" might display a peak at a particular frequency, indicating incidental amplitude modulation of the amplifier output due to the power supply.

Basically, the parameter spectrum is calculated by taking the magnitude of the FFT of the selected parameter and normalizing the result to the largest peak.

Frequency axis

When calculating a spectrum from a measured signal, the sample rate ensures a regular distance between two frequencies. In order to calculate the frequency axis for a parameter spectrum, the average PRI (pulse repetition interval) is taken to be the "sampling rate" for the FFT.

Interpolation

However, in cases where the signal has a non-uniform or staggered PRI the frequency axis must be interpreted with caution. In cases where the pulses only occur in non-contiguous intervals, using the PRI no longer provides useful results. A good solution to create equi-distant samples for calculation is to "fill up" the intervals between pulses with interpolated values. Based on the measured and interpolated values, the frequency axis can then be created.

The number of possible interpolation values is restricted to 100 000 by the R&S FSW Pulse application application. Thus, the resulting spectrum is limited. By default, the frequency span for the resulting spectrum is determined automatically. However, to improve the accuracy (and performance) of the interpolation, the maximum required frequency span can be restricted further manually.

Non-contiguous pulses - sections vs gaps

For the non-contiguous pulse measurements described above, interpolation in the long intervals where no pulses occur will distort the result. Therefore, time intervals without pulses are identified, referred to as gaps.The time intervals that contain pulses are also identified, referred to as sections. Interpolation is then performed only on the sections, whereas the gaps are ignored for the spectrum calculation.

A gap threshold ensures that pulses with large intervals are not split into multiple sections, while a section threshold ensures that singular pulses within a long gap are not included in calculation.

Example: Non-contiguous pulse measurement

A typical measurement setup that results in non-contiguous pulses is a rotating radar antenna scanning the air. For most of the time required for a single rotation, no pulses will be received. However, when an object comes within the scan area, several pulses will be detected within a short duration in time (this will be identified as a section). When the object leaves the scan area again, the pulses will stop, defining a gap until the next object is detected.

Blocks

Spectrum calculation is then performed for the individual sections only. However, the Fourier transformation is not performed on the entire section in one step. Each section is split into blocks, which may overlap. An FFT is performed on each block to calculate an individual result. The smaller the block size, the more individual results are calculated, and the more precise the final result. Thus, the block size determines the resolution bandwidth in the final spectrum. Note that while the block size may be defined manually, the RBW cannot.

Window functions

Each block with its measured and interpolated values is multiplied with a specific window function. Windowing helps minimize the discontinuities at the end of the measured signal interval and thus reduces the effect of spectral leakage, increasing the frequency resolution.

Various different window functions are provided in the R&S FSW Pulse application. Each of the window functions has specific characteristics, including some advantages and some trade-offs. These characteristics need to be considered carefully to find the optimum solution for the measurement task.

FFT window functions
Window type | Function
Rectangular | The regtangular window function is in effect not a function at all, it maintains the original sampled data. This may be useful to minimize the required bandwidth; however, heavy sidelobes may occur, which do not exist in the original signal.
Hamming |
Hann |
Blackman (default) |
Bartlett |
Averaging and final spectrum

After windowing, an FFT is performed on each block, and the individual spectrum results are then combined to a total result by averaging the traces. The complete process to calculate a parameter spectrum is shown in figure "Calculating a parameter spectrum for non-contiguous pulses".

Calculating a parameter spectrum for non-contiguous pulses


Segmented Data Capturing

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Segmented Data Capturing
Segmented Data Capturing

As described above, measuring pulses with a varying repetition interval is a common task in the R&S FSW Pulse application. Pulses to be measured may have a relatvely short duration compared to the repetition interval (low duty cycle). Performing a measurement over a long time period can lead to large volumes of data with only minor parts of it being relevant. Thus, a new segmented data capturing function has been introduced. Using this function, the input signal is measured for the entire time span, which may be very long; however, only user-defined segments of the data are actually stored on the R&S FSW. This leads to much less data, and only relevant data, which needs to be analyzed. Analyzing pulses becomes much quicker and more efficient.

Although segmented data capturing is similar to the common gated trigger method for data acquisition, there is a significant difference: absolute timing information is provided for the entire acquisition, in addition to the samples within the gating intervals. Furthermore, pretrigger information for the pulses within a segment is available, as opposed to gates that are triggered by a rising or falling edge, and do not provide pretrigger data.

Trigger and trigger offset

A precondition for segmented data capturing is a trigger, as the segment definition is based on the trigger event. A specified trigger offset is applied to each segment, thus allowing for pretrigger data to be included in the segment. Furthermore, the length of each segment (that is: the measurement time for an individual segment) must be defined such that the longest expected pulse can be captured in one segment. Finally, the number of trigger events for which data is to be captured can be defined.

Measurement time

If segmented capturing is active, the total measurement time is defined by the number of trigger events and the segment length. Thus, the "Measurement Time" setting in the "Data Acquisition" dialog box is not available.

Number of events vs number of segments

Generally, the number of trigger events corresponds to the number of captured segments. However, in some cases, multiple trigger events may occur within a time interval shorter than the specified segment length. Thus, the segments for the individual trigger events overlap. In this case, the overlapping segments are merged together and the number of segments is lower than the number of trigger events.

Result displays for segmented data

In the Magnitude Capture display an overview of the entire measurement is provided. However, for segmented data, the time span may be very long, whereas the relevant signal segments may be relatively short. Thus, to improve clarity, the display is compressed to eliminate the gaps between the captured segments. The segment ranges are indicated by vertical lines. Between two segments, the gap may be compressed in the display. The time span indicated for the x-axis in the diagram footer is only up-to-date when the measurement is completed. (See also "Magnitude Capture".)

Markers "jump" over the gaps, but indicate the correct absolute time within the segments.

This compressed time-axis display is also used for the pulse-based results.

The result tables are identical for segmented or full data capture.

Timestamps vs. sample number

As mentioned above, timing information is available for the entire measurement span, not only for the captured data segments. Thus, the absolute time that each segment starts at is available as a timestamp. On the other hand, only the data samples within the specified segments are actually stored. The samples are indexed. Thus, in addition to the timestamps, the start of a segment can also be referenced by the index number of the first sample in the segment, for example when retrieving the captured segment data in remote operation. (See also TRACe<n>:​IQ:​SCAPture:​BOUNdary?.)


Receiving Data Input and Providing Data Output

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Receiving Data Input and Providing Data Output
Receiving Data Input and Providing Data Output

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals).

Contents
  • RF Input Protection
  • Basics on Input from I/Q Data Files
  • Input from Noise Sources
  • Receiving and Providing Trigger Signals


RF Input Protection

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Receiving Data Input and Providing Data Output > RF Input Protection
RF Input Protection

The RF input connector of the R&S FSW must be protected against signal levels that exceed the ranges specified in the data sheet. Therefore, the R&S FSW is equipped with an overload protection mechanism. This mechanism becomes active as soon as the power at the input mixer exceeds the specified limit. It ensures that the connection between RF input and input mixer is cut off.

When the overload protection is activated, an error message is displayed in the status bar ("INPUT OVLD"), and a message box informs you that the RF Input was disconnected. Furthermore, a status bit (bit 3) in the STAT:QUES:POW status register is set. In this case you must decrease the level at the RF input connector and then close the message box. Then measurement is possible again. Reactivating the RF input is also possible via the remote command INPut:​ATTenuation:​PROTection:​RESet.


Basics on Input from I/Q Data Files

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Receiving Data Input and Providing Data Output > Basics on Input from I/Q Data Files
Basics on Input from I/Q Data Files

The I/Q data to be evaluated in a particular R&S FSW application can not only be captured by the application itself, it can also be loaded from a file, provided it has the correct format. The file is then used as the input source for the application.

Currently, this input source is only available in the R&S FSW Pulse application.

For example, you can capture I/Q data using the I/Q Analyzer application, store it to a file, and then analyze the pulse parameters for that data later using the R&S FSW Pulse application.

The I/Q data must be stored in a format with the file extension .iq.tar. For a detailed description see "I/Q Data File Format (iq-tar)".

As opposed to importing data from an I/Q data file using the import functions provided by some R&S FSW applications (e.g. the I/Q Analyzer or the R&S FSW VSA application), the data is not only stored temporarily in the capture buffer, where it overwrites the current measurement data and is in turn overwritten by a new measurement. Instead, the stored I/Q data remains available as input for any number of subsequent measurements. Furthermore, the (temporary) data import requires the current measurement settings in the current application to match the settings that were applied when the measurement results were stored (possibly in a different application). When the data is used as an input source, however, the data acquisition settings in the current application (attenuation, center frequency, measurement bandwidth, sample rate) can be ignored. As a result, these settings cannot be changed in the current application. Only the measurement time can be decreased, in order to perform measurements on an extract of the available data (from the beginning of the file) only.

When using input from an I/Q data file, the RUN SINGLE function starts a single Pulse measurement (i.e. analysis) of the stored I/Q data, while the RUN CONT function repeatedly analyzes the same data from the file.

Sample iq.tar files

If you have the optional R&S FSW VSA application (R&S FSW-K70), some sample iq.tar files are provided in the C:/R_S/Instr/user/vsa/DemoSignals directory on the R&S FSW.

Furthermore, you can create your own iq.tar files in the I/Q Analyzer, see "How to Export and Import I/Q Data" .


Input from Noise Sources

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Receiving Data Input and Providing Data Output > Input from Noise Sources
Input from Noise Sources

The R&S FSW provides a connector (NOISE SOURCE CONTROL) with a voltage supply for an external noise source. By switching the supply voltage for an external noise source on or off in the firmware, you can activate or deactive the device as required.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of an amplifier.

In this case, you can first connect an external noise source (whose noise power level is known in advance) to the R&S FSW and measure the total noise power. From this value you can determine the noise power of the R&S FSW. Then when you measure the power level of the actual DUT, you can deduct the known noise level from the total power to obtain the power level of the DUT.

The noise source is controlled in the "Output" settings, see "Noise Source"


Receiving and Providing Trigger Signals

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Receiving Data Input and Providing Data Output > Receiving and Providing Trigger Signals
Receiving and Providing Trigger Signals

Using one of the variable TRIGGER INPUT/OUTPUT connectors of the R&S FSW, the R&S FSW can use a signal from an external reference as a trigger to capture data. Alternatively, the internal trigger signal used by the R&S FSW can be output for use by other connected devices. Using the same trigger on several devices is useful to synchronize the transmitted and received signals within a measurement.

For details on the connectors see the R&S FSW "Getting Started" manual.

External trigger as input

If the trigger signal for the R&S FSW is provided by an external reference, the reference signal source must be connected to the R&S FSW and the trigger source must be defined as "External" on the R&S FSW.

Trigger output

The R&S FSW can provide output to another device either to pass on the internal trigger signal, or to indicate that the R&S FSW itself is ready to trigger.

The trigger signal can be output by the R&S FSW automatically, or manually by the user. If it is provided automatically, a high signal is output when the R&S FSW has triggered due to a sweep start ("Device Triggered"), or when the R&S FSW is ready to receive a trigger signal after a sweep start ("Trigger Armed").

Manual triggering

If the trigger output signal is initiated manually, the length and level (high/low) of the trigger pulse is also user-definable. Note, however, that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is provided.

Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .


Trace Evaluation

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Trace Evaluation
Trace Evaluation

Traces in graphical result displays based on the defined result range (see "Result Range") can be configured, for example to perform statistical evaluations over a defined number of sweeps, pulses, or samples.

You can configure up to 6 individual traces for the following result displays (see "Result Range"):
  • "Pulse Frequency"
  • "Pulse Magnitude"
  • "Pulse Phase"
  • "Pulse Phase (Wrapped)"
Contents
  • Mapping Samples to Sweep Points with the Trace Detector
  • Analyzing Several Traces - Trace Mode
  • Trace Statistics


Mapping Samples to Sweep Points with the Trace Detector

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Trace Evaluation > Mapping Samples to Sweep Points with the Trace Detector
Mapping Samples to Sweep Points with the Trace Detector

A trace displays the values measured at the sweep points. The number of samples taken during a sweep is much larger than the number of sweep points that are displayed in the measurement trace.

Example:

Assume the following measurement parameters:

  • Sample rate: 32 MSamples / s
  • Sweep points: 1000
  • Sweep time: 100 ms
  • Span: 5 GHz

During a single sweep, 3.2 * 106 samples are collected and distributed to 1000 sweep points, i.e. 3200 samples are collected per sweep point. For each sweep point, the measured data for a frequency span of 5 MHz (span/<sweep points>) is analyzed.

Note that if you increase the number of sweep points, the frequency span analyzed for each point in the trace decreases, making the result more stable.

Obviously, a data reduction must be performed to determine which of the samples are displayed for each sweep point. This is the trace detector's task.

The trace detector can analyze the measured data using various methods:

The detector activated for the specific trace is indicated in the corresponding trace information by an abbreviation.

Detector types
Detector | Abbrev. | Description
Positive Peak | Pk | Determines the largest of all positive peak values of the levels measured at the individual frequencies which are displayed in one sample point
Negative Peak | Mi | Determines the smallest of all negative peak values of the levels measured at the individual frequencies which are displayed in one sample point
Auto Peak | Ap | Combines the peak detectors; determines the maximum and the minimum value of the levels measured at the individual frequencies which are displayed in one sample point
RMS | Rm | Calculates the root mean square of all samples contained in a sweep point.
Average | Av | Calculates the linear average of all samples contained in a sweep point.
Sample | Sa | Selects the last measured value of the levels measured at the individual frequencies which are displayed in one sample point; all other measured values for the frequency range are ignored

The result obtained from the selected detector for a sweep point is displayed as the value at this frequency point in the trace.

The trace detector for the individual traces can be selected manually by the user or set automatically by the R&S FSW.

The detectors of the R&S FSW are implemented as pure digital devices. All detectors work in parallel in the background, which means that the measurement speed is independent of the detector combination used for different traces.

RMS detector and VBW

If the RMS detector is selected, the video bandwidth in the hardware is bypassed. Thus, duplicate trace averaging with small VBWs and RMS detector no longer occurs. However, the VBW is still considered when calculating the sweep time. This leads to a longer sweep time for small VBW values. Thus, you can reduce the VBW value to achieve more stable trace curves even when using an RMS detector. Normally, if the RMS detector is used the sweep time should be increased to get more stable traces.

Auto detector

If the R&S FSW is set to define the appropriate detector automatically, the detector is set depending on the selected trace mode:

Trace mode | Detector
Clear Write | Auto Peak
Max Hold | Positive Peak
Min Hold | Negative Peak
Average | Sample Peak
View | –
Blank | –


Analyzing Several Traces - Trace Mode

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Trace Evaluation > Analyzing Several Traces - Trace Mode
Analyzing Several Traces - Trace Mode

If several measurement are performed one after the other, or continuous measurement are performed, the trace mode determines how the data for subsequent traces is processed. After each measurement, the trace mode determines whether:

  • the data is frozen (View)
  • the data is hidden (Blank)
  • the data is replaced by new values (Clear Write)
  • the data is replaced selectively (Max Hold, Min Hold, Average)

Each time the trace mode is changed, the selected trace memory is cleared.

The trace mode also determines the detector type if the detector is set automatically, see "Mapping Samples to Sweep Points with the Trace Detector".

The R&S FSW supports the following trace modes:

Overview of available trace modes
Trace Mode | Description
Blank | Hides the selected trace.
Clear Write | Overwrite mode: the trace is overwritten by each measurement. This is the default setting. All available detectors can be selected.
Max Hold | The maximum value is determined over several measurements and displayed. The R&S FSW saves the measurement result in the trace memory only if the new value is greater than the previous one.
Min Hold | The minimum value is determined from several measurements and displayed. The R&S FSW saves the measurement result in the trace memory only if the new value is lower than the previous one.
Average | The average is formed over several measurements and displayed. The "Sweep/Average Count" determines the number of averaging procedures. (See also "Trace Statistics".)
View | The current contents of the trace memory are frozen and displayed.

If a trace is frozen ("View" mode), the instrument settings, apart from level range and reference level (see below), can be changed without impact on the displayed trace. The fact that the displayed trace no longer matches the current instrument setting is indicated by the [image] icon on the tab label.

If the level range or reference level is changed, the R&S FSW automatically adapts the trace data to the changed display range. This allows an amplitude zoom to be made after the measurement in order to show details of the trace.


Trace Statistics

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Trace Evaluation > Trace Statistics
Trace Statistics

Each trace represents an analysis of the data measured in one result range. As described in "Analyzing Several Traces - Trace Mode", statistical evaluations can be performed over several traces, that is, result ranges. Which ranges and how many are evaluated depends on the configuration settings.

Selected pulse vs all pulses

The "Sweep/Average Count" determines how many measurements are evaluated.

For each measurement, in turn, either the selected pulse only (that is: one result range), or all detected pulses (that is: possibly several result ranges) can be included in the statistical evaluation.

Thus, the overall number of averaging steps depends on the "Sweep/Average Count" and the statistical evaluation mode.

Trace statistics - number of averaging steps


Pulse Measurements in MSRA/MSRT Mode

Pulse Measurements (R&S FSW-K6) > Measurement Basics > Pulse Measurements in MSRA/MSRT Mode
Pulse Measurements in MSRA/MSRT Mode

The R&S FSW Pulse application can also be used to analyze data in MSRA or MSRT operating mode. The main difference between the two modes is that in MSRA mode, an I/Q analyzer performs data acquisition, while in MSRT mode, a realtime measurement is performed to capture data.

In MSRA/MSRT operating mode, only the MSRA/MSRT Master actually captures data; the MSRA/MSRT applications receive an extract of the captured data for analysis, referred to as the application data. For the Pulse application in MSRA/MSRT operating mode, the application data range is defined by the same settings used to define the signal capture in Signal and Spectrum Analyzer mode. In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the application data for pulse measurements. The "Capture Buffer" displays show the application data of the Pulse application in MSRA/MSRT mode.

Data coverage for each active application

Generally, if a signal contains multiple data channels for multiple standards, separate applications are used to analyze each data channel. Thus, it is of interest to know which application is analyzing which data channel. The MSRA/MSRT Master display indicates the data covered by each application, restricted to the channel bandwidth used by the corresponding standard, by vertical blue lines labeled with the application name.

Analysis interval

However, the individual result displays of the application need not analyze the complete data range. The data range that is actually analyzed by the individual result display is referred to as the analysis interval.

In the R&S FSW Pulse application the analysis interval is automatically determined according to the result range settings, as in Signal and Spectrum Analyzer mode, for result displays based on an individual pulse. For result displays based on the entire capture buffer, the MSRA/MSRT analysis interval corresponds to the measurement time. The currently used analysis interval (in seconds, related to measurement start) is indicated in the window header for each result display.

Analysis line

A frequent question when analyzing multi-standard signals is how each data channel is correlated (in time) to others. Thus, an analysis line has been introduced. The analysis line is a common time marker for all MSRA applications. It can be positioned in any MSRA application or the MSRA Master and is then adjusted in all other applications. Thus, you can easily analyze the results at a specific time in the measurement in all applications and determine correlations.

If the marked point in time is contained in the analysis interval of the application, the line is indicated in all time-based result displays, such as time, symbol, slot or bit diagrams. By default, the analysis line is displayed, however, it can be hidden from view manually. In all result displays, the "AL" label in the window title bar indicates whether or not the analysis line lies within the analysis interval or not:

  • orange "AL": the line lies within the interval
  • white "AL": the line lies within the interval, but is not displayed (hidden)
  • no "AL": the line lies outside the interval

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .


Configuration

Pulse Measurements (R&S FSW-K6) > Configuration
Configuration

Pulse measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you activate the Pulse application the first time, a set of parameters is passed on from the currently active application (see "Default Settings for Pulse measurements"). After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

When you activate the Pulse application, a pulse measurement for the input signal is started automatically with the default configuration. The "Pulse" menu is displayed and provides access to the most important configuration functions.

Pulse measurements in MSRT mode

When you switch to MSRT mode, the Sequencer is automatically activated in Continuous Sequence mode. Since the default trigger mode is "Free Run" and "Auto Rearm", the MSRT Master continuously performs a realtime measurement until it is stopped. During this time, the Sequencer never passes the data on to other MSRT applications and no evaluation is performed in those result displays.

Thus, it is important that you configure a trigger for the MSRT Master, or stop the Sequencer and switch between the Master and the application tabs manually. In this case, the continuous measurement is stopped when you switch tabs. However, you will have to update the subsequent application displays manually, using the "Refresh" functions (see "Refresh"/"Refresh All" ).

For details see "Configuring and Performing Measurements in MSRT Mode" .

For a description see
  • "Signal Description"
  • "Input and Output Settings"
  • "Data Acquisition"
  • "Pulse Detection"
  • "Pulse Measurement Settings"
  • "Result Configuration"
  • "Pulse Selection"
  • "Display Configuration"

The Auto Set, Marker To, Marker Function, Peak Search, and Lines menus are currently not used.

Automatic refresh of results after configuration changes

The R&S FSW supports you in finding the correct measurement settings quickly and easily - after each change in settings, the measurements are repeated and the result displays are updated immediately and automatically to reflect the changes. You do not need to refresh the display manually. Thus, you can see if the setting is appropriate or not directly through the transparent dialog boxes.

Contents
  • Default Settings for Pulse measurements
  • Configuration Overview
  • Signal Description
  • Input and Output Settings
  • Frontend Settings
  • Trigger Settings
  • Data Acquisition
  • Sweep Settings
  • Pulse Detection
  • Pulse Measurement Settings
  • Automatic Settings


Default Settings for Pulse measurements

Pulse Measurements (R&S FSW-K6) > Configuration > Default Settings for Pulse measurements
Default Settings for Pulse measurements

When you activate the Pulse application the first time, a set of parameters is passed on from the currently active application:

  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation
  • input coupling
  • impedance
  • YIG filter state

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after the Pulse application is activated, or after a "Preset Channel":

Default settings for Pulse channels
Parameter | Value
Sweep mode | CONTINUOUS
Trigger settings | FREE RUN
Trigger offset | 0
Pulse period | High to Low
Pulse Modulation | CW
Consider droop | ON
Pulse width | 50 ns ... 700.0 μs
Minimum off time | 1.0 μs
Measurement filter | Gauss
Measurement BW | 40.0 MHz
Measurement time | 500.0 μs
Sample rate | 140.0 MHz
Record length | 70000
Detection reference | peak
Detection threshold | -10.0 dB
Detection hysteresis | 0.0 dB
Max. pulse count | 1000
Pulse count limit check | off
Top level | Rise/Fall
Measurement levels | 10/50/90 %V
Measurement point | Center
Measurement range | 75 % of Top
Result length | 2.0 μs
Reference point position | Center
Result range alignment | Center
Evaluations | Window 1: Magnitude Capture Window 2: Pulse Results Window 4: Pulse Frequency Window 5: Pulse Magnitude Window 6: Pulse Phase


Configuration Overview

Pulse Measurements (R&S FSW-K6) > Configuration > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

Pulse measurements in MSRT mode

When you switch to MSRT mode, the Sequencer is automatically activated in Continuous Sequence mode. Since the default trigger mode is "Free Run" and "Auto Rearm", the MSRT Master continuously performs a realtime measurement until it is stopped. During this time, the Sequencer never passes the data on to other MSRT applications and no evaluation is performed in those result displays.

Thus, it is important that you configure a trigger for the MSRT Master, or stop the Sequencer and switch between the Master and the application tabs manually. In this case, the continuous measurement is stopped when you switch tabs. However, you will have to update the subsequent application displays manually, using the "Refresh" functions (see "Refresh"/"Refresh All" ).

For details see "Configuring and Performing Measurements in MSRT Mode" .

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. Thus, you can easily configure an entire measurement channel from input over processing to output and evaluation by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Signal Description

    See "Signal Description"

  2. Input and Frontend Settings

    See "Input and Output Settings"

  3. (Optionally:) Trigger/Gate

    See "Trigger Settings"

  4. Data Acquisition

    See "Data Acquisition"

  5. Pulse Detection

    See "Pulse Detection"

  6. Pulse Measurement

    See "Pulse Measurement Settings"

  7. Result Configuration

    See "Result Configuration"

  8. Display Configuration

    See "Display Configuration"

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

└ Preset Channel
└ Specifics for


Preset Channel

Pulse Measurements (R&S FSW-K6) > Configuration > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

For details see "Default Settings for Pulse measurements".

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Specifics for

Pulse Measurements (R&S FSW-K6) > Configuration > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Signal Description

Pulse Measurements (R&S FSW-K6) > Configuration > Signal Description
Signal Description

The signal description provides information on the expected input signal, which optimizes pulse detection and measurement.

└ Pulse Period
└ Pulse Has Droop
└ Pulse Modulation
└ Timing Auto Mode
└ Minimum Pulse Width, Maximum Pulse Width
└ Min Pulse Off Time
└ Frequency Offset Auto Mode
└ Frequency Offset Value
└ Chirp Rate Auto Mode
└ Chirp Rate


Pulse Period

Pulse Measurements (R&S FSW-K6) > Configuration > Signal Description > Pulse Period
Pulse Period

Defines how a pulse is detected.

"High to Low" | The pulse period begins with the falling edge of the preceeding pulse and ends with the falling edge of the current pulse.
"Low to High" | The pulse period begins with the rising edge of the current pulse and end with the rising edge of the succeeding pulse.
Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​PERiod


Pulse Has Droop

Pulse Measurements (R&S FSW-K6) > Configuration > Signal Description > Pulse Has Droop
Pulse Has Droop

If enabled, a pulse can be modeled as having amplitude droop, i.e. the pulse top may not be flat.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​ADRoop


Pulse Modulation

Pulse Measurements (R&S FSW-K6) > Configuration > Signal Description > Pulse Modulation
Pulse Modulation

Defines the expected pulse modulation:

"Arbitrary" | Modulation not considered (no phase error/frequency error results available)
"CW" | Continuous wave modulation, i.e. only the carrier power is modulated (On/Off) For CW modulation, additional parameters are available to define the frequency offset.
"Linear" | Linear frequency modulation (FM) (The frequency changes linearly over time within each pulse) For linear pulse modulation, additional parameters are available to define the chirp rate.
Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​MODulation


Timing Auto Mode

Pulse Measurements (R&S FSW-K6) > Configuration > Signal Description > Timing Auto Mode
Timing Auto Mode

If enabled, the timing parameters (minimum pulse width, maximum pulse width, minimum pulse off time) are determined automatically from the current capture settings.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​DURation:​AUTO


Minimum Pulse Width, Maximum Pulse Width

Pulse Measurements (R&S FSW-K6) > Configuration > Signal Description > Minimum Pulse Width, Maximum Pulse Width
Minimum Pulse Width, Maximum Pulse Width

Defines a minimum and maximum pulse width; pulses outside this range are not detected. The available value range is restricted by the sample rate.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​DURation:​MAX

SENSe:​TRACe:​MEASurement:​DEFine:​DURation:​MIN


Min Pulse Off Time

Pulse Measurements (R&S FSW-K6) > Configuration > Signal Description > Min Pulse Off Time
Min Pulse Off Time

The minimum time the pulse is "off", i.e. the time between successive pulses. This value is used to determine noise statistics and to reject short drops in amplitude during pulse "on" time. The available value range is 50ns to 100s, but may be restricted further by the sample rate.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​DURation:​OFF


Frequency Offset Auto Mode

Pulse Measurements (R&S FSW-K6) > Configuration > Signal Description > Frequency Offset Auto Mode
Frequency Offset Auto Mode

If enabled, the frequency offset is estimated automatically for each individual pulse.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​FREQuency:​OFFSet:​AUTO


Frequency Offset Value

Pulse Measurements (R&S FSW-K6) > Configuration > Signal Description > Frequency Offset Value
Frequency Offset Value

Defines a known frequency offset to be corrected in the pulse acquisition data.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​FREQuency:​OFFSet


Chirp Rate Auto Mode

Pulse Measurements (R&S FSW-K6) > Configuration > Signal Description > Chirp Rate Auto Mode
Chirp Rate Auto Mode

If enabled, the chirp rate is estimated automatically for each individual pulse.

This setting is only available for linear FM pulse modulation.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​FREQuency:​RATE:​AUTO


Chirp Rate

Pulse Measurements (R&S FSW-K6) > Configuration > Signal Description > Chirp Rate
Chirp Rate

Defines a known frequency chirp rate (in Hz/μs) to be used to generate an ideal pulse waveform for computing frequency and phase error parameters. This value is assumed constant for all measured pulses.

This setting is only available for linear pulse modulation.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​FREQuency:​RATE


Input and Output Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings
Input and Output Settings

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals). The settings for data input and output are described here.

The frontend settings are described in "Frontend Settings".

Contents
  • Input Source Settings
  • Output Settings
  • Digital I/Q Output Settings


Input Source Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Output settings are described in "Output Settings".

The Digital I/Q and the Analog Baseband input sources are only available in applications that support I/Q data processing and are described in detail in "Basics on I/Q Data Acquisition and Processing" .

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

Contents
  • Radio Frequency Input
  • Settings for Input from I/Q Data Files
  • External Mixer Settings
  • Digital I/Q Input Settings
  • Analog Baseband Input Settings


Radio Frequency Input

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector


Input Coupling

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Settings for Input from I/Q Data Files

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Settings for Input from I/Q Data Files
Settings for Input from I/Q Data Files

Settings for input from I/Q data files is configured in the "Input Source" > "IQ file" tab of the "Input/Frontend" dialog box, which is available when you do of the following:

  • Press the INPUT/OUTPUT key, then select the "Input Source Config" softkey.
  • Press the MEAS CONFIG key, then select the "Input/Frontend" softkey.
  • From the "Overview", select "Input/Frontend".

For details see "Basics on Input from I/Q Data Files".

└ IQ Input File State
└ Select I/Q Data File


IQ Input File State

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Settings for Input from I/Q Data Files > IQ Input File State
IQ Input File State

Activates input from the selected I/Q input file.

If enabled, the R&S FSW Pulse application performs measurements on the data from this file. Thus, most measurement settings related to data acquisition (attenuation, center frequency, measurement bandwidth, sample rate) cannot be changed. The measurement time can only be decreased, in order to perform measurements on an extract of the available data only.

For details see "Basics on Input from I/Q Data Files".

Note: Even when the file input is deactivated, the input file remains selected and can be activated again quickly by changing the state.

Remote command:

INPut:​SELect


Select I/Q Data File

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Settings for Input from I/Q Data Files > Select I/Q Data File
Select I/Q Data File

Opens a file selection dialog box to select an input file that contains I/Q data.

Note that the I/Q data must have a specific format (.iq.tar) as described in "I/Q Data File Format (iq-tar)".

The default storage location for I/Q data files is C:\R_S\Instr\user\.

For details see "Basics on Input from I/Q Data Files".

Remote command:

INPut:​FILE:​PATH


External Mixer Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings
External Mixer Settings

The external mixer is configured in the "External Mixer" tab of the "Input" dialog box which is available when you do one of the following, if the R&S FSW-B21 option is installed:

  • Press the INPUT/OUTPUT key, then select the "External Mixer Config" softkey.
  • From the "Overview", select "Input", then switch to the "External Mixer" tab under "Input Source".

Note that external mixers are not supported in MSRA/MSRT mode.

Contents
  • Mixer Settings
  • Basic Settings
  • Managing Conversion Loss Tables
  • Creating and Editing Conversion Loss Tables


Mixer Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings
Mixer Settings

In this tab you configure the band and specific mixer settings.

└ External Mixer State
└ RF Start / RF Stop
└ Handover Freq.
└ Band
└ RF Overrange
└ Preset Band
└ Mixer Type
└ Mixer Settings (Harmonics Configuration)
└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


External Mixer State

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


RF Start / RF Stop

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > RF Start / RF Stop
RF Start / RF Stop

Displays the start and stop frequency of the selected band (read-only).

The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

For details on available frequency ranges see table " Frequency ranges for pre-defined bands".

Remote command:

[SENSe:​]MIXer:​FREQuency:​STARt?

[SENSe:​]MIXer:​FREQuency:​STOP?


Handover Freq.

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Handover Freq.
Handover Freq.

Defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency can be selected freely within the overlapping frequency range.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​FREQuency:​HANDover


Band

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Band
Band

Defines the waveguide band or user-defined band to be used by the mixer.

The start and stop frequencies of the selected band are displayed in the "RF Start" and "RF Stop" fields.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

The mixer settings for the user-defined band can be selected freely. The frequency range for the user-defined band is defined via the harmonics configuration (see "Range 1/2").

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND[:​VALue]


RF Overrange

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > RF Overrange
RF Overrange

If enabled, the frequency range is not restricted by the band limits ("RF Start" and "RF Stop"). In this case, the full LO range of the selected harmonics is used.

For details see "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​RFOVerrange[:​STATe]


Preset Band

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Preset Band
Preset Band

Restores the presettings for the selected band.

Note: changes to the band and mixer settings are maintained even after using the PRESET function. This function allows you to restore the original band settings.

Remote command:

[SENSe:​]MIXer:​HARMonic:​BAND:​PRESet


Mixer Type

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Type
Mixer Type

The R&S FSW option B21 supports the following external mixer types:

(See also "Two-port and Three-port Mixers" )

"2 Port" | LO and IF data use the same port
"3 Port" | LO and IF data use separate ports
Remote command:

[SENSe:​]MIXer:​PORTs


Mixer Settings (Harmonics Configuration)

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration)
Mixer Settings (Harmonics Configuration)

The harmonics configuration determines the frequency range for user-defined bands (see "Band").

See also "Frequency Ranges" .

└ Harmonic Type
└ Range 1/2
└ Harmonic Order
└ Conversion loss


Harmonic Type

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Type
Harmonic Type

Defines if only even, only odd, or even and odd harmonics can be used for conversion. Depending on this selection, the order of harmonic to be used for conversion changes (see "Harmonic Order"). Which harmonics are supported depends on the mixer type.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​TYPE


Range 1/2

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Range 1/2
Range 1/2

Enables the use of a second harmonic to cover the band's frequency range.

For each range you can define which harmonic to use and how the "Conversion loss" is handled.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic:​HIGH:​STATe


Harmonic Order

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Harmonic Order
Harmonic Order

Defines which of the available harmonic orders of the LO is used to cover the frequency range.

By default, the lowest order of the specified harmonic type is selected that allows conversion of input signals in the whole band. If due to the LO frequency the conversion is not possible using one harmonic, the band is split.

For the band "USER", the order of harmonic is defined by the user. The order of harmonic can be between 2 and 61, the lowest usable frequency being 26.5 GHz.

See also "Frequency Ranges" .

Remote command:

[SENSe:​]MIXer:​HARMonic[:​LOW]

[SENSe:​]MIXer:​HARMonic:​HIGH[:​VALue]


Conversion loss

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Mixer Settings > Mixer Settings (Harmonics Configuration) > Conversion loss
Conversion loss

Defines how the conversion loss is handled. The following methods are available:

"Average"

Defines the average conversion loss for the entire range in dB.

"Table"

Defines the conversion loss via the table selected from the list. Predefined conversion loss tables are often provided with the external mixer and can be imported to the R&S FSW. Alternatively, you can define your own conversion loss tables. Imported tables are checked for compatibility with the current settings before being assigned.

Conversion loss tables are configured and managed in the "Managing Conversion Loss Tables" tab.

For details on conversion loss tables, see "Conversion Loss Tables" .

For details on importing tables, see "Import Table".

Remote command:

Average for range 1:

[SENSe:​]MIXer:​LOSS[:​LOW]

Table for range 1:

[SENSe:​]MIXer:​LOSS:​TABLe[:​LOW]

Average for range 2:

[SENSe:​]MIXer:​LOSS:​HIGH

Table for range 2:

[SENSe:​]MIXer:​LOSS:​TABLe:​HIGH


Basic Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings
Basic Settings

The basic settings concern general use of an external mixer. They are only available if the "External Mixer State" is "On".

└ External Mixer State
└ LO Level
└ Signal ID
└ Auto ID
└ Auto ID Threshold
└ Bias Settings
└ Write to <CVL table name>


External Mixer State

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


LO Level

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > LO Level
LO Level

Defines the LO level of the external mixer's LO port. Possible values are from 13.0 dBm to 17.0 dBm in 0.1 dB steps. Default value is 15.5 dB.

Remote command:

[SENSe:​]MIXer:​LOPower


Signal ID

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > Signal ID
Signal ID

Activates or deactivates visual signal identification. Two sweeps are performed alternately. Trace 1 shows the trace measured on the upper side band (USB) of the LO (the test sweep), trace 2 shows the trace measured on the lower side band (LSB), i.e. the reference sweep.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

(See also "Automatic Signal Identification" ).

Mathematical functions with traces and trace copy cannot be used with the Signal ID function.

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > Auto ID
Auto ID

Activates or deactivates automatic signal identification.

Auto ID basically functions like "Signal ID". However, the test and reference sweeps are converted into a single trace by a comparison of maximum peak values of each sweep point. The result of this comparison is displayed in trace 3 if "Signal ID" is active at the same time. If "Signal ID" is not active, the result can be displayed in any of the traces 1 to 3. Unwanted mixer products are suppressed in this calculated trace.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​SIGNal


Auto ID Threshold

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > Auto ID Threshold
Auto ID Threshold

Defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison ("Auto ID" function). The input range is between 0.1 dB and 100 dB. Values of about 10 dB (i.e. default setting) generally yield satisfactory results.

See also "Automatic Signal Identification" .

Remote command:

[SENSe:​]MIXer:​THReshold


Bias Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > Bias Settings
Bias Settings

Define the bias current for each range, which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

The trace is adapted to the settings immediately so you can check the results. To store the bias setting in the currently selected conversion loss table, select the "Write to <CVL table name>" button.

Remote command:

[SENSe:​]MIXer:​BIAS[:​LOW]

[SENSe:​]MIXer:​BIAS:​HIGH

└ Write to <CVL table name>


Write to <CVL table name>

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Basic Settings > Bias Settings > Write to <CVL table name>
Write to <CVL table name>

Stores the bias setting in the currently selected "Conversion loss table" for the range (see "Managing Conversion Loss Tables"). If no conversion loss table is selected yet, this function is not available ("CVL Table not selected").

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Managing Conversion Loss Tables

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables
Managing Conversion Loss Tables

In this tab you configure and manage conversion loss tables. Conversion loss tables consist of value pairs that describe the correction values for conversion loss at certain frequencies. The correction values for frequencies between the reference points are obtained via interpolation.

The currently selected table for each range is displayed at the top of the dialog box. All conversion loss tables found in the instrument's C:\r_s\instr\user\cvl\ directory are listed in the "Modify Tables" list.

└ External Mixer State
└ New Table
└ Edit Table
└ Delete Table
└ Import Table


External Mixer State

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > External Mixer State
External Mixer State

Activates or deactivates the external mixer for input. If activated, "ExtMix" is indicated in the channel bar of the application, together with the used band (see "Band").

Remote command:

[SENSe:​]MIXer[:​STATe]


New Table

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > New Table
New Table

Opens the "Edit Conversion loss table" dialog box to configure a new conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Edit Table

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > Edit Table
Edit Table

Opens the "Edit Conversion loss table" dialog box to edit the selected conversion loss table. For details on table configuration see "Creating and Editing Conversion Loss Tables".

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Delete Table

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > Delete Table
Delete Table

Deletes the currently selected conversion loss table after you confirm the action.

Remote command:

[SENSe:​]CORRection:​CVL:​CLEAr


Import Table

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Managing Conversion Loss Tables > Import Table
Import Table

Imports a stored conversion loss table from any directory and copies it to the instrument's C:\r_s\instr\user\cvl\ directory. It can then be assigned for use for a specific frequency range (see "Conversion loss").

For details see "Conversion Loss Tables" .


Creating and Editing Conversion Loss Tables

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables
Creating and Editing Conversion Loss Tables

Conversion loss tables can be defined and edited in the "Edit conversion loss table" dialog box which is displayed when you select the "New Table" button in the "External Mixer > Conversion loss table" settings.

A preview pane displays the current configuration of the conversion loss function as described by the position/value entries.

└ File Name
└ Comment
└ Band
└ Harmonic Order
└ Bias
└ Mixer Name
└ Mixer S/N
└ Mixer Type
└ Position/Value
└ Insert Value
└ Delete Value
└ Shift x
└ Shift y
└ Save


File Name

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > File Name
File Name

Defines the name under which the table is stored in the C:\r_s\instr\user\cvl\ directory on the instrument. The name of the table is identical with the name of the file (without extension) in which the table is stored. This setting is mandatory. The .ACL extension is automatically appended during storage.

Remote command:

[SENSe:​]CORRection:​CVL:​SELect


Comment

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Comment
Comment

An optional comment that describes the conversion loss table. The comment can be freely defined by the user.

Remote command:

[SENSe:​]CORRection:​CVL:​COMMent


Band

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Band
Band

The waveguide or user-defined band for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

Remote command:

[SENSe:​]CORRection:​CVL:​BAND


Harmonic Order

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Harmonic Order
Harmonic Order

The harmonic order of the range for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​HARMonic


Bias

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Bias
Bias

The bias current which is required to set the mixer to its optimum operating point. It corresponds to the short-circuit current. The bias current can range from -10 mA to 10 mA. The actual bias current is lower because of the forward voltage of the mixer diode(s).

Tip: You can also define the bias interactively while a preview of the trace with the changed setting is displayed, see "Bias Settings".

Remote command:

[SENSe:​]CORRection:​CVL:​BIAS


Mixer Name

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Name
Mixer Name

Specifies the name of the external mixer for which the table is to be applied. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​MIXer


Mixer S/N

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer S/N
Mixer S/N

Specifies the serial number of the external mixer for which the table is to be applied.

This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​SNUMber


Mixer Type

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Mixer Type
Mixer Type

Specifies whether the external mixer for which the table is to be applied is a two-port or three-port type. This setting is checked against the current mixer setting before the table can be assigned to the range.

Remote command:

[SENSe:​]CORRection:​CVL:​PORTs


Position/Value

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Position/Value
Position/Value

Each position/value pair defines the correction value for conversion loss for a specific frequency. The reference values must be entered in order of increasing frequencies. A maximum of 50 reference values can be entered. To enter a new value pair, select the "Position/Value" table, or select the "Insert Value" button.

Correction values for frequencies between the reference values are obtained by interpolation. Linear interpolation is performed if the table contains only two values. If it contains more than two reference values, spline interpolation is carried out. Outside the frequency range covered by the table the conversion loss is assumed to be the same as that for the first and last reference value.

(See "Conversion Loss Tables" .)

The current configuration of the conversion loss function as described by the position/value entries is displayed in the preview pane to the right of the table.

Remote command:

[SENSe:​]CORRection:​CVL:​DATA


Insert Value

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Insert Value
Insert Value

Inserts a new position/value entry in the table.

If the table is empty, a new entry at 0 Hz is inserted.

If entries already exist, a new entry is inserted above the selected entry. The position of the new entry is selected such that it divides the span to the previous entry in half.


Delete Value

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Delete Value
Delete Value

Deletes the currently selected position/value entry.


Shift x

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift x
Shift x

Shifts all positions in the table by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the x-axis.


Shift y

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Shift y
Shift y

Shifts all conversion loss values by a specific value. The value can be entered in the edit dialog box. The conversion loss function in the preview pane is shifted along the y-axis.


Save

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > External Mixer Settings > Creating and Editing Conversion Loss Tables > Save
Save

The conversion loss table is stored under the specified name in the C:\r_s\instr\user\cvl\ directory of the instrument.


Digital I/Q Input Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Digital I/Q Input Settings
Digital I/Q Input Settings

The following settings and functions are available to provide input via the Digital Baseband Interface (R&S FSW-B17) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see " Processing Data from the Digital Baseband Interface (-B17)" .

└ Digital I/Q Input State
└ Input Sample Rate
└ Full Scale Level
└ Adjust Reference Level to Full Scale Level
└ Connected Instrument
└ DigIConf


Digital I/Q Input State

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Digital I/Q Input State
Digital I/Q Input State

Enables or disable the use of the "Digital IQ" input source for measurements. "Digital IQ" is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

Remote command:

INPut:​SELect


Input Sample Rate

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Input Sample Rate
Input Sample Rate

Defines the sample rate of the digital I/Q signal source. This sample rate must correspond with the sample rate provided by the connected device, e.g. a generator.

If "Auto" is selected, the sample rate is adjusted automatically by the connected device.

The allowed range is from 100 Hz to 10 GHz.

Remote command:

INPut:​DIQ:​SRATe

INPut:​DIQ:​SRATe:​AUTO


Full Scale Level

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Full Scale Level
Full Scale Level

The "Full Scale Level" defines the level and unit that should correspond to an I/Q sample with the magnitude "1".

If "Auto" is selected, the level is automatically set to the value provided by the connected device.

Remote command:

INPut:​DIQ:​RANGe[:​UPPer]

INPut:​DIQ:​RANGe[:​UPPer]:​UNIT

INPut:​DIQ:​RANGe[:​UPPer]:​AUTO


Adjust Reference Level to Full Scale Level

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Adjust Reference Level to Full Scale Level
Adjust Reference Level to Full Scale Level

If enabled, the reference level is adjusted to the full scale level automatically if any change occurs.

Remote command:

INPut:​DIQ:​RANGe:​COUPling


Connected Instrument

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Connected Instrument
Connected Instrument

Displays the status of the Digital Baseband Interface connection.

This function is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
  • Sample rate of the data currently being transferred via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level"), if provided by connected instrument
Remote command:

INPut:​DIQ:​CDEVice


DigIConf

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > DigIConf
DigIConf

Starts the optional R&S DigIConf application. This softkey is available in the In-/Output menu, but only if the optional software is installed.

Note that R&S DigIConf requires a USB connection (not LAN!) from the R&S FSW to the R&S EX-IQ-BOX in addition to the Digital Baseband Interface (R&S FSW-B17) connection. R&S DigIConf version 2.20.360.86 Build 170 or higher is required.

To return to the R&S FSW application, press any key on the front panel. The R&S FSW application is displayed with the "Input/Output" menu, regardless of which key was pressed.

For details on the R&S DigIConf application, see the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Note: If you close the R&S DigIConf window using the "Close" icon, the window is minimized, not closed.
If you select the "File > Exit" menu item in the R&S DigIConf window, the application is closed. Note that in this case the settings are lost and the EX-IQ-BOX functionality is no longer available until you restart the application using the "DigIConf" softkey in the R&S FSW once again.


Analog Baseband Input Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Analog Baseband Input Settings
Analog Baseband Input Settings

The following settings and functions are available to provide input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see "Processing Data From the Analog Baseband Interface" .

└ Analog Baseband Input State
└ I/Q Mode
└ Input configuration
└ Center Frequency


Analog Baseband Input State

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Analog Baseband Input State
Analog Baseband Input State

Enables or disable the use of the "Analog Baseband" input source for measurements. "Analog Baseband" is only available if the Analog Baseband Interface (R&S FSW-B71) is installed.

Remote command:

INPut:​SELect


I/Q Mode

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > I/Q Mode
I/Q Mode

Defines the format of the input signal.

For more information see "I/Q Processing Modes" .

"I + jQ"

The input signal is filtered and resampled to the sample rate of the application.

Two inputs are required for a complex signal, one for the in-phase component, and one for the quadrature component.

"I Only / Low IF I"

The input signal at the BASEBAND INPUT I connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband I).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF I).

"Q Only / Low IF Q"

The input signal at the BASEBAND INPUT Q connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband Q).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF Q).

Remote command:

INPut:​IQ:​TYPE


Input configuration

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Input configuration
Input configuration

Defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Note: Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Single-ended" setting must be used for all probes.
For details on probes see "Using Probes" .

"Differential" | I, Q and inverse I,Q data
"Single Ended" | I, Q data only
Remote command:

INPut:​IQ:​BALanced[:​STATe]


Center Frequency

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Center Frequency
Center Frequency

Defines the center frequency for analog baseband input.

For real-type baseband input (I or Q only), the center frequency is always 0 Hz.

Note: If the analysis bandwidth to either side of the defined center frequency exceeds the minimum frequency (0 Hz) or the maximum frequency (40 MHz/80 MHz), an error is displayed. In this case, adjust the center frequency or the analysis bandwidth.

Remote command:

[SENSe:​]FREQuency:​CENTer


Output Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Noise Source

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

Remote command:

DIAGnostic:​SERVice:​NSOurce


Trigger 2/3

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Output Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Output Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered" | (Default) Sends a trigger when the R&S FSW triggers.
"Trigger Armed" | Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state. This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).
"User Defined" | Sends a trigger when user selects "Send Trigger" button. In this case, further parameters are available for the output signal.
Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Digital I/Q Output Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Digital I/Q Output Settings
Digital I/Q Output Settings

The optional Digital Baseband Interface (R&S FSW-B17) allows you to output I/Q data from any R&S FSW application that processes I/Q data to an external device. The configuration settings for digital I/Q output can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

Digital output is not available if the bandwidth extension option R&S FSW-B500 is active.

For details on digital I/Q output see "Digital Output" .

└ Digital Baseband Output
└ Output Settings Information
└ Connected Instrument


Digital Baseband Output

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Digital I/Q Output Settings > Digital Baseband Output
Digital Baseband Output

Enables or disables a digital output stream to the optional Digital Baseband Interface (R&S FSW-B17), if available.

Note: If digital baseband output is active, the sample rate is restricted to 200 MHz (max. 160 MHz bandwidth).
The only data source that can be used for digital baseband output is RF input.

Remote command:

OUTPut:​DIQ


Output Settings Information

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Digital I/Q Output Settings > Output Settings Information
Output Settings Information

Displays information on the settings for output via the Digital Baseband Interface (R&S FSW-B17).

The following information is displayed:

  • Maximum sample rate that can be used to transfer data via the Digital Baseband Interface (i.e. the maximum input sample rate that can be processed by the connected instrument)
  • Sample rate currently used to transfer data via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level")
Remote command:

OUTPut:​DIQ:​CDEVice


Connected Instrument

Pulse Measurements (R&S FSW-K6) > Configuration > Input and Output Settings > Digital I/Q Output Settings > Connected Instrument
Connected Instrument

Displays information on the instrument connected to the Digital Baseband Interface (R&S FSW-B17), if available.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
Remote command:

OUTPut:​DIQ:​CDEVice


Frontend Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings
Frontend Settings

The frequency and amplitude settings represent the "frontend" of the measurement setup.

Contents
  • Frequency Settings
  • Amplitude Settings


Frequency Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Frequency Settings
Frequency Settings

Frequency settings can be configured via the "Frequency" dialog box, which is displayed when you do one of the following:

  • Select the FREQ key and then the "Frequency Config" softkey.
  • Select the "Frequency" tab in the "Input/Frontend Settings" dialog box.
└ Center frequency
└ Center Frequency Stepsize
└ Frequency Offset


Center frequency

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Frequency Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

span > 0: spanmin/2 ≤ fcenter ≤ fmax – spanmin/2

zero span: 0 Hz ≤ fcenter ≤ fmax

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Center Frequency Stepsize

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Frequency Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to another value or it can be manually set to a fixed value.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"= Center" | Sets the step size to the value of the center frequency. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Frequency Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Note: In MSRA/MSRT mode, this function is only available for the MSRA/MSRT Master.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Amplitude Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Amplitude Settings
Amplitude Settings

Amplitude settings affect the y-axis values.

The scaling settings are described in "Y-Scaling". The units are described in "Units".

└ Reference Level
└ Shifting the Display (Offset)
└ Mechanical Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance
└ Auto Scale Window


Reference Level

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Amplitude Settings > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display.

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)


Shifting the Display (Offset)

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Amplitude Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Mechanical Attenuation

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Amplitude Settings > Mechanical Attenuation
Mechanical Attenuation

Defines the mechanical attenuation for RF input.

└ Attenuation Mode / Value


Attenuation Mode / Value

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Amplitude Settings > Mechanical Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Preamplifier (option B24)

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Auto Scale Window

Pulse Measurements (R&S FSW-K6) > Configuration > Frontend Settings > Amplitude Settings > Auto Scale Window
Auto Scale Window

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings in the currently selected window. No new measurement is performed.


Trigger Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings
Trigger Settings

Trigger settings determine when the input signal is measured.

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. Thus, no trigger settings are available in the Pulse application in MSRA/MSRT operating mode. However, a capture offset can be defined with a similar effect as a trigger offset. It defines an offset from the start of the captured data (from the MSRA/MSRT Master) to the start of the application data for pulse measurements. (See "Capture Offset".)

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

└ Trigger Settings
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ I/Q Power
└ IF Power
└ RF Power
└ Trigger Level (Repetition interval)
└ Drop-Out Time
└ Trigger Offset
└ Slope
└ Hysteresis
└ Trigger Holdoff
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger
└ Capture Offset
└ Segmented Capture
└ Activating/de-activating segmented data capturing
└ Events
└ Trigger Offset
└ Segment Length


Trigger Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings
Trigger Settings

The trigger settings define the beginning of a measurement.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ I/Q Power
└ IF Power
└ RF Power
└ Trigger Level (Repetition interval)
└ Drop-Out Time
└ Trigger Offset
└ Slope
└ Hysteresis
└ Trigger Holdoff


Trigger Source

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

Note: When triggering is activated, the squelch function is automatically disabled.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ I/Q Power
└ IF Power
└ RF Power


Free Run

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)").

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


I/Q Power

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Trigger Source > I/Q Power
I/Q Power

This trigger source is not available if the optional Digital Baseband Interface (R&S FSW-B17) or Analog Baseband Interface (R&S FSW-B71) is used for input. It is also not available for analysis bandwidths ≥ 160 MHz.

Triggers the measurement when the magnitude of the sampled I/Q data exceeds the trigger threshold.

Remote command:

TRIG:SOUR IQP, see TRIGger[:​SEQuence]:​SOURce


IF Power

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Trigger Source > IF Power
IF Power

The R&S FSW starts capturing data as soon as the trigger level is exceeded around the third intermediate frequency.

This trigger source is only available for RF input.

For frequency sweeps, the third IF represents the start frequency. The trigger bandwidth at the third IF depends on the RBW and sweep type.

For measurements on a fixed frequency (e.g. zero span or I/Q measurements), the third IF represents the center frequency.

The available trigger levels depend on the RF attenuation and preamplification. A reference level offset, if defined, is also considered.

For details on available trigger levels and trigger bandwidths see the data sheet.

Note: Be aware that in auto sweep type mode, due to a possible change in sweep types, the trigger bandwidth may vary considerably for the same RBW setting.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce


RF Power

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Trigger Source > RF Power
RF Power

Defines triggering of the measurement via signals which are outside the displayed measurement range.

For this purpose the instrument uses a level detector at the first intermediate frequency. The input signal must be in the frequency range between 500 MHz and 8 GHz.

The resulting trigger level at the RF input depends on the RF attenuation and preamplification. For details on available trigger levels see the data sheet.

Note: If the input signal contains frequencies outside of this range (e.g. for fullspan measurements), the sweep may be aborted and a message indicating the allowed input frequencies is displayed in the status bar.

A "Trigger Offset", "Trigger Polarity" and "Trigger Holdoff" (to improve the trigger stability) can be defined for the RF trigger, but no "Hysteresis".

Remote command:

TRIG:SOUR RFP, see TRIGger[:​SEQuence]:​SOURce


Trigger Level (Repetition interval)

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Trigger Level (Repetition interval)
Trigger Level (Repetition interval)

Defines the trigger level for the specified trigger source. For time triggers, the repetition interval is defined.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel:​IFPower

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]


Drop-Out Time

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time" .

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Trigger Offset

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

Note: In MSRA/MSRT mode, the trigger offset defines the start of the sweep only for the MSRA/MSRT Master. For MSRA/MSRT applications, use the "Capture Offset" instead.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger) Only possible for zero span (e.g. I/Q Analyzer application) and gated trigger switched off Maximum allowed range limited by the sweep time: pretriggermax = sweep time
Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Slope

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Hysteresis

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Trigger Settings > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Capture Offset

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Capture Offset
Capture Offset

This setting is only available for applications in MSRA or MSRT operating mode. It has a similar effect as the trigger offset in other measurements: it defines the time offset between the capture buffer start and the start of the extracted application data.

In MSRA mode, the offset must be a positive value, as the capture buffer starts at the trigger time = 0.

In MSRT mode, the offset may be negative if a pretrigger time is defined.

For details on the MSRA operating mode see "Applications and Operating Modes" .

For details on the MSRT operating mode see "Applications and Operating Modes" .

Remote command:

[SENSe:​]MSRA:​CAPTure:​OFFSet

[SENSe:​]RTMS:​CAPTure:​OFFSet


Segmented Capture

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Segmented Capture
Segmented Capture

Configures data capturing with a gating function, that is non-continuous data acquisition.

Segmented capture is only possible if an external, IF Power, or RF Power trigger is used (see "Trigger Source").

For details on segmented data capture see "Segmented Data Capturing".

└ Activating/de-activating segmented data capturing
└ Events
└ Trigger Offset
└ Segment Length


Activating/de-activating segmented data capturing

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Segmented Capture > Activating/de-activating segmented data capturing
Activating/de-activating segmented data capturing

If activated, data is captured for the specified duration before and after each trigger event, for the specified number of trigger events. The signal data between these capture times is not stored in the capture buffer.

Segmented capture is only possible if an external, IF Power, or RF Power trigger is used (see "Trigger Source"). For details on segmented data capture see "Segmented Data Capturing".

Remote command:

[SENSe:​]SWEep:​SCAPture[:​STATe]


Events

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Segmented Capture > Events
Events

Specifies the number of trigger events for which data segments are to be captured. If multiple events occur within one segment length, the segment is extended (see "Number of events vs number of segments").

Segmented capture is only possible if an external, IF Power, or RF Power trigger is used (see "Trigger Source"). For details on segmented data capture see "Segmented Data Capturing".

Remote command:

[SENSe:​]SWEep:​SCAPture:​EVENts


Trigger Offset

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Segmented Capture > Trigger Offset
Trigger Offset

Defines an offset to the trigger event at which data capturing starts. For a negative offset, data capturing starts before the actual trigger event.

Remote command:

[SENSe:​]SWEep:​SCAPture:​OFFSet[:​TIME]

TRACe<n>:​IQ:​SCAPture:​TSTamp:​SSTart?

TRACe<n>:​IQ:​SCAPture:​TSTamp:​TRIGger?


Segment Length

Pulse Measurements (R&S FSW-K6) > Configuration > Trigger Settings > Segmented Capture > Segment Length
Segment Length

Defines a time period starting from the "Trigger Offset" in which data is captured. If multiple events occur within one segment length, the segment is extended (see "Number of events vs number of segments").

Remote command:

[SENSe:​]SWEep:​SCAPture:​LENGth[:​TIME]


Data Acquisition

Pulse Measurements (R&S FSW-K6) > Configuration > Data Acquisition
Data Acquisition

You must define how much and how data is captured from the input signal.

The Pulse Detection settings are described in "Pulse Detection".

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. The data acquisition settings for the Pulse application in MSRA/MSRT mode define the application data extract and analysis interval.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

The settings in this dialog box are available when you do one of the following:

  • Select the "Data Acquisition" button from the "Overview".
  • Press the BW or SPAN key, then the "Bandwidth Config" softkey.
  • Press the MEAS key, then the "Data Acquisition" softkey.
Input from I/Q data files

If the input source is an I/Q data file (see "Settings for Input from I/Q Data Files"), most measurement settings related to data acquisition (attenuation, center frequency, measurement bandwidth, sample rate) cannot be changed. The measurement time can only be decreased, in order to perform measurements on an extract of the available data (from the beginning of the file) only.

For details see "Basics on Input from I/Q Data Files".

└ Filter type
└ Measurement Bandwidth
└ Sample rate
└ Measurement Time
└ Record length


Filter type

Pulse Measurements (R&S FSW-K6) > Configuration > Data Acquisition > Filter type
Filter type

Defines the filter to be used for demodulation.

"Flat" | Standard flat demodulation filter
"Gauss" | Filter with optimized settling behaviour (default) Note: For Gaussian filters whose -3dB bandwidth is large compared to the maximum I/Q bandwidth, the ideal Gaussian filter shape would exceed the maximum I/Q bandwidth at its outer edges. Thus, the actual filter only follows the ideal Gaussian filter shape in the inner range of the set I/Q bandwidth. At a certain frequency offset it must deviate from the ideal Gauss filter and drop off faster. For details see "Effects of Large Gauss Filters".
Remote command:

[SENSe:​]BANDwidth|BWIDth:​DEMod:​TYPE


Measurement Bandwidth

Pulse Measurements (R&S FSW-K6) > Configuration > Data Acquisition > Measurement Bandwidth
Measurement Bandwidth

The measurement bandwidth is defined by the used filter and the sample rate. Either a flat or a Gauss filter are available. For information on supported sample rates and filter bandwidths see the data sheet.

Note: If the input source is an I/Q data file (see "Settings for Input from I/Q Data Files"), the measurement bandwidth cannot be changed.
For details see "Basics on Input from I/Q Data Files".

Remote command:

[SENSe:​]BANDwidth:​DEMod


Sample rate

Pulse Measurements (R&S FSW-K6) > Configuration > Data Acquisition > Sample rate
Sample rate

The sample rate for I/Q data acquisition is indicated for reference only. It is calculated from the defined measurement bandwidth and measurement time, or taken from the I/Q data input file.


Measurement Time

Pulse Measurements (R&S FSW-K6) > Configuration > Data Acquisition > Measurement Time
Measurement Time

Defines how long data is captured for analysis ("Meas Time"), or how many samples are captured in each record ("Record Length").

Note: If the input source is an I/Q data file (see "Settings for Input from I/Q Data Files"), the measurement time can only be decreased, in order to perform measurements on an extract of the available data (from the beginning of the file) only.
For details see "Basics on Input from I/Q Data Files".

The maximum measurement time in the R&S FSW Pulse application is limited only by the available memory ("memory limit reached" message is shown in status bar). Note, however, that increasing the measurement time (and thus reducing the available memory space) may restrict the number of measurement channels that can be activated simultaneously on the R&S FSW.

Remote command:

[SENSe:​]SWEep:​TIME


Record length

Pulse Measurements (R&S FSW-K6) > Configuration > Data Acquisition > Record length
Record length

The record length for I/Q data acquisition is indicated for reference only. It is calculated from the defined measurement bandwidth and measurement time, or taken from the I/Q data input file.


Sweep Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Sweep Settings
Sweep Settings

The sweep settings define how often data from the input signal is acquired and then evaluated. They are configured via the SWEEP key.

└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep
└ Refresh
└ Measurement Time
└ Sweep/Average Count


Continuous Sweep/RUN CONT

Pulse Measurements (R&S FSW-K6) > Configuration > Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

After triggering, starts the sweep and repeats it continuously until stopped. This is the default setting.

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. If the Sequencer is active, the "Continuous Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in continuous sweep mode is swept repeatedly.
If the Sequencer is active in MSRT mode, the "Continuous Sweep" function does not start data capturing; it merely has an effect on trace averaging over multiple sequences. In this case, trace averaging is performed.
Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

Pulse Measurements (R&S FSW-K6) > Configuration > Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

After triggering, starts the number of sweeps set in "Sweep Count". The measurement stops after the defined number of sweeps has been performed.

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active, the "Single Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer.
If the Sequencer is active in MSRT mode, the "Single Sweep" function does not start data capturing; it merely has an effect on trace averaging over multiple sequences. In this case, no trace averaging is performed.
Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

Pulse Measurements (R&S FSW-K6) > Configuration > Sweep Settings > Continue Single Sweep
Continue Single Sweep

After triggering, repeats the number of sweeps set in "Sweep Count", without deleting the trace of the last measurement.

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Refresh

Pulse Measurements (R&S FSW-K6) > Configuration > Sweep Settings > Refresh
Refresh

This function is only available if the Sequencer is deactivated and only for MSRA or MSRT applications.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

This is useful, for example, after evaluation changes have been made or if a new sweep was performed from another application; in this case, only that application is updated automatically after data acquisition.

Note: To update all active applications at once, use the "Refresh all" function in the "Sequencer" menu.
(See "Refresh All" ).

Remote command:

INITiate:​REFResh


Measurement Time

Pulse Measurements (R&S FSW-K6) > Configuration > Sweep Settings > Measurement Time
Measurement Time

Defines how long data is captured for analysis ("Meas Time"), or how many samples are captured in each record ("Record Length").

Note: If the input source is an I/Q data file (see "Settings for Input from I/Q Data Files"), the measurement time can only be decreased, in order to perform measurements on an extract of the available data (from the beginning of the file) only.
For details see "Basics on Input from I/Q Data Files".

The maximum measurement time in the R&S FSW Pulse application is limited only by the available memory ("memory limit reached" message is shown in status bar). Note, however, that increasing the measurement time (and thus reducing the available memory space) may restrict the number of measurement channels that can be activated simultaneously on the R&S FSW.

Remote command:

[SENSe:​]SWEep:​TIME


Sweep/Average Count

Pulse Measurements (R&S FSW-K6) > Configuration > Sweep Settings > Sweep/Average Count
Sweep/Average Count

Defines the number of sweeps to be performed in the single sweep mode. Values from 0 to 200000 are allowed. If the values 0 or 1 are set, one sweep is performed.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

For more information see "How Much Data is Measured: Sweep Points and Sweep Count" .

The "Average Count" also determines the number of measurements used to calculate the pulse trace statistics for the result range displays (see "Trace Statistics").

Remote command:

[SENSe:​]SWEep:​COUNt

[SENSe:​]AVERage:​COUNt


Pulse Detection

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Detection
Pulse Detection

The pulse detection settings define the conditions under which a pulse is detected within the input signal.

└ Reference Source
└ Threshold
└ Hysteresis
└ Detection Limit
└ Maximum Pulse Count


Reference Source

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Detection > Reference Source
Reference Source

Defines the level to be used as a reference for the pulse detection threshold.

"Reference" | Current reference level
"Peak" | Peak level as measured over the entire capture data interval
"Noise" | Noise level determined from the current capture data according to the "Min Pulse Off Time" parameter set in "Signal Description".
"Absolute" | Absolute level defined by the "Threshold"
Remote command:

[SENSe:​]DETect:​REFerence


Threshold

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Detection > Threshold
Threshold

The threshold determines whether a pulse is detected or not. The top of a pulse must exceed the threshold in order to be detected. The threshold is defined in dB in relation to the defined reference, or as an absolute threshold in dBm.

Remote command:

[SENSe:​]DETect:​THReshold


Hysteresis

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Detection > Hysteresis
Hysteresis

Defines a hysteresis for pulse detection in dB in relation to the defined threshold. As long as the signal does not exceed the hysteresis, the next threshold crossing is ignored.

Remote command:

[SENSe:​]DETect:​HYSTeresis


Detection Limit

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Detection > Detection Limit
Detection Limit

Restricts the number of pulses to be detected. When the maximum number is exceeded, measurement is stopped for the current capture buffer. This limitation can be used to speed up the measurement if only a small number of pulses is of interest.

The maximum number of pulses to be detected is defined using the "Maximum Pulse Count" setting.

Remote command:

[SENSe:​]DETect:​LIMit


Maximum Pulse Count

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Detection > Maximum Pulse Count
Maximum Pulse Count

Defines the maximum number of pulses to be detected.

This limit is ignored if "Detection Limit" is disabled.

Remote command:

[SENSe:​]DETect:​LIMit:​COUNt


Pulse Measurement Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings
Pulse Measurement Settings

The pulse measurement settings determine how much data is measured for each pulse, in relation to defined levels, points, or ranges. Which definition is actually used during measurement depends on the selected evaluation method.

Contents
  • Measurement Levels
  • Measurement Point
  • Measurement Range


Measurement Levels

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Levels
Measurement Levels

Some measurements are performed depending on defined levels.

└ Position
└ Measurement Algorithm
└ Ripple Portion
└ Reference Level Unit
└ High (Distal) Threshold
└ Mid (Mesial) Threshold
└ Low (Proximal) Threshold
└ Boundary


Position

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Levels > Position
Position

Determines where the 100% value (from base to top) for the rise and fall time measurements is calculated.

This allows you to consider a "droop" in the pulse top during the pulse measurements. If a droop is to be considered, the 100% value must be calculated separately for the rising and falling edges.

"Edge" | The 100% value is measured separately for the rising and falling edges.
"Center" | The 100% value is measured at the pulse center and used for all measurements.
Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​COMPensate:​ADRoop


Measurement Algorithm

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Levels > Measurement Algorithm
Measurement Algorithm

Defines the algorithm used to detect the pulse top level.

"Mean" | The arithmetic average of the measured values
"Median" | The level for which half the values lie above, the other half below in the histogram
Remote command:

SENSe:​TRACe:​MEASurement:​ALGorithm


Ripple Portion

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Levels > Ripple Portion
Ripple Portion

Defines the portion of the pulse top which is used to measure the ripple.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​RIPPle


Reference Level Unit

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Levels > Reference Level Unit
Reference Level Unit

Defines the unit of the pulse amplitude values, i.e. whether magnitude (V) or power (W, dBm) values are used to determine the threshold levels for fall and rise times.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​AMPLitude:​UNIT


High (Distal) Threshold

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Levels > High (Distal) Threshold
High (Distal) Threshold

The upper threshold in percent of the pulse amplitude used to signify the end of a rising or beginning of a falling signal level.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​TRANsition:​HREFerence


Mid (Mesial) Threshold

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Levels > Mid (Mesial) Threshold
Mid (Mesial) Threshold

The middle threshold in percent of the pulse amplitude used to signify the signify the mid-transition level between pulse states.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​TRANsition:​REFerence


Low (Proximal) Threshold

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Levels > Low (Proximal) Threshold
Low (Proximal) Threshold

The lower threshold in percent of the pulse amplitude used to signify the end of a falling or beginning of a rising signal level.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​TRANsition:​LREFerence


Boundary

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Levels > Boundary
Boundary

The boundary in percent of the pulse amplitude to either side of the pulse top (ON state). Used to determine the settling time, for example. Once the signal remains within the boundary, it is assumed to have settled.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​BOUNdary:​TOP


Measurement Point

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Point
Measurement Point

Some specific pulse parameters, e.g. the phase or the frequency, are determined at a specific time instant (measurement point) within the pulse. You can configure this point based on a reference and offset value.

└ Measurement Point Reference
└ Offset
└ Averaging Window


Measurement Point Reference

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Point > Measurement Point Reference
Measurement Point Reference

Defines the reference which the "Offset" refers to.

"Rise" | The measurement point is defined in reference to the rising edge (mid-level crossing).
"Center" | The measurement point is defined in reference to the center of the pulse (equal distance from the rising and falling mid-level crossings).
"Fall" | The measurement point is defined in reference to the falling edge (mid-level crossing).
Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​INSTant:​REFerence


Offset

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Point > Offset
Offset

The time offset of the measurement point in reference to the pulse center or an edge, depending on the "Measurement Point Reference" setting.

The "Offset" is indicated in the dialog box.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​INSTant


Averaging Window

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Point > Averaging Window
Averaging Window

Measurement point results are averaged over a window centered at the measurement point. The length of the averaging window in seconds can be defined. A minimum length of 1 sample is enforced internally.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​INSTant:​AWINdow


Measurement Range

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Range
Measurement Range

Some measurements are performed over a range within the pulse, for example the phase or frequency deviation. The measurement range is specified either by start and end points relative to the rising and falling edges, or as a proportion of the pulse top.

└ Reference


Reference

Pulse Measurements (R&S FSW-K6) > Configuration > Pulse Measurement Settings > Measurement Range > Reference
Reference

Defines the reference for the measurement range definition. Depending on the selected reference type, an additional setting is available to define the range.

"Center" | Defines a relative range around the center of the pulse. The range is defined by its length in percent of the pulse top.
"Edge" | Defines the start and stop of the measurement range with respect to the pulse edges. The range is defined by a time offset from the middle of the rising edge and a time offset from the middle of the falling edge.
Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​ESTimation:​REFerence

Relative range (Center):

SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​ESTimation:​LENGth

Absolute range (Edge):

SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​ESTimation:​OFFSet:​LEFT

SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​ESTimation:​OFFSet:​RIGHt


Automatic Settings

Pulse Measurements (R&S FSW-K6) > Configuration > Automatic Settings
Automatic Settings

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

└ Auto Scale Continuous (All)
└ Auto Scale Once (All)


Auto Scale Continuous (All)

Pulse Measurements (R&S FSW-K6) > Configuration > Automatic Settings > Auto Scale Continuous (All)
Auto Scale Continuous (All)

Automatically determines the optimal result range and reference level position for each new measurement in all displayed diagrams (for graphical or pulse-based result displays only).

Remote command:

SENS:TRAC:MEAS:DEF:RRAN:AUTO ON, see SENSe:​TRACe:​MEASurement:​DEFine:​RRANge:​AUTO

DISP:TRAC:Y:SCAL:AUTO ON, see DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO


Auto Scale Once (All)

Pulse Measurements (R&S FSW-K6) > Configuration > Automatic Settings > Auto Scale Once (All)
Auto Scale Once (All)

Automatically determines the optimal result range and reference level position once for the current measurement settings in all displayed diagrams and pulse-based result displays. All automatic scaling functions are then switched off.

Remote command:

SENS:TRAC:MEAS:DEF:RRAN:AUTO ONCE, see SENSe:​TRACe:​MEASurement:​DEFine:​RRANge:​AUTO

DISP:TRAC:Y:SCAL:AUTO ONCE, see DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO


Analysis

Pulse Measurements (R&S FSW-K6) > Analysis
Analysis

After a Pulse measurement has been performed, you can analyze the results in various ways.

Contents
  • Result Configuration
  • Display Configuration
  • Markers
  • Trace Configuration
  • Export Functions
  • Zoom Functions
  • Analysis in MSRA/MSRT Mode


Result Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration
Result Configuration

Some evaluation methods require or allow for additional settings to configure the result display. Note that the available settings depend on the selected window (see "Specifics for").

The "Result Configuration" dialog box is available by selecting the "Result Config" softkey or the "Result Config" button in the "Overview".

Marker settings and functions are described in "Markers".

Contents
  • Pulse Selection
  • Result Range
  • Result Range Spectrum Configuration
  • Parameter Configuration for Result Displays
  • Table Configuration
  • Y-Scaling
  • Units


Pulse Selection

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Pulse Selection
Pulse Selection

The pulse traces (frequency, magnitude and pulse vs. time) always display the trace for one specific pulse, namely the currently selected pulse. To select a pulse, tap the "Selected Pulse" softkey in the "Pulse Meas" menu.

The currently selected pulse is highlighted blue in the Pulse Results and Pulse Statistics displays.

As soon as a new pulse is selected, all pulse-specific displays are automatically updated.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​SELected


Result Range

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Result Range
Result Range

The result range determines which data is displayed on the screen (see also "Measurement range vs result range"). This range applies to the pulse magnitude, frequency and phase vs time displays.

Furthermore, the spectrum for the result range can be displayed (see "Result Range Spectrum").

The "Result Range" settings are available from a tab in the "Result Configuration" dialog box, which is displayed when you select the "Result Config" softkey or the "Result Config" button in the "Overview".

The range is defined by a reference point, alignment and the range length.

└ Automatic Range Scaling
└ Result Range Reference Point
└ Offset
└ Alignment
└ Length


Automatic Range Scaling

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Result Range > Automatic Range Scaling
Automatic Range Scaling

Defines whether the result range length is determined automatically according to the width of the selected pulse (see "Pulse Selection").

Note: The result range is applied to all pulse-based result displays.

"OFF" | Switches automatic range scaling off
"ON" | Switches automatic range scaling on
"ONCE" | Executes automatic range scaling once and then switches it off
Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​RRANge:​AUTO


Result Range Reference Point

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Result Range > Result Range Reference Point
Result Range Reference Point

Defines the reference point for positioning the result range. The "Offset" is given with respect to this value.

"Rise" | The result range is defined in reference to the rising edge.
"Center" | The result range is defined in reference to the center of the pulse top.
"Fall" | The result range is defined in reference to the falling edge.
Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​RRANge:​REFerence


Offset

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Result Range > Offset
Offset

The offset in seconds from the pulse edge or center at which the result range reference point occurs.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​RRANge:​OFFSet


Alignment

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Result Range > Alignment
Alignment

Defines the alignment of the result range in relation to the selected "Result Range Reference Point".

"Left" | The result range starts at the pulse center or selected edge.
"Center" | The result range is centered around the pulse center or selected edge.
"Right" | The result range ends at the pulse center or selected edge.
Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​RRANge:​ALIGnment


Length

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Result Range > Length
Length

Defines the length or duration of the result range.

Remote command:

SENSe:​TRACe:​MEASurement:​DEFine:​RRANge:​LENGth


Result Range Spectrum Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Result Range Spectrum Configuration
Result Range Spectrum Configuration

For the Result Range Spectrum display additional settings are available for the FFT.

The "Result Range Spectrum" settings are available from a tab in the "Result Configuration" dialog box, which is displayed when you select the "Result Config" softkey or the "Result Config" button in the "Overview".

└ Window Type
└ ResBW Manual
└ RBW Auto


Window Type

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Result Range Spectrum Configuration > Window Type
Window Type

Used FFT window type for Result Range Spectrum. The same window types are available as for Parameter Spectrum displays (see "Window functions").

Remote command:

CALCulate<n>:​RRSPectrum:​WINDow


ResBW Manual

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Result Range Spectrum Configuration > ResBW Manual
ResBW Manual

Defines the resolution bandwidth for the Result Range Spectrum.

The resolution bandwidth defines the minimum frequency separation at which the individual components of a spectrum can be distinguished. Small values result in a high precision, as the distance between two distinguishable frequencies is small, but require a larger measurement interval (that is: longer Result Range length) for the calculation. Higher values decrease the precision, but can increase measurement speed.

Remote command:

CALCulate<n>:​RRSPectrum:​RBW


RBW Auto

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Result Range Spectrum Configuration > RBW Auto
RBW Auto

If activated, a resolution bandwidth is selected automatically which provides a good balance between fast measurement speed and high spectral resolution.

Remote command:

CALCulate<n>:​RRSPectrum:​AUTO


Parameter Configuration for Result Displays

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays
Parameter Configuration for Result Displays

For parameter trend or distribution displays you can define which parameters are to be evaluated in each window.

Contents
  • Parameter Distribution Configuration
  • Parameter Spectrum Configuration
  • Parameter Trend Configuration


Parameter Distribution Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Distribution Configuration
Parameter Distribution Configuration

The parameter distribution evaluations allow you to visualize the number of occurrances for a specific parameter value within the current capture buffer. For each parameter distribution window you can configure which measured parameter is to be displayed.

This tab is only available for windows with a Parameter Distribution evaluation.

└ Parameter Group
└ X-Axis
└ Y-Axis
└ Histogram Bins
└ Display Limit Lines


Parameter Group

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Distribution Configuration > Parameter Group
Parameter Group

Defines the group of parameters from which one can be selected to display the distribution of the measured values on the y-axis. For a description of the parameters see "Pulse Parameters".


X-Axis

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Distribution Configuration > X-Axis
X-Axis

Defines the parameter for which the values are displayed on the x-axis. The available parameters depend on the selected "Parameter Group".

Remote command:

CALCulate<n>:DISTribution:<GroupName> <X-Axis>,<Y-Axis>, see e.g. CALCulate<n>:​DISTribution:​FREQuency


Y-Axis

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Distribution Configuration > Y-Axis
Y-Axis

Defines the scaling of the y-axis.

"Pulse count" | Number of pulses in which the value occurred.
"Occurrence" | Number of occurrences in percent of all measured values.


Histogram Bins

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Distribution Configuration > Histogram Bins
Histogram Bins

Number of columns on the x-axis, i.e. the number of measurement value ranges for which the occurrences are determined.

Remote command:

CALCulate<n>:​DISTribution:​NBINs


Display Limit Lines

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Distribution Configuration > Display Limit Lines
Display Limit Lines

Hides or shows the limit lines in the selected Parameter Trend or Parameter Distribution result display. You can drag these lines to a new position in the window. The new position is maintained, the limit check is repeated, and the results of the limit check in any active table displays are adapted.

Note that this function only has an effect on the visibility of the lines in the graphical displays, it does not affect the limit check in general or the display of the limit check results in the table displays.

Remote command:

CALCulate<n>:​DISTribution:​LLINes[:​STATe]

CALCulate<n>:​TRENd:​LLINes[:​STATe]


Parameter Spectrum Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Spectrum Configuration
Parameter Spectrum Configuration

Calculates an FFT for a selected column of the Pulse Results table. This "spectrum" allows you to easily determine the frequency of periodicities in the pulse parameters.

For each Parameter Spectrum window you can configure which measured parameter is to be displayed and how the spectrum is determined.

This tab is only available for windows with a Parameter Spectrum evaluation.

For more information on how the parameter spectrum is calculated see "Parameter Spectrum Calculation".

└ Parameter Group
└ Parameter
└ Full Auto
└ Maximum Frequency
└ Window Type
└ Block Size
└ Gap Threshold
└ Sectioning Threshold


Parameter Group

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Spectrum Configuration > Parameter Group
Parameter Group

Defines the group of parameters from which one can be selected to display the FFT of the measured values. For a description of the parameters see "Pulse Parameters".


Parameter

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Spectrum Configuration > Parameter
Parameter

Defines the parameter for which the FFT is calculated and displayed. The available parameters depend on the selected "Parameter Group".

Remote command:

CALCulate<n>:PSPectrum:<GroupName> <X-Axis>, see e.g. CALCulate<n>:​PSPectrum:​FREQuency


Full Auto

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Spectrum Configuration > Full Auto
Full Auto

Determines the Parameter Spectrum settings automatically. For most measurement cases, automatic configuration should be suitable.

If enabled, the individual settings are not available.

For more information on how the parameter spectrum is calculated see "Parameter Spectrum Calculation".

Remote command:

CALCulate<n>:​PSPectrum:​AUTO


Maximum Frequency

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Spectrum Configuration > Maximum Frequency
Maximum Frequency

Defines the maximum frequency span for which the Spectrum is calculated. Internally, the span is limited by the number of possible interpolation samples (100 000). Limiting the span to the actually required frequencies decreases the calculation time and can improve the obtained RBW.

For more information see "Parameter Spectrum Calculation".

Remote command:

CALCulate<n>:​PSPectrum:​MAXFrequency


Window Type

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Spectrum Configuration > Window Type
Window Type

Used FFT window type

For more information see "Parameter Spectrum Calculation".

Remote command:

CALCulate<n>:​PSPectrum:​WINDow


Block Size

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Spectrum Configuration > Block Size
Block Size

Size of block used in spectrum calculation. Windowing and averaging are used to combine blocks. The block size also determines the resulting RBW of the spectrum.

For more information see "Parameter Spectrum Calculation".

Remote command:

CALCulate<n>:​PSPectrum:​BLOCksize


Gap Threshold

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Spectrum Configuration > Gap Threshold
Gap Threshold

Minimum time that must pass before a gap is detected as such.

For more information see "Parameter Spectrum Calculation".

Remote command:

CALCulate<n>:​PSPectrum:​GTHReshold


Sectioning Threshold

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Spectrum Configuration > Sectioning Threshold
Sectioning Threshold

Minimum section size as a percentage of the block size. Sections that are smaller than the threshold are ignored and considered to be in the detected gap.

For more information see "Parameter Spectrum Calculation".

Remote command:

CALCulate<n>:​PSPectrum:​STHReshold


Parameter Trend Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Trend Configuration
Parameter Trend Configuration

The parameter trend result displays allow you to visualize changes in a specific parameter for all measured pulses within the current capture buffer. For each parameter trend window you can configure which measured parameter is to be displayed on the x-axis and which on the y-axis.

This tab is only available for windows with a Parameter Trend result display.

└ Parameter Group Y
└ Y-Axis
└ Parameter Group X
└ X-Axis
└ Display Limit Lines


Parameter Group Y

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Trend Configuration > Parameter Group Y
Parameter Group Y

Defines the group of parameters from which one can be selected to display the trend on the y-axis. For a description of the parameters see "Pulse Parameters".


Y-Axis

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Trend Configuration > Y-Axis
Y-Axis

Defines the parameter for which the trend is displayed on the y-axis. The available parameters depend on the selected "Parameter Group Y".

Remote command:

CALCulate<n>:TRENd:<GroupName>:Y, see e.g. CALCulate<n>:​TRENd:​FREQuency:​Y

CALCulate<n>:TRENd:<GroupName> Y,X, see e.g. CALCulate<n>:​TRENd:​FREQuency


Parameter Group X

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Trend Configuration > Parameter Group X
Parameter Group X

Defines the group of parameters from which one can be selected to display the trend on the x-axis. For a description of the parameters see "Pulse Parameters".


X-Axis

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Parameter Configuration for Result Displays > Parameter Trend Configuration > X-Axis
X-Axis

Defines the parameter for which the trend is displayed on the y-axis. The available parameters depend on the selected "Parameter Group X".

Remote command:

CALCulate<n>:TRENd:<GroupName>:X, see e.g. CALCulate<n>:​TRENd:​FREQuency:​X

CALCulate<n>:TRENd:<GroupName> Y,X, see e.g. CALCulate<n>:​TRENd:​FREQuency


Table Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration
Table Configuration

During each measurement, a large number of statistical and characteristic values are determined. The "Pulse Statistics" and "Pulse Results" result displays provide an overview of the parameters selected here.

Note that the "Result Configuration" dialog box is window-specific; table configuration settings are only available if a table display is selected. However, the table configuration applies to all tables, regardless of which table is selected.

Select the parameters to be included in the tables, and the required unit scaling, if available. For a description of the individual parameters see "Pulse Parameters".

Remote command:

CALCulate<n>:TABLe:<GroupName>:<ParamName>, see "Configuring the Statistics and Parameter Tables"

Contents
  • Table Export Configuration
  • Limit Settings for Table Displays


Table Export Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration > Table Export Configuration
Table Export Configuration

Table results can be exported to an ASCII file for further evaluation in other (external) applications. Table export settings can be configured in the "Result Configuration" dialog box, in the "Table configuration" tab, in the vertical "Table Export" tab.

The settings are window-specific and only available for result tables.

The result tables can be exported either directly in the settings dialog box or via the "Export" function in the "Save/Recall" menu (via the toolbar).

For step-by-step instructions on how to export a trace, see "How to Export Trace Data and Numerical Results" .

└ Columns to Export
└ Decimal Separator
└ Export Table to ASCII File


Columns to Export

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration > Table Export Configuration > Columns to Export
Columns to Export

Defines which of the result table columns are to be included in the export file.

"Visible" | Only the currently visible columns in the result display are exported.
"All" | All columns, including currently hidden ones, for the result display are exported.
Remote command:

MMEMory:​STORe<n>:​TABLe


Decimal Separator

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration > Table Export Configuration > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Export Table to ASCII File

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration > Table Export Configuration > Export Table to ASCII File
Export Table to ASCII File

Opens a file selection dialog box and saves the selected result table in ASCII format (.DAT) to the specified file and directory.

For details on the file format see "Reference: ASCII File Export Format".

Note: To store the measurement results for all traces and tables in all windows, use the "Export Trace to ASCII File" command in the "Save/Recall" > "Export" menu. (See also "Trace / Data Export Configuration".)

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Remote command:

MMEMory:​STORe<n>:​TABLe


Limit Settings for Table Displays

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration > Limit Settings for Table Displays
Limit Settings for Table Displays

Measurement results can be checked against defined limits and the results of the limit check can then be indicated in the Result Table. Table limit settings can be configured in the "Result Configuration" dialog box, in the "Table configuration" tab, in the vertical "Limits" tab.

For details on limits see "Pulse Results".

The settings are window-specific and only available for result tables.

Optionally, limit lines can be displayed in the "Parameter Distribution" and "Parameter Trend" diagrams. You can drag these lines to a new position in the window. The new position is maintained, the limit check is repeated, and the results of the limit check in any active table displays are adapted.

└ Parameter Group
└ Parameter
└ Activating a limit check for a parameter
└ Defining lower and upper limits for a parameter
└ Deactivating a limit check for an entire parameter group
└ Deactivating all limit checks for all parameter groups


Parameter Group

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration > Limit Settings for Table Displays > Parameter Group
Parameter Group

Defines the group of parameters from which one can be selected to define limits. For a description of the parameters see "Pulse Parameters".


Parameter

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration > Limit Settings for Table Displays > Parameter
Parameter

Defines the parameter for which the limits are to be defined. The available parameters depend on the selected "Parameter Group".


Activating a limit check for a parameter

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration > Limit Settings for Table Displays > Activating a limit check for a parameter
Activating a limit check for a parameter

To activate a limit check for the selected parameter, set "Limit On/Off" to "ON".

Note: If a limit is defined for a parameter that is displayed in a "Parameter Trend" diagram, the "Auto Scale Window" function is not available for the axis this parameter is displayed on (see also "Automatic Grid Scaling").

Remote command:

CALCulate<n>:​TABLe:​<ParameterGroup>:​<Parameter>:​LIMit:​STATe


Defining lower and upper limits for a parameter

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration > Limit Settings for Table Displays > Defining lower and upper limits for a parameter
Defining lower and upper limits for a parameter

The "Lower Limit" and "Upper Limit" define the valid value range for the limit check for the selected parameter.

Note: Optionally, limit lines can be displayed in the "Parameter Distribution" and "Parameter Trend" diagrams. You can drag these lines to a new position in the window. The new position is maintained, the limit check is repeated, and the results of the limit check in any active table displays are adapted.

Remote command:

CALCulate<n>:​TABLe:​<ParameterGroup>:​<Parameter>:​LIMit


Deactivating a limit check for an entire parameter group

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration > Limit Settings for Table Displays > Deactivating a limit check for an entire parameter group
Deactivating a limit check for an entire parameter group

To deactivate all limits for an entire parameter group at once, select "Turn off all limits in group". This function is identical to setting "Limit On/Off" to "OFF" for each parameter in the group.

Remote command:

CALCulate<n>:​TABLe:​<ParameterGroup>:​ALL:​LIMit:​STATe


Deactivating all limit checks for all parameter groups

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Table Configuration > Limit Settings for Table Displays > Deactivating all limit checks for all parameter groups
Deactivating all limit checks for all parameter groups

To deactivate all limits for all parameter groups at once, select "Turn off limits". This function is identical to setting "Limit On/Off" to "OFF" for each parameter in each group.

Remote command:

CALCulate<n>:​TABLe:​ALL:​LIMit:​STATe


Y-Scaling

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Y-Scaling
Y-Scaling

The scaling for the vertical axis is highly configurable, using either absolute or relative values. These settings are described here.

To display this dialog box, do one of the following:

  • Press the AMPT key, then select the "Y-Scaling Config" softkey.
  • From the "Overview", select "Result Configuration", then switch to the "Y-Scaling" tab.
└ Automatic Grid Scaling
└ Auto Scale Once
└ Absolute Scaling (Min/Max Values)
└ Relative Scaling (Reference/ per Division)
└ Per Division
└ Ref Position
└ Ref Value


Automatic Grid Scaling

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Y-Scaling > Automatic Grid Scaling
Automatic Grid Scaling

The y-axis is scaled automatically according to the current measurement settings and results (continuously).

Note: If a limit is defined for a parameter that is displayed in a "Parameter Trend" diagram (see "Activating a limit check for a parameter"), autoscaling is not available for the axis this parameter is displayed on.

Note: Tip: To update the scaling automatically once when this setting for continuous scaling is off, use the "Auto Scale Once" button or the softkey in the AUTO SET menu.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO


Auto Scale Once

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Y-Scaling > Auto Scale Once
Auto Scale Once

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings.

The display is only set once; it is not adapted further if the measurement settings are changed again.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO


Absolute Scaling (Min/Max Values)

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Y-Scaling > Absolute Scaling (Min/Max Values)
Absolute Scaling (Min/Max Values)

Define the scaling using absolute minimum and maximum values.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MAXimum

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MINimum


Relative Scaling (Reference/ per Division)

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Y-Scaling > Relative Scaling (Reference/ per Division)
Relative Scaling (Reference/ per Division)

Define the scaling relative to a reference value, with a specified value range per division.

└ Per Division
└ Ref Position
└ Ref Value


Per Division

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Y-Scaling > Relative Scaling (Reference/ per Division) > Per Division
Per Division

Defines the value range to be displayed per division of the diagram (1/10 of total range).

Note: The value defined per division refers to the default display of 10 divisions on the y-axis. If fewer divisions are displayed (e.g. because the window is reduced in height), the range per division is increased in order to display the same result range in the smaller window. In this case, the per division value does not correspond to the actual display.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​PDIVision


Ref Position

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Y-Scaling > Relative Scaling (Reference/ per Division) > Ref Position
Ref Position

Defines the position of the reference value in percent of the total y-axis range.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Ref Value

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Y-Scaling > Relative Scaling (Reference/ per Division) > Ref Value
Ref Value

Defines the reference value to be displayed at the specified reference position.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RVALue


Units

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Units
Units

The unit for phase display is configurable. This setting is described here.

└ Phase Unit
└ Frequency Unit


Phase Unit

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Units > Phase Unit
Phase Unit

Defines the unit in which phases are displayed (degree or rad).

Remote command:

UNIT:​ANGLe


Frequency Unit

Pulse Measurements (R&S FSW-K6) > Analysis > Result Configuration > Units > Frequency Unit
Frequency Unit

Switches between relative (default) and absolute frequency values. This setting applies to Pulse Frequency, Result Range Spectrum, Parameter Distribution and Parameter Trend result displays.

Remote command:

CALCulate<n>:​UNIT:​FREQuency


Display Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Display Configuration
Display Configuration

The captured signal can be displayed using various evaluations. All evaluation available for the Pulse application are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the "Overview".
  • Press the MEAS key.
  • Select the "Display Config" softkey in any Pulse menu.

Up to six evaluation methods can be displayed simultaneously in separate windows. The Pulse evaluation methods are described in "Measurements and Result Displays".

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .


Markers

Pulse Measurements (R&S FSW-K6) > Analysis > Markers
Markers

Markers help you analyze your measurement results by determining particular values in the diagram. Thus you can extract numeric values from a graphical display. In Pulse result displays, up to 4 markers can be activated in each diagram at any time.

Markers are configured in the "Marker" dialog box which is displayed when you do one of the following:

  • In the "Overview", select "Result Config", and switch to the vertical "Marker" tab.
  • Press the , MKR key, then select the "Marker Config" softkey.
Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different Pulse window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

Contents
  • Individual Marker Settings
  • General Marker Settings
  • Marker Positioning Functions


Individual Marker Settings

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Individual Marker Settings
Individual Marker Settings

In Pulse result displays, up to 4 markers can be activated in each diagram at any time.

└ Marker 1 / Marker 2 / Marker 3 / Marker 4
└ Selected Marker
└ Marker State
└ X-value
└ Marker Type
└ Reference Marker
└ All Markers Off


Marker 1 / Marker 2 / Marker 3 / Marker 4

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Individual Marker Settings > Marker 1 / Marker 2 / Marker 3 / Marker 4
Marker 1 / Marker 2 / Marker 3 / Marker 4

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 4 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings" .

Note: Setting markers in Parameter Trend Displays. In Parameter Trend displays, especially when the x-axis unit is not pulse number, positioning a marker by defining its x-axis value (as in the "Marker Configuration" dialog box) can be very difficult or unambiguous. Thus, markers are positioned by defining the corresponding pulse number in the "Marker" edit field for all parameter trend displays, regardless of the displayed x-axis parameter. However, the position displayed in the marker information area or the marker table is shown in the defined x-axis unit.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X


Selected Marker

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Individual Marker Settings > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Individual Marker Settings > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


X-value

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Individual Marker Settings > X-value
X-value

Defines the position of the marker on the x-axis (channel, slot, symbol, depending on result display).

Note: Setting markers in Parameter Trend Displays. In Parameter Trend displays, especially when the x-axis unit is not pulse number, positioning a marker by defining its x-axis value can be very difficult or unambiguous. Thus, markers can be positioned by defining the corresponding pulse number in the "Marker" edit field for all parameter trend displays, regardless of the displayed x-axis parameter. The "Marker" edit field is displayed when you select one of the "Marker" softkeys.

Remote command:

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​MARKer<m>:​X


Marker Type

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Individual Marker Settings > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Reference Marker

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Individual Marker Settings > Reference Marker
Reference Marker

Defines a marker as the reference marker which is used to determine relative analysis results (delta marker values).

Remote command:

CALCulate<n>:​DELTamarker<m>:​MREF


All Markers Off

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Individual Marker Settings > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


General Marker Settings

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > General Marker Settings
General Marker Settings

General marker settings are defined in the "Marker Settings" tab of the "Result Configuration" dialog box.

└ Marker Table Display


Marker Table Display

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > General Marker Settings > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results" .

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
Remote command:

DISPlay:​MTABle


Marker Positioning Functions

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Marker Positioning Functions
Marker Positioning Functions

The following functions set the currently selected marker to the result of a peak search or set other characteristic values to the current marker value. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key.

└ Select Marker
└ Peak Search
└ Search Next Peak
└ Search Minimum
└ Search Next Minimum


Select Marker

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Marker Positioning Functions > Select Marker
Select Marker

Opens a dialog box to select and activate or deactivate one or more markers quickly.

Remote command:

Marker selected via suffix <m> in remote commands.


Peak Search

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Marker Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Next Peak

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Marker Positioning Functions > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Search Minimum

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Marker Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Search Next Minimum

Pulse Measurements (R&S FSW-K6) > Analysis > Markers > Marker Positioning Functions > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Trace Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration
Trace Configuration

Traces in graphical result displays based on the defined result range (see "Result Range") can be configured, for example to perform statistical evaluations over a defined number of sweeps, pulses, or samples.

For details on trace evaluation see "Trace Evaluation".

Trace data can also be exported to an ASCII file for further analysis. For details see "Trace / Data Export Configuration".

Contents
  • Trace Settings
  • Trace / Data Export Configuration


Trace Settings

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace Settings
Trace Settings
You can configure the settings for up to 6 individual traces for the following result displays, which are based on the defined result range (see "Result Range"):
  • "Pulse Frequency"
  • "Pulse Magnitude"
  • "Pulse Phase"
  • "Pulse Phase (Wrapped)"

Trace data can also be exported to an ASCII file for further analysis. For details see "Trace / Data Export Configuration".

└ Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
└ Trace Mode
└ Detector
└ Hold
└ Statistical Evaluation
└ Selected Pulse vs All Pulses
└ Sweep/Average Count
└ Maximum number of trace points
└ Predefined Trace Settings - Quick Config
└ Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)


Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6
Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6

Selects the corresponding trace for configuration. The currently selected trace is highlighted orange.

For details see "How to Configure a Standard Trace" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]

Selected via numeric suffix of TRACe<t> commands


Trace Mode

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace Settings > Trace Mode
Trace Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode".

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is greater than the previous one.
"Min Hold" | The minimum value is determined from several measurements and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is lower than the previous one.
"Average" | The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.
"View" | The current contents of the trace memory are frozen and displayed.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Detector

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace Settings > Detector
Detector

Defines the trace detector to be used for trace analysis.

For details see "Mapping Samples to Sweep Points with the Trace Detector".

"Auto" | Selects the optimum detector for the selected trace and filter mode. This is the default setting.
"Type" | Defines the selected detector type.
Remote command:

[SENSe:​][WINDow<n>:​]DETector<trace>[:​FUNCtion]

[SENSe:​][WINDow<n>:​]DETector<t>[:​FUNCtion]:​AUTO


Hold

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace Settings > Hold
Hold

If activated, traces in "Min Hold", "Max Hold" and "Average" mode are not reset after specific parameter changes have been made.

Normally, the measurement is started anew after parameter changes, before the measurement results are analyzed (e.g. using a marker). In all cases that require a new measurement after parameter changes, the trace is reset automatically to avoid false results (e.g. with span changes). For applications that require no reset after parameter changes, the automatic reset can be switched off.

The default setting is off.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE:​HCONtinuous


Statistical Evaluation

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace Settings > Statistical Evaluation
Statistical Evaluation

If the trace modes "Average", "Max Hold" or "Min Hold" are set, you can define how many pulses, sweeps and measurement samples are included in the statistical evaluation.

For details see "Trace Statistics".

└ Selected Pulse vs All Pulses
└ Sweep/Average Count
└ Maximum number of trace points


Selected Pulse vs All Pulses

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace Settings > Statistical Evaluation > Selected Pulse vs All Pulses
Selected Pulse vs All Pulses

Defines which pulses are included in the statistical evaluation.

For details see "Trace Statistics".

"Selected pulse" | Only the selected pulse from each sweep (capture) is included in the statistical evaluation.
"All Pulses" | All measured pulses from each sweep (capture) are included in the statistical evaluation.
Remote command:

[SENSe:​][STATistic<n>:​]TYPE


Maximum number of trace points

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace Settings > Statistical Evaluation > Maximum number of trace points
Maximum number of trace points

If the number of samples within the result range (see "Result Range") is larger than this value, the trace data is reduced to the defined maximum number of trace points using the selected detector.

For details see also "Mapping Samples to Sweep Points with the Trace Detector".

Restricting this value can improve performance during statistical evaulation of large result range lengths.

Remote command:

[SENSe:​]SWEep:​POINts


Predefined Trace Settings - Quick Config

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace Settings > Predefined Trace Settings - Quick Config
Predefined Trace Settings - Quick Config

Commonly required trace settings have been predefined and can be applied very quickly by selecting the appropriate button.

Function | Trace Settings
Preset All Traces | Trace 1: | Clear Write
 |  | Blank
Set Trace Mode Max | Avg | Min | Trace 1: | Max Hold
 | Trace 2: | Average
 | Trace 3: | Min Hold
 |  | Blank
Set Trace Mode Max | ClrWrite | Min | Trace 1: | Max Hold
 | Trace 2: | Clear Write
 | Trace 3: | Min Hold
 |  | Blank


Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)
Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Displays the "Traces" settings and focuses the "Mode" list for the selected trace.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]


Trace / Data Export Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace / Data Export Configuration
Trace / Data Export Configuration

The standard data management functions (e.g. saving or loading instrument settings) that are available for all R&S FSW applications are not described here.

See "Data Management" for a description of the standard functions.

Alternatively, they are available in the "Save/Recall" menu (> "Export" softkey) which is displayed when you select the "Save" or "Open" icon in the toolbar.

For step-by-step instructions on how to export a trace, see "How to Export Trace Data" .

└ Export all Traces and all Table Results
└ Include Instrument Measurement Settings
└ Trace to Export
└ Decimal Separator
└ Export Trace to ASCII File


Export all Traces and all Table Results

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace / Data Export Configuration > Export all Traces and all Table Results
Export all Traces and all Table Results

Selects all displayed traces and result tables (e.g. Result Summary, marker table etc.) in the current application for export to an ASCII file.

Alternatively, you can select one specific trace only for export (see "Trace to Export").

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

Remote command:

FORMat:​DEXPort:​TRACes


Include Instrument Measurement Settings

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace / Data Export Configuration > Include Instrument Measurement Settings
Include Instrument Measurement Settings

Includes additional instrument and measurement settings in the header of the export file for result data.

Remote command:

FORMat:​DEXPort:​HEADer


Trace to Export

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace / Data Export Configuration > Trace to Export
Trace to Export

Defines an individual trace that will be exported to a file.

This setting is not available if "Export all Traces and all Table Results" is selected.


Decimal Separator

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace / Data Export Configuration > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Export Trace to ASCII File

Pulse Measurements (R&S FSW-K6) > Analysis > Trace Configuration > Trace / Data Export Configuration > Export Trace to ASCII File
Export Trace to ASCII File

Opens a file selection dialog box and saves the selected trace in ASCII format (.dat) to the specified file and directory.

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Remote command:

MMEMory:​STORe<n>:​TRACe


Export Functions

Pulse Measurements (R&S FSW-K6) > Analysis > Export Functions
Export Functions

The following export functions are available via softkeys in the "Export" menu which is displayed when you select the "Save" icon in the toolbar and then "Export".

The standard data management functions (e.g. saving or loading instrument settings) that are available for all R&S FSW applications are not described here.

See "Data Management" for a description of the standard functions.

└ Export Table to ASCII File
└ Table Export Configuration
└ Columns to Export
└ Export Limits
└ Decimal Separator
└ Export Table to ASCII File
└ Export Trace to ASCII File
└ Trace Export Configuration
└ I/Q Export


Table Export Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Export Functions > Table Export Configuration
Table Export Configuration

Table results can be exported to an ASCII file for further evaluation in other (external) applications. Table export settings can be configured in the "Result Configuration" dialog box, in the "Table configuration" tab, in the vertical "Table Export" tab.

The settings are window-specific and only available for result tables.

└ Columns to Export
└ Export Limits
└ Decimal Separator
└ Export Table to ASCII File


Columns to Export

Pulse Measurements (R&S FSW-K6) > Analysis > Export Functions > Table Export Configuration > Columns to Export
Columns to Export

Defines which of the result table columns are to be included in the export file.

"Visible" | Only the currently visible columns in the result display are exported.
"All" | All columns, including currently hidden ones, for the result display are exported.
Remote command:

MMEMory:​STORe<n>:​TABLe


Export Limits

Pulse Measurements (R&S FSW-K6) > Analysis > Export Functions > Table Export Configuration > Export Limits
Export Limits

If activated, any limits defined for the table will be included in the export file.


Decimal Separator

Pulse Measurements (R&S FSW-K6) > Analysis > Export Functions > Table Export Configuration > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Trace Export Configuration

Pulse Measurements (R&S FSW-K6) > Analysis > Export Functions > Trace Export Configuration
Trace Export Configuration

Opens the "Traces" dialog box to configure the trace and data export settings. See "Trace / Data Export Configuration".


I/Q Export

Pulse Measurements (R&S FSW-K6) > Analysis > Export Functions > I/Q Export
I/Q Export

Opens a file selection dialog box to select an export file to which the IQ data will be stored. This function is only available in single sweep mode, and only in applications that process I/Q data, such as the I/Q Analyzer or optional applications.

For details see "I/Q Data Import and Export" .

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Remote command:

MMEMory:​STORe:​IQ:​STATe

MMEMory:​STORe:​IQ:​COMMent


Zoom Functions

Pulse Measurements (R&S FSW-K6) > Analysis > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

For details on the zoom functions see "Single Zoom Versus Multiple Zoom" .

└ Single Zoom
└ Multiple Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)


Single Zoom

Pulse Measurements (R&S FSW-K6) > Analysis > Zoom Functions > Single Zoom
Single Zoom

A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Multiple Zoom

Pulse Measurements (R&S FSW-K6) > Analysis > Zoom Functions > Multiple Zoom
Multiple Zoom

In multiple zoom mode, you can enlarge several different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​AREA


Restore Original Display

Pulse Measurements (R&S FSW-K6) > Analysis > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display and closes all zoom windows.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Deactivating Zoom (Selection mode)

Pulse Measurements (R&S FSW-K6) > Analysis > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode.

Tapping the screen no longer invokes a zoom, but selects an object.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Analysis in MSRA/MSRT Mode

Pulse Measurements (R&S FSW-K6) > Analysis > Analysis in MSRA/MSRT Mode
Analysis in MSRA/MSRT Mode

The data that was captured by the MSRA/MSRT Master can be analyzed in the Pulse application.

The analysis settings and functions available in MSRA/MSRT mode are those described for common Signal and Spectrum Analyzer mode.

See "Analysis".

Analysis line settings

In addition, an analysis line can be positioned. The analysis line is a common time marker for all MSRA/MSRT applications.

To hide or show and position the analysis line, a dialog box is available. To display the "Analysis Line" dialog box, tap the "AL" icon in the toolbar (only available in MSRA/MSRT mode). The current position of the analysis line is indicated on the icon.

└ Position
└ Show Line


Position

Pulse Measurements (R&S FSW-K6) > Analysis > Analysis in MSRA/MSRT Mode > Position
Position

Defines the position of the analysis line in the time domain. The position must lie within the measurement time of the multistandard measurement.

Remote command:

CALCulate:​MSRA:​ALINe[:​VALue]

CALCulate:​RTMS:​ALINe[:​VALue]


Show Line

Pulse Measurements (R&S FSW-K6) > Analysis > Analysis in MSRA/MSRT Mode > Show Line
Show Line

Hides or displays the analysis line in the time-based windows. By default, the line is displayed.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Remote command:

CALCulate:​MSRA:​ALINe:​SHOW

CALCulate:​RTMS:​ALINe:​SHOW


Decimal Separator

Pulse Measurements (R&S FSW-K6) > Export Functions > Table Export Configuration > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


How to Perform Measurements in the Pulse Application

Pulse Measurements (R&S FSW-K6) > How to Perform Measurements in the Pulse Application
How to Perform Measurements in the Pulse Application

The following step-by-step instructions demonstrate how to perform a Pulse measurement with the R&S FSW-K6 option.

  1. Press the MODE key on the front panel and select the "Pulse" application.

  2. Select the "Overview" softkey to display the "Overview" for a Pulse measurement.

  3. Select the "Signal Description" button and configure the expected pulse characteristics.

  4. Select the "Input/Frontend" button to define the input signal's center frequency, amplitude and other basic settings.

  5. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an external trigger to start capturing data only when a useful signal is transmitted.

  6. Select the "Data Acquisition" button and define the bandwidth parameters for the input signal:

    (In MSRA/MSRT mode, define the application data instead, see "Pulse Measurements in MSRA/MSRT Mode").

    • "Measurement Bandwidth": the amount of signal bandwidth to be captured
    • "Measurement Time": how long the input signal is to be captured

  7. Select the "Pulse Detection" button and define the criteria to detect the individual pulses within the input signal.

  8. Select the "Measurement" button and define the general measurement settings concerning:

    • the measurement levels
    • the measurement point
    • the measurement range

  9. Select the "Display" button and select the evaluation methods that are of interest to you.

    Arrange them on the display to suit your preferences.

  10. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  11. Select the "Result Config" button in the "Overview" to configure which data is displayed in the individual result displays, and other settings for specific evaluation methods. These settings can be configured individually for each window, so select the window first and then configure the settings.

    • Define the "Result Range", which determines the extent of measured data displayed in pulse magnitude, frequency and phase vs time traces.
    • Configure specific settings for the selected evaluation method(s).
    • Configure markers and delta markers to determine deviations and offsets within the results, e.g. when comparing errors or peaks.
    • Adapt the diagram scaling to the displayed data.

  12. Stop the continuous sweep and start a new sweep with the new configuration (e.g. using the RUN SINGLE key).

  13. Press the "Selected Pulse" softkey and select a specific pulse to be evaluated.

    The result displays are updated to show the results for the selected pulse.

Contents
  • How to Export Table Data


How to Export Table Data

Pulse Measurements (R&S FSW-K6) > How to Perform Measurements in the Pulse Application > How to Export Table Data
How to Export Table Data

The measured result table data can be exported to an ASCII file. For each parameter, the measured values are output.

For details on the storage format see "Reference: ASCII File Export Format".

Table data can be exported either from the "Result Configuration" dialog box, or from the "Save/Recall" menu.

To export from the "Save/Recall" menu

  1. Select an active result table whose data you want to export.

  2. Select the [image] "Save" icon in the toolbar.

  3. Select the "Export" softkey.

  4. If necessary, change the decimal separator to be used for the ASCII export file.

  5. Select the "ASCII Table Export" softkey.

  6. In the file selection dialog box, select the storage location and file name for the export file.

  7. Select "Save" to close the dialog box and export the table data to the file.

To export from the "Result configuration" dialog box

  1. Press the "Overview" softkey.

  2. Select the "Result Config" button.

  3. Select the window that contains the result table in the "Specifics for" selection box.

  4. Select the "Table Config" tab.

  5. Select the vertical "Table Export" tab.

  6. Select whether you want to export all columns or only the currently visible columns of the table.

  7. If necessary, change the decimal separator to be used for the ASCII export file.

  8. Select the "Export Table to ASCII File" button.

  9. In the file selection dialog box, select the storage location and file name for the export file.

  10. Select "Save" to close the dialog box and export the table data to the file.


Remote Commands for Pulse Measurements

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements
Remote Commands for Pulse Measurements

The following commands are required to perform measurements in the Pulse application in a remote environment. The R&S FSW must already be set up for remote operation in a network as described in the base unit manual.

(See "How to Set Up a Network and Remote Control" .)

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data, see "Managing Settings and Results"
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register" (specific status registers for Pulse measurements are not used)

After a short introduction, the tasks specific to the Pulse application are described here:

Contents
  • Common Suffixes
  • Activating Pulse Measurements
  • Signal Description
  • Input/Output Settings
  • Frontend Configuration
  • Triggering Measurements
  • Segmented Data Capturing
  • Data Acquisition
  • Pulse Detection
  • Configuring the Pulse Measurement
  • Configuring and Performing Sweeps
  • Configuring the Results
  • Configuring the Result Display
  • Configuring Standard Traces
  • Configuring an Analysis Interval and Line (MSRA mode only)
  • Configuring an Analysis Interval and Line (MSRT mode only)
  • Retrieving Results
  • Working with Markers
  • Programming Example: Pulse Measurement


Common Suffixes

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Common Suffixes
Common Suffixes

In the Pulse application, the following common suffixes are used in remote commands:

Suffix | Value range | Description
<m> | 1..4 | Marker
<n> | 1..6 | Window
<t> | 1 | Trace


Activating Pulse Measurements

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Activating Pulse Measurements
Activating Pulse Measurements

Pulse measurements require a special application on the R&S FSW. The measurement is started immediately with the default settings.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Activating Pulse Measurements > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

This command is not available if the MSRA/MSRT Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Activating Pulse Measurements > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Activating Pulse Measurements > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Activating Pulse Measurements > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Activating Pulse Measurements > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Activating Pulse Measurements > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Activating Pulse Measurements > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType>

This command activates a new measurement channel with the defined channel type, or selects an existing measurement channel with the specified name.

See also INSTrument:​CREate[:​NEW].

For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".

Parameters:
<ChannelType>
PULSe

Pulse option, R&S FSW–K6


SYSTem:PRESet:CHANnel[:EXECute]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Activating Pulse Measurements > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Signal Description

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description
Signal Description

The signal description provides information on the expected input signal, which optimizes pulse detection.

List of Commands
SENSe:TRACe:MEASurement:DEFine:DURation:AUTO
SENSe:TRACe:MEASurement:DEFine:DURation:MAX
SENSe:TRACe:MEASurement:DEFine:DURation:MIN
SENSe:TRACe:MEASurement:DEFine:DURation:OFF
SENSe:TRACe:MEASurement:DEFine:FREQuency:OFFSet
SENSe:TRACe:MEASurement:DEFine:FREQuency:OFFSet:AUTO
SENSe:TRACe:MEASurement:DEFine:FREQuency:RATE
SENSe:TRACe:MEASurement:DEFine:FREQuency:RATE:AUTO
SENSe:TRACe:MEASurement:DEFine:PULSe:ADRoop
SENSe:TRACe:MEASurement:DEFine:PULSe:MODulation
SENSe:TRACe:MEASurement:DEFine:PULSe:PERiod


SENSe:TRACe:MEASurement:DEFine:DURation:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description > SENSe:TRACe:MEASurement:DEFine:DURation:AUTO
SENSe:TRACe:MEASurement:DEFine:DURation:AUTO <State>

If this flag is set to ON, the pulse timing parameters (min/max width, min off time) are determined automatically from the current capture settings.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: ON
Manual operation: See "Timing Auto Mode"


SENSe:TRACe:MEASurement:DEFine:DURation:MAX

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description > SENSe:TRACe:MEASurement:DEFine:DURation:MAX
SENSe:TRACe:MEASurement:DEFine:DURation:MAX <PulseMaxWidth>

Defines a maximum pulse width; pulses outside this range are not detected. The available value range is 50ns to 100s, but may be restricted further by the sample rate.

Parameters:
<PulseMaxWidth>
*RST: | 5 ms
Default unit: | S
Manual operation: See "Minimum Pulse Width, Maximum Pulse Width"


SENSe:TRACe:MEASurement:DEFine:DURation:MIN

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description > SENSe:TRACe:MEASurement:DEFine:DURation:MIN
SENSe:TRACe:MEASurement:DEFine:DURation:MIN <PulseMinWidth>

Defines a minimum pulse width; pulses outside this range are not detected. The available value range is 50ns to 100s, but may be restricted further by the sample rate.

Parameters:
<PulseMinWidth>
*RST: | 50 ns
Default unit: | S
Manual operation: See "Minimum Pulse Width, Maximum Pulse Width"


SENSe:TRACe:MEASurement:DEFine:DURation:OFF

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description > SENSe:TRACe:MEASurement:DEFine:DURation:OFF
SENSe:TRACe:MEASurement:DEFine:DURation:OFF <PulseMinOff>

The minimum time the pulse is "off", i.e. the time between successive pulses. This value is used to determine noise statistics and to reject short drops in amplitude during pulse "ON" time. The available value range is 50ns to 100s, but may be restricted further by the sample rate.

Parameters:
<PulseMinOff>
*RST: | 1 us
Default unit: | S
Manual operation: See "Min Pulse Off Time"


SENSe:TRACe:MEASurement:DEFine:FREQuency:OFFSet

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description > SENSe:TRACe:MEASurement:DEFine:FREQuency:OFFSet
SENSe:TRACe:MEASurement:DEFine:FREQuency:OFFSet <Offset>

Defines a known frequency offset to be corrected in the pulse acquisition data.

Use the SENSe:​TRACe:​MEASurement:​DEFine:​FREQuency:​OFFSet:​AUTO to define the frequency offset automatically.

Parameters:
<Offset>
*RST: | 0
Default unit: | HZ
Manual operation: See "Frequency Offset Value"


SENSe:TRACe:MEASurement:DEFine:FREQuency:OFFSet:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description > SENSe:TRACe:MEASurement:DEFine:FREQuency:OFFSet:AUTO
SENSe:TRACe:MEASurement:DEFine:FREQuency:OFFSet:AUTO <State>

If enabled, the frequency offset is estimated automatically for each individual pulse.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: ON
Manual operation: See "Frequency Offset Auto Mode"


SENSe:TRACe:MEASurement:DEFine:FREQuency:RATE

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description > SENSe:TRACe:MEASurement:DEFine:FREQuency:RATE
SENSe:TRACe:MEASurement:DEFine:FREQuency:RATE <PulseChirpRate>

Defines a known frequency chirp rate (in Hz/μs) to be used to generate an ideal pulse waveform for computing frequency and phase error parameters. This value is assumed constant for all measured pulses.

Use the SENSe:​TRACe:​MEASurement:​DEFine:​FREQuency:​RATE:​AUTO to define the chirp rate automatically.

Parameters:
<PulseChirpRate>
*RST: | 0
Default unit: | Hz/μs
Manual operation: See "Chirp Rate"


SENSe:TRACe:MEASurement:DEFine:FREQuency:RATE:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description > SENSe:TRACe:MEASurement:DEFine:FREQuency:RATE:AUTO
SENSe:TRACe:MEASurement:DEFine:FREQuency:RATE:AUTO <State>

If enabled, the chirp rate is estimated automatically for each individual pulse.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: ON
Manual operation: See "Chirp Rate Auto Mode"


SENSe:TRACe:MEASurement:DEFine:PULSe:ADRoop

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description > SENSe:TRACe:MEASurement:DEFine:PULSe:ADRoop
SENSe:TRACe:MEASurement:DEFine:PULSe:ADRoop <State>

If ON, a pulse can be modeled as having amplitude droop, otherwise the pulse top is assumed to be flat.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: ON
Manual operation: See "Pulse Has Droop"


SENSe:TRACe:MEASurement:DEFine:PULSe:MODulation

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description > SENSe:TRACe:MEASurement:DEFine:PULSe:MODulation
SENSe:TRACe:MEASurement:DEFine:PULSe:MODulation <Modulation>

The type of pulse modulation which is expected.

Parameters:
<Modulation>
ARB | CW | LFM
ARB

Arbitrary

CW

Continuous wave

LFM

Linear FM (fixed value)

*RST: CW
Manual operation: See "Pulse Modulation"


SENSe:TRACe:MEASurement:DEFine:PULSe:PERiod

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Signal Description > SENSe:TRACe:MEASurement:DEFine:PULSe:PERiod
SENSe:TRACe:MEASurement:DEFine:PULSe:PERiod <PulsePeriod>

This command defines how a pulse is detected.

Parameters:
<PulsePeriod>
HL | LH
HL

The pulse period begins with the falling edge of the preceeding pulse and ends with the falling edge of the current pulse.

LH

The pulse period begins with the rising edge of the current pulse and end with the rising edge of the succeeding pulse.

*RST: HL
Manual operation: See "Pulse Period"


Input/Output Settings

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings
Input/Output Settings

The R&S FSW can analyze signals from different input sources (such as RF, power sensors etc.) and provide various types of output (such as noise or trigger signals). The following commands are required to configure data input and output.

Contents
  • RF Input
  • Using External Mixers
  • Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
  • Configuring Digital I/Q Input and Output
  • Input from I/Q Data Files
  • Configuring the Outputs


RF Input

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

(For details on the status register see the R&S FSW User Manual).

The command works only if the overload condition has been eliminated first.

Usage: Event


INPut:COUPling

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"


INPut:SELect

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

FIQ

I/Q data file (selected by INPut:​FILE:​PATH)

For details see "Basics on Input from I/Q Data Files".

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "IQ Input File State"
See "Digital I/Q Input State"
See "Analog Baseband Input State"


Using External Mixers

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers
Using External Mixers

The commands required to work with external mixers in a remote environment are described here. Note that these commands require the R&S FSW-B21 option to be installed and an external mixer to be connected to the front panel of the R&S FSW. In MSRA/MSRT mode, external mixers are not supported.

For details on working with external mixers see "Basics on External Mixers" .

Contents
  • Basic Settings
  • Mixer Settings
  • Conversion Loss Table Settings
  • Programming Example: Working with an External Mixer


Basic Settings

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Basic Settings
Basic Settings

The basic settings concern general usage of an external mixer.

List of Commands
[SENSe:]MIXer[:STATe]
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold


[SENSe:]MIXer[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer[:STATe]
[SENSe:]MIXer[:STATe] <State>

Activates or deactivates the use of a connected external mixer as input for the measurement. This command is only available if the R&S FSW-B21 option is installed and an external mixer is connected.

(See "How to Work with External Mixers" ).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX ON
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "External Mixer State"


[SENSe:]MIXer:BIAS:HIGH

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS:HIGH <BiasSetting>

This command defines the bias current for the high (second) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Manual operation: See "Bias Settings"


[SENSe:]MIXer:BIAS[:LOW]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:BIAS[:LOW] <BiasSetting>

This command defines the bias current for the low (first) range.

(See also "Bias Current" ).

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<BiasSetting>
*RST: | 0.0 A
Default unit: | A
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Bias Settings"


[SENSe:]MIXer:LOPower

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOPower <Level>

This command specifies the LO level of the external mixer's LO port.

Parameters:
<Level>
numeric value
Range: | 13.0 dBm to 17.0 dBm
Increment: | 0.1 dB
*RST: | 15.5 dBm
Example: MIX:LOP 16.0dBm
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "LO Level"


[SENSe:]MIXer:SIGNal

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:SIGNal
[SENSe:]MIXer:SIGNal <State>

This command specifies whether automatic signal detection is active or not.

Note that automatic signal identification is only available for measurements that perform frequency sweeps (not in vector signal analysis or the I/Q Analyzer, for instance).

Parameters:
<State>
OFF | ON | AUTO | ALL
OFF

No automatic signal detection is active.

ON

Automatic signal detection (Signal ID) is active.

AUTO

Automatic signal detection (Auto ID) is active.

ALL

Both automatic signal detection functions (Signal ID+Auto ID) are active.

*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Signal ID"
See "Auto ID"


[SENSe:]MIXer:THReshold

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Basic Settings > [SENSe:]MIXer:THReshold
[SENSe:]MIXer:THReshold <Value>

This command defines the maximum permissible level difference between test sweep and reference sweep to be corrected during automatic comparison (see [SENSe:​]MIXer:​SIGNal).

Parameters:
<Value>
<numeric value>
Range: | 0.1 dB to 100 dB
*RST: | 10 dB
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer"

Manual operation: See "Auto ID Threshold"


Mixer Settings

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings
Mixer Settings

The following commands are required to configure the band and specific mixer settings.

List of Commands
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]


[SENSe:]MIXer:FREQuency:HANDover

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:HANDover <Frequency>

This command defines the frequency at which the mixer switches from one range to the next (if two different ranges are selected). The handover frequency for each band can be selected freely within the overlapping frequency range.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Frequency> | numeric value
Example: | MIX ON Activates the external mixer. MIX:FREQ:HAND 78.0299GHz Sets the handover frequency to 78.0299 GHz.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Handover Freq."


[SENSe:]MIXer:FREQuency:STARt?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STARt?

This command queries the frequency at which the external mixer band starts.

Example: | MIX:FREQ:STAR? Queries the start frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:FREQuency:STOP?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:FREQuency:STOP?

This command queries the frequency at which the external mixer band stops.

Example: | MIX:FREQ:STOP? Queries the stop frequency of the band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Usage: | Query only
Manual operation: | See "RF Start / RF Stop"


[SENSe:]MIXer:HARMonic:BAND:PRESet

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND:PRESet

This command restores the preset frequency ranges for the selected standard waveguide band.

Note:Changes to the band and mixer settings are maintained even after using the PRESET function. Use this command to restore the predefined band ranges.

Example: | MIX:HARM:BAND:PRES Presets the selected waveguide band.
Usage: | Event
Manual operation: | See "Preset Band"


[SENSe:]MIXer:HARMonic:BAND[:VALue]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:BAND[:VALue] <Band>

This command selects the external mixer band. The query returns the currently selected band.

This command is only available if the external mixer is active (see [SENSe:​]MIXer[:​STATe]).

Parameters:
<Band> | KA | Q | U | V | E | W | F | D | G | Y | J | USER Standard waveguide band or user-defined band.
Example: | See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Band"
Frequency ranges for pre-defined bands
Band | Frequency start [GHz] | Frequency stop [GHz]
KA (A) *) | 26.5 | 40.0
Q | 33.0 | 50.0
U | 40.0 | 60.0
V | 50.0 | 75.0
E | 60.0 | 90.0
W | 75.0 | 110.0
F | 90.0 | 140.0
D | 110.0 | 170.0
G | 140.0 | 220.0
J | 220.0 | 325.0
Y | 325.0 | 500.0
USER | 32.18 (default) | 68.22 (default)
*) The band formerly referred to as "A" is now named "KA".


[SENSe:]MIXer:HARMonic:HIGH:STATe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH:STATe <State>

This command specifies whether a second (high) harmonic is to be used to cover the band's frequency range.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: MIX:HARM:HIGH:STAT ON
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Range 1/2"


[SENSe:]MIXer:HARMonic:HIGH[:VALue]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:HIGH[:VALue] <HarmOrder>

This command specifies the harmonic order to be used for the high (second) range.

Parameters:
<HarmOrder
numeric value
Range: 2 to 61 (USER band); for other bands: see band definition
Example: MIX:HARM:HIGH 2
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:HARMonic:TYPE

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic:TYPE <OddEven>

This command specifies whether the harmonic order to be used should be odd, even, or both.

Which harmonics are supported depends on the mixer type.

Parameters:
<OddEven>
ODD | EVEN | EODD
*RST: EVEN
Example: MIX:HARM:TYPE ODD
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Type"


[SENSe:]MIXer:HARMonic[:LOW]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:HARMonic[:LOW] <HarmOrder>

This command specifies the harmonic order to be used for the low (first) range.

Parameters:
<HarmOrder>
numeric value
Range: | 2 to 61 (USER band); for other bands: see band definition
*RST: | 2 (for band F)
Example: MIX:HARM 3
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]MIXer:LOSS:HIGH

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:HIGH <Average>

This command defines the average conversion loss to be used for the entire high (second) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS:HIGH 20dB
Example:

See "Programming Example: Working with an External Mixer" and "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe:HIGH

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH <FileName>

This command defines the file name of the conversion loss table to be used for the high (second) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL:HIGH 'MyCVLTable'
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS:TABLe[:LOW]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS:TABLe[:LOW] <FileName>

This command defines the file name of the conversion loss table to be used for the low (first) range.

Parameters:
<FileName> | string ('<file name>')
Example: | MIX:LOSS:TABL 'mix_1_4' Specifies the conversion loss table mix_1_4.
Example: | See "Configuring a conversion loss table for a user-defined band"
Manual operation: | See "Conversion loss"


[SENSe:]MIXer:LOSS[:LOW]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:LOSS[:LOW] <Average>

This command defines the average conversion loss to be used for the entire low (first) range.

Parameters:
<Average>
numeric value
Range: | 0 to 100
*RST: | 24.0 dB
Default unit: | dB
Example: MIX:LOSS 20dB
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Conversion loss"


[SENSe:]MIXer:PORTs

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:PORTs
[SENSe:]MIXer:PORTs <PortType>

This command specifies whether the mixer is a 2-port or 3-port type.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: MIX:PORT 3
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "Mixer Type"


[SENSe:]MIXer:RFOVerrange[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Mixer Settings > [SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:RFOVerrange[:STATe] <State>

If enabled, the band limits are extended beyond "RF Start" and "RF Stop" due to the capabilities of the used harmonics.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Programming Example: Working with an External Mixer".

Manual operation: See "RF Overrange"


Conversion Loss Table Settings

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings
Conversion Loss Table Settings

The following settings are required to configure and manage conversion loss tables.

List of Commands
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber


[SENSe:]CORRection:CVL:BAND

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BAND <Type>

This command defines the waveguide band for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Band>
K | A | KA | Q | U | V | E | W | F | D | G | Y | J | USER

Standard waveguide band or user-defined band.

Note: The band formerly referred to as "A" is now named "KA"; the input parameter "A" is still available and refers to the same band as "KA".

For a definition of the frequency range for the pre-defined bands, see table " Frequency ranges for pre-defined bands").

*RST: F (90 GHz - 140 GHz)
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BAND KA

Sets the band to KA (26.5 GHz - 40 GHz).

Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Band"


[SENSe:]CORRection:CVL:BIAS

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:BIAS <BiasSetting>

This command defines the bias setting to be used with the conversion loss table.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<BiasSetting>
numeric value
*RST: | 0.0 A
Default unit: | A
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:BIAS 3A
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Write to <CVL table name>"
See "Bias"


[SENSe:]CORRection:CVL:CATAlog?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CATAlog?

This command queries all available conversion loss tables saved in the C:\r_s\instr\user\cvl\ directory on the instrument.

This command is only available with option B21 (External Mixer) installed.

Usage: Query only


[SENSe:]CORRection:CVL:CLEAr

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:CLEAr

This command deletes the selected conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:CLE
Usage: | Event
Manual operation: | See "Delete Table"


[SENSe:]CORRection:CVL:COMMent

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:COMMent <Text>

This command defines a comment for the conversion loss table. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Text> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:COMM 'Conversion loss table for FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Comment"


[SENSe:]CORRection:CVL:DATA

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:DATA <Freq>,<Level>

This command defines the reference values of the selected conversion loss tables. The values are entered as a set of frequency/level pairs. A maximum of 50 frequency/level pairs may be entered. Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Freq> | numeric value The frequencies have to be sent in ascending order.
<Level> |
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:DATA 1MHZ,-30DB,2MHZ,-40DB
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Position/Value"


[SENSe:]CORRection:CVL:HARMonic

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:HARMonic <HarmOrder>

This command defines the harmonic order for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<HarmOrder>
numeric value
Range: 2 to 65
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:HARM 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Harmonic Order"


[SENSe:]CORRection:CVL:MIXer

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:MIXer <Type>

This command defines the mixer name in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<Type> | string Name of mixer with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX 'FS_Z60'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer Name"


[SENSe:]CORRection:CVL:PORTs

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:PORTs <PortNo>

This command defines the mixer type in the conversion loss table. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<PortType>
2 | 3
*RST: 2
Example: CORR:CVL:SEL 'LOSS_TAB_4'

Selects the conversion loss table.

CORR:CVL:PORT 3
Example:

See "Configuring a conversion loss table for a user-defined band".

Manual operation: See "Mixer Type"


[SENSe:]CORRection:CVL:SELect

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SELect <FileName>

This command selects the conversion loss table with the specified file name. If <file_name> is not available, a new conversion loss table is created.

This command is only available with option B21 (External Mixer) installed.

Parameters:
<FileName> | '<File name>'
Example: | CORR:CVL:SEL 'LOSS_TAB_4'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "New Table" See "Edit Table" See "File Name"


[SENSe:]CORRection:CVL:SNUMber

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Conversion Loss Table Settings > [SENSe:]CORRection:CVL:SNUMber
[SENSe:]CORRection:CVL:SNUMber <SerialNo>

This command defines the serial number of the mixer for which the conversion loss table is to be used. This setting is checked against the current mixer setting before the table can be assigned to the range.

Before this command can be performed, the conversion loss table must be selected (see [SENSe:​]CORRection:​CVL:​SELect).

This command is only available with option B21 (External Mixer) installed.

Parameters:
<SerialNo> | Serial number with a maximum of 16 characters
Example: | CORR:CVL:SEL 'LOSS_TAB_4' Selects the conversion loss table. CORR:CVL:MIX '123.4567'
Example: | See "Configuring a conversion loss table for a user-defined band".
Manual operation: | See "Mixer S/N"


Programming Example: Working with an External Mixer

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Using External Mixers > Programming Example: Working with an External Mixer
Programming Example: Working with an External Mixer

This example demonstrates how to work with an external mixer in a remote environment. It is performed in the Spectrum application in the default layout configuration. Note that without a real input signal and connected mixer, this measurement will not return useful results.

//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//----------- Configuring basic mixer behavior -------------
//Set the LO level of the mixer's LO port to 15 dBm.
SENS:MIX:LOP 15dBm
//Set the bias current to -1 mA .
SENS:MIX:BIAS:LOW -1mA
//----------- Configuring the mixer and band settings -------------
//Use band "V" to full possible range extent for assigned harmonic (6).
SENS:MIX:HARM:BAND V
SENS:MIX:RFOV ON
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)
//Use a 3-port mixer type
SENS:MIX:PORT 3
//Split the frequency range into two ranges;
//range 1 covers 47.48 GHz GHz to 80 GHz; harmonic 6, average conv. loss of 20 dB
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:LOW  20dB
SENS:MIX:HARM:HIGH 8
SENS:MIX:LOSS:HIGH 30dB
//--------- Activating automatic signal identification functions -----------
//Activate both automatic signal identification functions.
SENS:MIX:SIGN ALL
//Use auto ID threshold of 8 dB.
SENS:MIX:THR 8dB

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data for the input signal without distortions
//(default screen configuration)
TRAC:DATA? TRACE3
Configuring a conversion loss table for a user-defined band
//--------------Preparing the instrument -----------
//Reset the instrument
*RST
//Activate the use of the connected external mixer.
SENS:MIX ON
//--------------Configuring a new conversion loss table --------------
//Define cvl table for range 1 of band as described in previous example
// (extended V band)
SENS:CORR:CVL:SEL 'UserTable'
SENS:CORR:CVL:COMM 'User-defined conversion loss table for USER band'
SENS:CORR:CVL:BAND USER
SENS:CORR:CVL:HARM 6
SENS:CORR:CVL:BIAS -1mA
SENS:CORR:CVL:MIX 'FS_Z60'
SENS:CORR:CVL:SNUM '123.4567'
SENS:CORR:CVL:PORT 3
//Conversion loss is linear from 55 GHz to 75 GHz
SENS:CORR:CVL:DATA 55GHZ,-20DB,75GHZ,-30DB
//----------- Configuring the mixer and band settings -------------
//Use user-defined band and assign new cvl table.
SENS:MIX:HARM:BAND USER
//Define band by two ranges;
//range 1 covers 47.48 GHz to 80 GHz; harmonic 6, cvl table 'UserTable'
//range 2 covers 80 GHz to 138.02 GHz; harmonic 8, average conv.loss of 30 dB
SENS:MIX:HARM:TYPE EVEN
SENS:MIX:HARM:HIGH:STAT ON
SENS:MIX:FREQ:HAND 80GHz
SENS:MIX:HARM:LOW 6
SENS:MIX:LOSS:TABL:LOW 'UserTable'
SENS:MIX:HARM:HIGH 8

SENS:MIX:LOSS:HIGH 30dB
//Query the possible range
SENS:MIX:FREQ:STAR?
//Result: 47480000000 (47.48 GHz)
SENS:MIX:FREQ:STOP?
//Result: 138020000000 (138.02 GHz)

//--------------Performing the Measurement-----
//Select single sweep mode.
INIT:CONT OFF
//Initiate a basic frequency sweep and wait until the sweep has finished.
INIT;*WAI
//---------------Retrieving Results-------------
//Return the trace data (default screen configuration)
TRAC:DATA? TRACe1


Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

The following commands are required to control the Analog Baseband Interface (R&S FSW-B71) in a remote environment.They are only available if this option is installed.

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface" .

Useful commands for Analog Baseband data described elsewhere:
  • INP:SEL AIQ (see INPut:​SELect)
  • [SENSe:​]FREQuency:​CENTer
For calibration:
  • DIAGnostic:​SERVice:​INPut[:​SELect]
  • DIAGnostic:​SERVice:​INPut:​AIQ[:​TYPE]
Remote commands exclusive to Analog Baseband data input and output
List of Commands
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
[SENSe:]PROBe<ch>:SETup:CMOFfset
TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?


INPut:IQ:BALanced[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:BALanced[:STATe]
INPut:IQ:BALanced[:STATe] <State>

This command defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Parameters:
<State>
ON

Differential

OFF

Simple-ended

*RST: ON
Example: INP:IQ:BAL OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Input configuration"


INPut:IQ:FULLscale:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale:AUTO <State>

This command defines whether the full scale level (i.e. the maximum input power on the Baseband Input connector) is defined automatically according to the reference level, or manually.

Parameters:
<State>
ON

Automatic definition

OFF

Manual definition according to INPut:​IQ:​FULLscale[:​LEVel]

*RST: ON
Example: INP:IQ:FULL:AUTO OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


INPut:IQ:FULLscale[:LEVel]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale[:LEVel]
INPut:IQ:FULLscale[:LEVel] <PeakVoltage>

This command defines the peak voltage at the Baseband Input connector if the full scale level is set to manual mode (see INPut:​IQ:​FULLscale:​AUTO).

Parameters:
<PeakVoltage>
0.25 V | 0.5 V | 1 V | 2 V

Peak voltage level at the connector.

For probes, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

*RST: 1V
Example: INP:IQ:FULL 0.5V
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


INPut:IQ:TYPE

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:TYPE
INPut:IQ:TYPE <DataType>

This command defines the format of the input signal.

Parameters:
<DataType>
IQ | I | Q
IQ

The input signal is filtered and resampled to the sample rate of the application.

Two input channels are required for each input signal, one for the in-phase component, and one for the quadrature component.

I

The in-phase component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0 (see [SENSe:​]FREQuency:​CENTer), the in-phase component of the input signal is down-converted first (Low IF I).

Q

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

*RST: IQ
Example:

INP:IQ:TYPE Q

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "I/Q Mode"


CALibration:AIQ:DCOFfset:I

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:I <Offset>

This command defines a DC offset of the I input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:I 0.001


CALibration:AIQ:DCOFfset:Q

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:Q
CALibration:AIQ:DCOFfset:Q <Offset>

This command defines a DC offset of the Q input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:Q 0.001


[SENSe:]PROBe<ch>:SETup:CMOFfset

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > [SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<ch>:SETup:CMOFfset <CMOffset>

Sets the common mode offset. The setting is only available if a differential probe is connected to the R&S FSW.

If the probe is disconnected, the common mode offset of the probe is reset to 0.0 V.

For details see "Common Mode Offset" .

Suffix:
<ch>
1..4

Selects the input channel.

Parameters:
<CMOffset>
Range: | -100E+24 to 100E+24
Increment: | 1E-3
*RST: | 0
Default unit: | V


TRACe:IQ:APCon[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon[:STATe] <State>

If enabled, the average power consumption is calculated at the end of the I/Q data measurement. This command must be set before the measurement is performed!

The conversion factors A and B for the calculation are defined using TRACe:​IQ:​APCon:​A and TRACe:​IQ:​APCon:​B.

The results can be queried using TRACe:​IQ:​APCon:​RESult?.

For details see "Average Power Consumption" .

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:A

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:A
TRACe:IQ:APCon:A <ConvFact>

Defines the conversion factor A for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 1.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:B

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:B
TRACe:IQ:APCon:B <ConvFact>

Defines the conversion factor B for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 0.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:RESult?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon:RESult?

Queries the average power consumption for an analog baseband input. This value is only calculated at the end of the I/Q data measurement if the TRACe:​IQ:​APCon[:​STATe] command is set to ON before the measurement is performed!

For details see "Average Power Consumption" .

Parameters:
<Average>
numeric value
Default unit: W
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?
Usage: Query only


Configuring Digital I/Q Input and Output

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output
Configuring Digital I/Q Input and Output
Remote commands for the R&S DigIConf software

Remote commands for the R&S DigIConf software always begin with SOURce:EBOX. Such commands are passed on from the R&S FSW to the R&S DigIConf automatically which then configures the R&S EX-IQ-BOX via the USB connection.

Be sure to connect the R&S EX-IQ-BOX to the R&S FSW via USB, not via LAN!

All remote commands available for configuration via the R&S DigIConf software are described in the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Example 1:

SOURce:EBOX:*RST

SOURce:EBOX:*IDN?

Result:

"Rohde&Schwarz,DigIConf,02.05.436 Build 47"

Example 2:

SOURce:EBOX:USER:CLOCk:REFerence:FREQuency 5MHZ

Defines the frequency value of the reference clock.

Remote commands exclusive to digital I/Q data input and output
List of Commands
INPut:DIQ:CDEVice
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
OUTPut:DIQ
OUTPut:DIQ:CDEVice


INPut:DIQ:CDEVice

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:CDEVice
INPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q input from the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<SampleRate>

Maximum or currently used sample rate of the connected device in Hz (depends on the used connection protocol version; indicated by <SampleRateType> parameter)

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<SampleRateType>
0

Maximum sample rate is displayed

1

Current sample rate is displayed

<FullScaleLevel>

The level (in dBm) that should correspond to an I/Q sample with the magnitude "1" (if transferred from connected device);

If not available, 9.97e37 is returned

Example: INP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Connected Instrument"


INPut:DIQ:RANGe[:UPPer]:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:AUTO <State>

If enabled, the digital input full scale level is automatically set to the value provided by the connected device (if available).

This command is only available if the optional Digital Baseband interface (option R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe:COUPling

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe:COUPling <State>

If enabled, the reference level for digital input is adjusted to the full scale level automatically if the full scale level changes.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Adjust Reference Level to Full Scale Level"


INPut:DIQ:RANGe[:UPPer]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer] <Level>

Defines or queries the "Full Scale Level", i.e. the level that corresponds to an I/Q sample with the magnitude "1".

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
<numeric value>
Range: | 1 μV to 7.071 V
*RST: | 1 V
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe[:UPPer]:UNIT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:RANGe[:UPPer]:UNIT <Unit>

Defines the unit of the full scale level (see "Full Scale Level"). The availability of units depends on the measurement application you are using.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
VOLT | DBM | DBPW | WATT | DBMV | DBUV | DBUA | AMPere
*RST: Volt
Manual operation: See "Full Scale Level"


INPut:DIQ:SRATe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe
INPut:DIQ:SRATe <SampleRate>

This command specifies or queries the sample rate of the input signal from the Digital Baseband Interface (R&S FSW-B17, see "Input Sample Rate").

Parameters:
<SampleRate>
Range: | 1 Hz to 10 GHz
*RST: | 32 MHz
Example:

INP:DIQ:SRAT 200 MHz

Manual operation: See "Input Sample Rate"


INPut:DIQ:SRATe:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe:AUTO
INPut:DIQ:SRATe:AUTO <State>

If enabled, the sample rate of the digital I/Q input signal is set automatically by the connected device.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Input Sample Rate"


OUTPut:DIQ

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > OUTPut:DIQ
OUTPut:DIQ <State>

This command turns continuous output of I/Q data to the optional Digital Baseband Interface (R&S FSW-B17) on and off.

Using the digital input and digital output simultaneously is not possible.

If digital baseband output is active, the sample rate is restricted to 100 MHz (200 MHz if enhanced mode is possible; max. 160 MHz bandwidth).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: OUTP:DIQ ON
Example:

See "Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (-B17)" .

Example:

See "Output via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Digital Baseband Output"


OUTPut:DIQ:CDEVice

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring Digital I/Q Input and Output > OUTPut:DIQ:CDEVice
OUTPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q data output to the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<NotUsed>

to be ignored

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<NotUsed>

to be ignored

<Placeholder>

for future use; currently "0"

Example: OUTP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Output via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Output Settings Information"
See "Connected Instrument"


Input from I/Q Data Files

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Input from I/Q Data Files
Input from I/Q Data Files

The input for measurements can be provided from I/Q data files.The commands required to configure the use of such files are described here.

For details see "Basics on Input from I/Q Data Files".

Useful commands for retrieving results described elsewhere:
  • INPut:​SELect
Remote commands exclusive to input from I/Q data files:
List of Commands
INPut:FILE:PATH


INPut:FILE:PATH

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Input from I/Q Data Files > INPut:FILE:PATH
INPut:FILE:PATH <FileName>

This command selects the I/Q data file to be used as input for further measurements.

The I/Q data must have a specific format as described in "I/Q Data File Format (iq-tar)".

For details see "Basics on Input from I/Q Data Files".

Parameters:
<FileName> | String containing the path and name of the source file. The file extension is *.iq.tar.
Example: | INP:FILE:PATH 'C:\R_S\Instr\user\data.iq.tar' Uses I/Q data from the specified file as input.
Usage: | Setting only
Manual operation: | See "Select I/Q Data File"


Configuring the Outputs

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:IF:IFFRequency


DIAGnostic:SERVice:NSOurce

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:IF:IFFRequency

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Input/Output Settings > Configuring the Outputs > OUTPut:IF:IFFRequency
OUTPut:IF:IFFRequency <Frequency>

This command defines the frequency for the IF output. The IF frequency of the signal is converted accordingly.

This command is available in the time domain and if the IF/VIDEO/DEMOD output is configured for IF.

Parameters:
<Frequency>
*RST: 50.0 MHz


Frontend Configuration

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration
Frontend Configuration

The following commands are required to configure frequency and amplitude settings, which represent the "frontend" of the measurement setup.

Contents
  • Frequency
  • Amplitude Settings
  • Configuring the Attenuation


Frequency

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Frequency
Frequency
List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet


[SENSe:]FREQuency:CENTer

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center Frequency"
See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

You can increase or decrease the center frequency quickly in fixed steps using the SENS:FREQ UP AND SENS:FREQ DOWN commands, see [SENSe:​]FREQuency:​CENTer.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <State>

This command couples or decouples the center frequency step size to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: FREQ:CENT:STEP:AUTO ON

Activates the coupling of the step size to the span.


[SENSe:]FREQuency:OFFSet

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

See also "Frequency Offset".

Note: In MSRA/MSRT mode, the setting command is only available for the MSRA/MSRT Master. For MSRA/MSRT applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


Amplitude Settings

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Amplitude Settings
Amplitude Settings

The following commands are required to configure the amplitude settings in a remote environment.

Useful commands for amplitude settings described elsewhere:
  • INPut:​COUPling
  • INPut:​IMPedance
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO
Remote commands exclusive to amplitude settings:
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
INPut:GAIN:STATe
INPut:GAIN[:VALue]


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

With a reference level offset ≠ 0, the value range of the reference level is modified by the offset.

Parameters:
<ReferenceLevel>

The unit is variable.

Range: | see datasheet
*RST: | 0 dBm
Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


INPut:GAIN:STATe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Amplitude Settings > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the preamplification is defined by INPut:​GAIN[:​VALue].

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Amplitude Settings > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Configuring the Attenuation

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Configuring the Attenuation
Configuring the Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Configuring the Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If an electronic attenuator is available and active, the command defines a mechanical attenuation (see INPut:​EATT:​STATe).

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Configuring the Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Configuring the Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Configuring the Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Frontend Configuration > Configuring the Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Triggering Measurements

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements
Triggering Measurements
MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. Thus, no trigger settings are available in the Pulse application in MSRA/MSRT operating mode. However, a capture offset can be defined with a similar effect as a trigger offset. It defines an offset from the start of the captured data (from the MSRA/MSRT Master) to the start of the application data for pulse measurements. (See "Configuring an Analysis Interval and Line (MSRA mode only)"/ "Configuring an Analysis Interval and Line (MSRT mode only)".)

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

Useful commands for triggering described elsewhere:
  • [SENSe:​]FREQuency:​CENTer
Remote commands exclusive to triggering:
Contents
  • Configuring the Triggering Conditions
  • Configuring the Trigger Output


Configuring the Triggering Conditions

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:RFPower:HOLDoff
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval


TRIGger[:SEQuence]:DTIMe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

A negative offset is possible for time domain measurements.

Parameters:
<Offset>

For measurements in the frequency domain, the range is 0 s to 30 s.

For measurements in the time domain, the range is the negative sweep time to 30 s.

*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Note that the variable INPUT/OUTPUT connectors (ports 2+3) must be set for use as input using the OUTPut:​TRIGger<port>:​DIRection command.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:LEVel:IFPower

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Level (Repetition interval)"


TRIGger[:SEQuence]:LEVel:IQPower

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance" .


TRIGger[:SEQuence]:LEVel:RFPower

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:RFPower <TriggerLevel>

This command defines the power level the RF input must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

The input signal must be between 500 MHz and 8 GHz.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -20 dBm
Example: TRIG:LEV:RFP -30dBm


TRIGger[:SEQuence]:RFPower:HOLDoff

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:RFPower:HOLDoff
TRIGger[:SEQuence]:RFPower:HOLDoff <Time>

This command defines the holding time before the next trigger event. Note that this command is available for any trigger source, not just RF Power.

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Time>
Default unit: S


TRIGger[:SEQuence]:SLOPe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

IFPower

Second intermediate frequency

IQPower

Magnitude of sampled I/Q data

For applications that process I/Q data, such as the I/Q Analyzer or optional applications.

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "I/Q Power"
See "IF Power"
See "RF Power"


TRIGger[:SEQuence]:TIME:RINTerval

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:TIME:RINTerval
TRIGger[:SEQuence]:TIME:RINTerval <Interval>

This command defines the repetition interval for the time trigger.

Parameters:
<Interval>
2.0 ms to 5000
Range: | 2 ms to 5000 s
*RST: | 1.0 s
Example: TRIG:SOUR TIME

Selects the time trigger input for triggering.

TRIG:TIME:RINT 50

The sweep starts every 50 s.


Configuring the Trigger Output

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


Segmented Data Capturing

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Segmented Data Capturing
Segmented Data Capturing

Configures data capturing with a gating function, that is non-continuous data acquisition.

Segmented capture is only possible if an external, IF Power, or RF Power trigger is used (see "Trigger Source").

List of Commands
[SENSe:]SWEep:SCAPture:EVENts
[SENSe:]SWEep:SCAPture:LENGth[:TIME]
[SENSe:]SWEep:SCAPture:OFFSet[:TIME]
[SENSe:]SWEep:SCAPture[:STATe]


[SENSe:]SWEep:SCAPture:EVENts

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Segmented Data Capturing > [SENSe:]SWEep:SCAPture:EVENts
[SENSe:]SWEep:SCAPture:EVENts <NoEvents>

Specifies the number of trigger events for which data segments are to be captured.

Parameters:
<NoEvents>
numeric value
*RST: 2
Manual operation: See "Events"


[SENSe:]SWEep:SCAPture:LENGth[:TIME]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Segmented Data Capturing > [SENSe:]SWEep:SCAPture:LENGth[:TIME]
[SENSe:]SWEep:SCAPture:LENGth[:TIME] <SegmentLen>

Defines a time period (starting from the trigger offset) in which data is captured. If multiple events occur within one segment length, the segment is extended (see "Number of events vs number of segments").

Parameters:
<SegmentLen>
*RST: | 0
Default unit: | s
Manual operation: See "Segment Length"


[SENSe:]SWEep:SCAPture:OFFSet[:TIME]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Segmented Data Capturing > [SENSe:]SWEep:SCAPture:OFFSet[:TIME]
[SENSe:]SWEep:SCAPture:OFFSet[:TIME] <Offset>

Defines an offset to the trigger event at which data capturing starts. For a negative offset, data capturing starts before the actual trigger event.

Parameters:
<Offset>
*RST: | 0
Default unit: | s
Manual operation: See "Trigger Offset"


[SENSe:]SWEep:SCAPture[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Segmented Data Capturing > [SENSe:]SWEep:SCAPture[:STATe]
[SENSe:]SWEep:SCAPture[:STATe] <State>

If activated, data is captured for the specified duration before and after each trigger event, for the specified number of trigger events. The signal data between these capture times is not stored in the capture buffer.

Parameters:
<State>
ON | OFF | 0 | 1
OFF | 0

Switches the function off

ON | 1

Switches the function on

*RST: 0
Example:
//Configure a power trigger at -20dBm
TRIG:SOUR RFP
TRIG:LEV:RFP -20dBm
//Activate segmented capture
SENS:SWE:SCAP ON
//Define a pretrigger offset of 5 us
SENS:SWE:SCAP:OFFS -5 us
//Capture data for 20us for 20 trigger events
SENS:SWE:SCAP:EVEN 20
SENS:SWE:SCAP:LENG 20 us

//Select single sweep mode.
INIT:CONT OFF
//Initiate a new measurement and wait until the sweep
//has finished.
INIT;*WAI

//Query the timestamps at which segments were captured
TRAC:IQ:SCAP:TST:SST?
//Query the timestamps at which trigger events occured
TRAC:IQ:SCAP:TST:TRIG?
Manual operation: See "Activating/de-activating segmented data capturing"


Data Acquisition

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Data Acquisition
Data Acquisition

The following commands are required to configure how much and how data is captured from the input signal.

MSRA/MSRT operating mode

In MSRA/MSRT operating mode, only the MSRA/MSRT Master channel actually captures data from the input signal. The data acquisition settings for pulse measurements in MSRA/MSRT mode define the application data extract and analysis interval.

For details on the MSRA operating mode see "Applications and Operating Modes" . For details on the MSRT operating mode see "Applications and Operating Modes" .

List of Commands
[SENSe:]BANDwidth:DEMod
[SENSe:]BWIDth:DEMod
[SENSe:]BANDwidth|BWIDth:DEMod:TYPE
[SENSe:]SRATe?
[SENSe:]SWEep:TIME


[SENSe:]BANDwidth:DEMod

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Data Acquisition > [SENSe:]BANDwidth:DEMod
[SENSe:]BANDwidth:DEMod <Bandwidth>
[SENSe:]BWIDth:DEMod <Bandwidth>

Sets/queries the measurement bandwidth in Hz.

The measurement bandwidth is defined by the used filter and the sample rate. For information on supported sample rates and filter bandwidths see the data sheet.

Parameters:
<Bandwidth>
*RST: | 80.0 MHz
Default unit: | HZ


[SENSe:]BANDwidth|BWIDth:DEMod:TYPE

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Data Acquisition > [SENSe:]BANDwidth|BWIDth:DEMod:TYPE
[SENSe:]BANDwidth|BWIDth:DEMod:TYPE <FilterType>

This command defines the type of demodulation filter to be used. For information on supported filter bandwidths see the data sheet.

Parameters:
<FilterType>
FLAT

Standard flat demodulation filter

GAUSs

Gaussian filter for optimized settling behaviour

For Gaussian filters with a large 3dB bandwidth (> 40 MHz, only available with the bandwidth extension option R&S FSW-B160/-B320/-B500) the actual filter shape deviates strongly from the ideal Gauss filter outside a range of approximately ±80 MHz. For this range the flat filter is more accurate.

For details see "Effects of Large Gauss Filters".

*RST: GAUS
Example:

See "Programming Example: Pulse Measurement".

Manual operation: See "Filter type"


[SENSe:]SRATe?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Data Acquisition > [SENSe:]SRATe?
[SENSe:]SRATe?

This command returns the sample rate set up for current measurement settings.

Return values:
<SampleRate> | Current sample rate used by the application.
Usage: | Query only


[SENSe:]SWEep:TIME

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Data Acquisition > [SENSe:]SWEep:TIME
[SENSe:]SWEep:TIME <Time>

This command defines the sweep (or: data capture) time.

The maximum measurement time in the R&S FSW Pulse application is limited only by the available memory ("memory limit reached" message is shown in status bar). Note, however, that increasing the measurement time (and thus reducing the available memory space) may restrict the number of measurement channels that can be activated simultaneously on the R&S FSW.

Parameters:
<Time>
refer to data sheet
*RST: depends on current settings (determined automatically)
Example: SWE:TIME 10s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Measurement Time"


Pulse Detection

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Pulse Detection
Pulse Detection

The pulse detection settings define the conditions under which a pulse is detected within the input signal.

List of Commands
[SENSe:]DETect:LIMit
[SENSe:]DETect:LIMit:COUNt
[SENSe:]DETect:HYSTeresis
[SENSe:]DETect:REFerence
[SENSe:]DETect:THReshold


[SENSe:]DETect:LIMit

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Pulse Detection > [SENSe:]DETect:LIMit
[SENSe:]DETect:LIMit <MaxCountLimit>

If enabled, the number of pulses to be detected is restricted. When the maximum number is exceeded, measurement is stopped for the current capture buffer. This limitation can be used to speed up the measurement if only a small number of pulses is of interest.

The maximum number of pulses to be detected is defined using the [SENSe:​]DETect:​LIMit:​COUNt command.

Parameters:
<MaxCountLimit>
ON | OFF
*RST: OFF
Manual operation: See "Detection Limit"


[SENSe:]DETect:LIMit:COUNt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Pulse Detection > [SENSe:]DETect:LIMit:COUNt
[SENSe:]DETect:LIMit:COUNt <MaxPulseCount>

Defines the maximum number of pulses to be detected.

This limit is only considered if [SENSe:​]DETect:​LIMit is enabled.

Parameters:
<MaxPulseCount>
integer
*RST: 1000
Manual operation: See "Maximum Pulse Count"


[SENSe:]DETect:HYSTeresis

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Pulse Detection > [SENSe:]DETect:HYSTeresis
[SENSe:]DETect:HYSTeresis <Hysteresis>

Defines a hysteresis for pulse detection in dB in relation to the defined threshold (see [SENSe:​]DETect:​THReshold). As long as the signal does not exceed the hysteresis, the next threshold crossing is ignored.

Parameters:
<Hysteresis>
*RST: | 0
Default unit: | DB
Manual operation: See "Hysteresis"


[SENSe:]DETect:REFerence

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Pulse Detection > [SENSe:]DETect:REFerence
[SENSe:]DETect:REFerence <Reference>

The reference level to be used for setting the pulse detection threshold.

Parameters:
<Reference>
REFLevel | PEAK | NOISe | ABSolute
REFLevel

Current reference level

PEAK

Peak level as measured over the entire capture data interval

NOISe

Noise level determined from the current capture data according to SENSe:​TRACe:​MEASurement:​DEFine:​DURation:​MIN.

ABSolute

Absolute level defined by [SENSe:​]DETect:​THReshold.

*RST: PEAK
Manual operation: See "Reference Source"


[SENSe:]DETect:THReshold

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Pulse Detection > [SENSe:]DETect:THReshold
[SENSe:]DETect:THReshold <Level>

The threshold determines whether a pulse is detected or not. The top of a pulse must exceed the threshold in order to be detected. The threshold is defined in relation to the reference defined by [SENSe:​]DETect:​REFerence.

Parameters:
<Level>
numeric value in dB or dBm, depending on reference type
*RST: -10.0
Manual operation: See "Threshold"


Configuring the Pulse Measurement

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement
Configuring the Pulse Measurement

The following commands determine how much data is measured for each pulse, in relation to defined levels, points, or ranges.

Contents
  • Measurement Levels
  • Measurement Point
  • Measurement Range


Measurement Levels

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Levels
Measurement Levels
List of Commands
SENSe:TRACe:MEASurement:ALGorithm
SENSe:TRACe:MEASurement:DEFine:AMPLitude:UNIT
SENSe:TRACe:MEASurement:DEFine:BOUNdary:TOP
SENSe:TRACe:MEASurement:DEFine:COMPensate:ADRoop
SENSe:TRACe:MEASurement:DEFine:RIPPle
SENSe:TRACe:MEASurement:DEFine:TRANsition:HREFerence
SENSe:TRACe:MEASurement:DEFine:TRANsition:LREFerence
SENSe:TRACe:MEASurement:DEFine:TRANsition:REFerence


SENSe:TRACe:MEASurement:ALGorithm

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Levels > SENSe:TRACe:MEASurement:ALGorithm
SENSe:TRACe:MEASurement:ALGorithm <Algorithm>

The measurement algorithm used for finding the pulse top and base levels.

Parameters:
<Algorithm>
MEAN | MEDian | HISTogram | FIXed
*RST: MEDian
Manual operation: See "Measurement Algorithm"


SENSe:TRACe:MEASurement:DEFine:AMPLitude:UNIT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Levels > SENSe:TRACe:MEASurement:DEFine:AMPLitude:UNIT
SENSe:TRACe:MEASurement:DEFine:AMPLitude:UNIT <Unit>

Defines the unit of the pulse amplitude values, i.e. whether magnitude (V) or power (W, dBm) values are used to determine the threshold levels for fall and rise times.

Parameters:
<Unit>
V | W | DBM
*RST: V
Manual operation: See "Reference Level Unit"


SENSe:TRACe:MEASurement:DEFine:BOUNdary:TOP

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Levels > SENSe:TRACe:MEASurement:DEFine:BOUNdary:TOP
SENSe:TRACe:MEASurement:DEFine:BOUNdary:TOP <PulseInstant>

The boundary in percent of the pulse amplitude to either side of the pulse top (ON state). Used to determine the settling time, for example. Once the signal remains within the boundary, it is assumed to have settled.

Parameters:
<PulseInstant>
percentage
Range: | 0 to 100
*RST: | 3
Manual operation: See "Boundary"


SENSe:TRACe:MEASurement:DEFine:COMPensate:ADRoop

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Levels > SENSe:TRACe:MEASurement:DEFine:COMPensate:ADRoop
SENSe:TRACe:MEASurement:DEFine:COMPensate:ADRoop <State>

Determines whether the 100% value (from base to top) for the rise and fall time measurements is calculated from the Edges.

This allows you to consider a "droop" in the pulse top during the pulse measurements. If a droop is to be considered, the 100% value must be calculated separately for the rising and falling edges.

Parameters:
<State>
ON

The 100% value is measured separately for the rising and falling edges.

OFF

The 100% value is measured at the pulse center and used for all measurements.

*RST: ON
Manual operation: See "Position"


SENSe:TRACe:MEASurement:DEFine:RIPPle

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Levels > SENSe:TRACe:MEASurement:DEFine:RIPPle
SENSe:TRACe:MEASurement:DEFine:RIPPle <Portion>

Determines portion of the pulse top which is used to measure the ripple.

Parameters:
<Portion>
percentage
Range: | 0 to 100
*RST: | 50
Manual operation: See "Ripple Portion"


SENSe:TRACe:MEASurement:DEFine:TRANsition:HREFerence

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Levels > SENSe:TRACe:MEASurement:DEFine:TRANsition:HREFerence
SENSe:TRACe:MEASurement:DEFine:TRANsition:HREFerence <QueryRange>

The upper threshold in percent of the pulse amplitude used to signify the end of a rising or beginning of a falling signal level.

Parameters:
<QueryRange>
percentage
Range: | 0 to 100
*RST: | 90
Manual operation: See "High (Distal) Threshold"


SENSe:TRACe:MEASurement:DEFine:TRANsition:LREFerence

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Levels > SENSe:TRACe:MEASurement:DEFine:TRANsition:LREFerence
SENSe:TRACe:MEASurement:DEFine:TRANsition:LREFerence <QueryRange>

The lower threshold in percent of the pulse amplitude used to signify the end of a falling or beginning of a rising signal level.

Parameters:
<QueryRange>
percentage
Range: | 0 to 100
*RST: | 10
Manual operation: See "Low (Proximal) Threshold"


SENSe:TRACe:MEASurement:DEFine:TRANsition:REFerence

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Levels > SENSe:TRACe:MEASurement:DEFine:TRANsition:REFerence
SENSe:TRACe:MEASurement:DEFine:TRANsition:REFerence <QueryRange>

The threshold in percent of the pulse amplitude used to signify the mid-transition level between pulse states.

Parameters:
<QueryRange>
percentage
Range: | 0 to 100
*RST: | 50
Manual operation: See "Mid (Mesial) Threshold"


Measurement Point

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Point
Measurement Point
List of Commands
SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant
SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant:AWINdow
SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant:REFerence


SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Point > SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant
SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant <PulseInstant>

The offset of the reference time instant used for in-pulse measurements e.g. phase or for the pulse timestamp.

Parameters:
<PulseInstant>
*RST: | 0
Default unit: | S
Manual operation: See "Offset"


SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant:AWINdow

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Point > SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant:AWINdow
SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant:AWINdow <WindowSize>

Measurement point results are averaged over a window centered at the measurement point. The length of the averaging window in seconds can be defined. A minimum length of 1 sample is enforced internally.

Parameters:
<WindowSize>

Size of the window around the measurement point used for averaging

Range: | 0 to 10000
*RST: | 0.0
Default unit: | s
Manual operation: See "Averaging Window"


SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant:REFerence

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Point > SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant:REFerence
SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant:REFerence <Reference>

The reference point used for specifying the pulse time instant.

Parameters:
<Reference>
RISE | CENTer | FALL
RISE

The measurement point is defined in reference to the rising edge (mid-level crossing).

CENTer

The measurement point is defined in reference to the center of the pulse (equal distance from the rising and falling mid-level crossings).

FALL

The measurement point is defined in reference to the falling edge (mid-level crossing).

*RST: CENTer
Manual operation: See "Measurement Point Reference"


Measurement Range

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Range
Measurement Range
List of Commands
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:LENGth
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:OFFSet:LEFT
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:OFFSet:RIGHt
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:REFerence


SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:LENGth

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Range > SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:LENGth
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:LENGth <Length>

The estimation range length as a percentage of the pulse top length.

Parameters:
<Length>
percentage
Range: | 0 to 100
*RST: | 75
Manual operation: See "Reference"


SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:OFFSet:LEFT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Range > SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:OFFSet:LEFT
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:OFFSet:LEFT <OffsetLeft>

The offset in seconds from the pulse rising edge at which the estimation range begins.

Parameters:
<OffsetLeft>
*RST: | 0
Default unit: | S
Manual operation: See "Reference"


SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:OFFSet:RIGHt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Range > SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:OFFSet:RIGHt
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:OFFSet:RIGHt <OffsetRight>

The offset in seconds from the pulse falling edge at which the estimation range ends.

Parameters:
<OffsetRight>
*RST: | 0
Default unit: | S
Manual operation: See "Reference"


SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:REFerence

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Pulse Measurement > Measurement Range > SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:REFerence
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:REFerence <Reference>

Defines the reference for the measurement range definition. Depending on the selected reference type, an additional setting is available to define the range.

Parameters:
<Reference>
CENTer | EDGE
CENTer

Defines a relative range around the center of the pulse. The range is defined by its length in percent of the pulse top.

EDGE

Defines the start and stop of the measurement range with respect to the pulse edges. The range is defined by a time offset from the middle of the rising edge and a time offset from the middle of the falling edge.

*RST: CENTer
Manual operation: See "Reference"


Configuring and Performing Sweeps

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps
Configuring and Performing Sweeps

When the Pulse application is activated, a continuous sweep is performed automatically. However, you can stop and start a new measurement any time.

Furthermore, you can perform a sequence of measurements using the Sequencer (see "Multiple Measurement Channels and Sequencer Function").

Useful commands for configuring sweeps described elsewhere:
  • [SENSe:​]SWEep:​TIME
  • [SENSe:​]SWEep:​POINts
Remote commands exclusive to configuring sweeps:
List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:REFResh
INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
[SENSe:]AVERage:COUNt
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt:CURRent?
SYSTem:SEQuencer


ABORt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the measurement mode.

Note that in single measurement mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous measurement mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous measurement mode in remote control, as results like trace data or markers are only valid after a single measurement end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the measurement mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous measurement

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the measurement mode to single measurement.

INIT:CONT ON

Switches the measurement mode to continuous measurement.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

With sweep count or average count > 0, this means a restart of the corresponding number of measurements. With trace mode MAXHold, MINHold and AVERage, the previous results are reset on restarting the measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:REFResh

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > INITiate:REFResh
INITiate:REFResh

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only for applications in MSRA/MSRT mode, not the MSRA/MSRT Master.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INST:SEL 'IQ ANALYZER' Selects the IQ Analyzer channel. INIT:REFR Refreshes the display for the I/Q Analyzer channel.
Usage: | Event
Manual operation: | See "Refresh"


INITiate:SEQuencer:REFResh[:ALL]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:REFResh[:ALL]

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active MSRA/MSRT applications.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INIT:SEQ:REFR Refreshes the display for all channels.
Usage: | Event


INITiate:SEQuencer:ABORt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


[SENSe:]AVERage:COUNt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > [SENSe:]AVERage:COUNt
[SENSe:]AVERage:COUNt <AverageCount>
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps that the application uses to average traces.

(For Pulse measurements, see also "Trace Statistics").

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweeps, the application stops the measurement and calculates the average after the average count has been reached.

Parameters:
<SweepCount>

When you set a sweep count of 0 or 1, the R&S FSW performs one single sweep in single sweep mode.

In continuous sweep mode, if the sweep count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 200000
*RST: | 0
<SweepCount>

If you set a sweep count of 0 or 1, the application performs one single sweep in single sweep mode.

In continuous sweep mode, if the average count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 100000
*RST: | 0
Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"


[SENSe:]SWEep:COUNt:CURRent?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > [SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:COUNt:CURRent?

This query returns the current number of started sweeps or measurements. This command is only available if a sweep count value is defined and the instrument is in single sweep mode.

Usage: Query only


SYSTem:SEQuencer

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring and Performing Sweeps > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


Configuring the Results

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results
Configuring the Results

Some evaluation methods require or allow for additional settings to configure the result display.

Contents
  • Selecting the Pulse
  • Defining the Result Range
  • Configuring a Parameter Distribution
  • Configuring a Parameter Spectrum
  • Configuring a Parameter Trend
  • Configuring a Result Range Spectrum
  • Configuring the Statistics and Parameter Tables
  • Configuring Limit Checks
  • Configuring the Y-Axis Scaling and Units


Selecting the Pulse

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Selecting the Pulse
Selecting the Pulse

The pulse traces (frequency, magnitude and pulse vs. time) always display the trace for one specific pulse, namely the currently selected pulse. To select a pulse, use the following command:

List of Commands
SENSe:TRACe:MEASurement:DEFine:PULSe:SELected


SENSe:TRACe:MEASurement:DEFine:PULSe:SELected

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Selecting the Pulse > SENSe:TRACe:MEASurement:DEFine:PULSe:SELected
SENSe:TRACe:MEASurement:DEFine:PULSe:SELected <PulseNumber>

Selects a particular pulse for which the traces, parameters and results are displayed, or queries the number of the selected pulse. The number of the current or all detected pulses can be queried using [SENSe:​]PULSe:​NUMBer? or [SENSe:​]PULSe:​ID?.

Note that this command causes an error if no measurement results are available.

Parameters:
<PulseNumber>
Range: | 0 to number of detected pulses
*RST: | 0


Defining the Result Range

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Defining the Result Range
Defining the Result Range

The result range determines which data is displayed on the screen (see also "Measurement range vs result range"). This range applies to the pulse magnitude, frequency and phase vs time displays.

List of Commands
SENSe:TRACe:MEASurement:DEFine:RRANge:ALIGnment
SENSe:TRACe:MEASurement:DEFine:RRANge:AUTO
SENSe:TRACe:MEASurement:DEFine:RRANge:LENGth
SENSe:TRACe:MEASurement:DEFine:RRANge:OFFSet
SENSe:TRACe:MEASurement:DEFine:RRANge:REFerence


SENSe:TRACe:MEASurement:DEFine:RRANge:ALIGnment

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Defining the Result Range > SENSe:TRACe:MEASurement:DEFine:RRANge:ALIGnment
SENSe:TRACe:MEASurement:DEFine:RRANge:ALIGnment <Alignment>

Specifies the alignment with respect to the reference point used to define the result range.

Parameters:
<Alignment>
LEFT | CENTer | RIGHt
LEFT

The result range starts at the pulse center or selected edge.

CENTer

The result range is centered around the pulse center or selected edge.

RIGHt

The result range ends at the pulse center or selected edge.

*RST: CENTer
Manual operation: See "Alignment"


SENSe:TRACe:MEASurement:DEFine:RRANge:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Defining the Result Range > SENSe:TRACe:MEASurement:DEFine:RRANge:AUTO
SENSe:TRACe:MEASurement:DEFine:RRANge:AUTO <State>

If enabled, the result range length is determined automatically according to the width of the selected pulse (see SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​SELected).

Parameters for setting and query:
<State>
OFF

Switch the function off

ON

Switch the function on

ONCE

Execute the function once and then switch it off

*RST: ON
Manual operation: See "Auto Scale Continuous (All)"
See "Auto Scale Once (All)"
See "Automatic Range Scaling"


SENSe:TRACe:MEASurement:DEFine:RRANge:LENGth

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Defining the Result Range > SENSe:TRACe:MEASurement:DEFine:RRANge:LENGth
SENSe:TRACe:MEASurement:DEFine:RRANge:LENGth <Length>

The length of the pulse result range (in seconds).

Parameters:
<Length>
*RST: | 30 us
Default unit: | S
Manual operation: See "Length"


SENSe:TRACe:MEASurement:DEFine:RRANge:OFFSet

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Defining the Result Range > SENSe:TRACe:MEASurement:DEFine:RRANge:OFFSet
SENSe:TRACe:MEASurement:DEFine:RRANge:OFFSet <Offset>

The offset (in seconds) from the reference point at which the pulse result range is aligned.

Parameters:
<Offset>
*RST: | 0
Default unit: | S
Manual operation: See "Offset"


SENSe:TRACe:MEASurement:DEFine:RRANge:REFerence

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Defining the Result Range > SENSe:TRACe:MEASurement:DEFine:RRANge:REFerence
SENSe:TRACe:MEASurement:DEFine:RRANge:REFerence <Reference>

Specifies the reference point used to define the result range.

Parameters:
<Reference>
RISE | CENTer | FALL
RISE

The result range is defined in reference to the rising edge.

CENTer

The result range is defined in reference to the center of the pulse top.

FALL

The result range is defined in reference to the falling edge.

*RST: CENTer
Manual operation: See "Result Range Reference Point"


Configuring a Parameter Distribution

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Distribution
Configuring a Parameter Distribution

The parameter distribution evaluations allow you to visualize the number of occurrances for a specific parameter value within the current capture buffer. For each parameter distribution window you can configure which measured parameter is to be displayed.

List of Commands
CALCulate<n>:DISTribution:FREQuency
CALCulate<n>:DISTribution:LLINes[:STATe]
CALCulate<n>:DISTribution:NBINs
CALCulate<n>:DISTribution:PHASe
CALCulate<n>:DISTribution:POWer
CALCulate<n>:DISTribution:TIMing


CALCulate<n>:DISTribution:FREQuency

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Distribution > CALCulate<n>:DISTribution:FREQuency
CALCulate<n>:DISTribution:FREQuency <XAxis>, <YAxis>

Configures the Parameter Distribution result display.

Setting parameters:
<XAxis>
POINt | PPFRequency | RERRor | PERRor | DEViation | CRATe

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Frequency Parameters".

POINt

Frequency at measurement point

PPFRequency

Pulse-Pulse Frequency Difference

RERRor

Frequency Error (RMS)

PERRor

Frequency Error (Peak)

DEViation

Frequency Deviation

CRATe

Chirp Rate

*RST: POINt
<YAxis>
COUNt | OCCurrence

Parameter to be displayed on the y-axis.

COUNt

Number of pulses in which the parameter value occurred.

OCCurence

Percentage of all measured pulses in which the parameter value occurred.

*RST: COUNt
Usage: Setting only
Manual operation: See "X-Axis"


CALCulate<n>:DISTribution:LLINes[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Distribution > CALCulate<n>:DISTribution:LLINes[:STATe]
CALCulate<n>:DISTribution:LLINes[:STATe] <State>

Hides or shows the limit lines in the selected Parameter Trend or Parameter Distribution result display.

Note that this function only has an effect on the visibility of the lines in the graphical displays, it does not affect the limit check in general or the display of the limit check results in the table displays.

Parameters:
<State>
ON | OFF
*RST: ON
Usage: Setting only
Manual operation: See "Display Limit Lines"


CALCulate<n>:DISTribution:NBINs

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Distribution > CALCulate<n>:DISTribution:NBINs
CALCulate<n>:DISTribution:NBINs <# bins>

This command sets the number of bins used to calculate the histogram.

Parameters:
<# bins>
numeric value
Range: | 1 to 1000
*RST: | 100
Manual operation: See "Histogram Bins"


CALCulate<n>:DISTribution:PHASe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Distribution > CALCulate<n>:DISTribution:PHASe
CALCulate<n>:DISTribution:PHASe <XAxis>, <YAxis>

Configures the Parameter Distribution result display.

Setting parameters:
<XAxis>
POINt | PPPHase | RERRor | PERRor | DEViation

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Phase Parameters".

POINt

Pulse phase at measurement point

PPPHase

Pulse-Pulse Phase Difference

RERRor

Phase Error (RMS)

PERRor

Phase Error (Peak)

DEViation

Phase Deviation

*RST: POINt
<YAxis>
COUNt | OCCurrence

Parameter to be displayed on the y-axis.

COUNt

Number of pulses in which the parameter value occurred.

OCCurance

Percentage of all measured pulses in which the parameter value occurred.

*RST: COUNt
Usage: Setting only


CALCulate<n>:DISTribution:POWer

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Distribution > CALCulate<n>:DISTribution:POWer
CALCulate<n>:DISTribution:POWer <XAxis>, <YAxis>

Configures the Parameter Distribution result display.

Setting parameters:
<XAxis>
TOP | BASE | AMPLitude | ON | AVG | MIN | MAX | PON | PAVG | PMIN | ADPercent | ADDB | RPERcent | RDB | OPERcent | ODB | POINt | PPRatio

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Phase Parameters".

TOP

Top Power

BASE

Base Power

AMPLitude

Pulse Amplitude

ON

Average ON Power

AVG

Average Tx Power

MIN

Minimum Power

MAX

Peak Power

PON

Peak-to-Avg ON Power Ratio

PAVG

Peak-to-Average Tx Power Ratio

PMIN

Peak-to-Min Power Ratio

ADPercent

Droop in %

ADDB

Droop in dB

RPERcent

Ripple in %

RDB

Ripple in dB

OPERcent

Overshoot in %

ODB

Overshoot in dB

POINt

Pulse power measured at measurement point

PPRatio

Pulse-to-Pulse Power Difference

*RST: TOP
<YAxis>
COUNt | OCCurrence

Parameter to be displayed on the y-axis.

COUNt

Number of pulses in which the parameter value occurred.

OCCurance

Percentage of all measured pulses in which the parameter value occurred.

*RST: COUNt
Usage: Setting only


CALCulate<n>:DISTribution:TIMing

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Distribution > CALCulate<n>:DISTribution:TIMing
CALCulate<n>:DISTribution:TIMing <XAxis>, <YAxis>

Configures the Parameter Distribution result display.

Setting parameters:
<XAxis>
TSTamp | SETTling | RISE | FALL | PWIDth | OFF | DRATio | DCYCle | PRI | PRF

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Timing Parameters".

TSTamp

Timestamp

SETTling

Settling Time

RISE

Rise Time

FALL

Fall Time

PWIDth

Pulse Width (ON Time)

OFF

Off Time

DRATio

Duty Ratio

DCYCle

Duty Cycle (%)

PRI

Pulse Repetition Interval

PRF

Pulse Repetition Frequency (Hz)

*RST: RISE
<YAxis>
COUNt | OCCurrence

Parameter to be displayed on the y-axis.

COUNt

Number of pulses in which the parameter value occurred.

OCCurance

Percentage of all measured pulses in which the parameter value occurred.

*RST: COUNt
Usage: Setting only


Configuring a Parameter Spectrum

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum
Configuring a Parameter Spectrum

The parameter spectrum evaluations allow you to visualize the spectrum of results for a specific parameter for all measured pulses within the current capture buffer. For each parameter spectrum window you can configure which measured parameter is to be displayed.

For more information see "Parameter Spectrum Calculation".

List of Commands
CALCulate<n>:PSPectrum:AUTO
CALCulate<n>:PSPectrum:BLOCksize
CALCulate<n>:PSPectrum:FREQuency
CALCulate<n>:PSPectrum:GTHReshold
CALCulate<n>:PSPectrum:MAXFrequency
CALCulate<n>:PSPectrum:PHASe
CALCulate<n>:PSPectrum:POWer
CALCulate<n>:PSPectrum:RBW?
CALCulate<n>:PSPectrum:STHReshold
CALCulate<n>:PSPectrum:TIMing
CALCulate<n>:PSPectrum:WINDow


CALCulate<n>:PSPectrum:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum > CALCulate<n>:PSPectrum:AUTO
CALCulate<n>:PSPectrum:AUTO <State>

Enables or disables automatic configuration for Parameter Spectrum displays. If enabled, the commands for individual settings are not available.

For more information see "Parameter Spectrum Calculation".

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Full Auto"


CALCulate<n>:PSPectrum:BLOCksize

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum > CALCulate<n>:PSPectrum:BLOCksize
CALCulate<n>:PSPectrum:BLOCksize <BlockSize>

Defines the size of blocks used in spectrum calculation. The block size also determines the resulting RBW of the spectrum (see CALCulate<n>:​PSPectrum:​RBW?).

For more information see "Parameter Spectrum Calculation".

Parameters:
<BlockSize>
powers of 2
Range: | 8 to 100k
*RST: | 1024
Manual operation: See "Block Size"


CALCulate<n>:PSPectrum:FREQuency

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum > CALCulate<n>:PSPectrum:FREQuency
CALCulate<n>:PSPectrum:FREQuency <XAxis>

Configures the Parameter Spectrum result display.

Setting parameters:
<XAxis>
POINt | PPFRequency | RERRor | PERRor | DEViation | CRATe

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Frequency Parameters".

POINt

Frequency at measurement point

PPFRequency

Pulse-Pulse Frequency Difference

RERRor

Frequency Error (RMS)

PERRor

Frequency Error (Peak)

DEViation

Frequency Deviation

CRATe

Chirp Rate

*RST: POINt
Usage: Setting only
Manual operation: See "Parameter"


CALCulate<n>:PSPectrum:GTHReshold

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum > CALCulate<n>:PSPectrum:GTHReshold
CALCulate<n>:PSPectrum:GTHReshold <Time>

Defines the minimum time that must pass before a gap is detected as such.

For more information see "Parameter Spectrum Calculation".

Parameters:
<Time>
Range: | minimum spacing between pulses to sweep time
Default unit: | S
Manual operation: See "Gap Threshold"


CALCulate<n>:PSPectrum:MAXFrequency

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum > CALCulate<n>:PSPectrum:MAXFrequency
CALCulate<n>:PSPectrum:MAXFrequency <Span>

Defines the maximum frequency span for which the Spectrum is calculated. Internally, the span is limited by the number of possible interpolation samples (100 000).

Parameters:
<Span>
Range: | >0 to 1/10 of sample rate
Default unit: | HZ
Manual operation: See "Maximum Frequency"


CALCulate<n>:PSPectrum:PHASe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum > CALCulate<n>:PSPectrum:PHASe
CALCulate<n>:PSPectrum:PHASe <XAxis>

Configures the Parameter Spectrum result display.

Setting parameters:
<XAxis>
POINt | PPPHase | RERRor | PERRor | DEViation

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Phase Parameters".

POINt

Pulse phase at measurement point

PPPHase

Pulse-Pulse Phase Difference

RERRor

Phase Error (RMS)

PERRor

Phase Error (Peak)

DEViation

Phase Deviation

*RST: POINt
Usage: Setting only


CALCulate<n>:PSPectrum:POWer

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum > CALCulate<n>:PSPectrum:POWer
CALCulate<n>:PSPectrum:POWer <XAxis>

Configures the Parameter Spectrum result display.

Setting parameters:
<XAxis>
TOP | BASE | AMPLitude | ON | AVG | MIN | MAX | PON | PAVG | PMIN | ADPercent | ADDB | RPERcent | RDB | OPERcent | ODB | POINt | PPRatio

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Phase Parameters".

TOP

Top Power

BASE

Base Power

AMPLitude

Pulse Amplitude

ON

Average ON Power

AVG

Average Tx Power

MIN

Minimum Power

MAX

Peak Power

PON

Peak-to-Avg ON Power Ratio

PAVG

Peak-to-Average Tx Power Ratio

PMIN

Peak-to-Min Power Ratio

ADPercent

Droop in %

ADDB

Droop in dB

RPERcent

Ripple in %

RDB

Ripple in dB

OPERcent

Overshoot in %

ODB

Overshoot in dB

POINt

Pulse power measured at measurement point

PPRatio

Pulse-to-Pulse Power Difference

*RST: TOP
Usage: Setting only


CALCulate<n>:PSPectrum:RBW?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum > CALCulate<n>:PSPectrum:RBW?
CALCulate<n>:PSPectrum:RBW?

Queries the resulting resolution bandwidth for the spectrum. Depends on the block size (see CALCulate<n>:​PSPectrum:​BLOCksize).

Return values:
<RBW>
Default unit: Hz
Usage: Query only


CALCulate<n>:PSPectrum:STHReshold

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum > CALCulate<n>:PSPectrum:STHReshold
CALCulate<n>:PSPectrum:STHReshold <Size>

Defines the minimum section size. Sections that are smaller than the threshold are ignored and considered to be part of the detected gap.

For more information see "Parameter Spectrum Calculation".

Parameters:
<Size>

Minimum section size as a percentage of the block size (see CALCulate<n>:​PSPectrum:​BLOCksize)

Range: | 0 to 100
*RST: | 50
Manual operation: See "Sectioning Threshold"


CALCulate<n>:PSPectrum:TIMing

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum > CALCulate<n>:PSPectrum:TIMing
CALCulate<n>:PSPectrum:TIMing <XAxis>

Configures the Parameter Spectrum result display.

Setting parameters:
<XAxis>
TSTamp | SETTling | RISE | FALL | PWIDth | OFF | DRATio | DCYCle | PRI | PRF

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Timing Parameters".

TSTamp

Timestamp

SETTling

Settling Time

RISE

Rise Time

FALL

Fall Time

PWIDth

Pulse Width (ON Time)

OFF

Off Time

DRATio

Duty Ratio

DCYCle

Duty Cycle (%)

PRI

Pulse Repetition Interval

PRF

Pulse Repetition Frequency (Hz)

*RST: RISE
Usage: Setting only


CALCulate<n>:PSPectrum:WINDow

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Spectrum > CALCulate<n>:PSPectrum:WINDow
CALCulate<n>:PSPectrum:WINDow <WindowType>

Defines the used FFT window type

For more information see "Parameter Spectrum Calculation".

Setting parameters:
<WindowType>
RECTangle | BARTlett | HAMMming | HANNing | BLACkman
*RST: BLACkman
Manual operation: See "Window Type"


Configuring a Parameter Trend

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend
Configuring a Parameter Trend

The parameter trend evaluations allow you to visualize changes in a specific parameter for all measured pulses within the current capture buffer. For each parameter trend window you can configure which measured parameter is to be displayed.

List of Commands
CALCulate<n>:TRENd:FREQuency
CALCulate<n>:TRENd:FREQuency:X
CALCulate<n>:TRENd:FREQuency:Y
CALCulate<n>:TRENd:LLINes[:STATe]
CALCulate<n>:TRENd:PHASe
CALCulate<n>:TRENd:PHASe:X
CALCulate<n>:TRENd:PHASe:Y
CALCulate<n>:TRENd:POWer
CALCulate<n>:TRENd:POWer:X
CALCulate<n>:TRENd:POWer:Y
CALCulate<n>:TRENd:TIMing
CALCulate<n>:TRENd:TIMing:X
CALCulate<n>:TRENd:TIMing:Y


CALCulate<n>:TRENd:FREQuency

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:FREQuency
CALCulate<n>:TRENd:FREQuency <YAxis>, <XAxis>

Configures the Parameter Trend result display for time trends. This command defines both x-axis and y-axis parameters in one step. It is equivalent to the two subsequent commands:

CALCulate<n>:TRENd:TIMing:X TSTamp | PNUMber (see CALCulate<n>:​TRENd:​TIMing:​X)

CALCulate<n>:TRENd:FREQuency:Y <YAxis> (see CALCulate<n>:​TRENd:​FREQuency:​Y)

Setting parameters:
<YAxis>
POINt | PPFRequency | RERRor | PERRor | DEViation | CRATe

Pulse parameter to be displayed on the y-axis. For a description of the available parameters see "Frequency Parameters".

POINt

Frequency at measurement point

PPFRequency

Pulse-Pulse Frequency Difference

RERRor

Frequency Error (RMS)

PERRor

Frequency Error (Peak)

DEViation

Frequency Deviation

CRATe

Chirp Rate

*RST: POINt
<XAxis>
PNUMber | TSTamp
PNUMber

The pulse numbers are represented on the x-axis (available numbers can be queried using [SENSe:​]PULSe:​NUMBer?). Intervals without pulses are not displayed.

TSTamp

The x-axis is a time scale on which the timestamps of the detected pulses are indicated (timestamps at which pulses occurred can be queried using [SENSe:​]PULSe:​TIMing:​TSTamp?). Using this setting, intervals in which no pulses were detected are visible.

*RST: PNUMber
Usage: Setting only
Manual operation: See "Y-Axis"
See "X-Axis"


CALCulate<n>:TRENd:FREQuency:X

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:FREQuency:X
CALCulate<n>:TRENd:FREQuency:X <XAxis>

Configures the x-axis of the Parameter Trend result display.

The y-axis is configured using the CALCulate<n>:TRENd:<GroupName>:Y commands.

Setting parameters:
<XAxis>
POINt | PPFRequency | RERRor | PERRor | DEViation | CRATe

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Frequency Parameters".

POINt

Frequency at measurement point

PPFRequency

Pulse-Pulse Frequency Difference

RERRor

Frequency Error (RMS)

PERRor

Frequency Error (Peak)

DEViation

Frequency Deviation

CRATe

Chirp Rate

*RST: POINt
Example: CALC2:TREN:FREQ:X PERR
Usage: Setting only
Manual operation: See "Parameter Trend"
See "X-Axis"


CALCulate<n>:TRENd:FREQuency:Y

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:FREQuency:Y
CALCulate<n>:TRENd:FREQuency:Y <YAxis>

Configures the y-axis of the Parameter Trend result display.

The x-axis is configured using the CALCulate<n>:TRENd:<GroupName>:X commands.

Setting parameters:
<YAxis>
POINt | PPFRequency | RERRor | PERRor | DEViation | CRATe

Pulse parameter to be displayed on the y-axis. For a description of the available parameters see "Frequency Parameters".

POINt

Frequency at measurement point

PPFRequency

Pulse-Pulse Frequency Difference

RERRor

Frequency Error (RMS)

PERRor

Frequency Error (Peak)

DEViation

Frequency Deviation

CRATe

Chirp Rate

*RST: POINt
Usage: Setting only
Manual operation: See "Parameter Trend"
See "Y-Axis"


CALCulate<n>:TRENd:LLINes[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:LLINes[:STATe]
CALCulate<n>:TRENd:LLINes[:STATe] <State>

Hides or shows the limit lines in the selected Parameter Trend or Parameter Distribution result display.

Note that this function only has an effect on the visibility of the lines in the graphical displays, it does not affect the limit check in general or the display of the limit check results in the table displays.

Parameters:
<State>
ON | OFF
*RST: ON
Usage: Setting only
Manual operation: See "Display Limit Lines"


CALCulate<n>:TRENd:PHASe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:PHASe
CALCulate<n>:TRENd:PHASe <YAxis>, <XAxis>

Configures the Parameter Trend result display for time trends. This command defines both x-axis and y-axis parameters in one step. It is equivalent to the two subsequent commands:

CALCulate<n>:TRENd:TIMing:X TSTamp | PNUMber (see CALCulate<n>:​TRENd:​TIMing:​X)

CALCulate<n>:TRENd:PHASe:Y <YAxis> (see CALCulate<n>:​TRENd:​PHASe:​Y)

Setting parameters:
<YAxis>
POINt | PPPHase | RERRor | PERRor | DEViation

Pulse parameter to be displayed on the y-axis. For a description of the available parameters see "Phase Parameters".

POINt

Pulse phase at measurement point

PPPHase

Pulse-Pulse Phase Difference

RERRor

Phase Error (RMS)

PERRor

Phase Error (Peak)

DEViation

Phase Deviation

*RST: POINt
<XAxis>
PNUMber | TSTamp
PNUMber

The pulse numbers are represented on the x-axis (available numbers can be queried using [SENSe:​]PULSe:​NUMBer?). Intervals without pulses are not displayed.

TSTamp

The x-axis is a time scale on which the timestamps of the detected pulses are indicated (timestamps at which pulses occurred can be queried using [SENSe:​]PULSe:​TIMing:​TSTamp?). Using this setting, intervals in which no pulses were detected are visible.

*RST: PNUMber
Usage: Setting only


CALCulate<n>:TRENd:PHASe:X

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:PHASe:X
CALCulate<n>:TRENd:PHASe:X <XAxis>

Configures the x-axis of the Parameter Trend result display.

The y-axis is configured using the CALCulate<n>:TRENd:<GroupName>:Y commands.

Setting parameters:
<XAxis>
POINt | PPPHase | RERRor | PERRor | DEViation

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Phase Parameters".

POINt

Pulse phase at measurement point

PPPHase

Pulse-Pulse Phase Difference

RERRor

Phase Error (RMS)

PERRor

Phase Error (Peak)

DEViation

Phase Deviation

*RST: POINt
Example: CALC2:TREN:PHAS:X PERR
Usage: Setting only


CALCulate<n>:TRENd:PHASe:Y

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:PHASe:Y
CALCulate<n>:TRENd:PHASe:Y <YAxis>

Configures the y-axis of the Parameter Trend result display.

The x-axis is configured using the CALCulate<n>:TRENd:<GroupName>:X commands.

Setting parameters:
<YAxis>
POINt | PPPHase | RERRor | PERRor | DEViation

Pulse parameter to be displayed on the y-axis. For a description of the available parameters see "Phase Parameters".

POINt

Pulse phase at measurement point

PPPHase

Pulse-Pulse Phase Difference

RERRor

Phase Error (RMS)

PERRor

Phase Error (Peak)

DEViation

Phase Deviation

*RST: POINt
Usage: Setting only


CALCulate<n>:TRENd:POWer

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:POWer
CALCulate<n>:TRENd:POWer <YAxis>, <XAxis>

Configures the Parameter Trend result display for time trends. This command defines both x-axis and y-axis parameters in one step. It is equivalent to the two subsequent commands:

CALCulate<n>:TRENd:TIMing:X TSTamp | PNUMber (see CALCulate<n>:​TRENd:​TIMing:​X)

CALCulate<n>:TRENd:POWer:Y <YAxis> (see CALCulate<n>:​TRENd:​POWer:​Y)

Setting parameters:
<YAxis>
TOP | BASE | AMPLitude | ON | AVG | MIN | MAX | PON | PAVG | PMIN | ADPercent | ADDB | RPERcent | RDB | OPERcent | ODB | POINt | PPRatio

Pulse parameter to be displayed on the y-axis. For a description of the available parameters see "Power/Amplitude Parameters".

TOP

Top Power

BASE

Base Power

AMPLitude

Pulse Amplitude

ON

Average ON Power

AVG

Average Tx Power

MIN

Minimum Power

MAX

Peak Power

PON

Peak-to-Avg ON Power Ratio

PAVG

Peak-to-Average Tx Power Ratio

PMIN

Peak-to-Min Power Ratio

ADPercent

Droop in %

ADDB

Droop in dB

RPERcent

Ripple in %

RDB

Ripple in dB

OPERcent

Overshoot in %

ODB

Overshoot in dB

POINt

Pulse power measured at measurement point

PPRatio

Pulse-to-Pulse Power Difference

*RST: TOP
<XAxis>
PNUMber | TSTamp
PNUMber

The pulse numbers are represented on the x-axis (available numbers can be queried using [SENSe:​]PULSe:​NUMBer?). Intervals without pulses are not displayed.

TSTamp

The x-axis is a time scale on which the timestamps of the detected pulses are indicated (timestamps at which pulses occurred can be queried using [SENSe:​]PULSe:​TIMing:​TSTamp?). Using this setting, intervals in which no pulses were detected are visible.

*RST: PNUMber
Usage: Setting only


CALCulate<n>:TRENd:POWer:X

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:POWer:X
CALCulate<n>:TRENd:POWer:X <XAxis>

Configures the x-axis of the Parameter Trend result display.

The y-axis is configured using the CALCulate<n>:TRENd:<GroupName>:Y commands.

Setting parameters:
<XAxis>
TOP | BASE | AMPLitude | ON | AVG | MIN | MAX | PON | PAVG | PMIN | ADPercent | ADDB | RPERcent | RDB | OPERcent | ODB | POINt | PPRatio

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Power/Amplitude Parameters".

TOP

Top Power

BASE

Base Power

AMPLitude

Pulse Amplitude

ON

Average ON Power

AVG

Average Tx Power

MIN

Minimum Power

MAX

Peak Power

PON

Peak-to-Avg ON Power Ratio

PAVG

Peak-to-Average Tx Power Ratio

PMIN

Peak-to-Min Power Ratio

ADPercent

Droop in %

ADDB

Droop in dB

RPERcent

Ripple in %

RDB

Ripple in dB

OPERcent

Overshoot in %

ODB

Overshoot in dB

POINt

Pulse power measured at measurement point

PPRatio

Pulse-to-Pulse Power Difference

*RST: TOP
Example: CALC2:TREN:POW:X ODB
Usage: Setting only


CALCulate<n>:TRENd:POWer:Y

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:POWer:Y
CALCulate<n>:TRENd:POWer:Y <YAxis>

Configures the y-axis of the Parameter Trend result display.

The x-axis is configured using the CALCulate<n>:TRENd:<GroupName>:X commands.

Setting parameters:
<YAxis>
TOP | BASE | AMPLitude | ON | AVG | MIN | MAX | PON | PAVG | PMIN | ADPercent | ADDB | RPERcent | RDB | OPERcent | ODB | POINt | PPRatio

Pulse parameter to be displayed on the y-axis. For a description of the available parameters see "Power/Amplitude Parameters".

TOP

Top Power

BASE

Base Power

AMPLitude

Pulse Amplitude

ON

Average ON Power

AVG

Average Tx Power

MIN

Minimum Power

MAX

Peak Power

PON

Peak-to-Avg ON Power Ratio

PAVG

Peak-to-Average Tx Power Ratio

PMIN

Peak-to-Min Power Ratio

ADPercent

Droop in %

ADDB

Droop in dB

RPERcent

Ripple in %

RDB

Ripple in dB

OPERcent

Overshoot in %

ODB

Overshoot in dB

POINt

Pulse power measured at measurement point

PPRatio

Pulse-to-Pulse Power Difference

*RST: TOP
Usage: Setting only


CALCulate<n>:TRENd:TIMing

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:TIMing
CALCulate<n>:TRENd:TIMing <YAxis>, <XAxis>

Configures the Parameter Trend result display for time trends. This command defines both x-axis and y-axis parameters in one step. It is equivalent to the two subsequent commands:

CALCulate<n>:TRENd:TIMing:X TSTamp | PNUMber (see CALCulate<n>:​TRENd:​TIMing:​X)

CALCulate<n>:TRENd:TIMing:Y <YAxis> (see CALCulate<n>:​TRENd:​TIMing:​Y)

Setting parameters:
<YAxis>
TSTamp | SETTling | RISE | FALL | PWIDth | OFF | DRATio | DCYCle | PRI | PRF

Pulse parameter to be displayed on the y-axis. For a description of the available parameters see "Timing Parameters".

TSTamp

Timestamp

SETTling

Settling Time

RISE

Rise Time

FALL

Fall Time

PWIDth

Pulse Width (ON Time)

OFF

Off Time

DRATio

Duty Ratio

DCYCle

Duty Cycle (%)

PRI

Pulse Repetition Interval

PRF

Pulse Repetition Frequency (Hz)

*RST: RISE
<XAxis>
PNUMber | TSTamp
PNUMber

The pulse numbers are represented on the x-axis (available numbers can be queried using [SENSe:​]PULSe:​NUMBer?). Intervals without pulses are not displayed.

TSTamp

The x-axis is a time scale on which the timestamps of the detected pulses are indicated (timestamps at which pulses occurred can be queried using [SENSe:​]PULSe:​TIMing:​TSTamp?). Using this setting, intervals in which no pulses were detected are visible.

*RST: PNUMber
Usage: Setting only


CALCulate<n>:TRENd:TIMing:X

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:TIMing:X
CALCulate<n>:TRENd:TIMing:X <XAxis>

Configures the x-axis of the Parameter Trend result display.

The y-axis is configured using the CALCulate<n>:TRENd:<GroupName>:Y commands.

Setting parameters:
<XAxis>
PNUMber | TSTamp | SETTling | RISE | FALL | PWIDth | OFF | DRATio | DCYCle | PRI | PRF

Pulse parameter to be displayed on the x-axis. For a description of the available parameters see "Timing Parameters".

TSTamp

Timestamp

PNUMber

The pulse numbers are represented on the x-axis (available numbers can be queried using [SENSe:​]PULSe:​NUMBer?). Intervals without pulses are not displayed.

SETTling

Settling Time

RISE

Rise Time

FALL

Fall Time

PWIDth

Pulse Width (ON Time)

OFF

Off Time

DRATio

Duty Ratio

DCYCle

Duty Cycle (%)

PRI

Pulse Repetition Interval

PRF

Pulse Repetition Frequency (Hz)

*RST: PNUMber
Example: CALC2:TREN:TIM:X DCYCle
Usage: Setting only


CALCulate<n>:TRENd:TIMing:Y

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Parameter Trend > CALCulate<n>:TRENd:TIMing:Y
CALCulate<n>:TRENd:TIMing:Y <YAxis>

Configures the y-axis of the Parameter Trend result display.

The x-axis is configured using the CALCulate<n>:TRENd:<GroupName>:X commands.

Setting parameters:
<YAxis>
TSTamp | SETTling | RISE | FALL | PWIDth | OFF | DRATio | DCYCle | PRI | PRF

Pulse parameter to be displayed on the y-axis. For a description of the available parameters see "Timing Parameters".

TSTamp

Timestamp

SETTling

Settling Time

RISE

Rise Time

FALL

Fall Time

PWIDth

Pulse Width (ON Time)

OFF

Off Time

DRATio

Duty Ratio

DCYCle

Duty Cycle (%)

PRI

Pulse Repetition Interval

PRF

Pulse Repetition Frequency (Hz)

*RST: RISE
Example: CALC2:TREN:TIM:Y DCYCle
Usage: Setting only


Configuring a Result Range Spectrum

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Result Range Spectrum
Configuring a Result Range Spectrum

The following commands determine the FFT parameters for spectrum calculation.

List of Commands
CALCulate<n>:RRSPectrum:WINDow
CALCulate<n>:RRSPectrum:AUTO
CALCulate<n>:RRSPectrum:RBW


CALCulate<n>:RRSPectrum:WINDow

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Result Range Spectrum > CALCulate<n>:RRSPectrum:WINDow
CALCulate<n>:RRSPectrum:WINDow <WindowType>

Defines the RBW for the Result Range Spectrum.

The same window types are available as for Parameter Spectrum displays (see "Window functions").

Setting parameters:
<WindowType> | RECTangle | BARTlett | HAMMming | HANNing | BLACkman
Manual operation: | See "Window Type"


CALCulate<n>:RRSPectrum:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Result Range Spectrum > CALCulate<n>:RRSPectrum:AUTO
CALCulate<n>:RRSPectrum:AUTO <State>

If activated, the optimal RBW for the Result Range Spectrum is selected automatically.

Parameters:
<State>
ON | OFF | 0 | 1
OFF | 0

Switches the function off

ON | 1

Switches the function on

*RST: 0
Manual operation: See "RBW Auto"


CALCulate<n>:RRSPectrum:RBW

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring a Result Range Spectrum > CALCulate<n>:RRSPectrum:RBW
CALCulate<n>:RRSPectrum:RBW <RBW>

This command sets the resolution bandwidth for Result Range Spectrum Settings.

Parameters:
<RBW>
*RST: | 1000
Default unit: | Hz
Manual operation: See "ResBW Manual"


Configuring the Statistics and Parameter Tables

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables
Configuring the Statistics and Parameter Tables

The following commands select which parameters are displayed in the Pulse Statistics and Pulse Results evaluation.

For details on the individual parameters see "Pulse Parameters".

List of Commands
CALCulate<n>:TABLe:FREQuency:ALL[:STATe]
CALCulate<n>:TABLe:FREQuency:CRATe
CALCulate<n>:TABLe:FREQuency:DEViation
CALCulate<n>:TABLe:FREQuency:PERRor
CALCulate<n>:TABLe:FREQuency:POINt
CALCulate<n>:TABLe:FREQuency:PPFRequency
CALCulate<n>:TABLe:FREQuency:RERRor
CALCulate<n>:TABLe:PHASe:ALL[:STATe]
CALCulate<n>:TABLe:PHASe:DEViation
CALCulate<n>:TABLe:PHASe:PERRor
CALCulate<n>:TABLe:PHASe:POINt
CALCulate<n>:TABLe:PHASe:PPPHase
CALCulate<n>:TABLe:PHASe:RERRor
CALCulate<n>:TABLe:POWer:ADRoop:DB
CALCulate<n>:TABLe:POWer:ADRoop[:PERCent]
CALCulate<n>:TABLe:POWer:ALL[:STATe]
CALCulate<n>:TABLe:POWer:AMPLitude
CALCulate<n>:TABLe:POWer:AVG
CALCulate<n>:TABLe:POWer:BASE
CALCulate<n>:TABLe:POWer:MAX
CALCulate<n>:TABLe:POWer:MIN
CALCulate<n>:TABLe:POWer:ON
CALCulate<n>:TABLe:POWer:OVERshoot:DB
CALCulate<n>:TABLe:POWer:OVERshoot[:PERCent]
CALCulate<n>:TABLe:POWer:PAVG
CALCulate<n>:TABLe:POWer:PMIN
CALCulate<n>:TABLe:POWer:POINt
CALCulate<n>:TABLe:POWer:PON
CALCulate<n>:TABLe:POWer:PPRatio
CALCulate<n>:TABLe:POWer:RIPPle:DB
CALCulate<n>:TABLe:POWer:RIPPle[:PERCent]
CALCulate<n>:TABLe:POWer:TOP
CALCulate<n>:TABLe:TIMing:ALL[:STATe]
CALCulate<n>:TABLe:TIMing:DCYCle
CALCulate<n>:TABLe:TIMing:DRATio
CALCulate<n>:TABLe:TIMing:FALL
CALCulate<n>:TABLe:TIMing:OFF
CALCulate<n>:TABLe:TIMing:PRF
CALCulate<n>:TABLe:TIMing:PRI
CALCulate<n>:TABLe:TIMing:PWIDth
CALCulate<n>:TABLe:TIMing:RISE
CALCulate<n>:TABLe:TIMing:SETTling
CALCulate<n>:TABLe:TIMing:TSTamp


CALCulate<n>:TABLe:FREQuency:ALL[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:FREQuency:ALL[:STATe]
CALCulate<n>:TABLe:FREQuency:ALL[:STATe] <Visibility>[, <Scaling>]

If enabled, all frequency parameters are included in the result tables.

Setting parameters:
<Visibility>
ON | OFF
*RST: OFF
<Scaling>
GHZ | MHZ | KHZ | HZ

Optional: Defines the unit in which the results are displayed.

Usage: Setting only


CALCulate<n>:TABLe:FREQuency:CRATe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:FREQuency:CRATe
CALCulate<n>:TABLe:FREQuency:CRATe <Visibility>[, <Scaling>]

If enabled, the chirp rate (per μs) is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Setting parameters:
<Scaling>
GHZ | MHZ | KHZ | HZ

Defines the unit in which the results are displayed.

*RST: MHZ
Manual operation: See "Chirp Rate"


CALCulate<n>:TABLe:FREQuency:DEViation

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:FREQuency:DEViation
CALCulate<n>:TABLe:FREQuency:DEViation <Visibility>[, <Scaling>]

If enabled, the frequency deviation is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Setting parameters:
<Scaling>
GHZ | MHZ | KHZ | HZ

Defines the unit in which the results are displayed.

*RST: KHZ
Manual operation: See "Frequency Deviation"


CALCulate<n>:TABLe:FREQuency:PERRor

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:FREQuency:PERRor
CALCulate<n>:TABLe:FREQuency:PERRor <Visibility>[, <Scaling>]

If enabled, the peak frequency error is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Setting parameters:
<Scaling>
GHZ | MHZ | KHZ | HZ

Defines the unit in which the results are displayed.

*RST: KHZ
Manual operation: See "Frequency Error (Peak)"


CALCulate<n>:TABLe:FREQuency:POINt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:FREQuency:POINt
CALCulate<n>:TABLe:FREQuency:POINt <Visibility>[, <Scaling>]

If enabled, the frequency at the measurement point is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: ON
Setting parameters:
<Scaling>
GHZ | MHZ | KHZ | HZ

Defines the unit in which the results are displayed.

*RST: KHZ
Manual operation: See "Frequency"


CALCulate<n>:TABLe:FREQuency:PPFRequency

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:FREQuency:PPFRequency
CALCulate<n>:TABLe:FREQuency:PPFRequency <Visibility>[, <Scaling>]

If enabled, the Pulse-Pulse Frequency Difference is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Setting parameters:
<Scaling>
GHZ | MHZ | KHZ | HZ

Defines the unit in which the results are displayed.

*RST: KHZ
Manual operation: See "Pulse-Pulse Frequency Difference"


CALCulate<n>:TABLe:FREQuency:RERRor

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:FREQuency:RERRor
CALCulate<n>:TABLe:FREQuency:RERRor <Visibility>[, <Scaling>]

If enabled, the RMS frequency error is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Setting parameters:
<Scaling>
GHZ | MHZ | KHZ | HZ

Optional: Defines the unit in which the results are displayed.

*RST: KHZ
Manual operation: See "Frequency Error (RMS)"


CALCulate<n>:TABLe:PHASe:ALL[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:PHASe:ALL[:STATe]
CALCulate<n>:TABLe:PHASe:ALL[:STATe] <Visibility>

If enabled, all phase parameters are included in the result tables.

Setting parameters:
<Visibility>
ON | OFF
*RST: OFF
Usage: Setting only


CALCulate<n>:TABLe:PHASe:DEViation

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:PHASe:DEViation
CALCulate<n>:TABLe:PHASe:DEViation <Visibility>

If enabled, the Phase Deviation is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Phase Deviation"


CALCulate<n>:TABLe:PHASe:PERRor

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:PHASe:PERRor
CALCulate<n>:TABLe:PHASe:PERRor <Visibility>

If enabled, the Phase Error (Peak) is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Phase Error (Peak)"


CALCulate<n>:TABLe:PHASe:POINt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:PHASe:POINt
CALCulate<n>:TABLe:PHASe:POINt <Visibility>

If enabled, the phase at the measurement point is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: ON
Manual operation: See "Phase"


CALCulate<n>:TABLe:PHASe:PPPHase

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:PHASe:PPPHase
CALCulate<n>:TABLe:PHASe:PPPHase <Visibility>

If enabled, the Pulse-Pulse Phase Difference is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Pulse-Pulse Phase Difference"


CALCulate<n>:TABLe:PHASe:RERRor

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:PHASe:RERRor
CALCulate<n>:TABLe:PHASe:RERRor <Visibility>

If enabled, the Phase Error (RMS) is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Phase Error (RMS)"


CALCulate<n>:TABLe:POWer:ADRoop:DB

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:ADRoop:DB
CALCulate<n>:TABLe:POWer:ADRoop:DB <Visibility>

If enabled, the Droop in dB is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Droop"


CALCulate<n>:TABLe:POWer:ADRoop[:PERCent]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:ADRoop[:PERCent]
CALCulate<n>:TABLe:POWer:ADRoop[:PERCent] <Visibility>

If enabled, the droop in percent is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Droop"


CALCulate<n>:TABLe:POWer:ALL[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:ALL[:STATe]
CALCulate<n>:TABLe:POWer:ALL[:STATe] <Visibility>

If enabled, all power parameters are included in the result tables.

Setting parameters:
<Visibility>
ON | OFF
*RST: OFF
Usage: Setting only


CALCulate<n>:TABLe:POWer:AMPLitude

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:AMPLitude
CALCulate<n>:TABLe:POWer:AMPLitude <Visibility>

If enabled, the pulse amplitude is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Pulse Amplitude"


CALCulate<n>:TABLe:POWer:AVG

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:AVG
CALCulate<n>:TABLe:POWer:AVG <Visibility>

If enabled, the average Tx power is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: ON
Manual operation: See "Average Tx Power"


CALCulate<n>:TABLe:POWer:BASE

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:BASE
CALCulate<n>:TABLe:POWer:BASE <Visibility>

If enabled, the base power is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Base Power"


CALCulate<n>:TABLe:POWer:MAX

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:MAX
CALCulate<n>:TABLe:POWer:MAX <Visibility>

If enabled, the maximum Tx power is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Peak Power"


CALCulate<n>:TABLe:POWer:MIN

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:MIN
CALCulate<n>:TABLe:POWer:MIN <Visibility>

If enabled, the minimum Tx power is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Minimum Power"


CALCulate<n>:TABLe:POWer:ON

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:ON
CALCulate<n>:TABLe:POWer:ON <Visibility>

If enabled, the average ON power is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: ON
Manual operation: See "Average ON Power"


CALCulate<n>:TABLe:POWer:OVERshoot:DB

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:OVERshoot:DB
CALCulate<n>:TABLe:POWer:OVERshoot:DB <Visibility>

If enabled, the overshoot in dB is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Overshoot"


CALCulate<n>:TABLe:POWer:OVERshoot[:PERCent]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:OVERshoot[:PERCent]
CALCulate<n>:TABLe:POWer:OVERshoot[:PERCent] <Visibility>

If enabled, the overshoot in percent is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Overshoot"


CALCulate<n>:TABLe:POWer:PAVG

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:PAVG
CALCulate<n>:TABLe:POWer:PAVG <Visibility>

If enabled, the Peak-to-Average Tx Power Ratio is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Peak-to-Average Tx Power Ratio"


CALCulate<n>:TABLe:POWer:PMIN

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:PMIN
CALCulate<n>:TABLe:POWer:PMIN <Visibility>

If enabled, the Peak-to-Min Power Ratio is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Peak-to-Min Power Ratio"


CALCulate<n>:TABLe:POWer:POINt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:POINt
CALCulate<n>:TABLe:POWer:POINt <Visibility>

If enabled, the power at the measurement point is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Power"


CALCulate<n>:TABLe:POWer:PON

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:PON
CALCulate<n>:TABLe:POWer:PON <Visibility>

If enabled, the Peak-to-Avg ON Power Ratio is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Peak-to-Avg ON Power Ratio"


CALCulate<n>:TABLe:POWer:PPRatio

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:PPRatio
CALCulate<n>:TABLe:POWer:PPRatio <Visibility>

If enabled, the Pulse-to-Pulse Power Difference

is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Pulse-to-Pulse Power Difference"


CALCulate<n>:TABLe:POWer:RIPPle:DB

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:RIPPle:DB
CALCulate<n>:TABLe:POWer:RIPPle:DB <Visibility>

If enabled, the ripple in dB is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Ripple"


CALCulate<n>:TABLe:POWer:RIPPle[:PERCent]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:RIPPle[:PERCent]
CALCulate<n>:TABLe:POWer:RIPPle[:PERCent] <Visibility>

If enabled, the ripple in percent is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Ripple"


CALCulate<n>:TABLe:POWer:TOP

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:POWer:TOP
CALCulate<n>:TABLe:POWer:TOP <Visibility>

If enabled, the Top power is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Top Power"


CALCulate<n>:TABLe:TIMing:ALL[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:TIMing:ALL[:STATe]
CALCulate<n>:TABLe:TIMing:ALL[:STATe] <Visibility>[, <Scaling>]

If enabled, all timing parameters are included in the result tables.

Setting parameters:
<Visibility>
ON | OFF
*RST: OFF
<Scaling>
S | MS | US | NS

Optional: Defines the unit in which the results are displayed.

Usage: Setting only


CALCulate<n>:TABLe:TIMing:DCYCle

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:TIMing:DCYCle
CALCulate<n>:TABLe:TIMing:DCYCle <Visibility>

If enabled, the duty cycle (in %) is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: ON
Manual operation: See "Duty Cycle (%)"


CALCulate<n>:TABLe:TIMing:DRATio

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:TIMing:DRATio
CALCulate<n>:TABLe:TIMing:DRATio <Visibility>

If enabled, the duty ratio (in dB) is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Manual operation: See "Duty Ratio"


CALCulate<n>:TABLe:TIMing:FALL

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:TIMing:FALL
CALCulate<n>:TABLe:TIMing:FALL <Visibility>[, <Scaling>]

If enabled, the fall time is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Setting parameters:
<Scaling>
S | MS | US | NS

Optional: Defines the unit in which the results are displayed.

*RST: MS
Manual operation: See "Fall Time"


CALCulate<n>:TABLe:TIMing:OFF

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:TIMing:OFF
CALCulate<n>:TABLe:TIMing:OFF <Visibility>[, <Scaling>]

If enabled, the "OFF" time is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Setting parameters:
<Scaling>
S | MS | US | NS

Optional: Defines the unit in which the results are displayed.

*RST: MS
Manual operation: See "Off Time"


CALCulate<n>:TABLe:TIMing:PRF

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:TIMing:PRF
CALCulate<n>:TABLe:TIMing:PRF <Visibility>[, <Scaling>]

If enabled, the pulse repetition frequency is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Setting parameters:
<Scaling>
GHZ | MHZ | KHZ | HZ

Optional: Defines the unit in which the results are displayed.

*RST: KHZ
Manual operation: See "Pulse Repetition Frequency (Hz)"


CALCulate<n>:TABLe:TIMing:PRI

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:TIMing:PRI
CALCulate<n>:TABLe:TIMing:PRI <Visibility>[, <Scaling>]

If enabled, the pulse repetition interval is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: ON
Setting parameters:
<Scaling>
S | MS | US | NS

Optional: Defines the unit in which the results are displayed.

*RST: US
Manual operation: See "Pulse Repetition Interval"


CALCulate<n>:TABLe:TIMing:PWIDth

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:TIMing:PWIDth
CALCulate<n>:TABLe:TIMing:PWIDth <Visibility>[, <Scaling>]

If enabled, the pulse width is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: ON
Setting parameters:
<Scaling>
S | MS | US | NS

Optional: Defines the unit in which the results are displayed.

*RST: US
Manual operation: See "Pulse Width (ON Time)"


CALCulate<n>:TABLe:TIMing:RISE

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:TIMing:RISE
CALCulate<n>:TABLe:TIMing:RISE <Visibility>[, <Scaling>]

If enabled, the rise time is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: ON
Setting parameters:
<Scaling>
S | MS | US | NS

Optional: Defines the unit in which the results are displayed.

*RST: NS
Manual operation: See "Rise Time"


CALCulate<n>:TABLe:TIMing:SETTling

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:TIMing:SETTling
CALCulate<n>:TABLe:TIMing:SETTling <Visibility>[, <Scaling>]

If enabled, the settling time is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Setting parameters:
<Scaling>
S | MS | US | NS

Optional: Defines the unit in which the results are displayed.

*RST: MS
Manual operation: See "Settling Time"


CALCulate<n>:TABLe:TIMing:TSTamp

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Statistics and Parameter Tables > CALCulate<n>:TABLe:TIMing:TSTamp
CALCulate<n>:TABLe:TIMing:TSTamp <Visibility>[, <Scaling>]

If enabled, the timestamp is included in the result tables.

Parameters:
<Visibility>
ON | OFF
*RST: OFF
Setting parameters:
<Scaling>
S | MS | US | NS

Optional: Defines the unit in which the results are displayed.

*RST: MS
Manual operation: See "Timestamp"


Configuring Limit Checks

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring Limit Checks
Configuring Limit Checks

For each parameter in the result tables you can activate a limit check and define the valid value ranges. For details see "Pulse Results".

Useful commands for configuring limit checks described elsewhere:
  • CALCulate<n>:​DISTribution:​LLINes[:​STATe]
  • CALCulate<n>:​TRENd:​LLINes[:​STATe]
Remote commands exclusive to configuring limit checks:
List of Commands
CALCulate<n>:TABLe:<ParameterGroup>:<Parameter>:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:CRATe:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:DEViation:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:PERRor:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:POINt:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:PPFRequency:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:RERRor:LIMit:STATe
CALCulate<n>:TABLe:PHASe:DEViation:LIMit:STATe
CALCulate<n>:TABLe:PHASe:PERRor:LIMit:STATe
CALCulate<n>:TABLe:PHASe:POINt:LIMit:STATe
CALCulate<n>:TABLe:PHASe:PPPHase:LIMit:STATe
CALCulate<n>:TABLe:PHASe:RERRor:LIMit:STATe
CALCulate<n>:TABLe:POWer:ADRoop:DB:LIMit:STATe
CALCulate<n>:TABLe:POWer:ADRoop[:PERCent]:LIMit:STATe
CALCulate<n>:TABLe:POWer:AMPLitude:LIMit:STATe
CALCulate<n>:TABLe:POWer:AVG:LIMit:STATe
CALCulate<n>:TABLe:POWer:BASE:LIMit:STATe
CALCulate<n>:TABLe:POWer:MAX:LIMit:STATe
CALCulate<n>:TABLe:POWer:MIN:LIMit:STATe
CALCulate<n>:TABLe:POWer:ON:LIMit:STATe
CALCulate<n>:TABLe:POWer:OVERshoot:DB:LIMit:STATe
CALCulate<n>:TABLe:POWer:OVERshoot[:PERCent]:LIMit:STATe
CALCulate<n>:TABLe:POWer:PAVG:LIMit:STATe
CALCulate<n>:TABLe:POWer:PMIN:LIMit:STATe
CALCulate<n>:TABLe:POWer:POINt:LIMit:STATe
CALCulate<n>:TABLe:POWer:PON:LIMit:STATe
CALCulate<n>:TABLe:POWer:PPRatio:LIMit:STATe
CALCulate<n>:TABLe:POWer:RIPPle:DB:LIMit:STATe
CALCulate<n>:TABLe:POWer:RIPPle[:PERCent]:LIMit:STATe
CALCulate<n>:TABLe:POWer:TOP:LIMit:STATe
CALCulate<n>:TABLe:TIMing:DCYCle:LIMit:STATe
CALCulate<n>:TABLe:TIMing:DRATio:LIMit:STATe
CALCulate<n>:TABLe:TIMing:FALL:LIMit:STATe
CALCulate<n>:TABLe:TIMing:OFF:LIMit:STATe
CALCulate<n>:TABLe:TIMing:PRF:LIMit:STATe
CALCulate<n>:TABLe:TIMing:PRI:LIMit:STATe
CALCulate<n>:TABLe:TIMing:PWIDth:LIMit:STATe
CALCulate<n>:TABLe:TIMing:RISE:LIMit:STATe
CALCulate<n>:TABLe:TIMing:SETTling:LIMit:STATe
CALCulate<n>:TABLe:TIMing:TSTamp:LIMit:STATe
CALCulate<n>:TABLe:<ParameterGroup>:ALL:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:ALL:LIMit:STATe
CALCulate<n>:TABLe:PHASe:ALL:LIMit:STATe
CALCulate<n>:TABLe:POWer:ALL:LIMit:STATe
CALCulate<n>:TABLe:TIMing:ALL:LIMit:STATe
CALCulate<n>:TABLe:ALL:LIMit:STATe
CALCulate<n>:TABLe:<ParameterGroup>:<Parameter>:LIMit
CALCulate<n>:TABLe:FREQuency:CRATe:LIMit
CALCulate<n>:TABLe:FREQuency:DEViation:LIMit
CALCulate<n>:TABLe:FREQuency:PERRor:LIMit
CALCulate<n>:TABLe:FREQuency:POINt:LIMit
CALCulate<n>:TABLe:FREQuency:PPFRequency:LIMit
CALCulate<n>:TABLe:FREQuency:RERRor:LIMit
CALCulate<n>:TABLe:PHASe:DEViation:LIMit
CALCulate<n>:TABLe:PHASe:PERRor:LIMit
CALCulate<n>:TABLe:PHASe:POINt:LIMit
CALCulate<n>:TABLe:PHASe:PPPHase:LIMit
CALCulate<n>:TABLe:PHASe:RERRor:LIMit
CALCulate<n>:TABLe:POWer:ADRoop:DB:LIMit
CALCulate<n>:TABLe:POWer:ADRoop[:PERCent]:LIMit
CALCulate<n>:TABLe:POWer:AMPLitude:LIMit
CALCulate<n>:TABLe:POWer:AVG:LIMit
CALCulate<n>:TABLe:POWer:BASE:LIMit
CALCulate<n>:TABLe:POWer:MAX:LIMit
CALCulate<n>:TABLe:POWer:MIN:LIMit
CALCulate<n>:TABLe:POWer:ON:LIMit
CALCulate<n>:TABLe:POWer:OVERshoot:DB:LIMit
CALCulate<n>:TABLe:POWer:OVERshoot[:PERCent]:LIMit
CALCulate<n>:TABLe:POWer:PAVG:LIMit
CALCulate<n>:TABLe:POWer:PMIN:LIMit
CALCulate<n>:TABLe:POWer:POINt:LIMit
CALCulate<n>:TABLe:POWer:PON:LIMit
CALCulate<n>:TABLe:POWer:PPRatio:LIMit
CALCulate<n>:TABLe:POWer:RIPPle:DB:LIMit
CALCulate<n>:TABLe:POWer:RIPPle[:PERCent]:LIMit
CALCulate<n>:TABLe:POWer:TOP:LIMit
CALCulate<n>:TABLe:TIMing:DCYCle:LIMit
CALCulate<n>:TABLe:TIMing:DRATio:LIMit
CALCulate<n>:TABLe:TIMing:FALL:LIMit
CALCulate<n>:TABLe:TIMing:OFF:LIMit
CALCulate<n>:TABLe:TIMing:PRF:LIMit
CALCulate<n>:TABLe:TIMing:PRI:LIMit
CALCulate<n>:TABLe:TIMing:PWIDth:LIMit
CALCulate<n>:TABLe:TIMing:RISE:LIMit
CALCulate<n>:TABLe:TIMing:SETTling:LIMit
CALCulate<n>:TABLe:TIMing:TSTamp:LIMit


CALCulate<n>:TABLe:<ParameterGroup>:<Parameter>:LIMit:STATe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring Limit Checks > CALCulate<n>:TABLe:<ParameterGroup>:<Parameter>:LIMit:STATe
CALCulate<n>:TABLe:<ParameterGroup>:<Parameter>:LIMit:STATe <State>
CALCulate<n>:TABLe:FREQuency:CRATe:LIMit:STATe <State>
CALCulate<n>:TABLe:FREQuency:DEViation:LIMit:STATe <State>
CALCulate<n>:TABLe:FREQuency:PERRor:LIMit:STATe <State>
CALCulate<n>:TABLe:FREQuency:POINt:LIMit:STATe <State>
CALCulate<n>:TABLe:FREQuency:PPFRequency:LIMit:STATe <State>
CALCulate<n>:TABLe:FREQuency:RERRor:LIMit:STATe <State>
CALCulate<n>:TABLe:PHASe:DEViation:LIMit:STATe <State>
CALCulate<n>:TABLe:PHASe:PERRor:LIMit:STATe <State>
CALCulate<n>:TABLe:PHASe:POINt:LIMit:STATe <State>
CALCulate<n>:TABLe:PHASe:PPPHase:LIMit:STATe <State>
CALCulate<n>:TABLe:PHASe:RERRor:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:ADRoop:DB:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:ADRoop[:PERCent]:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:AMPLitude:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:AVG:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:BASE:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:MAX:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:MIN:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:ON:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:OVERshoot:DB:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:OVERshoot[:PERCent]:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:PAVG:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:PMIN:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:POINt:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:PON:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:PPRatio:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:RIPPle:DB:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:RIPPle[:PERCent]:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:TOP:LIMit:STATe <State>
CALCulate<n>:TABLe:TIMing:DCYCle:LIMit:STATe <State>
CALCulate<n>:TABLe:TIMing:DRATio:LIMit:STATe <State>
CALCulate<n>:TABLe:TIMing:FALL:LIMit:STATe <State>
CALCulate<n>:TABLe:TIMing:OFF:LIMit:STATe <State>
CALCulate<n>:TABLe:TIMing:PRF:LIMit:STATe <State>
CALCulate<n>:TABLe:TIMing:PRI:LIMit:STATe <State>
CALCulate<n>:TABLe:TIMing:PWIDth:LIMit:STATe <State>
CALCulate<n>:TABLe:TIMing:RISE:LIMit:STATe <State>
CALCulate<n>:TABLe:TIMing:SETTling:LIMit:STATe <State>
CALCulate<n>:TABLe:TIMing:TSTamp:LIMit:STATe <State>

Activates or deactivates a limit check for the selected parameter. The limits are defined using CALCulate<n>:​TABLe:​<ParameterGroup>:​<Parameter>:​LIMit.

Parameters:
<State>
ON | OFF
*RST: OFF


CALCulate<n>:TABLe:<ParameterGroup>:ALL:LIMit:STATe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring Limit Checks > CALCulate<n>:TABLe:<ParameterGroup>:ALL:LIMit:STATe
CALCulate<n>:TABLe:<ParameterGroup>:ALL:LIMit:STATe <State>
CALCulate<n>:TABLe:FREQuency:ALL:LIMit:STATe <State>
CALCulate<n>:TABLe:PHASe:ALL:LIMit:STATe <State>
CALCulate<n>:TABLe:POWer:ALL:LIMit:STATe <State>
CALCulate<n>:TABLe:TIMing:ALL:LIMit:STATe <State>

Activates or deactivates a limit check for all parameters in the selected parameter group.

Parameters:
<State>
ON | OFF
*RST: OFF


CALCulate<n>:TABLe:ALL:LIMit:STATe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring Limit Checks > CALCulate<n>:TABLe:ALL:LIMit:STATe
CALCulate<n>:TABLe:ALL:LIMit:STATe <State>

Activates or deactivates a limit check for all parameters in all parameter groups.

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: Setting only
Manual operation: See "Deactivating all limit checks for all parameter groups"


CALCulate<n>:TABLe:<ParameterGroup>:<Parameter>:LIMit

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring Limit Checks > CALCulate<n>:TABLe:<ParameterGroup>:<Parameter>:LIMit
CALCulate<n>:TABLe:<ParameterGroup>:<Parameter>:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:FREQuency:CRATe:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:FREQuency:DEViation:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:FREQuency:PERRor:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:FREQuency:POINt:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:FREQuency:PPFRequency:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:FREQuency:RERRor:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:PHASe:DEViation:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:PHASe:PERRor:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:PHASe:POINt:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:PHASe:PPPHase:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:PHASe:RERRor:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:ADRoop:DB:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:ADRoop[:PERCent]:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:AMPLitude:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:AVG:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:BASE:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:MAX:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:MIN:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:ON:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:OVERshoot:DB:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:OVERshoot[:PERCent]:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:PAVG:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:PMIN:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:POINt:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:PON:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:PPRatio:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:RIPPle:DB:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:RIPPle[:PERCent]:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:POWer:TOP:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:TIMing:DCYCle:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:TIMing:DRATio:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:TIMing:FALL:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:TIMing:OFF:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:TIMing:PRF:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:TIMing:PRI:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:TIMing:PWIDth:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:TIMing:RISE:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:TIMing:SETTling:LIMit <LowLimit>, <UppLimit>
CALCulate<n>:TABLe:TIMing:TSTamp:LIMit <LowLimit>, <UppLimit>

Defines the valid value range for the limit check for the selected parameter if limit check is active (CALCulate<n>:​TABLe:​<ParameterGroup>:​<Parameter>:​LIMit:​STATe ON).

For details on the individual parameters see "Pulse Parameters".

Parameters:
<LowLimit>

Lower limit of the valid value range.

Default unit: S
<UppLimit>

Upper limit of the valid value range.

Default unit: S


Configuring the Y-Axis Scaling and Units

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Y-Axis Scaling and Units
Configuring the Y-Axis Scaling and Units

The scaling for the vertical axis is highly configurable, using either absolute or relative values. These commands are described here.

Useful commands for configuring scaling described elsewhere:
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel
Remote commands exclusive to scaling the y-axis
List of Commands
CALCulate<n>:UNIT:FREQuency
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MINimum
UNIT:ANGLe


CALCulate<n>:UNIT:FREQuency

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Y-Axis Scaling and Units > CALCulate<n>:UNIT:FREQuency
CALCulate<n>:UNIT:FREQuency <Unit>

Switches between relative (default) and absolute frequency values. This setting applies to Pulse Frequency, Result Range Spectrum, Parameter Distribution and Parameter Trend result displays.

Parameters:
<Unit> | REL | ABS
Manual operation: | See "Frequency Unit"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO <State>

If enabled, the Y-axis is scaled automatically according to the current measurement.

Parameters for setting and query:
<State>
OFF

Switch the function off

ON

Switch the function on

ONCE

Execute the function once

*RST: ON
Manual operation: See "Auto Scale Continuous (All)"
See "Auto Scale Once (All)"
See "Automatic Grid Scaling"
See "Auto Scale Once"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum <Value>

This command defines the maximum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Absolute Scaling (Min/Max Values)"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum <Value>

This command defines the minimum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Absolute Scaling (Min/Max Values)"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision <Value>

This remote command determines the grid spacing on the Y-axis for all diagrams, where possible.

Parameters:
<Value>
numeric value WITHOUT UNIT (unit according to the result display)

Defines the range per division (total range = 10*<Value>)

*RST: depends on the result display
Example: DISP:TRAC:Y:PDIV 10

Sets the grid spacing to 10 units (e.g. dB) per division

Manual operation: See "Per Division"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition <Position>

This command defines the vertical position of the reference level on the display grid.

The R&S FSW adjusts the scaling of the y-axis accordingly.

Parameters:
<Position>

0 PCT corresponds to the lower display border, 100% corresponds to the upper display border.

*RST: 100 PCT = frequency display; 50 PCT = time display
Example:

DISP:TRAC:Y:RPOS 50PCT

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Ref Position"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue <Value>

This command defines the reference value assigned to the reference position in the specified window. Separate reference values are maintained for the various displays.

Parameters:
<Value>
numeric value WITHOUT UNIT
Default unit: dBm
Example:

See "Programming Example: Pulse Measurement".

Manual operation: See "Ref Value"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MAXimum

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MAXimum <Value>

This command defines the maximum value on the y-axis in the specified window.

Parameters:
<Value>
numeric value
Default unit: dBm


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MINimum

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Y-Axis Scaling and Units > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MINimum <Value>

This command defines the minimum value on the y-axis in the specified window.

Parameters:
<Value>
numeric_value
Default unit: dBm


UNIT:ANGLe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Results > Configuring the Y-Axis Scaling and Units > UNIT:ANGLe
UNIT:ANGLe <Unit>

This command selects the unit for angles (for PM display).

This command is identical to CALC:UNIT:ANGL

Parameters:
<Unit>
DEG | RAD
*RST: RAD
Example:

UNIT:ANGL DEG

Manual operation: See "Phase Unit"


Configuring the Result Display

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display
Configuring the Result Display

The following commands are required to configure the screen display in a remote environment. The tasks for manual operation are described in "Measurements and Result Displays".

Contents
  • General Window Commands
  • Working with Windows in the Display


General Window Commands

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "Magnitude Capture"
See "Marker Table"
See "Parameter Distribution"
See "Parameter Spectrum"
See "Parameter Trend"
See "Pulse Frequency"
See "Pulse Magnitude"
See "Pulse Phase"
See "Pulse Phase (Wrapped)"
See "Pulse Results"
See "Pulse Statistics"
See "Result Range Spectrum"

For a detailed example see "Programming Example: Pulse Measurement".

<WindowType> parameter values for Pulse application
Parameter value | Window type
MCAPture | Magnitude Capture Buffer
MTABle | Marker Table
PDIStribution | Parameter Distribution
PFRequency | Pulse Frequency
PMAGnitude | Pulse Magnitude
PPHase | Pulse Phase
PPWrapped | Pulse phase, wrapped
PRESults | Pulse Results
PSPectrum | Parameter Spectrum
PSTatistics | Pulse Statistics
PTRend | Parameter Trend
RRSPectrum | Result Range Spectrum


LAYout:CATalog[:WINDow]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Configuring Standard Traces

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring Standard Traces
Configuring Standard Traces
Useful commands for configuring traces described elsewhere:
  • [SENSe:​]AVERage:​COUNt
  • [SENSe:​]SWEep:​COUNt
Remote commands exclusive to configuring traces
List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
[SENSe:]AVERage<n>[:STATe<t>]
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:][STATistic<n>:]TYPE
[SENSe:]SWEep:POINts


DISPlay[:WINDow<n>]:TRACe<t>:MODE

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

For more information see "Analyzing Several Traces - Trace Mode" .

Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trace Mode"


DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous <State>

This command turns an automatic reset of a trace on and off after a parameter has changed.

The reset works for trace modes min hold, max hold and average.

Note that the command has no effect if critical parameters like the span have been changed to avoid invalid measurement results

Parameters:
<State>
ON

The automatic reset is off.

OFF

The automatic reset is on.

*RST: OFF
Example: DISP:WIND:TRAC3:MODE:HCON ON

Switches off the reset function.

Manual operation: See "Hold"


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace 1/Trace 2/Trace 3/Trace 4/Trace 5/Trace 6"
See "Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)"


[SENSe:]AVERage<n>[:STATe<t>]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring Standard Traces > [SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]AVERage<n>[:STATe<t>] <State>

This command turns averaging for a particular trace in a particular window on and off.

Parameters:
<State>
ON | OFF
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring Standard Traces > [SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion] <Detector>

Defines the trace detector to be used for trace analysis.

For details see "Mapping Samples to Sweep Points with the Trace Detector".

Parameters:
<Detector>
APEak

Autopeak

NEGative

Negative peak

POSitive

Positive peak

SAMPle

First value detected per trace point

RMS

RMS value

AVERage

Average

*RST: APEak (I/Q Analyzer: RMS)

For more information see "Mapping Samples to Sweep Points with the Trace Detector".

Example: DET POS

Sets the detector to "positive peak".

Example:

See "Programming Example: EMI Measurement" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Detector"


[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring Standard Traces > [SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO <State>

This command couples and decouples the detector to the trace mode.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: DET:AUTO OFF

The selection of the detector is not coupled to the trace mode.

Manual operation: See "Detector"


[SENSe:][STATistic<n>:]TYPE

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring Standard Traces > [SENSe:][STATistic<n>:]TYPE
[SENSe:][STATistic<n>:]TYPE <TraceStatistic>

Defines which pulses are included in the statistical evaluation of traces in result displays based on the result range.

Parameters:
<TraceStatistic>
SEL | ALL
SEL

Only the selected pulse from each sweep (capture) is included in the statistical evaluation of trace results. The pulse is selected using SENSe:​TRACe:​MEASurement:​DEFine:​PULSe:​SELected.

ALL

All measured pulses from each sweep (capture) are included in the statistical evaluation of trace results.

Manual operation: See "Selected Pulse vs All Pulses"


[SENSe:]SWEep:POINts

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring Standard Traces > [SENSe:]SWEep:POINts
[SENSe:]SWEep:POINts <SweepPoints>

Sets/queries the number of trace points to be displayed and used for statistical evaulation.

Parameters:
<SweepPoints> |
Manual operation: | See "Maximum number of trace points"


Configuring an Analysis Interval and Line (MSRA mode only)

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring an Analysis Interval and Line (MSRA mode only)
Configuring an Analysis Interval and Line (MSRA mode only)

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRA applications.

For the Pulse application, the commands to define the analysis interval are the same as those used to define the actual data acquisition (see "Data Acquisition". Be sure to select the correct measurement channel before executing these commands.

Useful commands related to MSRA mode described elsewhere:
  • INITiate:​REFResh
  • INITiate:​SEQuencer:​REFResh[:​ALL]
Remote commands exclusive to MSRA applications

The following commands are only available for MSRA application channels:

List of Commands
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
[SENSe:]MSRA:CAPTure:OFFSet


CALCulate:MSRA:ALINe:SHOW

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRA applications and the MSRA Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:MSRA:ALINe[:VALue]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRA applications and the MSRA Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time of the MSRA measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:MSRA:WINDow<n>:IVAL?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring an Analysis Interval and Line (MSRA mode only) > CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRA View or MSRA Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


[SENSe:]MSRA:CAPTure:OFFSet

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring an Analysis Interval and Line (MSRA mode only) > [SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRA mode, not for the MSRA Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | 0 to <Record length>
*RST: | 0
Manual operation: See "Capture Offset"


Configuring an Analysis Interval and Line (MSRT mode only)

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring an Analysis Interval and Line (MSRT mode only)
Configuring an Analysis Interval and Line (MSRT mode only)

In MSRT operating mode, only the MSRT Master actually captures data; the MSRT applications define an extract of the captured data for analysis, referred to as the analysis interval. The analysis line is a common time marker for all MSRT applications.

For the Pulse application, the commands to define the analysis interval are the same as those used to define the actual data acquisition (see "Data Acquisition". Be sure to select the correct measurement channel before executing these commands.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the Pulse measurement.

Useful commands related to MSRT mode described elsewhere:
  • INITiate:​REFResh
  • INITiate:​SEQuencer:​REFResh[:​ALL]
Remote commands exclusive to MSRT applications

The following commands are only available for MSRT application channels:

List of Commands
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
[SENSe:]RTMS:CAPTure:OFFSet


CALCulate:RTMS:ALINe:SHOW

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRT applications and the MSRT Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON
Manual operation: See "Show Line"


CALCulate:RTMS:ALINe[:VALue]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRT applications and the MSRT Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time (pretrigger + posttrigger) of the MSRT measurement.

Default unit: s
Manual operation: See "Position"


CALCulate:RTMS:WINDow<n>:IVAL?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring an Analysis Interval and Line (MSRT mode only) > CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate:RTMS:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRT View or MSRT Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


[SENSe:]RTMS:CAPTure:OFFSet

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Configuring an Analysis Interval and Line (MSRT mode only) > [SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]RTMS:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRT mode, not for the MSRT Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | - [pretrigger time] to min (posttrigger time; sweep time)
*RST: | 0
Manual operation: See "Capture Offset"


Retrieving Results

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results
Retrieving Results

The following commands are required to retrieve the calculated pulse parameters.

Note that for each pulse result query you can specify for which pulse(s) you require results:

  • ALL: for all pulses detected in the entire measurement
  • CURRent: for all pulses in the current capture buffer
  • SELected: only for the currently selected pulse

For each pulse result, you can query either the current value (default) or the following statistical values for the pulses detected in the capture buffer or the entire measurement:

  • AVER: average of the results
  • MIN: minimum of the results
  • MAX: maximum of the results
  • SDEV: standard deviation of the results
Contents
  • Retrieving and Storing Trace Data
  • Retrieving Information on Data Segments
  • Retrieving Information on Detected Pulses
  • Retrieving Power / Amplitude Parameters
  • Retrieving Timing Parameters
  • Retrieving Frequency Parameters
  • Retrieving Phase Parameters
  • Exporting Trace Results to an ASCII File
  • Exporting Table Results to an ASCII File
  • Exporting I/Q Results to an iq-tar File


Retrieving and Storing Trace Data

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving and Storing Trace Data
Retrieving and Storing Trace Data

In order to retrieve the trace results in a remote environment, use the following command:

List of Commands
TRACe<n>[:DATA]?
TRACe<n>[:DATA]:X?
MMEMory:STORe<n>:TRACe


TRACe<n>[:DATA]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving and Storing Trace Data > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? <Trace>

This command queries the y-values in the selected result display. It is only available for graphical displays.

For each trace point, the measured or calculated value is returned. For the Magnitude Capture display, the maximum y-value for each trace point is returned.

The unit depends on the display and on the unit you have currently set.

Query parameters:
<Trace> | TRACE1 The trace number whose values are to be returned. Currently only one trace is available.
Example: | See "Programming Example: Pulse Measurement".
Usage: | Query only


TRACe<n>[:DATA]:X?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving and Storing Trace Data > TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]:X? <Trace>

This remote control command returns the X values only for the trace in the selected result display. Depending on the type of result display and the scaling of the x-axis, this can be either the pulse number or a timestamp for each detected pulse in the capture buffer.

This command is only available for graphical displays, except for the Magnitude Capture display.

Query parameters:
<Trace> | TRACe1 The trace number whose values are to be returned. Currently only one trace is available.
Example: | See "Programming Example: Pulse Measurement".
Usage: | Query only


MMEMory:STORe<n>:TRACe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving and Storing Trace Data > MMEMory:STORe<n>:TRACe
MMEMory:STORe<n>:TRACe <Trace>, <FileName>

This command exports trace data from the specified window to an ASCII file.

For details on the file format see "Reference: ASCII File Export Format".

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<Trace> | Number of the trace to be stored
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR1:TRAC 3,'C:\TEST.ASC' Stores trace 3 from window 1 in the file TEST.ASC.
Example: | See "Programming Example: Pulse Measurement".
Usage: | SCPI confirmed
Manual operation: | See "Export Trace to ASCII File"


Retrieving Information on Data Segments

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Information on Data Segments
Retrieving Information on Data Segments

The following commands return information on data segments for segmented data capture (see "Segmented Data Capturing").

List of Commands
TRACe<n>:IQ:SCAPture:BOUNdary?
TRACe<n>:IQ:SCAPture:TSTamp:SSTart?
TRACe<n>:IQ:SCAPture:TSTamp:TRIGger?


TRACe<n>:IQ:SCAPture:BOUNdary?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Information on Data Segments > TRACe<n>:IQ:SCAPture:BOUNdary?
TRACe<n>:IQ:SCAPture:BOUNdary?

This remote control command returns an array of sample indices for the start of each captured data segment. The length of the array depends on the number of trigger events specified by [SENSe:​]SWEep:​SCAPture:​EVENts.

Example: | See TRACe<n>:​IQ:​SCAPture:​TSTamp:​SSTart?.
Usage: | Query only
Manual operation: | See "Magnitude Capture"


TRACe<n>:IQ:SCAPture:TSTamp:SSTart?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Information on Data Segments > TRACe<n>:IQ:SCAPture:TSTamp:SSTart?
TRACe<n>:IQ:SCAPture:TSTamp:SSTart?

This remote control command returns an array of timestamps for each segment start in the captured data. The length of the array depends on the number of trigger events specified by [SENSe:​]SWEep:​SCAPture:​EVENts. For details see "Timestamps vs. sample number".

Example:
//Configure a power trigger at -20dBm
TRIG:SOUR RFP
TRIG:LEV:RFP -20dBm
//Activate segmented capture
SENS:SWE:SCAP ON
//Define a pretrigger offset of 5 us
SENS:SWE:SCAP:OFFS -5 us
//Capture data for 25us for 10 trigger events
SENS:SWE:SCAP:EVEN 10
SENS:SWE:SCAP:LENG 25 us
//Query the sample rate
SRATE?
//Result: 200 MHz
//Measurement time = 10 Events * Segment Len (25 us) = 250 us
//Record length = Sample Rate(200 MHz)*Meas Time(250us)=50000

//Select single sweep mode.
INIT:CONT OFF
//Initiate a new measurement and wait until the sweep
//has finished.
INIT;*WAI

//Query the sample indices at which segments start
TRAC:IQ:SCAP:BOUN?
//Result:
//0,5000,10000,15000,20000,25000,30000,35000,40000,45000

//Query the timestamps at which segments were captured
TRAC:IQ:SCAP:TST:SST?
//Result:
//-4.999999874E-006,+7.450049743E-004,+1.494999975E-003,
//+2.245004987E-003,+2.994999988E-003,+3.745000111E-003,
//+4.495000001E-003,+5.245004781E-003,+5.994999781E-003,
//+6.745005026E-003

//Query the timestamps at which trigger events occured
TRAC:IQ:SCAP:TST:TRIG?
//Result:
//+0.000000000,+7.500050124E-004,+1.500000013E-003,
//+2.250005025E-003,+3.000000026E-003,+3.749999916E-003,
//+4.499999806E-003,+5.250005051E-003,+6.000000052E-003,
//+6.750004832E-003
Usage: Query only
Manual operation: See "Magnitude Capture"
See "Trigger Offset"


TRACe<n>:IQ:SCAPture:TSTamp:TRIGger?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Information on Data Segments > TRACe<n>:IQ:SCAPture:TSTamp:TRIGger?
TRACe<n>:IQ:SCAPture:TSTamp:TRIGger?

This remote control command returns an array of trigger event time stamps for the captured data segments. The length of the array depends on the number of trigger events specified by [SENSe:​]SWEep:​SCAPture:​EVENts.

Usage: | Query only
Manual operation: | See "Magnitude Capture" See "Trigger Offset"


Retrieving Information on Detected Pulses

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Information on Detected Pulses
Retrieving Information on Detected Pulses

The following commands return general information on the currently selected or all detected pulses.

List of Commands
[SENSe:]PULSe:ID?
[SENSe:]PULSe:NUMBer?


[SENSe:]PULSe:ID?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Information on Detected Pulses > [SENSe:]PULSe:ID?
[SENSe:]PULSe:ID? <QueryRange>

Queries the ids of the detected pulses, i.e the unique index within the entire measurement (as opposed to [SENSe:​]PULSe:​NUMBer?).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:NUMBer?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Information on Detected Pulses > [SENSe:]PULSe:NUMBer?
[SENSe:]PULSe:NUMBer? <QueryRange>

Queries the detected pulse numbers, i.e. the index within the capture buffer (as opposed to [SENSe:​]PULSe:​ID?).

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


Retrieving Power / Amplitude Parameters

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters
Retrieving Power / Amplitude Parameters

The following commands return the calculated pulse parameters.

For details on the individual parameters see "Power/Amplitude Parameters".

The [SENS:]TRAC:MEAS:POW... commands are maintained for compatibility reasons only. For new remote control programs, use the corresponding [SENS:]PULS:POW... commands instead.

List of Commands
[SENSe:]PULSe:POWer:ADRoop:DB?
[SENSe:]PULSe:POWer:ADRoop:DB:AVERage?
[SENSe:]PULSe:POWer:ADRoop:DB:MAXimum?
[SENSe:]PULSe:POWer:ADRoop:DB:MINimum?
[SENSe:]PULSe:POWer:ADRoop:DB:SDEViation?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:AVERage?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:MAXimum?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:MINimum?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:SDEViation?
[SENSe:]PULSe:POWer:AMPLitude?
[SENSe:]PULSe:POWer:AMPLitude:AVERage?
[SENSe:]PULSe:POWer:AMPLitude:MAXimum?
[SENSe:]PULSe:POWer:AMPLitude:MINimum?
[SENSe:]PULSe:POWer:AMPLitude:SDEViation?
[SENSe:]PULSe:POWer:AVG?
[SENSe:]PULSe:POWer:AVG:AVERage?
[SENSe:]PULSe:POWer:AVG:MAXimum?
[SENSe:]PULSe:POWer:AVG:MINimum?
[SENSe:]PULSe:POWer:AVG:SDEViation?
[SENSe:]PULSe:POWer:BASE?
[SENSe:]PULSe:POWer:BASE:AVERage?
[SENSe:]PULSe:POWer:BASE:MAXimum?
[SENSe:]PULSe:POWer:BASE:MINimum?
[SENSe:]PULSe:POWer:BASE:SDEViation?
[SENSe:]PULSe:POWer:MAX?
[SENSe:]PULSe:POWer:MAX:AVERage?
[SENSe:]PULSe:POWer:MAX:MAXimum?
[SENSe:]PULSe:POWer:MAX:MINimum?
[SENSe:]PULSe:POWer:MAX:SDEViation?
[SENSe:]PULSe:POWer:MIN?
[SENSe:]PULSe:POWer:MIN:AVERage?
[SENSe:]PULSe:POWer:MIN:MAXimum?
[SENSe:]PULSe:POWer:MIN:MINimum?
[SENSe:]PULSe:POWer:MIN:SDEViation?
[SENSe:]PULSe:POWer:ON?
[SENSe:]PULSe:POWer:ON:AVERage?
[SENSe:]PULSe:POWer:ON:MAXimum?
[SENSe:]PULSe:POWer:ON:MINimum?
[SENSe:]PULSe:POWer:ON:SDEViation?
[SENSe:]PULSe:POWer:OVERshoot:DB?
[SENSe:]PULSe:POWer:OVERshoot:DB:AVERage?
[SENSe:]PULSe:POWer:OVERshoot:DB:MAXimum?
[SENSe:]PULSe:POWer:OVERshoot:DB:MINimum?
[SENSe:]PULSe:POWer:OVERshoot:DB:SDEViation?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:AVERage?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:MAXimum?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:MINimum?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:SDEViation?
[SENSe:]PULSe:POWer:PAVG?
[SENSe:]PULSe:POWer:PAVG:AVERage?
[SENSe:]PULSe:POWer:PAVG:MAXimum?
[SENSe:]PULSe:POWer:PAVG:MINimum?
[SENSe:]PULSe:POWer:PAVG:SDEViation?
[SENSe:]PULSe:POWer:PMIN?
[SENSe:]PULSe:POWer:PMIN:AVERage?
[SENSe:]PULSe:POWer:PMIN:MAXimum?
[SENSe:]PULSe:POWer:PMIN:MINimum?
[SENSe:]PULSe:POWer:PMIN:SDEViation?
[SENSe:]PULSe:POWer:POINt?
[SENSe:]PULSe:POWer:POINt:AVERage?
[SENSe:]PULSe:POWer:POINt:MAXimum?
[SENSe:]PULSe:POWer:POINt:MINimum?
[SENSe:]PULSe:POWer:POINt:SDEViation?
[SENSe:]PULSe:POWer:PON?
[SENSe:]PULSe:POWer:PON:AVERage?
[SENSe:]PULSe:POWer:PON:MAXimum?
[SENSe:]PULSe:POWer:PON:MINimum?
[SENSe:]PULSe:POWer:PON:SDEViation?
[SENSe:]PULSe:POWer:PPRatio?
[SENSe:]PULSe:POWer:PPRatio:AVERage?
[SENSe:]PULSe:POWer:PPRatio:MAXimum?
[SENSe:]PULSe:POWer:PPRatio:MINimum?
[SENSe:]PULSe:POWer:PPRatio:SDEViation?
[SENSe:]PULSe:POWer:RIPPle:DB?
[SENSe:]PULSe:POWer:RIPPle:DB:AVERage?
[SENSe:]PULSe:POWer:RIPPle:DB:MAXimum?
[SENSe:]PULSe:POWer:RIPPle:DB:MINimum?
[SENSe:]PULSe:POWer:RIPPle:DB:SDEViation?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:AVERage?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:MAXimum?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:MINimum?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:SDEViation?
[SENSe:]PULSe:POWer:TOP?
[SENSe:]PULSe:POWer:TOP:AVERage?
[SENSe:]PULSe:POWer:TOP:MAXimum?
[SENSe:]PULSe:POWer:TOP:MINimum?
[SENSe:]PULSe:POWer:TOP:SDEViation?
SENSe:TRACe:MEASurement:POWer:AVG?
SENSe:TRACe:MEASurement:POWer:AVG[:AVERage]?
SENSe:TRACe:MEASurement:POWer:AVG:MAXimum?
SENSe:TRACe:MEASurement:POWer:AVG:MINimum?
SENSe:TRACe:MEASurement:POWer:AVG:SDEViation?
SENSe:TRACe:MEASurement:POWer:CRESt?
SENSe:TRACe:MEASurement:POWer:CRESt[:AVERage]?
SENSe:TRACe:MEASurement:POWer:CRESt:MAXimum?
SENSe:TRACe:MEASurement:POWer:CRESt:MINimum?
SENSe:TRACe:MEASurement:POWer:CRESt:SDEViation?
SENSe:TRACe:MEASurement:POWer:MAX?
SENSe:TRACe:MEASurement:POWer:MAX[:AVERage]?
SENSe:TRACe:MEASurement:POWer:MAX:MAXimum?
SENSe:TRACe:MEASurement:POWer:MAX:MINimum?
SENSe:TRACe:MEASurement:POWer:MAX:SDEViation?
SENSe:TRACe:MEASurement:POWer:MIN?
SENSe:TRACe:MEASurement:POWer:MIN[:AVERage]?
SENSe:TRACe:MEASurement:POWer:MIN:MAXimum?
SENSe:TRACe:MEASurement:POWer:MIN:MINimum?
SENSe:TRACe:MEASurement:POWer:MIN:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:ON?
SENSe:TRACe:MEASurement:POWer:PULSe:ON[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:ON:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:ON:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:ON:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP:SDEViation?
SENSe:TRACe:MEASurement:POWer:RANGe?
SENSe:TRACe:MEASurement:POWer:RANGe[:AVERage]?
SENSe:TRACe:MEASurement:POWer:RANGe:MAXimum?
SENSe:TRACe:MEASurement:POWer:RANGe:MINimum?
SENSe:TRACe:MEASurement:POWer:RANGe:SDEViation?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot[:AVERage]?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot:MAXimum?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot:MINimum?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot:SDEViation?


[SENSe:]PULSe:POWer:ADRoop:DB?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:ADRoop:DB?
[SENSe:]PULSe:POWer:ADRoop:DB? <QueryRange>

Returns the amplitude droop in dB for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Droop"


[SENSe:]PULSe:POWer:ADRoop:DB:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:ADRoop:DB:AVERage?
[SENSe:]PULSe:POWer:ADRoop:DB:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:ADRoop:DB:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:ADRoop:DB:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:ADRoop:DB:SDEViation? <QueryRange>

Returns the statistical value for the amplitude droop in dB over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:ADRoop[:PERCent]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:ADRoop[:PERCent]?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]? <QueryRange>

Returns the amplitude droop in percent for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Droop"


[SENSe:]PULSe:POWer:ADRoop[:PERCent]:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:ADRoop[:PERCent]:AVERage?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:SDEViation? <QueryRange>

Returns the statistical value for the amplitude droop in percent over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:AMPLitude?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:AMPLitude?
[SENSe:]PULSe:POWer:AMPLitude? <QueryRange>

Returns the pulse amplitude for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Pulse Amplitude"


[SENSe:]PULSe:POWer:AMPLitude:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:AMPLitude:AVERage?
[SENSe:]PULSe:POWer:AMPLitude:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:AMPLitude:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:AMPLitude:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:AMPLitude:SDEViation? <QueryRange>

Returns the statistical value for the pule amplitude over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:AVG?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:AVG?
[SENSe:]PULSe:POWer:AVG? <QueryRange>

Returns the average transmission power for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Average Tx Power"


[SENSe:]PULSe:POWer:AVG:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:AVG:AVERage?
[SENSe:]PULSe:POWer:AVG:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:AVG:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:AVG:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:AVG:SDEViation? <QueryRange>

Returns the statistical value for the average transmission power over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:BASE?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:BASE?
[SENSe:]PULSe:POWer:BASE? <QueryRange>

Returns the base power for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Base Power"


[SENSe:]PULSe:POWer:BASE:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:BASE:AVERage?
[SENSe:]PULSe:POWer:BASE:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:BASE:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:BASE:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:BASE:SDEViation? <QueryRange>

Returns the statistical value for the base power over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:MAX?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:MAX?
[SENSe:]PULSe:POWer:MAX? <QueryRange>

Returns the maximum transmission power for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Peak Power"


[SENSe:]PULSe:POWer:MAX:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:MAX:AVERage?
[SENSe:]PULSe:POWer:MAX:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:MAX:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:MAX:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:MAX:SDEViation? <QueryRange>

Returns the statistical value for the maximum transmission power over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:MIN?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:MIN?
[SENSe:]PULSe:POWer:MIN? <QueryRange>

Returns the minimum transmission power for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Minimum Power"


[SENSe:]PULSe:POWer:MIN:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:MIN:AVERage?
[SENSe:]PULSe:POWer:MIN:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:MIN:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:MIN:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:MIN:SDEViation? <QueryRange>

Returns the statistical value for the minimum transmission power over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:ON?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:ON?
[SENSe:]PULSe:POWer:ON? <QueryRange>

Returns the average ON power for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Average ON Power"


[SENSe:]PULSe:POWer:ON:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:ON:AVERage?
[SENSe:]PULSe:POWer:ON:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:ON:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:ON:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:ON:SDEViation? <QueryRange>

Returns the statistical value for the average ON power over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:OVERshoot:DB?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:OVERshoot:DB?
[SENSe:]PULSe:POWer:OVERshoot:DB? <QueryRange>

Returns the overshoot in dB for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Overshoot"


[SENSe:]PULSe:POWer:OVERshoot:DB:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:OVERshoot:DB:AVERage?
[SENSe:]PULSe:POWer:OVERshoot:DB:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:OVERshoot:DB:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:OVERshoot:DB:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:OVERshoot:DB:SDEViation? <QueryRange>

Returns the statistical value for the overshoot in dB over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:OVERshoot[:PERCent]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:OVERshoot[:PERCent]?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]? <QueryRange>

Returns the overshoot in percent for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Overshoot"


[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:OVERshoot[:PERCent]:AVERage?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:SDEViation? <QueryRange>

Returns the statistical value for the overshoot in percent over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:PAVG?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:PAVG?
[SENSe:]PULSe:POWer:PAVG? <QueryRange>

Returns the Peak-to-Average Tx Power Ratio for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Peak-to-Average Tx Power Ratio"


[SENSe:]PULSe:POWer:PAVG:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:PAVG:AVERage?
[SENSe:]PULSe:POWer:PAVG:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:PAVG:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:PAVG:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:PAVG:SDEViation? <QueryRange>

Returns the statistical value for the Peak-to-Average Tx Power Ratio over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:PMIN?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:PMIN?
[SENSe:]PULSe:POWer:PMIN? <QueryRange>

Returns the Peak-to-Min Power Ratio for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Peak-to-Min Power Ratio"


[SENSe:]PULSe:POWer:PMIN:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:PMIN:AVERage?
[SENSe:]PULSe:POWer:PMIN:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:PMIN:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:PMIN:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:PMIN:SDEViation? <QueryRange>

Returns the statistical value for the Peak-to-Min Power Ratio over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:POINt?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:POINt?
[SENSe:]PULSe:POWer:POINt? <QueryRange>

Returns the power in the measurement point for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Power"


[SENSe:]PULSe:POWer:POINt:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:POINt:AVERage?
[SENSe:]PULSe:POWer:POINt:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:POINt:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:POINt:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:POINt:SDEViation? <QueryRange>

Returns the statistical value for the power in the measurement point over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:PON?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:PON?
[SENSe:]PULSe:POWer:PON? <QueryRange>

Returns the Peak-to-Avg ON Power Ratio for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Peak-to-Avg ON Power Ratio"


[SENSe:]PULSe:POWer:PON:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:PON:AVERage?
[SENSe:]PULSe:POWer:PON:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:PON:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:PON:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:PON:SDEViation? <QueryRange>

Returns the statistical value for the Peak-to-Avg ON Power Ratio over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:PPRatio?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:PPRatio?
[SENSe:]PULSe:POWer:PPRatio? <QueryRange>

Returns the Pulse-to-Pulse Power Difference for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Pulse-to-Pulse Power Difference"


[SENSe:]PULSe:POWer:PPRatio:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:PPRatio:AVERage?
[SENSe:]PULSe:POWer:PPRatio:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:PPRatio:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:PPRatio:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:PPRatio:SDEViation? <QueryRange>

Returns the statistical value for the Pulse-to-Pulse Power Difference over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:RIPPle:DB?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:RIPPle:DB?
[SENSe:]PULSe:POWer:RIPPle:DB? <QueryRange>

Returns the ripple in dB for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Ripple"


[SENSe:]PULSe:POWer:RIPPle:DB:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:RIPPle:DB:AVERage?
[SENSe:]PULSe:POWer:RIPPle:DB:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:RIPPle:DB:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:RIPPle:DB:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:RIPPle:DB:SDEViation? <QueryRange>

Returns the statistical value for the ripple in dB over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:RIPPle[:PERCent]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:RIPPle[:PERCent]?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]? <QueryRange>

Returns the ripple in percent for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Ripple"


[SENSe:]PULSe:POWer:RIPPle[:PERCent]:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:RIPPle[:PERCent]:AVERage?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:SDEViation? <QueryRange>

Returns the statistical value for the ripple in percent over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:POWer:TOP?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:TOP?
[SENSe:]PULSe:POWer:TOP? <QueryRange>

Returns the Top power for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Top Power"


[SENSe:]PULSe:POWer:TOP:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > [SENSe:]PULSe:POWer:TOP:AVERage?
[SENSe:]PULSe:POWer:TOP:AVERage? <QueryRange>
[SENSe:]PULSe:POWer:TOP:MAXimum? <QueryRange>
[SENSe:]PULSe:POWer:TOP:MINimum? <QueryRange>
[SENSe:]PULSe:POWer:TOP:SDEViation? <QueryRange>

Returns the statistical value for the Top power over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:AVG?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:AVG?
SENSe:TRACe:MEASurement:POWer:AVG?

Query the pulse average (Tx) power values from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:POWer:AVG[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:AVG[:AVERage]?
SENSe:TRACe:MEASurement:POWer:AVG[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:AVG:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:AVG:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:AVG:SDEViation? <arg0>

Query the pulse average (Tx) power values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:CRESt?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:CRESt?
SENSe:TRACe:MEASurement:POWer:CRESt?
Usage: Query only


SENSe:TRACe:MEASurement:POWer:CRESt[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:CRESt[:AVERage]?
SENSe:TRACe:MEASurement:POWer:CRESt[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:CRESt:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:CRESt:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:CRESt:SDEViation? <arg0>

Query the pulse peak-to-average Tx power ratio values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:MAX?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:MAX?
SENSe:TRACe:MEASurement:POWer:MAX?

Query the pulse peak power values from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:POWer:MAX[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:MAX[:AVERage]?
SENSe:TRACe:MEASurement:POWer:MAX[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:MAX:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:MAX:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:MAX:SDEViation? <arg0>

Query the pulse peak power values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:MIN?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:MIN?
SENSe:TRACe:MEASurement:POWer:MIN?

Query the pulse minimum power values from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:POWer:MIN[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:MIN[:AVERage]?
SENSe:TRACe:MEASurement:POWer:MIN[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:MIN:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:MIN:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:MIN:SDEViation? <arg0>

Query the pulse minimum power values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop?
Usage: Query only


SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop:SDEViation? <arg0>

Query the pulse amplitude droop values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude?
Usage: Query only


SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude:SDEViation? <arg0>

Query the pulse amplitude values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:PULSe:BASE?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:BASE?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE?

Query the pulse base power values from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:POWer:PULSe:BASE[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:BASE[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:BASE:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:BASE:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:BASE:SDEViation? <arg0>

Query the pulse base power values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:PULSe:CRESt?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:CRESt?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt?
Usage: Query only


SENSe:TRACe:MEASurement:POWer:PULSe:CRESt[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:CRESt[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt:SDEViation? <arg0>

Query the pulse peak-to-average ON power ratio values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:PULSe:ON?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:ON?
SENSe:TRACe:MEASurement:POWer:PULSe:ON?
Usage: Query only


SENSe:TRACe:MEASurement:POWer:PULSe:ON[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:ON[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:ON[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:ON:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:ON:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:ON:SDEViation? <arg0>

Query the pulse average ON power values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:PULSe:POINt?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:POINt?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt?
Usage: Query only


SENSe:TRACe:MEASurement:POWer:PULSe:POINt[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:POINt[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:POINt:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:POINt:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:POINt:SDEViation? <arg0>

Query the pulse power (at "measurement point") values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:PULSe:PPPower?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:PPPower?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower?
Usage: Query only


SENSe:TRACe:MEASurement:POWer:PULSe:PPPower[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:PPPower[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower:SDEViation? <arg0>

Query the pulse-pulse power (at "measurement point") difference values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle?
Usage: Query only


SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle:SDEViation? <arg0>

Query the pulse top ripple power ratio values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:PULSe:TOP?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:TOP?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP?

Query the pulse top power values from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:POWer:PULSe:TOP[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:PULSe:TOP[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:TOP:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:TOP:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:PULSe:TOP:SDEViation? <arg0>

Query the pulse top power values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:POWer:RANGe?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:RANGe?
SENSe:TRACe:MEASurement:POWer:RANGe?
Usage: Query only


SENSe:TRACe:MEASurement:POWer:RANGe[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:POWer:RANGe[:AVERage]?
SENSe:TRACe:MEASurement:POWer:RANGe[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:POWer:RANGe:MAXimum? <arg0>
SENSe:TRACe:MEASurement:POWer:RANGe:MINimum? <arg0>
SENSe:TRACe:MEASurement:POWer:RANGe:SDEViation? <arg0>

Query the pulse peak-to-min power ratio values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot?

Query the pulse rising overshoot power ratio values from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Power / Amplitude Parameters > SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot[:AVERage]?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot:MAXimum? <arg0>
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot:MINimum? <arg0>
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot:SDEViation? <arg0>

Query the pulse rising overshoot power ratio values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


Retrieving Timing Parameters

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters
Retrieving Timing Parameters

The following commands return the calculated pulse parameters.

For details on the individual parameters see "Timing Parameters".

The [SENS:]TRAC:MEAS:PULS... commands are maintained for compatibility reasons only. For new remote control programs, use the corresponding [SENS:]PULS:TIM... commands instead.

List of Commands
[SENSe:]PULSe:TIMing:DCYCle?
[SENSe:]PULSe:TIMing:DCYCle:AVERage?
[SENSe:]PULSe:TIMing:DCYCle:MAXimum?
[SENSe:]PULSe:TIMing:DCYCle:MINimum?
[SENSe:]PULSe:TIMing:DCYCle:SDEViation?
[SENSe:]PULSe:TIMing:DRATio?
[SENSe:]PULSe:TIMing:DRATio:AVERage?
[SENSe:]PULSe:TIMing:DRATio:MAXimum?
[SENSe:]PULSe:TIMing:DRATio:MINimum?
[SENSe:]PULSe:TIMing:DRATio:SDEViation?
[SENSe:]PULSe:TIMing:FALL?
[SENSe:]PULSe:TIMing:FALL:AVERage?
[SENSe:]PULSe:TIMing:FALL:MAXimum?
[SENSe:]PULSe:TIMing:FALL:MINimum?
[SENSe:]PULSe:TIMing:FALL:SDEViation?
[SENSe:]PULSe:TIMing:OFF?
[SENSe:]PULSe:TIMing:OFF:AVERage?
[SENSe:]PULSe:TIMing:OFF:MAXimum?
[SENSe:]PULSe:TIMing:OFF:MINimum?
[SENSe:]PULSe:TIMing:OFF:SDEViation?
[SENSe:]PULSe:TIMing:PRF?
[SENSe:]PULSe:TIMing:PRF:AVERage?
[SENSe:]PULSe:TIMing:PRF:MAXimum?
[SENSe:]PULSe:TIMing:PRF:MINimum?
[SENSe:]PULSe:TIMing:PRF:SDEViation?
[SENSe:]PULSe:TIMing:PRI?
[SENSe:]PULSe:TIMing:PRI:AVERage?
[SENSe:]PULSe:TIMing:PRI:MAXimum?
[SENSe:]PULSe:TIMing:PRI:MINimum?
[SENSe:]PULSe:TIMing:PRI:SDEViation?
[SENSe:]PULSe:TIMing:PWIDth?
[SENSe:]PULSe:TIMing:PWIDth:AVERage?
[SENSe:]PULSe:TIMing:PWIDth:MAXimum?
[SENSe:]PULSe:TIMing:PWIDth:MINimum?
[SENSe:]PULSe:TIMing:PWIDth:SDEViation?
[SENSe:]PULSe:TIMing:RISE?
[SENSe:]PULSe:TIMing:RISE:AVERage?
[SENSe:]PULSe:TIMing:RISE:MAXimum?
[SENSe:]PULSe:TIMing:RISE:MINimum?
[SENSe:]PULSe:TIMing:RISE:SDEViation?
[SENSe:]PULSe:TIMing:SETTling?
[SENSe:]PULSe:TIMing:SETTling:AVERage?
[SENSe:]PULSe:TIMing:SETTling:MAXimum?
[SENSe:]PULSe:TIMing:SETTling:MINimum?
[SENSe:]PULSe:TIMing:SETTling:SDEViation?
[SENSe:]PULSe:TIMing:TSTamp?
[SENSe:]PULSe:TIMing:TSTamp:AVERage?
[SENSe:]PULSe:TIMing:TSTamp:MAXimum?
[SENSe:]PULSe:TIMing:TSTamp:MINimum?
[SENSe:]PULSe:TIMing:TSTamp:SDEViation?
SENSe:TRACe:MEASurement:PULSe:DCYCle?
SENSe:TRACe:MEASurement:PULSe:DCYCle[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:DCYCle:MAXimum?
SENSe:TRACe:MEASurement:PULSe:DCYCle:MINimum?
SENSe:TRACe:MEASurement:PULSe:DCYCle:SDEViation?
SENSe:TRACe:MEASurement:PULSe:DURation?
SENSe:TRACe:MEASurement:PULSe:DURation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:DURation:MAXimum?
SENSe:TRACe:MEASurement:PULSe:DURation:MINimum?
SENSe:TRACe:MEASurement:PULSe:DURation:SDEViation?
SENSe:TRACe:MEASurement:PULSe:DUTRatio?
SENSe:TRACe:MEASurement:PULSe:DUTRatio[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:DUTRatio:MAXimum?
SENSe:TRACe:MEASurement:PULSe:DUTRatio:MINimum?
SENSe:TRACe:MEASurement:PULSe:DUTRatio:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PERiod?
SENSe:TRACe:MEASurement:PULSe:PERiod[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PERiod:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PERiod:MINimum?
SENSe:TRACe:MEASurement:PULSe:PERiod:SDEViation?
SENSe:TRACe:MEASurement:PULSe:RATE?
SENSe:TRACe:MEASurement:PULSe:RATE[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:RATE:MAXimum?
SENSe:TRACe:MEASurement:PULSe:RATE:MINimum?
SENSe:TRACe:MEASurement:PULSe:RATE:SDEViation?
SENSe:TRACe:MEASurement:PULSe:SEParation?
SENSe:TRACe:MEASurement:PULSe:SEParation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:SEParation:MAXimum?
SENSe:TRACe:MEASurement:PULSe:SEParation:MINimum?
SENSe:TRACe:MEASurement:PULSe:SEParation:SDEViation?
SENSe:TRACe:MEASurement:PULSe:TIME?
SENSe:TRACe:MEASurement:PULSe:TIME[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:TIME:MAXimum?
SENSe:TRACe:MEASurement:PULSe:TIME:MINimum?
SENSe:TRACe:MEASurement:PULSe:TIME:SDEViation?
SENSe:TRACe:MEASurement:TRANsition:NEGative:DURation?
SENSe:TRACe:MEASurement:TRANsition:POSitive:DURation?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling[:AVERage]?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling:MAXimum?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling:MINimum?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling:SDEViation?


[SENSe:]PULSe:TIMing:DCYCle?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:DCYCle?
[SENSe:]PULSe:TIMing:DCYCle? <QueryRange>

Returns the duty cycle (in %) for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Duty Cycle (%)"


[SENSe:]PULSe:TIMing:DCYCle:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:DCYCle:AVERage?
[SENSe:]PULSe:TIMing:DCYCle:AVERage? <QueryRange>
[SENSe:]PULSe:TIMing:DCYCle:MAXimum? <QueryRange>
[SENSe:]PULSe:TIMing:DCYCle:MINimum? <QueryRange>
[SENSe:]PULSe:TIMing:DCYCle:SDEViation? <QueryRange>

Returns the statistical value for the duty cycle (in %) over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:TIMing:DRATio?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:DRATio?
[SENSe:]PULSe:TIMing:DRATio? <QueryRange>

Returns the duty ratio for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Duty Ratio"


[SENSe:]PULSe:TIMing:DRATio:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:DRATio:AVERage?
[SENSe:]PULSe:TIMing:DRATio:AVERage? <QueryRange>
[SENSe:]PULSe:TIMing:DRATio:MAXimum? <QueryRange>
[SENSe:]PULSe:TIMing:DRATio:MINimum? <QueryRange>
[SENSe:]PULSe:TIMing:DRATio:SDEViation? <QueryRange>

Returns the statistical value for the duty ratio over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:TIMing:FALL?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:FALL?
[SENSe:]PULSe:TIMing:FALL? <QueryRange>

Returns the fall time for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Fall Time"


[SENSe:]PULSe:TIMing:FALL:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:FALL:AVERage?
[SENSe:]PULSe:TIMing:FALL:AVERage? <QueryRange>
[SENSe:]PULSe:TIMing:FALL:MAXimum? <QueryRange>
[SENSe:]PULSe:TIMing:FALL:MINimum? <QueryRange>
[SENSe:]PULSe:TIMing:FALL:SDEViation? <QueryRange>

Returns the statistical value for the fall time over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:TIMing:OFF?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:OFF?
[SENSe:]PULSe:TIMing:OFF? <QueryRange>

Returns the Off time for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Off Time"


[SENSe:]PULSe:TIMing:OFF:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:OFF:AVERage?
[SENSe:]PULSe:TIMing:OFF:AVERage? <QueryRange>
[SENSe:]PULSe:TIMing:OFF:MAXimum? <QueryRange>
[SENSe:]PULSe:TIMing:OFF:MINimum? <QueryRange>
[SENSe:]PULSe:TIMing:OFF:SDEViation? <QueryRange>

Returns the statistical value for the Off time over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:TIMing:PRF?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:PRF?
[SENSe:]PULSe:TIMing:PRF? <QueryRange>

Returns the Pulse Repetition Frequency (Hz) for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Pulse Repetition Frequency (Hz)"


[SENSe:]PULSe:TIMing:PRF:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:PRF:AVERage?
[SENSe:]PULSe:TIMing:PRF:AVERage? <QueryRange>
[SENSe:]PULSe:TIMing:PRF:MAXimum? <QueryRange>
[SENSe:]PULSe:TIMing:PRF:MINimum? <QueryRange>
[SENSe:]PULSe:TIMing:PRF:SDEViation? <QueryRange>

Returns the statistical value for the Pulse Repetition Frequency (Hz) over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:TIMing:PRI?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:PRI?
[SENSe:]PULSe:TIMing:PRI? <QueryRange>

Returns the Pulse Repetition Interval for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Pulse Repetition Interval"


[SENSe:]PULSe:TIMing:PRI:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:PRI:AVERage?
[SENSe:]PULSe:TIMing:PRI:AVERage? <QueryRange>
[SENSe:]PULSe:TIMing:PRI:MAXimum? <QueryRange>
[SENSe:]PULSe:TIMing:PRI:MINimum? <QueryRange>
[SENSe:]PULSe:TIMing:PRI:SDEViation? <QueryRange>

Returns the statistical value for the Pulse Repetition Interval over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:TIMing:PWIDth?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:PWIDth?
[SENSe:]PULSe:TIMing:PWIDth? <QueryRange>

Returns the pulse width for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Pulse Width (ON Time)"


[SENSe:]PULSe:TIMing:PWIDth:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:PWIDth:AVERage?
[SENSe:]PULSe:TIMing:PWIDth:AVERage? <QueryRange>
[SENSe:]PULSe:TIMing:PWIDth:MAXimum? <QueryRange>
[SENSe:]PULSe:TIMing:PWIDth:MINimum? <QueryRange>
[SENSe:]PULSe:TIMing:PWIDth:SDEViation? <QueryRange>

Returns the pulse width for the phase deviation over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:TIMing:RISE?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:RISE?
[SENSe:]PULSe:TIMing:RISE? <QueryRange>

Returns the rise time for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Rise Time"


[SENSe:]PULSe:TIMing:RISE:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:RISE:AVERage?
[SENSe:]PULSe:TIMing:RISE:AVERage? <QueryRange>
[SENSe:]PULSe:TIMing:RISE:MAXimum? <QueryRange>
[SENSe:]PULSe:TIMing:RISE:MINimum? <QueryRange>
[SENSe:]PULSe:TIMing:RISE:SDEViation? <QueryRange>

Returns the statistical value for the rise time over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:TIMing:SETTling?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:SETTling?
[SENSe:]PULSe:TIMing:SETTling? <QueryRange>

Returns the settling time for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Settling Time"


[SENSe:]PULSe:TIMing:SETTling:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:SETTling:AVERage?
[SENSe:]PULSe:TIMing:SETTling:AVERage? <QueryRange>
[SENSe:]PULSe:TIMing:SETTling:MAXimum? <QueryRange>
[SENSe:]PULSe:TIMing:SETTling:MINimum? <QueryRange>
[SENSe:]PULSe:TIMing:SETTling:SDEViation? <QueryRange>

Returns the statistical value for the settling time over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:TIMing:TSTamp?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:TSTamp?
[SENSe:]PULSe:TIMing:TSTamp? <QueryRange>

Returns the timestamp for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Timestamp"


[SENSe:]PULSe:TIMing:TSTamp:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > [SENSe:]PULSe:TIMing:TSTamp:AVERage?
[SENSe:]PULSe:TIMing:TSTamp:AVERage? <QueryRange>
[SENSe:]PULSe:TIMing:TSTamp:MAXimum? <QueryRange>
[SENSe:]PULSe:TIMing:TSTamp:MINimum? <QueryRange>
[SENSe:]PULSe:TIMing:TSTamp:SDEViation? <QueryRange>

Returns the timestamp for the phase deviation over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:DCYCle?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:DCYCle?
SENSe:TRACe:MEASurement:PULSe:DCYCle?

Query the duty cycle values in percent from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:PULSe:DCYCle[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:DCYCle[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:DCYCle[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:DCYCle:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:DCYCle:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:DCYCle:SDEViation? <arg0>

Query the duty cycle values in percent from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:DURation?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:DURation?
SENSe:TRACe:MEASurement:PULSe:DURation?

Query the pulse width values in seconds from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:PULSe:DURation[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:DURation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:DURation[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:DURation:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:DURation:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:DURation:SDEViation? <arg0>

Query the pulse width values in seconds from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:DUTRatio?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:DUTRatio?
SENSe:TRACe:MEASurement:PULSe:DUTRatio?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:DUTRatio[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:DUTRatio[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:DUTRatio[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:DUTRatio:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:DUTRatio:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:DUTRatio:SDEViation? <arg0>

Query the duty ratio values (unitless) from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:PERiod?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:PERiod?
SENSe:TRACe:MEASurement:PULSe:PERiod?

Query the pulse repetion interval values in seconds from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:PULSe:PERiod[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:PERiod[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PERiod[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:PERiod:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PERiod:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PERiod:SDEViation? <arg0>

Query the pulse repetion interval values in seconds from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:RATE?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:RATE?
SENSe:TRACe:MEASurement:PULSe:RATE?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:RATE[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:RATE[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:RATE[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:RATE:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:RATE:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:RATE:SDEViation? <arg0>

Query the pulse repetion rate (frequency) values in Hz from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:SEParation?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:SEParation?
SENSe:TRACe:MEASurement:PULSe:SEParation?

Query the pulse seüaration (off time) values in seconds from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:PULSe:SEParation[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:SEParation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:SEParation[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:SEParation:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:SEParation:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:SEParation:SDEViation? <arg0>

Query the pulse seüaration (off time) values in seconds from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:TIME?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:TIME?
SENSe:TRACe:MEASurement:PULSe:TIME?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:TIME[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:PULSe:TIME[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:TIME[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:TIME:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:TIME:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:TIME:SDEViation? <arg0>

Query the pulse timestamp values in seconds from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:TRANsition:NEGative:DURation?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:TRANsition:NEGative:DURation?
SENSe:TRACe:MEASurement:TRANsition:NEGative:DURation?

Query the fall time values in seconds from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:TRANsition:POSitive:DURation?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:TRANsition:POSitive:DURation?
SENSe:TRACe:MEASurement:TRANsition:POSitive:DURation?

Query the rise time values in seconds from the current capture.

Usage: Query only


SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling?
Usage: Query only


SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Timing Parameters > SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling[:AVERage]?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling:MAXimum? <arg0>
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling:MINimum? <arg0>
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling:SDEViation? <arg0>

Query the settling time values in seconds from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


Retrieving Frequency Parameters

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters
Retrieving Frequency Parameters

The following commands return the calculated pulse parameters.

For details on the individual parameters see "Frequency Parameters".

The [SENS:]TRAC:MEAS:PULS... commands are maintained for compatibility reasons only. For new remote control programs, use the corresponding [SENS:]PULS:FREQ... commands instead.

List of Commands
[SENSe:]PULSe:FREQuency:CRATe?
[SENSe:]PULSe:FREQuency:CRATe:AVERage?
[SENSe:]PULSe:FREQuency:CRATe:MAXimum?
[SENSe:]PULSe:FREQuency:CRATe:MINimum?
[SENSe:]PULSe:FREQuency:CRATe:SDEViation?
[SENSe:]PULSe:FREQuency:DEViation?
[SENSe:]PULSe:FREQuency:DEViation:AVERage?
[SENSe:]PULSe:FREQuency:DEViation:MAXimum?
[SENSe:]PULSe:FREQuency:DEViation:MINimum?
[SENSe:]PULSe:FREQuency:DEViation:SDEViation?
[SENSe:]PULSe:FREQuency:PERRor?
[SENSe:]PULSe:FREQuency:PERRor:AVERage?
[SENSe:]PULSe:FREQuency:PERRor:MAXimum?
[SENSe:]PULSe:FREQuency:PERRor:MINimum?
[SENSe:]PULSe:FREQuency:PERRor:SDEViation?
[SENSe:]PULSe:FREQuency:POINt?
[SENSe:]PULSe:FREQuency:POINt:AVERage?
[SENSe:]PULSe:FREQuency:POINt:MAXimum?
[SENSe:]PULSe:FREQuency:POINt:MINimum?
[SENSe:]PULSe:FREQuency:POINt:SDEViation?
[SENSe:]PULSe:FREQuency:PPFRequency?
[SENSe:]PULSe:FREQuency:PPFRequency:AVERage?
[SENSe:]PULSe:FREQuency:PPFRequency:MAXimum?
[SENSe:]PULSe:FREQuency:PPFRequency:MINimum?
[SENSe:]PULSe:FREQuency:PPFRequency:SDEViation?
[SENSe:]PULSe:FREQuency:RERRor?
[SENSe:]PULSe:FREQuency:RERRor:AVERage?
[SENSe:]PULSe:FREQuency:RERRor:MAXimum?
[SENSe:]PULSe:FREQuency:RERRor:MINimum?
[SENSe:]PULSe:FREQuency:RERRor:SDEViation?
SENSe:TRACe:MEASurement:PULSe:FRDeviation?
SENSe:TRACe:MEASurement:PULSe:FRDeviation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:FRDeviation:MAXimum?
SENSe:TRACe:MEASurement:PULSe:FRDeviation:MINimum?
SENSe:TRACe:MEASurement:PULSe:FRDeviation:SDEViation?
SENSe:TRACe:MEASurement:PULSe:FREQuency?
SENSe:TRACe:MEASurement:PULSe:FREQuency[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:FREQuency:MAXimum?
SENSe:TRACe:MEASurement:PULSe:FREQuency:MINimum?
SENSe:TRACe:MEASurement:PULSe:FREQuency:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PFReqerror?
SENSe:TRACe:MEASurement:PULSe:PFReqerror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PFReqerror:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PFReqerror:MINimum?
SENSe:TRACe:MEASurement:PULSe:PFReqerror:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PPFRequency?
SENSe:TRACe:MEASurement:PULSe:PPFRequency[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PPFRequency:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PPFRequency:MINimum?
SENSe:TRACe:MEASurement:PULSe:PPFRequency:SDEViation?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror:MAXimum?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror:MINimum?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror:SDEViation?


[SENSe:]PULSe:FREQuency:CRATe?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:CRATe?
[SENSe:]PULSe:FREQuency:CRATe? <QueryRange>

Returns the chirp rate (per μs) for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Chirp Rate"


[SENSe:]PULSe:FREQuency:CRATe:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:CRATe:AVERage?
[SENSe:]PULSe:FREQuency:CRATe:AVERage? <QueryRange>
[SENSe:]PULSe:FREQuency:CRATe:MAXimum? <QueryRange>
[SENSe:]PULSe:FREQuency:CRATe:MINimum? <QueryRange>
[SENSe:]PULSe:FREQuency:CRATe:SDEViation? <QueryRange>

Returns the statistical value for the chirp rate (per μs) over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:FREQuency:DEViation?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:DEViation?
[SENSe:]PULSe:FREQuency:DEViation? <QueryRange>

Returns the frequency at the measurement point for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Frequency Deviation"


[SENSe:]PULSe:FREQuency:DEViation:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:DEViation:AVERage?
[SENSe:]PULSe:FREQuency:DEViation:AVERage? <QueryRange>
[SENSe:]PULSe:FREQuency:DEViation:MAXimum? <QueryRange>
[SENSe:]PULSe:FREQuency:DEViation:MINimum? <QueryRange>
[SENSe:]PULSe:FREQuency:DEViation:SDEViation? <QueryRange>

Returns the statistical value for the chirp rate (per μs) over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:FREQuency:PERRor?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:PERRor?
[SENSe:]PULSe:FREQuency:PERRor? <QueryRange>

Returns the peak frequency error for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Frequency Error (Peak)"


[SENSe:]PULSe:FREQuency:PERRor:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:PERRor:AVERage?
[SENSe:]PULSe:FREQuency:PERRor:AVERage? <QueryRange>
[SENSe:]PULSe:FREQuency:PERRor:MAXimum? <QueryRange>
[SENSe:]PULSe:FREQuency:PERRor:MINimum? <QueryRange>
[SENSe:]PULSe:FREQuency:PERRor:SDEViation? <QueryRange>

Returns the statistical value for the peak frequency error over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:FREQuency:POINt?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:POINt?
[SENSe:]PULSe:FREQuency:POINt? <QueryRange>

Returns the frequency at the measurement point for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Frequency"


[SENSe:]PULSe:FREQuency:POINt:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:POINt:AVERage?
[SENSe:]PULSe:FREQuency:POINt:AVERage? <QueryRange>
[SENSe:]PULSe:FREQuency:POINt:MAXimum? <QueryRange>
[SENSe:]PULSe:FREQuency:POINt:MINimum? <QueryRange>
[SENSe:]PULSe:FREQuency:POINt:SDEViation? <QueryRange>

Returns the statistical value for the phase deviation over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:FREQuency:PPFRequency?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:PPFRequency?
[SENSe:]PULSe:FREQuency:PPFRequency? <QueryRange>

Returns the Pulse-Pulse Frequency Difference for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Pulse-Pulse Frequency Difference"


[SENSe:]PULSe:FREQuency:PPFRequency:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:PPFRequency:AVERage?
[SENSe:]PULSe:FREQuency:PPFRequency:AVERage? <QueryRange>
[SENSe:]PULSe:FREQuency:PPFRequency:MAXimum? <QueryRange>
[SENSe:]PULSe:FREQuency:PPFRequency:MINimum? <QueryRange>
[SENSe:]PULSe:FREQuency:PPFRequency:SDEViation? <QueryRange>

Returns the statistical value for the Pulse-Pulse Frequency Difference over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:FREQuency:RERRor?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:RERRor?
[SENSe:]PULSe:FREQuency:RERRor? <QueryRange>

Returns the Frequency Error (RMS) for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Frequency Error (RMS)"


[SENSe:]PULSe:FREQuency:RERRor:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > [SENSe:]PULSe:FREQuency:RERRor:AVERage?
[SENSe:]PULSe:FREQuency:RERRor:AVERage? <QueryRange>
[SENSe:]PULSe:FREQuency:RERRor:MAXimum? <QueryRange>
[SENSe:]PULSe:FREQuency:RERRor:MINimum? <QueryRange>
[SENSe:]PULSe:FREQuency:RERRor:SDEViation? <QueryRange>

Returns the statistical value for the Frequency Error (RMS) over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:FRDeviation?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > SENSe:TRACe:MEASurement:PULSe:FRDeviation?
SENSe:TRACe:MEASurement:PULSe:FRDeviation?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:FRDeviation[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > SENSe:TRACe:MEASurement:PULSe:FRDeviation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:FRDeviation[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:FRDeviation:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:FRDeviation:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:FRDeviation:SDEViation? <arg0>

Query the frequency deviation (over "measurement range") values in Hz from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:FREQuency?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > SENSe:TRACe:MEASurement:PULSe:FREQuency?
SENSe:TRACe:MEASurement:PULSe:FREQuency?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:FREQuency[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > SENSe:TRACe:MEASurement:PULSe:FREQuency[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:FREQuency[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:FREQuency:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:FREQuency:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:FREQuency:SDEViation? <arg0>

Query the pulse frequency (at "measurement point") values in Hz from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:PFReqerror?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > SENSe:TRACe:MEASurement:PULSe:PFReqerror?
SENSe:TRACe:MEASurement:PULSe:PFReqerror?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:PFReqerror[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > SENSe:TRACe:MEASurement:PULSe:PFReqerror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PFReqerror[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:PFReqerror:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PFReqerror:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PFReqerror:SDEViation? <arg0>

Query the peak frequency error (over "measurement range") values in Hz from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:PPFRequency?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > SENSe:TRACe:MEASurement:PULSe:PPFRequency?
SENSe:TRACe:MEASurement:PULSe:PPFRequency?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:PPFRequency[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > SENSe:TRACe:MEASurement:PULSe:PPFRequency[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PPFRequency[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:PPFRequency:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PPFRequency:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PPFRequency:SDEViation? <arg0>

Query the pulse-pulse frequency (at "measurement point") difference values in Hz from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:RMSFreqerror?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > SENSe:TRACe:MEASurement:PULSe:RMSFreqerror?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:RMSFreqerror[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Frequency Parameters > SENSe:TRACe:MEASurement:PULSe:RMSFreqerror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror:SDEViation? <arg0>

Query the RMS frequency error (over "measurement range") values in Hz from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


Retrieving Phase Parameters

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters
Retrieving Phase Parameters

The following commands return the calculated pulse parameters.

For details on the individual parameters see "Phase Parameters".

The [SENS:]TRAC:MEAS:PULS:PHAS... commands are maintained for compatibility reasons only. For new remote control programs, use the corresponding [SENS:]PULS:PHAS... commands instead.

List of Commands
[SENSe:]PULSe:PHASe:DEViation?
[SENSe:]PULSe:PHASe:DEViation:AVERage?
[SENSe:]PULSe:PHASe:DEViation:MAXimum?
[SENSe:]PULSe:PHASe:DEViation:MINimum?
[SENSe:]PULSe:PHASe:DEViation:SDEViation?
[SENSe:]PULSe:PHASe:PERRor?
[SENSe:]PULSe:PHASe:PERRor:AVERage?
[SENSe:]PULSe:PHASe:PERRor:MAXimum?
[SENSe:]PULSe:PHASe:PERRor:MINimum?
[SENSe:]PULSe:PHASe:PERRor:SDEViation?
[SENSe:]PULSe:PHASe:POINt?
[SENSe:]PULSe:PHASe:POINt:AVERage?
[SENSe:]PULSe:PHASe:POINt:MAXimum?
[SENSe:]PULSe:PHASe:POINt:MINimum?
[SENSe:]PULSe:PHASe:POINt:SDEViation?
[SENSe:]PULSe:PHASe:PPPHase?
[SENSe:]PULSe:PHASe:PPPHase:AVERage?
[SENSe:]PULSe:PHASe:PPPHase:MAXimum?
[SENSe:]PULSe:PHASe:PPPHase:MINimum?
[SENSe:]PULSe:PHASe:PPPHase:SDEViation?
[SENSe:]PULSe:PHASe:RERRor?
[SENSe:]PULSe:PHASe:RERRor:AVERage?
[SENSe:]PULSe:PHASe:RERRor:MAXimum?
[SENSe:]PULSe:PHASe:RERRor:MINimum?
[SENSe:]PULSe:PHASe:RERRor:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PHASe?
SENSe:TRACe:MEASurement:PULSe:PHASe[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PHASe:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PHASe:MINimum?
SENSe:TRACe:MEASurement:PULSe:PHASe:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PHDeviation?
SENSe:TRACe:MEASurement:PULSe:PHDeviation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PHDeviation:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PHDeviation:MINimum?
SENSe:TRACe:MEASurement:PULSe:PHDeviation:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror:MINimum?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PPPHase?
SENSe:TRACe:MEASurement:PULSe:PPPHase[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PPPHase:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PPPHase:MINimum?
SENSe:TRACe:MEASurement:PULSe:PPPHase:SDEViation?
SENSe:TRACe:MEASurement:PULSe:RMSPherror?
SENSe:TRACe:MEASurement:PULSe:RMSPherror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:RMSPherror:MAXimum?
SENSe:TRACe:MEASurement:PULSe:RMSPherror:MINimum?
SENSe:TRACe:MEASurement:PULSe:RMSPherror:SDEViation?


[SENSe:]PULSe:PHASe:DEViation?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > [SENSe:]PULSe:PHASe:DEViation?
[SENSe:]PULSe:PHASe:DEViation? <QueryRange>

Returns the phase deviation for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Phase Deviation"


[SENSe:]PULSe:PHASe:DEViation:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > [SENSe:]PULSe:PHASe:DEViation:AVERage?
[SENSe:]PULSe:PHASe:DEViation:AVERage? <QueryRange>
[SENSe:]PULSe:PHASe:DEViation:MAXimum? <QueryRange>
[SENSe:]PULSe:PHASe:DEViation:MINimum? <QueryRange>
[SENSe:]PULSe:PHASe:DEViation:SDEViation? <QueryRange>

Returns the statistical value for the phase deviation over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:PHASe:PERRor?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > [SENSe:]PULSe:PHASe:PERRor?
[SENSe:]PULSe:PHASe:PERRor? <QueryRange>

Returns the peak phase error for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Phase Error (Peak)"


[SENSe:]PULSe:PHASe:PERRor:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > [SENSe:]PULSe:PHASe:PERRor:AVERage?
[SENSe:]PULSe:PHASe:PERRor:AVERage? <QueryRange>
[SENSe:]PULSe:PHASe:PERRor:MAXimum? <QueryRange>
[SENSe:]PULSe:PHASe:PERRor:MINimum? <QueryRange>
[SENSe:]PULSe:PHASe:PERRor:SDEViation? <QueryRange>

Returns the statistical value for the peak phase error over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:PHASe:POINt?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > [SENSe:]PULSe:PHASe:POINt?
[SENSe:]PULSe:PHASe:POINt? <QueryRange>

Returns the phase at the measurement point for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Phase"


[SENSe:]PULSe:PHASe:POINt:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > [SENSe:]PULSe:PHASe:POINt:AVERage?
[SENSe:]PULSe:PHASe:POINt:AVERage? <QueryRange>
[SENSe:]PULSe:PHASe:POINt:MAXimum? <QueryRange>
[SENSe:]PULSe:PHASe:POINt:MINimum? <QueryRange>
[SENSe:]PULSe:PHASe:POINt:SDEViation? <QueryRange>

Returns the statistical value for the phase at the measurement point over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:PHASe:PPPHase?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > [SENSe:]PULSe:PHASe:PPPHase?
[SENSe:]PULSe:PHASe:PPPHase? <QueryRange>

Returns the Pulse-Pulse Phase Difference for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Pulse-Pulse Phase Difference"


[SENSe:]PULSe:PHASe:PPPHase:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > [SENSe:]PULSe:PHASe:PPPHase:AVERage?
[SENSe:]PULSe:PHASe:PPPHase:AVERage? <QueryRange>
[SENSe:]PULSe:PHASe:PPPHase:MAXimum? <QueryRange>
[SENSe:]PULSe:PHASe:PPPHase:MINimum? <QueryRange>
[SENSe:]PULSe:PHASe:PPPHase:SDEViation? <QueryRange>

Returns the statistical value for the Pulse-Pulse Phase Difference over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


[SENSe:]PULSe:PHASe:RERRor?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > [SENSe:]PULSe:PHASe:RERRor?
[SENSe:]PULSe:PHASe:RERRor? <QueryRange>

Returns the phase error (RMS) for the specified pulse(s).

Query parameters:
<QueryRange> | SELected | CURRent | ALL SELected Currently selected pulse CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only
Manual operation: | See "Phase Error (RMS)"


[SENSe:]PULSe:PHASe:RERRor:AVERage?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > [SENSe:]PULSe:PHASe:RERRor:AVERage?
[SENSe:]PULSe:PHASe:RERRor:AVERage? <QueryRange>
[SENSe:]PULSe:PHASe:RERRor:MAXimum? <QueryRange>
[SENSe:]PULSe:PHASe:RERRor:MINimum? <QueryRange>
[SENSe:]PULSe:PHASe:RERRor:SDEViation? <QueryRange>

Returns the statistical value for the phase error (RMS) over the specified pulses.

Query parameters:
<QueryRange> | CURRent | ALL CURRent Detected pulses in the current capture buffer ALL All detected pulses in the entire measurement.
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:PHASe?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > SENSe:TRACe:MEASurement:PULSe:PHASe?
SENSe:TRACe:MEASurement:PULSe:PHASe?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:PHASe[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > SENSe:TRACe:MEASurement:PULSe:PHASe[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PHASe[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:PHASe:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PHASe:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PHASe:SDEViation? <arg0>

Query the pulse phase (at "measurement point") values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:PHDeviation?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > SENSe:TRACe:MEASurement:PULSe:PHDeviation?
SENSe:TRACe:MEASurement:PULSe:PHDeviation?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:PHDeviation[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > SENSe:TRACe:MEASurement:PULSe:PHDeviation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PHDeviation[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:PHDeviation:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PHDeviation:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PHDeviation:SDEViation? <arg0>

Query the phase deviation (over "measurement range") values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:PPHeqerror?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > SENSe:TRACe:MEASurement:PULSe:PPHeqerror?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:PPHeqerror[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > SENSe:TRACe:MEASurement:PULSe:PPHeqerror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:PPHeqerror:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PPHeqerror:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PPHeqerror:SDEViation? <arg0>

Query the phase peak error (over "measurement range") values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:PPPHase?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > SENSe:TRACe:MEASurement:PULSe:PPPHase?
SENSe:TRACe:MEASurement:PULSe:PPPHase?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:PPPHase[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > SENSe:TRACe:MEASurement:PULSe:PPPHase[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PPPHase[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:PPPHase:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PPPHase:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:PPPHase:SDEViation? <arg0>

Query the pulse-pulse phase (at "measurement point") difference values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


SENSe:TRACe:MEASurement:PULSe:RMSPherror?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > SENSe:TRACe:MEASurement:PULSe:RMSPherror?
SENSe:TRACe:MEASurement:PULSe:RMSPherror?
Usage: Query only


SENSe:TRACe:MEASurement:PULSe:RMSPherror[:AVERage]?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Retrieving Phase Parameters > SENSe:TRACe:MEASurement:PULSe:RMSPherror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:RMSPherror[:AVERage]? <arg0>
SENSe:TRACe:MEASurement:PULSe:RMSPherror:MAXimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:RMSPherror:MINimum? <arg0>
SENSe:TRACe:MEASurement:PULSe:RMSPherror:SDEViation? <arg0>

Query the RMS phase error (over "measurement range") values from the current capture.

Parameters:
<arg0> | SELected | CURRent | ALL
Usage: | Query only


Exporting Trace Results to an ASCII File

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Exporting Trace Results to an ASCII File
Exporting Trace Results to an ASCII File

Trace results can be exported to an ASCII file for further evaluation in other (external) applications.

List of Commands
FORMat[:DATA]
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes


FORMat[:DATA]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Exporting Trace Results to an ASCII File > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


FORMat:DEXPort:DSEParator

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Exporting Trace Results to an ASCII File > FORMat:DEXPort:DSEParator
FORMat:DEXPort:DSEParator <Separator>

This command selects the decimal separator for data exported in ASCII format.

Parameters:
<Separator>
COMMa

Uses a comma as decimal separator, e.g. 4,05.

POINt

Uses a point as decimal separator, e.g. 4.05.

*RST: *RST has no effect on the decimal separator. Default is POINt.
Example: FORM:DEXP:DSEP POIN

Sets the decimal point as separator.

Manual operation: See "Decimal Separator"


FORMat:DEXPort:HEADer

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Exporting Trace Results to an ASCII File > FORMat:DEXPort:HEADer
FORMat:DEXPort:HEADer <State>

If enabled, additional instrument and measurement settings are included in the header of the export file for result data. If disabled, only the pure result data from the selected traces and tables is exported.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Usage: SCPI confirmed
Manual operation: See "Include Instrument Measurement Settings"


FORMat:DEXPort:TRACes

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Exporting Trace Results to an ASCII File > FORMat:DEXPort:TRACes
FORMat:DEXPort:TRACes <Selection>

This command selects the data to be included in a data export file (see MMEMory:​STORe<n>:​TRACe).

Parameters:
<Selection>
SINGle

Only a single trace is selected for export, namely the one specified by the MMEMory:​STORe<n>:​TRACe command.

ALL

Selects all active traces and result tables (e.g. Result Summary, marker peak list etc.) in the current application for export to an ASCII file.

The <trace> parameter for the MMEMory:​STORe<n>:​TRACe command is ignored.

*RST: SINGle
Usage: SCPI confirmed
Manual operation: See "Export all Traces and all Table Results"


Exporting Table Results to an ASCII File

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Exporting Table Results to an ASCII File
Exporting Table Results to an ASCII File

Table results can be exported to an ASCII file for further evaluation in other (external) applications.

Useful commands for exporting table results described elsewhere:
  • FORMat:​DEXPort:​DSEParator
  • "Configuring the Statistics and Parameter Tables"
Remote commands exclusive to exporting table results
List of Commands
MMEMory:STORe<n>:TABLe


MMEMory:STORe<n>:TABLe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Exporting Table Results to an ASCII File > MMEMory:STORe<n>:TABLe
MMEMory:STORe<n>:TABLe <Columns>, <FileName>

This command exports result table data from the specified window to an ASCii file (.DAT).

For details on the file format see "Reference: ASCII File Export Format".

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<Columns>

Columns to be stored in file

SELected

Export only the selected (visible) table columns

ALL

Export all table columns (all possible measured parameters)

*RST: SEL
<FileName>

String containing the path and name of the target file.

Example: MMEM:STOR1:TABL SEL,'TEST.DAT'

Stores the selected columns from the result table in window 1 in the file TEST.DAT.

Example:

See "Programming Example: Pulse Measurement".

Example:

See "Programming Example: Pulse Measurement".

Usage: SCPI confirmed
Manual operation: See "Columns to Export"
See "Export Table to ASCII File"
See "Columns to Export"


Exporting I/Q Results to an iq-tar File

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Exporting I/Q Results to an iq-tar File
Exporting I/Q Results to an iq-tar File

The I/Q data results can be exported to an iq-tar file. For details see "Export Functions".

List of Commands
MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:STATe


MMEMory:STORe:IQ:COMMent

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Exporting I/Q Results to an iq-tar File > MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:COMMent <Comment>

This command adds a comment to a file that contains I/Q data.

Parameters:
<Comment> | String containing the comment.
Example: | MMEM:STOR:IQ:COMM 'Device test 1b' Creates a description for the export file. MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Stores I/Q data and the comment to the specified file.
Example: | See "Programming Example: Pulse Measurement".
Manual operation: | See "I/Q Export"


MMEMory:STORe:IQ:STATe

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Retrieving Results > Exporting I/Q Results to an iq-tar File > MMEMory:STORe:IQ:STATe
MMEMory:STORe:IQ:STATe 1, <FileName>

This command writes the captured I/Q data to a file.

The file extension is *.iq.tar. By default, the contents of the file are in 32-bit floating point format.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
1 |
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR:IQ:STAT 1, 'C:\R_S\Instr\user\data.iq.tar' Stores the captured I/Q data to the specified file.
Example: | See "Programming Example: Pulse Measurement".
Manual operation: | See "I/Q Export"


Working with Markers

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers
Working with Markers
Contents
  • Individual Marker Settings
  • General Marker Settings
  • Positioning Markers


Individual Marker Settings

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Individual Marker Settings
Individual Marker Settings
List of Commands
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<q>:Y?


CALCulate<n>:MARKer<m>:AOFF

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m>[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:MARKer<m>:X

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

The unit is either Hz (frequency domain) or s (time domain) or dB (statistics).

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"
See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "X-value"


CALCulate<n>:MARKer<m>:Y?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "Marker Table"


CALCulate<n>:DELTamarker:AOFF

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Individual Marker Settings > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>:MREF

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:MREF <Reference>

This command selects a reference marker for a delta marker other than marker 1.

The reference may be another marker or the fixed reference.

Parameters:
<Reference> | 1 to 16 Selects markers 1 to 16 as the reference. FIXed Selects the fixed reference as the reference.
Example: | CALC:DELT3:MREF 2 Specifies that the values of delta marker 3 are relative to marker 2.
Manual operation: | See "Reference Marker"


CALCulate<n>:DELTamarker<m>[:STATe]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:DELTamarker<m>:X

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Range: The value range and unit depend on the measurement and scale of the x-axis.
Example: CALC:DELT:X?

Outputs the absolute x-value of delta marker 1.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "X-value"


CALCulate<n>:DELTamarker<q>:Y?

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<q>:Y?
CALCulate<n>:DELTamarker<q>:Y?

This command moves a marker to a particular coordinate on the x-axis. If necessary, the command activates the marker.

Return values:
<Value> |
Usage: | Query only


General Marker Settings

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > General Marker Settings
General Marker Settings
List of Commands
DISPlay:MTABle


DISPlay:MTABle

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > General Marker Settings > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


Positioning Markers

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers
Positioning Markers
List of Commands
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]


CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

This command moves a delta marker to the next higher value.

The search includes only measurement values to the left of the current marker position.

Usage: Event


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

Usage: | Event
Manual operation: | See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

This command moves a delta marker to the next higher value.

The search includes only measurement values to the right of the current marker position.

Usage: Event


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:DELTamarker<m>:MINimum:LEFT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:LEFT

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: Event


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

Usage: | Event
Manual operation: | See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: Event


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:MARKer<m>:MAXimum:LEFT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:LEFT

This command moves a marker to the next lower peak.

The search includes only measurement values to the left of the current marker position.

Usage: Event


CALCulate<n>:MARKer<m>:MAXimum:NEXT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

Usage: | Event
Manual operation: | See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:RIGHt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:RIGHt

This command moves a marker to the next lower peak.

The search includes only measurement values to the right of the current marker position.

Usage: Event


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:MARKer<m>:MINimum:LEFT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:LEFT

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: Event


CALCulate<n>:MARKer<m>:MINimum:NEXT

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

Usage: | Event
Manual operation: | See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum:RIGHt

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:RIGHt

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: Event


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Working with Markers > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


Programming Example: Pulse Measurement

Pulse Measurements (R&S FSW-K6) > Remote Commands for Pulse Measurements > Programming Example: Pulse Measurement
Programming Example: Pulse Measurement

This example demonstrates how to perform a pulse measurement in a remote environment.

Note that some of the used commands may not be necessary as they define default values, but are included to demonstrate their use.

//----------- Preparing the measurement ------------
//Reset the instrument
*RST
//Activate the pulse measurement application
INST:SEL 'PULSE'

//-----------Configuring the measurement ------------
//Set the center frequency
FREQ:CENT 1GHz

// Set the filter, bandwidth, and implicitly the sample rate
SENS:BWID:DEM:TYPE GAUSS
SENS:BWID:DEM 80MHZ
SENS:SRAT?

//Configure the expected pulse:
//width between 1ms and 1.5ms, off time at least 0.5ms
SENS:TRAC:MEAS:DEF:DUR:AUTO OFF
SENS:TRAC:MEAS:DEF:DUR:MIN 1ms
SENS:TRAC:MEAS:DEF:DUR:MAX 1.5ms
SENS:TRAC:MEAS:DEF:DUR:OFF 0.5ms

//Assume amplitude droop
SENS:TRAC:MEAS:DEF:PULS:ADR ON
//Assume Linear FM modulation
SENS:TRAC:MEAS:DEF:PULS:MOD LFM
//Pulse starts with rising edge
SENS:TRAC:MEAS:DEF:PULS:PER LH
//Determine freq offset and chirp rate for each pulse automatically
SENS:TRAC:MEAS:DEF:FREQ:OFFS:AUTO ON
SENS:TRAC:MEAS:DEF:FREQ:RATE:AUTO ON

//Input from RF input connector
INP:SEL RF
//Alternatively: Input from I/Q data file
//INP:SEL FIQ
//INP:FILE:PATH 'C:\R_S\Instr\user\data.iq.tar'

//Configure a power trigger at -20dBm (pulse level - 10dB default attenuation)
TRIG:SOUR RFP
TRIG:LEV:RFP -20dBm
//Avoid triggering on overshoot:
//level must remain below trigger level at least 0.5ms
TRIG:DTIM 0.5ms

//Configure the conditions for pulse detection:
//max. 10 pulses, min. -30dB power level, 2dB hysteresis
DET:LIM ON
DET:LIM:COUN 10
DET:REF ABS
DET:THR -30dB
DET:HYST 2dB

//Configure how and which levels are used for pulse detection:
//mean level for top, power values in dBm, consider droop
//ripple calculated in first 5% of pulse top
SENS:TRAC:MEAS:ALG MEAN
SENS:TRAC:MEAS:DEF:AMPL:UNIT DBM
SENS:TRAC:MEAS:DEF:COMP:ADR ON
SENS:TRAC:MEAS:DEF:RIPP 5

// meas levels at 15,50,85% power
//in dB: -1.41, -6.02, -26.02
SENS:TRAC:MEAS:DEF:TRAN:HREF -1.41
SENS:TRAC:MEAS:DEF:TRAN:REF  -6.02
SENS:TRAC:MEAS:DEF:TRAN:LREF -26.02

//boundary calculated in top 5% = 0.26dB
SENS:TRAC:MEAS:DEF:BOUN:TOP 0.26

//Configure which point is used to determine pulse characteristics:
//0.1ms from top center, window 1ms
SENS:TRAC:MEAS:DEF:PULS:INST:REF CENT
SENS:TRAC:MEAS:DEF:PULS:INST 0.1ms
SENS:TRAC:MEAS:DEF:PULS:INST:AWIN 1ms

//Configure the range used for estimation: 0.1ms from either edge
SENS:TRAC:MEAS:DEF:PULS:EST:REF EDGE
SENS:TRAC:MEAS:DEF:PULS:EST:OFFS:LEFT 0.1ms
SENS:TRAC:MEAS:DEF:PULS:EST:OFFS:RIGH 0.1ms

//Configure the range for which individual pulse results are displayed:
//300us starting from left edge of pulse top
SENS:TRAC:MEAS:DEF:RRAN:REF RISE
SENS:TRAC:MEAS:DEF:RRAN:ALIG LEFT
SENS:TRAC:MEAS:DEF:RRAN:LENG 300us

//Configure data acquisition for 10ms
SWE:TIME 10ms

//------------- Configuring the results -------------------------------
//Result displays:
//upper row: (1)MagCapt (2)Pulse results (3)Pulse statistics
//bottom row: (4)Pulse magnitude (5)Pulse power dist vs occurance
//(6)Pulse power spectrum
LAY:REPL '1',MCAP
LAY:REPL '2',PRES
LAY:ADD:WIND? '2',RIGH,PST
LAY:REPL '4',PMAG
LAY:REPL '5',PDIS
CALC5:DIST:POW POIN,OCC
LAY:REPL '6',PSP
CALC6:PSP:POW POIN

//Configure magnitude capture: automatic scaling
DISP:WIND1:TRAC:Y:SCAL:AUTO ON

//Configure parameters in pulse results table:
//Freq.: freq. at meas point, pulse-pulse difference, freq.dev., freq. err peak
CALC2:TABL:FREQ:POIN ON
CALC2:TABL:FREQ:PPFR ON
CALC2:TABL:FREQ:DEV ON
CALC2:TABL:FREQ:PERR ON

//Phase: phase deviation
CALC2:TABL:PHAS:DEV ON

//Power: average ON, droop, pulse-pulse difference, amplitude
CALC2:TABL:POW:ON ON
CALC2:TABL:POW:ADR ON
CALC2:TABL:POW:PPR ON
CALC2:TABL:POW:AMPL ON

//Timing: settling time, pulse width
CALC2:TABL:TIM:SETT ON
CALC2:TABL:TIM:PWID ON

//Configure pulse statistics table - same par. as results table
CALC3:TABL:FREQ:POIN ON
CALC3:TABL:FREQ:PPFR ON
CALC3:TABL:FREQ:DEV ON
CALC3:TABL:FREQ:PERR ON
CALC3:TABL:PHAS:DEV ON
CALC3:TABL:POW:ON ON
CALC3:TABL:POW:ADR ON
CALC3:TABL:POW:PPR ON
CALC3:TABL:POW:AMPL ON
CALC3:TABL:TIM:SETT ON
CALC3:TABL:TIM:PWID ON

//Configure pulse magnitude:
//scaling is 25 dBm above and below pulse mid level
DISP:WIND4:TRAC:Y:SCAL:AUTO OFF
DISP:WIND4:TRAC:Y:SCAL:RPOS 50
DISP:WIND4:TRAC:Y:SCAL:RVAL 0
DISP:WIND4:TRAC:Y:SCAL:PDIV 2

//--------------Performing the Measurement-----
INIT:CONT OFF
//Selects single sweep mode.
INIT;*WAI
//Initiates a new measurement and waits until the sweep has finished.

//---------------Retrieving Results-------------
//Select pulse for individual pulse results: pulse 1
SENS:TRAC:MEAS:DEF:PULS:SEL 1
//    Determine pulse numbers in entire meas
SENS:PULS:NUMB? ALL
//    Determine pulse numbers in current capture buffer
SENS:PULS:NUMB? CURR

//Retrieve parameter results from results table (pulse 1)
SENS:PULS:FREQ:POIN? SEL
SENS:PULS:FREQ:PPFR? SEL
SENS:PULS:FREQ:DEV? SEL
SENS:PULS:FREQ:PERR? SEL
SENS:PULS:PHAS:DEV? SEL
SENS:PULS:POW:ON? SEL
SENS:PULS:POW:ADR? SEL
SENS:PULS:POW:PPR? SEL
SENS:PULS:POW:AMPL? SEL
SENS:PULS:TIM:SETT? SEL
SENS:PULS:TIM:PWID? SEL

//Retrieve pulse statistics (aver., min., max) for all pulses in entire meas
SENS:PULS:FREQ:POIN:AVER? ALL
SENS:PULS:FREQ:POIN:MIN? ALL
SENS:PULS:FREQ:POIN:MAX? ALL

SENS:PULS:FREQ:PPFR:AVER? ALL
SENS:PULS:FREQ:PPFR:MIN? ALL
SENS:PULS:FREQ:PPFR:MAX? ALL

SENS:PULS:FREQ:DEV:AVER? ALL
SENS:PULS:FREQ:DEV:MIN? ALL
SENS:PULS:FREQ:DEV:MAX? ALL

SENS:PULS:FREQ:PERR:AVER? ALL
SENS:PULS:FREQ:PERR:MIN? ALL
SENS:PULS:FREQ:PERR:MAX? ALL

SENS:PULS:PHAS:DEV:AVER? ALL
SENS:PULS:PHAS:DEV:MIN? ALL
SENS:PULS:PHAS:DEV:MAX? ALL

SENS:PULS:POW:ON:AVER? ALL
SENS:PULS:POW:ON:MIN? ALL
SENS:PULS:POW:ON:MAX? ALL

SENS:PULS:POW:ADR:AVER? ALL
SENS:PULS:POW:ADR:MIN? ALL
SENS:PULS:POW:ADR:MAX? ALL

SENS:PULS:POW:PPR:AVER? ALL
SENS:PULS:POW:PPR:MIN? ALL
SENS:PULS:POW:PPR:MAX? ALL

SENS:PULS:POW:AMPL:AVER? ALL
SENS:PULS:POW:AMPL:MIN? ALL
SENS:PULS:POW:AMPL:MAX? ALL

SENS:PULS:TIM:SETT:AVER? ALL
SENS:PULS:TIM:SETT:MIN? ALL
SENS:PULS:TIM:SETT:MAX? ALL

SENS:PULS:TIM:PWID:AVER? ALL
SENS:PULS:TIM:PWID:MIN? ALL
SENS:PULS:TIM:PWID:MAX? ALL

//Retrieve trace data for pulse magnitude (pulse 1)
//TRAC4:DATA? TRACe1
//TRAC4:DATA:X? TRACe1

//Export entire result table (all params) to an ASCII file
//MMEM:STOR2:TABL ALL,'C:\R_S\Instr\user\AllResults.dat'

//Store I/Q data for result range to an iq-tar file
//MMEM:STOR:IQ:COMM 'I/Q data for result range'
//MMEM:STOR:IQ:RANG RRAN
//MMEM:STOR:IQ:STAT 1,'C:\R_S\Instr\user\RRTestdata.iq.tar'


Annex: Reference

Pulse Measurements (R&S FSW-K6) > Annex: Reference
Annex: Reference
Contents
  • Reference: ASCII File Export Format
  • Effects of Large Gauss Filters
  • I/Q Data File Format (iq-tar)


Reference: ASCII File Export Format

Pulse Measurements (R&S FSW-K6) > Annex: Reference > Reference: ASCII File Export Format
Reference: ASCII File Export Format

Trace data can be exported to a file in ASCII format for further evaluation in other applications

The file consists of the header containing important scaling parameters and a data section containing the trace data.

Generally, the format of this ASCII file can be processed by spreadsheet calculation programs, e.g. MS-Excel. Different language versions of evaluation programs may require a different handling of the decimal point. Thus you can define the decimal separator to be used (decimal point or comma, see "Decimal Separator").

The data of the file header consist of three columns, each separated by a semicolon: parameter name; numeric value; basic unit. The data section starts with the two lines containing the measured parameter names and units, followed by the measured data in multiple columns (depending on measurement) which are also separated by a semicolon.

ASCII file format for table export
File contents | Description
Header data
Type;R&S FSW; | Instrument model
Version;5.00; | Firmware version
Date;01.Oct 2006; | Date of data set storage
Mode;PULSE; | Application
Center Freq;55000;Hz | Center frequency
Freq Offset;0;Hz | Frequency offset
Meas BW;10000000,Hz | Measurement Bandwidth
Filter Type;GAUS; | Measurement filter type can be Gaussian (GAUS) or flat (FLAT)
Ref Level;-30;dBm | Reference level
Level Offset;0;dB | Level offset
Rf Att;20;dB | Input attenuation
El Att;2.0;dB | Electrical attenuation
SWT;0.005;s | Sweep time (measurement time)
Sweep Count;20; | Number of sweeps set
Preamplifier;OFF | Preamplifier status
Top Pos.;CENT; | Top (100%) level position can be Edge (EDGE) or Center (CENT)
Top Alg.;MEDI | Top level measurement algorithm can be Median (MEDI) or Mean (MEAN)
Ripple Portion;50;% | Portion of pulse top where ripple is measured
High Level;90;%V | High (distal) threshold level
Mid Level;50;%V | Mid (mesial) threshold level
Low Level;10;%V | Low (proximal) threshold level
Boundary;3;%V | The (top +/-) boundary level
Point Ref;CENT; | Measurement point reference can be Rise (RISE), Center (CENT) or Fall (FALL)
Point Offset;0;s | Measurement point offset
Range Ref;CENT; | Measurement range reference can be Center (CENT) or Edge (EDGE)
Range Length;75;% | Measurement range length (only valid for “Range Ref:;CENT”)
Range Offset Rise;0;s | Measurement range offset from rising edge (only valid for “Range Ref:;EDGE”)
Range Offset Fall;0;s | Measurement range offset from falling edge (only valid for “Range Ref:;EDGE”)
Data section
Values; 1001; | Number of rows of measured values in the table
ID:;Pulse No.:;Rise Time:;… | Pulse parameter names
Unit;;s;… | Unit of pulse parameters
1;1;10.0e-9;… 2;2;10.1e-9;… 1;3;9.9e-9;… …;…;…;… | Measured values: <ID>, <Pulse No.>, <Param 1>, … , <Param N>


Effects of Large Gauss Filters

Pulse Measurements (R&S FSW-K6) > Annex: Reference > Effects of Large Gauss Filters
Effects of Large Gauss Filters

As an alternative to the nearly rectangular "flat" measurement filters, the R&S FSW also provides Gaussian filters. Gaussian filters have an optimized settling behavior, which avoids overshoot distortions in time domain data.

However, for Gaussian filters whose -3dB bandwidth is large compared to the maximum I/Q bandwidth, the ideal Gaussian filter shape would exceed the maximum I/Q bandwidth at its outer edges. Thus, the actual filter only follows the ideal Gaussian filter shape in the inner range of the set I/Q bandwidth. At a certain frequency offset it must deviate from the ideal Gauss filter and drop off faster.

Gaussian filters with small -3dB bandwidths (without active bandwidth extension options R&S FSW-B160/-B320/-B500)

For filter bandwidths of up to 10 MHz a sufficiently high attenuation occurs before the edge of the I/Q bandwidth range is reached (max. 80 MHz without the active bandwidth extension option R&S FSW-B160). These filters are truly Gaussian shaped.

Without the bandwidth extension options R&S FSW-B160/-B320/-B500 being active, filters with -3dB bandwidths larger than 10 MHz can follow the ideal filter shape only in the range from approximately -25 MHz to +25 MHz.

Gauss filters with small - 3dB bandwidths (without active R&S FSW-B160/-B320/-B500)
-3 dB BW | Max. freq. with Gaussian shape | Attenuation at max. freq. | Attenuation at I/Q range edge (±40 MHz)
40 MHz | +/-24 MHz | 4 dB | > 60 dB
28 MHz | +/-22 MHz | 7 dB | > 65 dB
18 MHz | +/-28 MHz | 29 dB | > 100 dB
10 MHz | +/-25 MHz | 75 dB | > 100 dB
Gauss filters with larger -3dB bandwidths (with active R&S FSW-B160/-B320/-B500)

With the bandwidth extension option R&S FSW-B160, -B320, or -B500 being active, all Gauss filters can follow the ideal filter shape in the range from approximately -80 MHz to +80 MHz. Thus, the deviation from the Gauss filter only has an effect for filter bandwidths > 40 MHz.

Gauss filters with larger bandwidths (with R&S FSW-B160)
-3 dB BW | Max. freq. with Gaussian shape | Attenuation at max. freq. | Attenuation at I/Q range edge (±100 MHz)
160 MHz | +/-80 MHz | 3 dB | > 83 dB
100 MHz | +/-80 MHz | 8 dB | > 88 dB
80 MHz | +/-80 MHz | 12 dB | > 92 dB
50 MHz | +/-80 MHz | 31 dB | > 100 dB
40 MHz | +/-80 MHz | 48 dB | > 100 dB
28 MHz | +/-80 MHz | 98 dB | > 100 dB


I/Q Data File Format (iq-tar)

Pulse Measurements (R&S FSW-K6) > Annex: Reference > I/Q Data File Format (iq-tar)
I/Q Data File Format (iq-tar)

I/Q data is packed in a file with the extension .iq.tar. An iq-tar file contains I/Q data in binary format together with meta information that describes the nature and the source of data, e.g. the sample rate. The objective of the iq-tar file format is to separate I/Q data from the meta information while still having both inside one file. In addition, the file format allows you to preview the I/Q data in a web browser, and allows you to include user-specific data.

The iq-tar container packs several files into a single .tar archive file. Files in .tar format can be unpacked using standard archive tools (see http://en.wikipedia.org/wiki/Comparison_of_file_archivers) available for most operating systems. The advantage of .tar files is that the archived files inside the .tar file are not changed (not compressed) and thus it is possible to read the I/Q data directly within the archive without the need to unpack (untar) the .tar file first.

Sample iq-tar files

If you have the optional R&S FSW VSA application (R&S FSW-K70), some sample iq-tar files are provided in the C:/R_S/Instr/user/vsa/DemoSignals directory on the R&S FSW.

Contained files
An iq-tar file must contain the following files:
  • I/Q parameter XML file, e.g. xyz.xml
    Contains meta information about the I/Q data (e.g. sample rate). The filename can be defined freely, but there must be only one single I/Q parameter XML file inside an iq-tar file.
  • I/Q data binary file, e.g. xyz.complex.float32
    Contains the binary I/Q data of all channels. There must be only one single I/Q data binary file inside an iq-tar file.
Optionally, an iq-tar file can contain the following file:
  • I/Q preview XSLT file, e.g. open_IqTar_xml_file_in_web_browser.xslt
    Contains a stylesheet to display the I/Q parameter XML file and a preview of the I/Q data in a web browser.
    A sample stylesheet is available at http://www.rohde-schwarz.com/file/open_IqTar_xml_file_in_web_browser.xslt.
Contents
  • I/Q Parameter XML File Specification
  • I/Q Data Binary File


I/Q Parameter XML File Specification

Pulse Measurements (R&S FSW-K6) > Annex: Reference > I/Q Data File Format (iq-tar) > I/Q Parameter XML File Specification
I/Q Parameter XML File Specification

The content of the I/Q parameter XML file must comply with the XML schema RsIqTar.xsd available at: http://www.rohde-schwarz.com/file/RsIqTar.xsd.

In particular, the order of the XML elements must be respected, i.e. iq-tar uses an "ordered XML schema". For your own implementation of the iq-tar file format make sure to validate your XML file against the given schema.

The following example shows an I/Q parameter XML file. The XML elements and attributes are explained in the following sections.

Sample I/Q parameter XML file: xyz.xml
<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/xsl"
href="open_IqTar_xml_file_in_web_browser.xslt"?>
<RS_IQ_TAR_FileFormat fileFormatVersion="1"
xsi:noNamespaceSchemaLocation="RsIqTar.xsd"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <Name>FSV-K10</Name>
  <Comment>Here is a comment</Comment>
  <DateTime>2011-01-24T14:02:49</DateTime>
  <Samples>68751</Samples>
  <Clock unit="Hz">6.5e+006</Clock>
  <Format>complex</Format>
  <DataType>float32</DataType>
  <ScalingFactor unit="V">1</ScalingFactor>
  <NumberOfChannels>1</NumberOfChannels>
<DataFilename>xyz.complex.float32</DataFilename>
<UserData>
  <UserDefinedElement>Example</UserDefinedElement>
</UserData>
  <PreviewData>...</PreviewData>
</RS_IQ_TAR_FileFormat>

Element

Description

RS_IQ_TAR_FileFormat

The root element of the XML file. It must contain the attribute fileFormatVersion that contains the number of the file format definition. Currently, fileFormatVersion "2" is used.

Name

Optional: describes the device or application that created the file.

Comment

Optional: contains text that further describes the contents of the file.

DateTime

Contains the date and time of the creation of the file. Its type is xs:dateTime (see RsIqTar.xsd).

Samples

Contains the number of samples of the I/Q data. For multi-channel signals all channels have the same number of samples. One sample can be:

  • A complex number represented as a pair of I and Q values
  • A complex number represented as a pair of magnitude and phase values
  • A real number represented as a single real value

See also Format element.

Clock

Contains the clock frequency in Hz, i.e. the sample rate of the I/Q data. A signal generator typically outputs the I/Q data at a rate that equals the clock frequency. If the I/Q data was captured with a signal analyzer, the signal analyzer used the clock frequency as the sample rate. The attribute unit must be set to "Hz".

Format

Specifies how the binary data is saved in the I/Q data binary file (see DataFilename element). Every sample must be in the same format. The format can be one of the following:

  • complex: Complex number in cartesian format, i.e. I and Q values interleaved. I and Q are unitless
  • real: Real number (unitless)
  • polar: Complex number in polar format, i.e. magnitude (unitless) and phase (rad) values interleaved. Requires DataType = float32 or float64

DataType

Specifies the binary format used for samples in the I/Q data binary file (see DataFilename element and "I/Q Data Binary File"). The following data types are allowed:

  • int8: 8 bit signed integer data
  • int16: 16 bit signed integer data
  • int32: 32 bit signed integer data
  • float32: 32 bit floating point data (IEEE 754)
  • float64: 64 bit floating point data (IEEE 754)

ScalingFactor

Optional: describes how the binary data can be transformed into values in the unit Volt. The binary I/Q data itself has no unit. To get an I/Q sample in the unit Volt the saved samples have to be multiplied by the value of the ScalingFactor. For polar data only the magnitude value has to be multiplied. For multi-channel signals the ScalingFactor must be applied to all channels.

The attribute unit must be set to "V".

The ScalingFactor must be > 0. If the ScalingFactor element is not defined, a value of 1 V is assumed.

NumberOfChannels

Optional: specifies the number of channels, e.g. of a MIMO signal, contained in the I/Q data binary file. For multi-channels, the I/Q samples of the channels are expected to be interleaved within the I/Q data file (see "I/Q Data Binary File"). If the NumberOfChannels element is not defined, one channel is assumed.

DataFilename

Contains the filename of the I/Q data binary file that is part of the iq-tar file.

It is recommended that the filename uses the following convention:

<xyz>.<Format>.<Channels>ch.<Type>
  • <xyz> = a valid Windows file name
  • <Format> = complex, polar or real (see Format element)
  • <Channels> = Number of channels (see NumberOfChannels element)
  • <Type> = float32, float64, int8, int16, int32 or int64 (see DataType element)
Examples:
  • xyz.complex.1ch.float32
  • xyz.polar.1ch.float64
  • xyz.real.1ch.int16
  • xyz.complex.16ch.int8

UserData

Optional: contains user, application or device-specific XML data which is not part of the iq-tar specification. This element can be used to store additional information, e.g. the hardware configuration. User data must be valid XML content.

PreviewData

Optional: contains further XML elements that provide a preview of the I/Q data. The preview data is determined by the routine that saves an iq-tar file (e.g. R&S FSW). For the definition of this element refer to the RsIqTar.xsd schema. Note that the preview can be only displayed by current web browsers that have JavaScript enabled and if the XSLT stylesheet open_IqTar_xml_file_in_web_browser.xslt is available.

Example: ScalingFactor

Data stored as int16 and a desired full scale voltage of 1 V

ScalingFactor = 1 V / maximum int16 value = 1 V / 215 = 3.0517578125e-5 V

Scaling Factor | Numerical value | Numerical value x ScalingFactor
Minimum (negative) int16 value | - 215 = - 32768 | -1 V
Maximum (positive) int16 value | 215-1= 32767 | 0.999969482421875 V
Example: PreviewData in XML
<PreviewData>
    <ArrayOfChannel length="1">
      <Channel>
        <PowerVsTime>
          <Min>
            <ArrayOfFloat length="256">
              <float>-134</float>
              <float>-142</float>
              ...
              <float>-140</float>
            </ArrayOfFloat>
          </Min>
          <Max>
            <ArrayOfFloat length="256">
              <float>-70</float>
              <float>-71</float>
              ...
              <float>-69</float>
            </ArrayOfFloat>
          </Max>
        </PowerVsTime>
        <Spectrum>
          <Min>
            <ArrayOfFloat length="256">
              <float>-133</float>
              <float>-111</float>
              ...
              <float>-111</float>
            </ArrayOfFloat>
          </Min>
          <Max>
            <ArrayOfFloat length="256">
              <float>-67</float>
              <float>-69</float>
              ...
              <float>-70</float>
              <float>-69</float>
            </ArrayOfFloat>
          </Max>
        </Spectrum>
        <IQ>
          <Histogram width="64" height="64">0123456789...0</Histogram>
        </IQ>
      </Channel>
    </ArrayOfChannel>
  </PreviewData>


I/Q Data Binary File

Pulse Measurements (R&S FSW-K6) > Annex: Reference > I/Q Data File Format (iq-tar) > I/Q Data Binary File
I/Q Data Binary File

The I/Q data is saved in binary format according to the format and data type specified in the XML file (see Format element and DataType element). To allow reading and writing of streamed I/Q data, all data is interleaved, i.e. complex values are interleaved pairs of I and Q values and multi-channel signals contain interleaved (complex) samples for channel 0, channel 1, channel 2 etc. If the NumberOfChannels element is not defined, one channel is presumed.

Example: Element order for real data (1 channel)
I[0],                         // Real sample 0
I[1],                         // Real sample 1
I[2],                         // Real sample 2
...
Example: Element order for complex cartesian data (1 channel)
I[0], Q[0],                   // Real and imaginary part of complex sample 0
I[1], Q[1],                   // Real and imaginary part of complex sample 1
I[2], Q[2],                   // Real and imaginary part of complex sample 2
...
Example: Element order for complex polar data (1 channel)
Mag[0], Phi[0],               // Magnitude and phase part of complex sample 0
Mag[1], Phi[1],               // Magnitude and phase part of complex sample 1
Mag[2], Phi[2],               // Magnitude and phase part of complex sample 2
...
Example: Element order for complex cartesian data (3 channels)

Complex data: I[channel no][time index], Q[channel no][time index]

I[0][0], Q[0][0],            // Channel 0, Complex sample 0
I[1][0], Q[1][0],            // Channel 1, Complex sample 0
I[2][0], Q[2][0],            // Channel 2, Complex sample 0

I[0][1], Q[0][1],            // Channel 0, Complex sample 1
I[1][1], Q[1][1],            // Channel 1, Complex sample 1
I[2][1], Q[2][1],            // Channel 2, Complex sample 1

I[0][2], Q[0][2],            // Channel 0, Complex sample 2
I[1][2], Q[1][2],            // Channel 1, Complex sample 2
I[2][2], Q[2][2],            // Channel 2, Complex sample 2
...
Example: Element order for complex cartesian data (1 channel)

This example demonstrates how to store complex cartesian data in float32 format using MATLAB®.

% Save vector of complex cartesian I/Q data, i.e. iqiqiq...
N = 100
iq = randn(1,N)+1j*randn(1,N)
fid = fopen('xyz.complex.float32','w');
for k=1:length(iq)
  fwrite(fid,single(real(iq(k))),'float32');
  fwrite(fid,single(imag(iq(k))),'float32');
end
fclose(fid)


List of Remote Commands (Pulse)

Pulse Measurements (R&S FSW-K6) > List of Remote Commands (Pulse)
List of Remote Commands (Pulse)
[SENSe:][STATistic<n>:]TYPE
[SENSe:][WINDow<n>:]DETector<t>[:FUNCtion]:AUTO
[SENSe:][WINDow<n>:]DETector<trace>[:FUNCtion]
[SENSe:]AVERage:COUNt
[SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]BANDwidth:DEMod
[SENSe:]BANDwidth|BWIDth:DEMod:TYPE
[SENSe:]BWIDth:DEMod
[SENSe:]CORRection:CVL:BAND
[SENSe:]CORRection:CVL:BIAS
[SENSe:]CORRection:CVL:CATAlog?
[SENSe:]CORRection:CVL:CLEAr
[SENSe:]CORRection:CVL:COMMent
[SENSe:]CORRection:CVL:DATA
[SENSe:]CORRection:CVL:HARMonic
[SENSe:]CORRection:CVL:MIXer
[SENSe:]CORRection:CVL:PORTs
[SENSe:]CORRection:CVL:SELect
[SENSe:]CORRection:CVL:SNUMber
[SENSe:]DETect:HYSTeresis
[SENSe:]DETect:LIMit
[SENSe:]DETect:LIMit:COUNt
[SENSe:]DETect:REFerence
[SENSe:]DETect:THReshold
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet
[SENSe:]MIXer:BIAS:HIGH
[SENSe:]MIXer:BIAS[:LOW]
[SENSe:]MIXer:FREQuency:HANDover
[SENSe:]MIXer:FREQuency:STARt?
[SENSe:]MIXer:FREQuency:STOP?
[SENSe:]MIXer:HARMonic:BAND:PRESet
[SENSe:]MIXer:HARMonic:BAND[:VALue]
[SENSe:]MIXer:HARMonic:HIGH:STATe
[SENSe:]MIXer:HARMonic:HIGH[:VALue]
[SENSe:]MIXer:HARMonic:TYPE
[SENSe:]MIXer:HARMonic[:LOW]
[SENSe:]MIXer:LOPower
[SENSe:]MIXer:LOSS:HIGH
[SENSe:]MIXer:LOSS:TABLe:HIGH
[SENSe:]MIXer:LOSS:TABLe[:LOW]
[SENSe:]MIXer:LOSS[:LOW]
[SENSe:]MIXer:PORTs
[SENSe:]MIXer:RFOVerrange[:STATe]
[SENSe:]MIXer:SIGNal
[SENSe:]MIXer:THReshold
[SENSe:]MIXer[:STATe]
[SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PULSe:FREQuency:CRATe:AVERage?
[SENSe:]PULSe:FREQuency:CRATe:MAXimum?
[SENSe:]PULSe:FREQuency:CRATe:MINimum?
[SENSe:]PULSe:FREQuency:CRATe:SDEViation?
[SENSe:]PULSe:FREQuency:CRATe?
[SENSe:]PULSe:FREQuency:DEViation:AVERage?
[SENSe:]PULSe:FREQuency:DEViation:MAXimum?
[SENSe:]PULSe:FREQuency:DEViation:MINimum?
[SENSe:]PULSe:FREQuency:DEViation:SDEViation?
[SENSe:]PULSe:FREQuency:DEViation?
[SENSe:]PULSe:FREQuency:PERRor:AVERage?
[SENSe:]PULSe:FREQuency:PERRor:MAXimum?
[SENSe:]PULSe:FREQuency:PERRor:MINimum?
[SENSe:]PULSe:FREQuency:PERRor:SDEViation?
[SENSe:]PULSe:FREQuency:PERRor?
[SENSe:]PULSe:FREQuency:POINt:AVERage?
[SENSe:]PULSe:FREQuency:POINt:MAXimum?
[SENSe:]PULSe:FREQuency:POINt:MINimum?
[SENSe:]PULSe:FREQuency:POINt:SDEViation?
[SENSe:]PULSe:FREQuency:POINt?
[SENSe:]PULSe:FREQuency:PPFRequency:AVERage?
[SENSe:]PULSe:FREQuency:PPFRequency:MAXimum?
[SENSe:]PULSe:FREQuency:PPFRequency:MINimum?
[SENSe:]PULSe:FREQuency:PPFRequency:SDEViation?
[SENSe:]PULSe:FREQuency:PPFRequency?
[SENSe:]PULSe:FREQuency:RERRor:AVERage?
[SENSe:]PULSe:FREQuency:RERRor:MAXimum?
[SENSe:]PULSe:FREQuency:RERRor:MINimum?
[SENSe:]PULSe:FREQuency:RERRor:SDEViation?
[SENSe:]PULSe:FREQuency:RERRor?
[SENSe:]PULSe:ID?
[SENSe:]PULSe:NUMBer?
[SENSe:]PULSe:PHASe:DEViation:AVERage?
[SENSe:]PULSe:PHASe:DEViation:MAXimum?
[SENSe:]PULSe:PHASe:DEViation:MINimum?
[SENSe:]PULSe:PHASe:DEViation:SDEViation?
[SENSe:]PULSe:PHASe:DEViation?
[SENSe:]PULSe:PHASe:PERRor:AVERage?
[SENSe:]PULSe:PHASe:PERRor:MAXimum?
[SENSe:]PULSe:PHASe:PERRor:MINimum?
[SENSe:]PULSe:PHASe:PERRor:SDEViation?
[SENSe:]PULSe:PHASe:PERRor?
[SENSe:]PULSe:PHASe:POINt:AVERage?
[SENSe:]PULSe:PHASe:POINt:MAXimum?
[SENSe:]PULSe:PHASe:POINt:MINimum?
[SENSe:]PULSe:PHASe:POINt:SDEViation?
[SENSe:]PULSe:PHASe:POINt?
[SENSe:]PULSe:PHASe:PPPHase:AVERage?
[SENSe:]PULSe:PHASe:PPPHase:MAXimum?
[SENSe:]PULSe:PHASe:PPPHase:MINimum?
[SENSe:]PULSe:PHASe:PPPHase:SDEViation?
[SENSe:]PULSe:PHASe:PPPHase?
[SENSe:]PULSe:PHASe:RERRor:AVERage?
[SENSe:]PULSe:PHASe:RERRor:MAXimum?
[SENSe:]PULSe:PHASe:RERRor:MINimum?
[SENSe:]PULSe:PHASe:RERRor:SDEViation?
[SENSe:]PULSe:PHASe:RERRor?
[SENSe:]PULSe:POWer:ADRoop:DB:AVERage?
[SENSe:]PULSe:POWer:ADRoop:DB:MAXimum?
[SENSe:]PULSe:POWer:ADRoop:DB:MINimum?
[SENSe:]PULSe:POWer:ADRoop:DB:SDEViation?
[SENSe:]PULSe:POWer:ADRoop:DB?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:AVERage?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:MAXimum?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:MINimum?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]:SDEViation?
[SENSe:]PULSe:POWer:ADRoop[:PERCent]?
[SENSe:]PULSe:POWer:AMPLitude:AVERage?
[SENSe:]PULSe:POWer:AMPLitude:MAXimum?
[SENSe:]PULSe:POWer:AMPLitude:MINimum?
[SENSe:]PULSe:POWer:AMPLitude:SDEViation?
[SENSe:]PULSe:POWer:AMPLitude?
[SENSe:]PULSe:POWer:AVG:AVERage?
[SENSe:]PULSe:POWer:AVG:MAXimum?
[SENSe:]PULSe:POWer:AVG:MINimum?
[SENSe:]PULSe:POWer:AVG:SDEViation?
[SENSe:]PULSe:POWer:AVG?
[SENSe:]PULSe:POWer:BASE:AVERage?
[SENSe:]PULSe:POWer:BASE:MAXimum?
[SENSe:]PULSe:POWer:BASE:MINimum?
[SENSe:]PULSe:POWer:BASE:SDEViation?
[SENSe:]PULSe:POWer:BASE?
[SENSe:]PULSe:POWer:MAX:AVERage?
[SENSe:]PULSe:POWer:MAX:MAXimum?
[SENSe:]PULSe:POWer:MAX:MINimum?
[SENSe:]PULSe:POWer:MAX:SDEViation?
[SENSe:]PULSe:POWer:MAX?
[SENSe:]PULSe:POWer:MIN:AVERage?
[SENSe:]PULSe:POWer:MIN:MAXimum?
[SENSe:]PULSe:POWer:MIN:MINimum?
[SENSe:]PULSe:POWer:MIN:SDEViation?
[SENSe:]PULSe:POWer:MIN?
[SENSe:]PULSe:POWer:ON:AVERage?
[SENSe:]PULSe:POWer:ON:MAXimum?
[SENSe:]PULSe:POWer:ON:MINimum?
[SENSe:]PULSe:POWer:ON:SDEViation?
[SENSe:]PULSe:POWer:ON?
[SENSe:]PULSe:POWer:OVERshoot:DB:AVERage?
[SENSe:]PULSe:POWer:OVERshoot:DB:MAXimum?
[SENSe:]PULSe:POWer:OVERshoot:DB:MINimum?
[SENSe:]PULSe:POWer:OVERshoot:DB:SDEViation?
[SENSe:]PULSe:POWer:OVERshoot:DB?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:AVERage?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:MAXimum?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:MINimum?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]:SDEViation?
[SENSe:]PULSe:POWer:OVERshoot[:PERCent]?
[SENSe:]PULSe:POWer:PAVG:AVERage?
[SENSe:]PULSe:POWer:PAVG:MAXimum?
[SENSe:]PULSe:POWer:PAVG:MINimum?
[SENSe:]PULSe:POWer:PAVG:SDEViation?
[SENSe:]PULSe:POWer:PAVG?
[SENSe:]PULSe:POWer:PMIN:AVERage?
[SENSe:]PULSe:POWer:PMIN:MAXimum?
[SENSe:]PULSe:POWer:PMIN:MINimum?
[SENSe:]PULSe:POWer:PMIN:SDEViation?
[SENSe:]PULSe:POWer:PMIN?
[SENSe:]PULSe:POWer:POINt:AVERage?
[SENSe:]PULSe:POWer:POINt:MAXimum?
[SENSe:]PULSe:POWer:POINt:MINimum?
[SENSe:]PULSe:POWer:POINt:SDEViation?
[SENSe:]PULSe:POWer:POINt?
[SENSe:]PULSe:POWer:PON:AVERage?
[SENSe:]PULSe:POWer:PON:MAXimum?
[SENSe:]PULSe:POWer:PON:MINimum?
[SENSe:]PULSe:POWer:PON:SDEViation?
[SENSe:]PULSe:POWer:PON?
[SENSe:]PULSe:POWer:PPRatio:AVERage?
[SENSe:]PULSe:POWer:PPRatio:MAXimum?
[SENSe:]PULSe:POWer:PPRatio:MINimum?
[SENSe:]PULSe:POWer:PPRatio:SDEViation?
[SENSe:]PULSe:POWer:PPRatio?
[SENSe:]PULSe:POWer:RIPPle:DB:AVERage?
[SENSe:]PULSe:POWer:RIPPle:DB:MAXimum?
[SENSe:]PULSe:POWer:RIPPle:DB:MINimum?
[SENSe:]PULSe:POWer:RIPPle:DB:SDEViation?
[SENSe:]PULSe:POWer:RIPPle:DB?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:AVERage?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:MAXimum?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:MINimum?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]:SDEViation?
[SENSe:]PULSe:POWer:RIPPle[:PERCent]?
[SENSe:]PULSe:POWer:TOP:AVERage?
[SENSe:]PULSe:POWer:TOP:MAXimum?
[SENSe:]PULSe:POWer:TOP:MINimum?
[SENSe:]PULSe:POWer:TOP:SDEViation?
[SENSe:]PULSe:POWer:TOP?
[SENSe:]PULSe:TIMing:DCYCle:AVERage?
[SENSe:]PULSe:TIMing:DCYCle:MAXimum?
[SENSe:]PULSe:TIMing:DCYCle:MINimum?
[SENSe:]PULSe:TIMing:DCYCle:SDEViation?
[SENSe:]PULSe:TIMing:DCYCle?
[SENSe:]PULSe:TIMing:DRATio:AVERage?
[SENSe:]PULSe:TIMing:DRATio:MAXimum?
[SENSe:]PULSe:TIMing:DRATio:MINimum?
[SENSe:]PULSe:TIMing:DRATio:SDEViation?
[SENSe:]PULSe:TIMing:DRATio?
[SENSe:]PULSe:TIMing:FALL:AVERage?
[SENSe:]PULSe:TIMing:FALL:MAXimum?
[SENSe:]PULSe:TIMing:FALL:MINimum?
[SENSe:]PULSe:TIMing:FALL:SDEViation?
[SENSe:]PULSe:TIMing:FALL?
[SENSe:]PULSe:TIMing:OFF:AVERage?
[SENSe:]PULSe:TIMing:OFF:MAXimum?
[SENSe:]PULSe:TIMing:OFF:MINimum?
[SENSe:]PULSe:TIMing:OFF:SDEViation?
[SENSe:]PULSe:TIMing:OFF?
[SENSe:]PULSe:TIMing:PRF:AVERage?
[SENSe:]PULSe:TIMing:PRF:MAXimum?
[SENSe:]PULSe:TIMing:PRF:MINimum?
[SENSe:]PULSe:TIMing:PRF:SDEViation?
[SENSe:]PULSe:TIMing:PRF?
[SENSe:]PULSe:TIMing:PRI:AVERage?
[SENSe:]PULSe:TIMing:PRI:MAXimum?
[SENSe:]PULSe:TIMing:PRI:MINimum?
[SENSe:]PULSe:TIMing:PRI:SDEViation?
[SENSe:]PULSe:TIMing:PRI?
[SENSe:]PULSe:TIMing:PWIDth:AVERage?
[SENSe:]PULSe:TIMing:PWIDth:MAXimum?
[SENSe:]PULSe:TIMing:PWIDth:MINimum?
[SENSe:]PULSe:TIMing:PWIDth:SDEViation?
[SENSe:]PULSe:TIMing:PWIDth?
[SENSe:]PULSe:TIMing:RISE:AVERage?
[SENSe:]PULSe:TIMing:RISE:MAXimum?
[SENSe:]PULSe:TIMing:RISE:MINimum?
[SENSe:]PULSe:TIMing:RISE:SDEViation?
[SENSe:]PULSe:TIMing:RISE?
[SENSe:]PULSe:TIMing:SETTling:AVERage?
[SENSe:]PULSe:TIMing:SETTling:MAXimum?
[SENSe:]PULSe:TIMing:SETTling:MINimum?
[SENSe:]PULSe:TIMing:SETTling:SDEViation?
[SENSe:]PULSe:TIMing:SETTling?
[SENSe:]PULSe:TIMing:TSTamp:AVERage?
[SENSe:]PULSe:TIMing:TSTamp:MAXimum?
[SENSe:]PULSe:TIMing:TSTamp:MINimum?
[SENSe:]PULSe:TIMing:TSTamp:SDEViation?
[SENSe:]PULSe:TIMing:TSTamp?
[SENSe:]RTMS:CAPTure:OFFSet
[SENSe:]SRATe?
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:POINts
[SENSe:]SWEep:SCAPture:EVENts
[SENSe:]SWEep:SCAPture:LENGth[:TIME]
[SENSe:]SWEep:SCAPture:OFFSet[:TIME]
[SENSe:]SWEep:SCAPture[:STATe]
[SENSe:]SWEep:TIME
ABORt
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:RTMS:ALINe:SHOW
CALCulate:RTMS:ALINe[:VALue]
CALCulate:RTMS:WINDow<n>:IVAL?
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<q>:Y?
CALCulate<n>:DISTribution:FREQuency
CALCulate<n>:DISTribution:LLINes[:STATe]
CALCulate<n>:DISTribution:NBINs
CALCulate<n>:DISTribution:PHASe
CALCulate<n>:DISTribution:POWer
CALCulate<n>:DISTribution:TIMing
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:PSPectrum:AUTO
CALCulate<n>:PSPectrum:BLOCksize
CALCulate<n>:PSPectrum:FREQuency
CALCulate<n>:PSPectrum:GTHReshold
CALCulate<n>:PSPectrum:MAXFrequency
CALCulate<n>:PSPectrum:PHASe
CALCulate<n>:PSPectrum:POWer
CALCulate<n>:PSPectrum:RBW?
CALCulate<n>:PSPectrum:STHReshold
CALCulate<n>:PSPectrum:TIMing
CALCulate<n>:PSPectrum:WINDow
CALCulate<n>:RRSPectrum:AUTO
CALCulate<n>:RRSPectrum:RBW
CALCulate<n>:RRSPectrum:WINDow
CALCulate<n>:TABLe:<ParameterGroup>:<Parameter>:LIMit
CALCulate<n>:TABLe:<ParameterGroup>:<Parameter>:LIMit:STATe
CALCulate<n>:TABLe:<ParameterGroup>:ALL:LIMit:STATe
CALCulate<n>:TABLe:ALL:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:ALL:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:ALL[:STATe]
CALCulate<n>:TABLe:FREQuency:CRATe
CALCulate<n>:TABLe:FREQuency:CRATe:LIMit
CALCulate<n>:TABLe:FREQuency:CRATe:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:DEViation
CALCulate<n>:TABLe:FREQuency:DEViation:LIMit
CALCulate<n>:TABLe:FREQuency:DEViation:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:PERRor
CALCulate<n>:TABLe:FREQuency:PERRor:LIMit
CALCulate<n>:TABLe:FREQuency:PERRor:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:POINt
CALCulate<n>:TABLe:FREQuency:POINt:LIMit
CALCulate<n>:TABLe:FREQuency:POINt:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:PPFRequency
CALCulate<n>:TABLe:FREQuency:PPFRequency:LIMit
CALCulate<n>:TABLe:FREQuency:PPFRequency:LIMit:STATe
CALCulate<n>:TABLe:FREQuency:RERRor
CALCulate<n>:TABLe:FREQuency:RERRor:LIMit
CALCulate<n>:TABLe:FREQuency:RERRor:LIMit:STATe
CALCulate<n>:TABLe:PHASe:ALL:LIMit:STATe
CALCulate<n>:TABLe:PHASe:ALL[:STATe]
CALCulate<n>:TABLe:PHASe:DEViation
CALCulate<n>:TABLe:PHASe:DEViation:LIMit
CALCulate<n>:TABLe:PHASe:DEViation:LIMit:STATe
CALCulate<n>:TABLe:PHASe:PERRor
CALCulate<n>:TABLe:PHASe:PERRor:LIMit
CALCulate<n>:TABLe:PHASe:PERRor:LIMit:STATe
CALCulate<n>:TABLe:PHASe:POINt
CALCulate<n>:TABLe:PHASe:POINt:LIMit
CALCulate<n>:TABLe:PHASe:POINt:LIMit:STATe
CALCulate<n>:TABLe:PHASe:PPPHase
CALCulate<n>:TABLe:PHASe:PPPHase:LIMit
CALCulate<n>:TABLe:PHASe:PPPHase:LIMit:STATe
CALCulate<n>:TABLe:PHASe:RERRor
CALCulate<n>:TABLe:PHASe:RERRor:LIMit
CALCulate<n>:TABLe:PHASe:RERRor:LIMit:STATe
CALCulate<n>:TABLe:POWer:ADRoop:DB
CALCulate<n>:TABLe:POWer:ADRoop:DB:LIMit
CALCulate<n>:TABLe:POWer:ADRoop:DB:LIMit:STATe
CALCulate<n>:TABLe:POWer:ADRoop[:PERCent]
CALCulate<n>:TABLe:POWer:ADRoop[:PERCent]:LIMit
CALCulate<n>:TABLe:POWer:ADRoop[:PERCent]:LIMit:STATe
CALCulate<n>:TABLe:POWer:ALL:LIMit:STATe
CALCulate<n>:TABLe:POWer:ALL[:STATe]
CALCulate<n>:TABLe:POWer:AMPLitude
CALCulate<n>:TABLe:POWer:AMPLitude:LIMit
CALCulate<n>:TABLe:POWer:AMPLitude:LIMit:STATe
CALCulate<n>:TABLe:POWer:AVG
CALCulate<n>:TABLe:POWer:AVG:LIMit
CALCulate<n>:TABLe:POWer:AVG:LIMit:STATe
CALCulate<n>:TABLe:POWer:BASE
CALCulate<n>:TABLe:POWer:BASE:LIMit
CALCulate<n>:TABLe:POWer:BASE:LIMit:STATe
CALCulate<n>:TABLe:POWer:MAX
CALCulate<n>:TABLe:POWer:MAX:LIMit
CALCulate<n>:TABLe:POWer:MAX:LIMit:STATe
CALCulate<n>:TABLe:POWer:MIN
CALCulate<n>:TABLe:POWer:MIN:LIMit
CALCulate<n>:TABLe:POWer:MIN:LIMit:STATe
CALCulate<n>:TABLe:POWer:ON
CALCulate<n>:TABLe:POWer:ON:LIMit
CALCulate<n>:TABLe:POWer:ON:LIMit:STATe
CALCulate<n>:TABLe:POWer:OVERshoot:DB
CALCulate<n>:TABLe:POWer:OVERshoot:DB:LIMit
CALCulate<n>:TABLe:POWer:OVERshoot:DB:LIMit:STATe
CALCulate<n>:TABLe:POWer:OVERshoot[:PERCent]
CALCulate<n>:TABLe:POWer:OVERshoot[:PERCent]:LIMit
CALCulate<n>:TABLe:POWer:OVERshoot[:PERCent]:LIMit:STATe
CALCulate<n>:TABLe:POWer:PAVG
CALCulate<n>:TABLe:POWer:PAVG:LIMit
CALCulate<n>:TABLe:POWer:PAVG:LIMit:STATe
CALCulate<n>:TABLe:POWer:PMIN
CALCulate<n>:TABLe:POWer:PMIN:LIMit
CALCulate<n>:TABLe:POWer:PMIN:LIMit:STATe
CALCulate<n>:TABLe:POWer:POINt
CALCulate<n>:TABLe:POWer:POINt:LIMit
CALCulate<n>:TABLe:POWer:POINt:LIMit:STATe
CALCulate<n>:TABLe:POWer:PON
CALCulate<n>:TABLe:POWer:PON:LIMit
CALCulate<n>:TABLe:POWer:PON:LIMit:STATe
CALCulate<n>:TABLe:POWer:PPRatio
CALCulate<n>:TABLe:POWer:PPRatio:LIMit
CALCulate<n>:TABLe:POWer:PPRatio:LIMit:STATe
CALCulate<n>:TABLe:POWer:RIPPle:DB
CALCulate<n>:TABLe:POWer:RIPPle:DB:LIMit
CALCulate<n>:TABLe:POWer:RIPPle:DB:LIMit:STATe
CALCulate<n>:TABLe:POWer:RIPPle[:PERCent]
CALCulate<n>:TABLe:POWer:RIPPle[:PERCent]:LIMit
CALCulate<n>:TABLe:POWer:RIPPle[:PERCent]:LIMit:STATe
CALCulate<n>:TABLe:POWer:TOP
CALCulate<n>:TABLe:POWer:TOP:LIMit
CALCulate<n>:TABLe:POWer:TOP:LIMit:STATe
CALCulate<n>:TABLe:TIMing:ALL:LIMit:STATe
CALCulate<n>:TABLe:TIMing:ALL[:STATe]
CALCulate<n>:TABLe:TIMing:DCYCle
CALCulate<n>:TABLe:TIMing:DCYCle:LIMit
CALCulate<n>:TABLe:TIMing:DCYCle:LIMit:STATe
CALCulate<n>:TABLe:TIMing:DRATio
CALCulate<n>:TABLe:TIMing:DRATio:LIMit
CALCulate<n>:TABLe:TIMing:DRATio:LIMit:STATe
CALCulate<n>:TABLe:TIMing:FALL
CALCulate<n>:TABLe:TIMing:FALL:LIMit
CALCulate<n>:TABLe:TIMing:FALL:LIMit:STATe
CALCulate<n>:TABLe:TIMing:OFF
CALCulate<n>:TABLe:TIMing:OFF:LIMit
CALCulate<n>:TABLe:TIMing:OFF:LIMit:STATe
CALCulate<n>:TABLe:TIMing:PRF
CALCulate<n>:TABLe:TIMing:PRF:LIMit
CALCulate<n>:TABLe:TIMing:PRF:LIMit:STATe
CALCulate<n>:TABLe:TIMing:PRI
CALCulate<n>:TABLe:TIMing:PRI:LIMit
CALCulate<n>:TABLe:TIMing:PRI:LIMit:STATe
CALCulate<n>:TABLe:TIMing:PWIDth
CALCulate<n>:TABLe:TIMing:PWIDth:LIMit
CALCulate<n>:TABLe:TIMing:PWIDth:LIMit:STATe
CALCulate<n>:TABLe:TIMing:RISE
CALCulate<n>:TABLe:TIMing:RISE:LIMit
CALCulate<n>:TABLe:TIMing:RISE:LIMit:STATe
CALCulate<n>:TABLe:TIMing:SETTling
CALCulate<n>:TABLe:TIMing:SETTling:LIMit
CALCulate<n>:TABLe:TIMing:SETTling:LIMit:STATe
CALCulate<n>:TABLe:TIMing:TSTamp
CALCulate<n>:TABLe:TIMing:TSTamp:LIMit
CALCulate<n>:TABLe:TIMing:TSTamp:LIMit:STATe
CALCulate<n>:TRENd:FREQuency
CALCulate<n>:TRENd:FREQuency:X
CALCulate<n>:TRENd:FREQuency:Y
CALCulate<n>:TRENd:LLINes[:STATe]
CALCulate<n>:TRENd:PHASe
CALCulate<n>:TRENd:PHASe:X
CALCulate<n>:TRENd:PHASe:Y
CALCulate<n>:TRENd:POWer
CALCulate<n>:TRENd:POWer:X
CALCulate<n>:TRENd:POWer:Y
CALCulate<n>:TRENd:TIMing
CALCulate<n>:TRENd:TIMing:X
CALCulate<n>:TRENd:TIMing:Y
CALCulate<n>:UNIT:FREQuency
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
DIAGnostic:SERVice:NSOurce
DISPlay:FORMat
DISPlay:MTABle
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue:MINimum
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
FORMat:DEXPort:DSEParator
FORMat:DEXPort:HEADer
FORMat:DEXPort:TRACes
FORMat[:DATA]
INITiate:CONMeas
INITiate:CONTinuous
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:COUPling
INPut:DIQ:CDEVice
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILE:PATH
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:STORe:IQ:COMMent
MMEMory:STORe:IQ:STATe
MMEMory:STORe<n>:TABLe
MMEMory:STORe<n>:TRACe
OUTPut:DIQ
OUTPut:DIQ:CDEVice
OUTPut:IF:IFFRequency
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
SENSe:TRACe:MEASurement:ALGorithm
SENSe:TRACe:MEASurement:DEFine:AMPLitude:UNIT
SENSe:TRACe:MEASurement:DEFine:BOUNdary:TOP
SENSe:TRACe:MEASurement:DEFine:COMPensate:ADRoop
SENSe:TRACe:MEASurement:DEFine:DURation:AUTO
SENSe:TRACe:MEASurement:DEFine:DURation:MAX
SENSe:TRACe:MEASurement:DEFine:DURation:MIN
SENSe:TRACe:MEASurement:DEFine:DURation:OFF
SENSe:TRACe:MEASurement:DEFine:FREQuency:OFFSet
SENSe:TRACe:MEASurement:DEFine:FREQuency:OFFSet:AUTO
SENSe:TRACe:MEASurement:DEFine:FREQuency:RATE
SENSe:TRACe:MEASurement:DEFine:FREQuency:RATE:AUTO
SENSe:TRACe:MEASurement:DEFine:PULSe:ADRoop
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:LENGth
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:OFFSet:LEFT
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:OFFSet:RIGHt
SENSe:TRACe:MEASurement:DEFine:PULSe:ESTimation:REFerence
SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant
SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant:AWINdow
SENSe:TRACe:MEASurement:DEFine:PULSe:INSTant:REFerence
SENSe:TRACe:MEASurement:DEFine:PULSe:MODulation
SENSe:TRACe:MEASurement:DEFine:PULSe:PERiod
SENSe:TRACe:MEASurement:DEFine:PULSe:SELected
SENSe:TRACe:MEASurement:DEFine:RIPPle
SENSe:TRACe:MEASurement:DEFine:RRANge:ALIGnment
SENSe:TRACe:MEASurement:DEFine:RRANge:AUTO
SENSe:TRACe:MEASurement:DEFine:RRANge:LENGth
SENSe:TRACe:MEASurement:DEFine:RRANge:OFFSet
SENSe:TRACe:MEASurement:DEFine:RRANge:REFerence
SENSe:TRACe:MEASurement:DEFine:TRANsition:HREFerence
SENSe:TRACe:MEASurement:DEFine:TRANsition:LREFerence
SENSe:TRACe:MEASurement:DEFine:TRANsition:REFerence
SENSe:TRACe:MEASurement:POWer:AVG:MAXimum?
SENSe:TRACe:MEASurement:POWer:AVG:MINimum?
SENSe:TRACe:MEASurement:POWer:AVG:SDEViation?
SENSe:TRACe:MEASurement:POWer:AVG?
SENSe:TRACe:MEASurement:POWer:AVG[:AVERage]?
SENSe:TRACe:MEASurement:POWer:CRESt:MAXimum?
SENSe:TRACe:MEASurement:POWer:CRESt:MINimum?
SENSe:TRACe:MEASurement:POWer:CRESt:SDEViation?
SENSe:TRACe:MEASurement:POWer:CRESt?
SENSe:TRACe:MEASurement:POWer:CRESt[:AVERage]?
SENSe:TRACe:MEASurement:POWer:MAX:MAXimum?
SENSe:TRACe:MEASurement:POWer:MAX:MINimum?
SENSe:TRACe:MEASurement:POWer:MAX:SDEViation?
SENSe:TRACe:MEASurement:POWer:MAX?
SENSe:TRACe:MEASurement:POWer:MAX[:AVERage]?
SENSe:TRACe:MEASurement:POWer:MIN:MAXimum?
SENSe:TRACe:MEASurement:POWer:MIN:MINimum?
SENSe:TRACe:MEASurement:POWer:MIN:SDEViation?
SENSe:TRACe:MEASurement:POWer:MIN?
SENSe:TRACe:MEASurement:POWer:MIN[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop?
SENSe:TRACe:MEASurement:POWer:PULSe:ADRoop[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude?
SENSe:TRACe:MEASurement:POWer:PULSe:AMPLitude[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE?
SENSe:TRACe:MEASurement:POWer:PULSe:BASE[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt?
SENSe:TRACe:MEASurement:POWer:PULSe:CRESt[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:ON:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:ON:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:ON:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:ON?
SENSe:TRACe:MEASurement:POWer:PULSe:ON[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt?
SENSe:TRACe:MEASurement:POWer:PULSe:POINt[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower?
SENSe:TRACe:MEASurement:POWer:PULSe:PPPower[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle?
SENSe:TRACe:MEASurement:POWer:PULSe:RIPPle[:AVERage]?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP:MAXimum?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP:MINimum?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP:SDEViation?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP?
SENSe:TRACe:MEASurement:POWer:PULSe:TOP[:AVERage]?
SENSe:TRACe:MEASurement:POWer:RANGe:MAXimum?
SENSe:TRACe:MEASurement:POWer:RANGe:MINimum?
SENSe:TRACe:MEASurement:POWer:RANGe:SDEViation?
SENSe:TRACe:MEASurement:POWer:RANGe?
SENSe:TRACe:MEASurement:POWer:RANGe[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:DCYCle:MAXimum?
SENSe:TRACe:MEASurement:PULSe:DCYCle:MINimum?
SENSe:TRACe:MEASurement:PULSe:DCYCle:SDEViation?
SENSe:TRACe:MEASurement:PULSe:DCYCle?
SENSe:TRACe:MEASurement:PULSe:DCYCle[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:DURation:MAXimum?
SENSe:TRACe:MEASurement:PULSe:DURation:MINimum?
SENSe:TRACe:MEASurement:PULSe:DURation:SDEViation?
SENSe:TRACe:MEASurement:PULSe:DURation?
SENSe:TRACe:MEASurement:PULSe:DURation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:DUTRatio:MAXimum?
SENSe:TRACe:MEASurement:PULSe:DUTRatio:MINimum?
SENSe:TRACe:MEASurement:PULSe:DUTRatio:SDEViation?
SENSe:TRACe:MEASurement:PULSe:DUTRatio?
SENSe:TRACe:MEASurement:PULSe:DUTRatio[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:FRDeviation:MAXimum?
SENSe:TRACe:MEASurement:PULSe:FRDeviation:MINimum?
SENSe:TRACe:MEASurement:PULSe:FRDeviation:SDEViation?
SENSe:TRACe:MEASurement:PULSe:FRDeviation?
SENSe:TRACe:MEASurement:PULSe:FRDeviation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:FREQuency:MAXimum?
SENSe:TRACe:MEASurement:PULSe:FREQuency:MINimum?
SENSe:TRACe:MEASurement:PULSe:FREQuency:SDEViation?
SENSe:TRACe:MEASurement:PULSe:FREQuency?
SENSe:TRACe:MEASurement:PULSe:FREQuency[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PERiod:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PERiod:MINimum?
SENSe:TRACe:MEASurement:PULSe:PERiod:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PERiod?
SENSe:TRACe:MEASurement:PULSe:PERiod[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PFReqerror:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PFReqerror:MINimum?
SENSe:TRACe:MEASurement:PULSe:PFReqerror:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PFReqerror?
SENSe:TRACe:MEASurement:PULSe:PFReqerror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PHASe:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PHASe:MINimum?
SENSe:TRACe:MEASurement:PULSe:PHASe:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PHASe?
SENSe:TRACe:MEASurement:PULSe:PHASe[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PHDeviation:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PHDeviation:MINimum?
SENSe:TRACe:MEASurement:PULSe:PHDeviation:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PHDeviation?
SENSe:TRACe:MEASurement:PULSe:PHDeviation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PPFRequency:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PPFRequency:MINimum?
SENSe:TRACe:MEASurement:PULSe:PPFRequency:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PPFRequency?
SENSe:TRACe:MEASurement:PULSe:PPFRequency[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror:MINimum?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror?
SENSe:TRACe:MEASurement:PULSe:PPHeqerror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:PPPHase:MAXimum?
SENSe:TRACe:MEASurement:PULSe:PPPHase:MINimum?
SENSe:TRACe:MEASurement:PULSe:PPPHase:SDEViation?
SENSe:TRACe:MEASurement:PULSe:PPPHase?
SENSe:TRACe:MEASurement:PULSe:PPPHase[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:RATE:MAXimum?
SENSe:TRACe:MEASurement:PULSe:RATE:MINimum?
SENSe:TRACe:MEASurement:PULSe:RATE:SDEViation?
SENSe:TRACe:MEASurement:PULSe:RATE?
SENSe:TRACe:MEASurement:PULSe:RATE[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror:MAXimum?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror:MINimum?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror:SDEViation?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror?
SENSe:TRACe:MEASurement:PULSe:RMSFreqerror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:RMSPherror:MAXimum?
SENSe:TRACe:MEASurement:PULSe:RMSPherror:MINimum?
SENSe:TRACe:MEASurement:PULSe:RMSPherror:SDEViation?
SENSe:TRACe:MEASurement:PULSe:RMSPherror?
SENSe:TRACe:MEASurement:PULSe:RMSPherror[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:SEParation:MAXimum?
SENSe:TRACe:MEASurement:PULSe:SEParation:MINimum?
SENSe:TRACe:MEASurement:PULSe:SEParation:SDEViation?
SENSe:TRACe:MEASurement:PULSe:SEParation?
SENSe:TRACe:MEASurement:PULSe:SEParation[:AVERage]?
SENSe:TRACe:MEASurement:PULSe:TIME:MAXimum?
SENSe:TRACe:MEASurement:PULSe:TIME:MINimum?
SENSe:TRACe:MEASurement:PULSe:TIME:SDEViation?
SENSe:TRACe:MEASurement:PULSe:TIME?
SENSe:TRACe:MEASurement:PULSe:TIME[:AVERage]?
SENSe:TRACe:MEASurement:TRANsition:NEGative:DURation?
SENSe:TRACe:MEASurement:TRANsition:POSitive:DURation?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot:MAXimum?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot:MINimum?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot:SDEViation?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot?
SENSe:TRACe:MEASurement:TRANsition:POSitive:OVERshoot[:AVERage]?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling:MAXimum?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling:MINimum?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling:SDEViation?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling?
SENSe:TRACe:MEASurement:TRANsition:POSitive:SETTling[:AVERage]?
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon[:STATe]
TRACe<n>:IQ:SCAPture:BOUNdary?
TRACe<n>:IQ:SCAPture:TSTamp:SSTart?
TRACe<n>:IQ:SCAPture:TSTamp:TRIGger?
TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]?
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:RFPower:HOLDoff
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval
UNIT:ANGLe


Legal Notice

R&S®FSW-K6
Pulse Measurement Option

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.